Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Probleme mit Robocopy bei Datenmigration

Frage Microsoft Windows Server

Mitglied: hexhex

hexhex (Level 1) - Jetzt verbinden

09.10.2007, aktualisiert 11.10.2007, 7170 Aufrufe, 5 Kommentare

Wir haben in unserer Windows 2003 Domäne einen Netapp Fileserver.
Eine Freigabe ist für die Servergespeicherten Profile, eine andere für die Homeverzeichnisse.

Nun haben wir einen neuen Fileserver von Sun bekommen und möchten die Daten per Robocopy von dem alten auf den neuen Fileserver kopieren.

Ich habe als Domänenadmin Vollzugriff auf alle Daten.
Das Kopieren der Profile (über 50.000) klappt ohne Probleme

Bei Kopieren der Homeverzeichnisse bekomme ich Fehler.

robocopy.exe \\server_alt\home$ \\server_neu\home$ /ndl /mon:5 /NP /E /ZB /xo /purge /copy:datso /R:0 /W:0

2007/10/09 10:37:54 ERROR 1338 (0x0000053A) Copying NTFS Security to Destination
\\server_alt\home$\dir1\beispieldir
The security descriptor structure is invalid.

Ersetze ich im robocopy "/copy:datso" durch "/copy:dat" - also reines Kopieren ohne Rechte klappts ohne probleme. Rechte auf der Quelle lesen ODER Rechte auf dem Ziel schreiben verursacht den Fehler 1338.
Kann mir das aber nicht so recht erklären, da ich auf der Quelle UND dem Ziel Vollzugriff habe.
Mitglied: Biber
09.10.2007 um 21:18 Uhr
Moin hexhex,

dieses Phänomen ist durchaus logisch erklärlich - es passiert konsequenterweise genau dann, wenn Du die Folder Redirecton über GPO machst.
Denn dabei bekommt ja jeder User erstmal exklusiven Zugriff auf "sein" %username%-Verzeichnis. "Exklusiv" ist neudeutscher M$-Slang und heißt soviel wie "nur der (oder die)".

Windows works as designed....... [um deutsche Formulierungen wie "selbst verschuldetes Elend" zu vermeiden].

Abhilfe siehe hier JSI 3471.

Oder kürzer ausdrückt:

Minimal: Dem SYSTEM-Account "FULL CONTROL"/Vollzugriff auf den jeweiligen %username%-Ordner (inherited, also auch auf alle Unterordner) geben.
Pragmatischer: Dem System-Account, der Gruppe "Admistratoren" und dem Owner/Creator Vollzugriff auf <bla, s.o.> geben.

Grüße
Biber

P.S. Ja, ich weiß - dadurch wird die GPO natürlich wieder verwässert bzw. ad absurdum geführt - aber anders bekommst Du Windows nicht zum Fliegen.
Bitte warten ..
Mitglied: hexhex
10.10.2007 um 09:51 Uhr
Ich werde es nun mal Testen.
Ändere gerade mein script um die Rechte der Homedirs anzupassen. SYSTEM kommt nun hinzu.
Die Gruppe der Domänenadmins hatte schon Vollzugriff - vererbt nach unten!! Dachte das reicht.
Bitte warten ..
Mitglied: hexhex
10.10.2007 um 13:26 Uhr
Hmmm- hab mal die GPO's gescheckt - wir haben keine Ordnerumleitung.
Bitte warten ..
Mitglied: Biber
10.10.2007 um 22:23 Uhr
Hm, hexhex,

das versteh ich nicht ..haben die User kein Homeverzeichnis \users\%username%\ auf dem Server?
Und sind sie dort nicht der exklusiv berechtigte User?
Du hast doch geschrieben "Bei Kopieren der Homeverzeichnisse bekomme ich Fehler."

Wo kommen denn die Home-Verzeichnisse her?
Hast Du das JSI überflogen?
Ich versuchs mal mit einfachen Worten:
Wenn Du Ordner des Users kopierst (=neu anlegst) und gleichzeitig dem neuen Ordner die Eigenschaft vererben sollst, dass darin ausschließlich dieser User irgendwelche Rechte hat, dann zeigt Dir Windows einen Vogel. Spätestens wenn Du kurz danach Unterverzeichnisse in Users Exklusivordner anlegen willst.
Und selbst richtige Betriebssysteme würden das tun.

Grüße
Biber
Bitte warten ..
Mitglied: hexhex
11.10.2007 um 08:24 Uhr
Moin Biber,
Jeder User hat ein Homeverzeichnis \\servername\username
Jedoch haben wir keine GPO's für Folder Direktion (hat historische Gründe).

Normalerweise ist es so, da nur der User exklusive Rechte hat. Aber wenn ich als Domönenadmin keine rechte habe, kann aich die daten auch nicht auf den neuen Fileserver migrieren.
Ich habe jedoch ein script geschrieben (bei 50.000 Usern kann man nur noch mit scripen arbeiten), das erst den Besitz des Homeverzeichnis übernimmt, dann der Gruppe Domänenadministratoren Vollzugriff gibt und anschliessend den Besitz wieder an den User übergibt.

Das JSI habe ich überflogen - mein script noch geändert und "Creator Owner" und "System" vollzugriff gegeben.

Komischerweise kann ich ca. 95% der Daten inzwischen kopieren - bekomme aber immer noch die gleiche Fehlermeldung bei den restlichen 5%.
z.B. bei \\server\user\eigene bilder\desktop.ini - Ordner wird angelegt, aber die ini nicht geschrieben, obwohl ich Vollzugriff habe.

Gruß
Hexhex
Bitte warten ..
Neuester Wissensbeitrag
Exchange Server

WSUS bietet CU22 für Exchange 2007 SP3 nicht an. EOL Exchange 2007

Tipp von DerWoWusste zum Thema Exchange Server ...

Ähnliche Inhalte
Mac OS X
Adobe Acrobat Probleme (6)

Frage von uridium69 zum Thema Mac OS X ...

Exchange Server
Exchange 2010 SMART Host SMTP Relay Probleme (6)

Frage von dawdad zum Thema Exchange Server ...

Windows Server
Active Directory-Verwaltungscenter macht Probleme (1)

Frage von MrFuzz zum Thema Windows Server ...

Heiß diskutierte Inhalte
Batch & Shell
gelöst Batch xls nach aktuellem Datum auslesen und email senden (14)

Frage von michi-ffm zum Thema Batch & Shell ...

Windows Server
SBS 2011 Standard virtualisieren (13)

Frage von HeinrichM zum Thema Windows Server ...

Backup
Datensicherung ARCHIV (12)

Frage von fautec56 zum Thema Backup ...

LAN, WAN, Wireless
Per Script auf UniFi-controller zugreifen und WPA2-Key ändern (11)

Frage von Winfried-HH zum Thema LAN, WAN, Wireless ...