Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Probleme mit Routing / Webserver

Frage Netzwerke

Mitglied: nico-droste

nico-droste (Level 1) - Jetzt verbinden

27.09.2005, aktualisiert 14:30 Uhr, 3745 Aufrufe, 2 Kommentare

Hallo,
ich setze einen Win2k Server mit IIS ein, welcher an einer DSL-Leitung mit dyn. Ip hängt.
Das Problem ist, dass Clients aus dem lokalen Netzwerk nicht über die öffentliche IP-Adresse (xyz.dyndns.org/intern/) auf den Server zugreifen können, sondern nur Lokal über http://server/intern/ .
Zu bemerken ist, dass zwischen dem Server und dem Internet noch eine Hardware-Firewall ist, welche den Port 80 auf den Server forewarded. Außerdem kann man von Extern ohne Probleme über die xyz.dyndns.org/intern/ mit dem Webserver arbeiten.
Warum können die Clients aus dem lokalen Netz nicht über die öffentliche Adresse des Servers auf ihn zugreifen?
Hat Jemand eine Idee?

Vielen Dank und Gruß
Nico
Mitglied: 16640
27.09.2005 um 13:12 Uhr
Weil bei den SoHo-Routern das portforwarding nur von dem externen Interface (WAN) funktioniert.

Verdeutliche Dir mal, was abläuft.... Du gibst intern die öffentliche URL von Deinem Webserver ein. Ein DNS-Request wird erzeugt, um die Adresse zu erhalten. Du bekommst die WAN-Adresse von Deinem eigenen Router geliefert und schickst jetzt einen HTTP-Request an diese Adresse raus. Dein Router weiss, welche Adresse er WAN-seitig hat und bezieht den Request auf sich. Aber weil der Request von seiner LAN-Seite kommt, gibt er ihn nicht gemäß der forwarding-Tabelle weiter, sondern 'unterschlägt' ihn einfach.

Das Handling kann von Router zu Router unterschiedlich sein. Wenn aber die Reaktion so wie in Deiner Beschreibung aussieht, dann ist zu 99,9% der Grund hierin zu finden.
Bitte warten ..
Mitglied: nico-droste
27.09.2005 um 14:30 Uhr
Hallo, das komische ist aber, dass es heute morgen um ca. 9:00 noch funktioniert hat und vorher auch immer funktioniert hat, nur jetzt funktioniert es plötzlich nicht mehr, obwohl keine änderungen an der firewall vorgenommen wurden. gibt es noch eine andere möglichkeit woran das liegen kann?
auf dem win2k server ist auch ein dns server installiert...
gruß
nico
Bitte warten ..
Ähnliche Inhalte
Exchange Server
gelöst Probleme mit Active Sync (6)

Frage von Henere zum Thema Exchange Server ...

Router & Routing
gelöst Mikrotik Switching und Routing Problem (11)

Frage von aqui zum Thema Router & Routing ...

Voice over IP
gelöst RTP Probleme bei Yealink T46G - erster Satz ist oft nicht zu hören (4)

Frage von istike2 zum Thema Voice over IP ...

Router & Routing
Site2Site VPN - Routing Sonicwall, Zyxel (8)

Frage von KMUlife zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Windows 7
gelöst BOOTMGR is missing (auch nach bootrec -RebuildBcd) (19)

Frage von Mipronimo zum Thema Windows 7 ...

Router & Routing
Tipps für Router (ca. 100 clients, VPN) (19)

Frage von oel-auge zum Thema Router & Routing ...

TK-Netze & Geräte
gelöst Convert von TAPI auf CAPI gesucht (13)

Frage von StefanKittel zum Thema TK-Netze & Geräte ...