Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Probleme mit Routing zwischen VLANs

Frage Netzwerke Router & Routing

Mitglied: flugfaust

flugfaust (Level 2) - Jetzt verbinden

17.06.2007, aktualisiert 22.06.2007, 5147 Aufrufe, 8 Kommentare

Hallo,

ich habe folgendes Szenario aufgebaut.

12 Stück Layer3 Switches (Allied Telesyn AT-9748) mit jeweils 3 VLANS:

Switch1:
VLAN1(default) 192.168.0.254
VLAN2 192.168.1.254
VLAN3 192.168.2.254

Die anderen Switches wurden genauso konfiguriert von 254 abwärts

Nun ist das Problem dass sich VLAN1 und VLAN2 einwandfrei untereinander unterhalten können. VLAN 3 kann nicht mit den anderen VLANs kommunizieren. Ich frage mich wieso dass das so ist denn das VLAN Routing auf Layer 3 sollte eigentlich ohne angabe von Routen auf den Switches funktioneren was man anhand von VLAN1 und VLAN2 sieht.

Kannmir jemand sagen wieso die kommunikation zum VLAN3 nicht funktioniert bzw was ich da nochmachen muss?
Mitglied: aqui
17.06.2007 um 16:52 Uhr
Ja, das ist richtig. Wenn einer der Switches das VLAN Routing macht und im VLAN 3 auf dem Layer 3 Interface die 192.168.2.254 hat dann sollte das problemlos klappen ?!

  • Haben alle Clients in den VLANs sauber immer die Switch Adresse als Gateway konfiguriert ?
  • Kannst du von den Clients in VLAN3 das VLAN Interface auf dem Switch pingen ?

Vielleicht hast du ja auch nur einen Zahlendreher in der IP Adresse. Pfiffiger waere es gewesen immer das 3te Byte der IP Adresse auch der VLAN ID zuzuordenen wie:
VLAN 1 = 192.168.1.0/24
VLAN 2 = 192.168.2.0/24
VLAN 3 = 192.168.3.0/24
so haettest du kosmetisch schneller sehen koennen aus welchem VLAN die IP kommt und umgekehrt !
Bitte warten ..
Mitglied: flugfaust
17.06.2007 um 17:43 Uhr
Es ist so dass das Netz einen CoreSwitch hat und dieser als Gatway fungieren soll.
Dieser hat auf den VLANS die IP 254........also
VLAN1 192.168.0.254
VLAN2 192.168.1.254
VLAN3 192.168.2.254


Die anderen Switches sind so eingerichtet
Switch1
VLAN1 192.168.0.253
VLAN2 192.168.1.253
VLAN3 192.168.2.253

und so geht es mit den Switchen weiter 252, 251 etc.

Im VLAN3 kann ich alle Clients im VLAN3 im Netzwerk anpingen, also auch z.B. das VLAN Interface VLAN3 auf Switch4 aber halt nicht die VLAN Interface von VLAN1 und VLAN2


Überall wurde der Core Switch als Gateway eingerichtet. Oder ist dies nur möglich wenn der Switch selbst als Gatway fungiert?
Wegen der Logik bei den IP zuordnungen waren es Kundenvorgaben.
Bitte warten ..
Mitglied: aqui
18.06.2007 um 15:48 Uhr
So wie sich das anhört hast du wohl schlicht und einfach vergessen auf den Switches selber auch ein default Gateway einzurichten. Fehlt das kannst du dessen VLAN interface Adressen NUR immer aus dem gleichen VLAN pingen und natürlich nicht aus anderen VLANs.
Also was du beschreibst von VLAN3 ist dann ein pingen dieser Interfaces von VLAN1 und VLAN2 nicht möglich, da ihnen das Gateway fehlt.

Also wenn du dann immer ein default Gateway der Nicht Core Switches auf die .254 zeigen lässt sollte das dein Problem lösen !
Bitte warten ..
Mitglied: flugfaust
18.06.2007 um 19:37 Uhr
Ich kann aber pro Switch nur ein Default Gateway setzen zudem frage ich mich wieso ich VLAN2 aus VLAN1 anpingen kann..................

Beim Anlegen der VLANs habe ich auf den Switches Interfaces angelegt und den VLANs zugewiesen............da konnte ich kein Gateway angeben. Das Gateway kann ich nur für das Default Gateway (VLAN1) angeben oder ich weise die IP zu nem anderen VLAN zu aber ich kann nur ein Gateway angeben
Bitte warten ..
Mitglied: aqui
19.06.2007 um 11:01 Uhr
Eigentlich darf nur der Core Switch IP Adressen in den VLANs haben, denn der routet ja auch zentral. Das default VLAN1 solltest du dann nur als Mangement VLAN benutzen.
Du solltest auf allen Access Switches nur eine reine Layer 2 Konfig aufsetzen, also nur die VLANs definieren, die Ports zuweisen und auf den Backbone Uplinks zum Core Switch den Modus auf tagged setzen unm alle VLANs dahin transparent zu übertragen.
Damit sollte es eigentlich fehlerfrei funktionieren !
Bitte warten ..
Mitglied: flugfaust
19.06.2007 um 22:19 Uhr
Ouh und ich glaub es liegt an den TAGGED Ports. Ich muss nur die Uplinks auf TAGGED setzen und dann sollte es gehen.
DANKE
Bitte warten ..
Mitglied: aqui
20.06.2007 um 23:07 Uhr
Das ist der Trick !!! (Ist ja wohl auch klar, sonst werden deine VLANs auf den Uplinks ja gar nicht übertragen !!!)
Bitte warten ..
Mitglied: flugfaust
22.06.2007 um 11:43 Uhr
Also so ungefähr war's. Die Uplinks waren schon auf Tagged gesetzt aber auch andere Ports auf dem CoreSwitch. Ich hab die Config nochmal neu gemacht und NUR die Uplinks zu den VLANs getagged und schon ging es.
Ein Switch macht allerdings etwas Probleme und bringt beim Ping ins Netzwerk ab und zu Abbrüche und auf die TTL wird auf 255 gesetzt. Dies ist allerdings ein Layer2 Switch aber egal...........ist ein andres Thema und ich muss schauen wie ich das lösen kann
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Router & Routing
gelöst Routing zwischen zwei Netzen (31)

Frage von Xaero1982 zum Thema Router & Routing ...

Netzwerke
Routing zwischen 2 Fritzboxen langsam (2)

Frage von danielr1996 zum Thema Netzwerke ...

Router & Routing
gelöst Routing - Netzwerk Problem - zwischen Filiale und Zentrale (12)

Frage von clonex zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (13)

Frage von Motte990 zum Thema Microsoft Office ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...