Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Probleme mit RPC OVER HTTP(s)

Frage Microsoft Exchange Server

Mitglied: ozer

ozer (Level 1) - Jetzt verbinden

06.11.2008, aktualisiert 13.11.2008, 4955 Aufrufe, 1 Kommentar

Windows2003 Server + Exchange2003 + Outlook2003 + WINXP SP2
Kann keine Verbindung herstellen

Hallo,
habe hier seit einigen Tagen Probleme mit der Exchange2003 Funktion RPCoverHTTP.
Ich kann über die Clients keine Verbindung zum Server herstellen.

Ich bin nach folgender Anleitung vorgangen. http://msexchangefaq.de/clients/rpchttp.htm

Eingestellt ist soweit ich sehen kann alles.
Zur Info:
Wir haben mehrere Server die als DC fungieren und soweit auch richtig laufen.
Der Exchange Server ist kein DC, auch dieser ist soweit richtig eingestellt.
Zertifikate sind mit dem Exchange Server erstellt und bei den Testclients richtig installiert.
In der Registry des Exchange Server ist folgender Schlüssel von mir eingetragen worden:
HKLM\Software\Microsoft\Rpc\RPCproxy\ValidPorts = exchange:6001-6002;exchange:6004
Die Option "Passwort wird in Klartext gesendet" ist Testweiße auch angekreuzt.
Es wird kein RPC Proxy verwendet. Der Port 443, 80 wird per Firewall direkt an den Exchange geleitet, welcher die Anfragen bearbeitet.
OWA geht ohne Fehlermeldung. Auch owa.meinedomain.de/rpc gibt keinen Fehler zurück.
Anmeldung funktioniert.
Es folgt dann natürlich eine Fehlermeldung: "Sie haben nicht die erforderliche Berechtigung, um die Seite anzuzeigen"

Die Testclients sind verschiedene Rechner.
1) Ein Notebook sich bereits früher im LAN die ersten Einstellungen geholt hat.
2) Ein Rechner der zum ersten mal mit dem Exchange kommuniziert.

Beide Rechner bringen verschiedene Fehlermeldungen.

Der 1. Rechner versucht sich, nach der Anmeldung, mit dem Exchange zu verbinden, bricht dann aber irgendwann ab und geht in den Offline Modus.
Der 2. Rechner bringt kurz nach der Anmeldung den Fehler dass der Exchange nicht vergügbar ist, und als Optionen kann ich dann "erneut verbinden", "Offline arbeiten", "abbrechen". Offline arbeiten geht dann natürlich nicht, da er sich ja noch nie mit dem Server ausgetauscht hat.

In der Datei C:\WINDOWS\system32\LogFiles\HTTPERR\httperr.log habe ich zu der IP Adresse des Clients folgendes gefunden.
2008-11-06 14:45:59 80.187.96.85 2280 192.168.0.202 443 - - - - - Timer_ConnectionIdle -
Der RPCoverHTTP Dienst laüft.

Habt ihr vielleicht einen Vorschlag wo ich noch nach dem Fehler suchen kann?


Gruß
Mitglied: ozer
13.11.2008 um 12:38 Uhr
Hallo,

habe das Problem nun gelöst.
Problem waren 2 weitere Registry einträge.
Im DC musste noch einer gesetzt werden, damit das mit dem globalen Katalog klappt.
und im Exchange musste folgender noch erweitert werden:
HKLM\Software\Microsoft\Rpc\RPCproxy\ValidPorts = exchange:100-5000;exchange:6001-6002;exchange:6004;exchange.DOMAIN.local:6001-6002;exchange.DOMAIN.local:6004;owa.doain.de:6001-6002;owa.doain.de:6004;

Neustart

So hats dann bei mir wunderbar geklappt.
Bitte warten ..
Ähnliche Inhalte
Windows Server
Probleme mit Serververbindung (1)

Frage von Enriqe zum Thema Windows Server ...

Windows Server
Probleme mit Client Software Zugriff auf Windows Server 2012 (8)

Frage von it-kolli zum Thema Windows Server ...

Windows Update
Immer wieder Probleme mit WSUS (W10 u W2k16 ) (4)

Frage von Leo-le zum Thema Windows Update ...

Netzwerke
gelöst PfSense: Probleme mit Wirksamkeit von Rules (12)

Frage von Fenris14 zum Thema Netzwerke ...

Heiß diskutierte Inhalte
Verschlüsselung & Zertifikate
gelöst Festplattenverschlüsselung im Ausland (13)

Frage von Nicolaas zum Thema Verschlüsselung & Zertifikate ...

Festplatten, SSD, Raid
gelöst Fehlerhafte Blöcke im RAID 10 (12)

Frage von Kojak-LE zum Thema Festplatten, SSD, Raid ...

Windows Server
gelöst Microsoft-Lizenz CALs und passendes Server-Betriebssystem (12)

Frage von planetIT2016 zum Thema Windows Server ...

Netzwerkgrundlagen
gelöst Cisco SG500 Series LAG hat sich von selbst umgestellt (11)

Frage von Ex0r2k16 zum Thema Netzwerkgrundlagen ...