Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Probleme mit Shop Optimierung

Frage Internet

Mitglied: charinfo

charinfo (Level 1) - Jetzt verbinden

11.01.2009, aktualisiert 11:20 Uhr, 3014 Aufrufe, 2 Kommentare

Hi Leute,

ich habe ein Problem bei der Optimierung von Homepage / Shopsystem. Bei der Veränderung handelt es sich um zusätzliche Einträge in der htaccess.

Mit dem Eintrag sollte erreicht werden, das der Benutzer das Shopsystem bzw. Homepage mit und ohne www aufrufen kann, aber für die Suchmaschinen nur die URL ohne www (http:\\domain.de) existiert.

Bei Suchmaschinen wird der Eintrag ohne und mit www gelistet. Somit sind f. die Suchmaschine die Domain "zweimal" vorhanden und als Kopie erkannt. Das ganze legt sich negativ auf ein gutes Ranking z.B. bei Google.

Ich habe folgenden Eintrag in der htaccess vorgenommen. Kennt sich jemand mit diesen Sachen aus? Wo könnte der Fehlerteufel liegen?

Auszug aus der htaccess:

RewriteEngine on
RewriteCond %{HTTP_HOST} !^www\.domain\.de$
RewriteRule ^(.*)$ http://www.domain.de/$1 [L,R=301]


Bitte helft mir. Danke
Mitglied: dog
12.01.2009 um 07:58 Uhr
Hallo,

Wo könnte der Fehlerteufel liegen?

Was denn für ein Fehler? Du sagt ja nicht, was nicht geht.

nur die URL ohne www (http:\\domain.de) existiert.

nach deinem Beispiel wird aber domain.de auf www.domain.de umgeschrieben.

Somit sind f. die Suchmaschine die Domain "zweimal" vorhanden

Was Google angeht kannst du das Problem ganz einfach lösen:

1. Melde dich für die Webmaster Tools an: https://www.google.com/webmasters/tools/
2. Füge die Seite dort hinzu
3. Dann kannst du unter Einstellungen für die Domain einstellen ob sie mit oder ohne www in Google gezeigt werden soll.

Grüße

Max
Bitte warten ..
Mitglied: charinfo
12.01.2009 um 10:05 Uhr
HI Max,

wie recht du hast. Frage euch nach einer Lösung und schreibe nichts vom Problem.

Das Problem ist,

Not Found

The requested URL /shop/index.php was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Das Shopstat Modul schreibt die Links um, also anstatt http://www.domain.de/index.php?cat=18 wir daraus http://www.domain.de/shop/Seite:.:1.html .

Werde mir auch mal google anschauen, aber vielleicht können wir auch das Problem lösen.

Danke
Bitte warten ..
Ähnliche Inhalte
Exchange Server
Probleme mit Exchange-Dienste, E-Mails sind nicht angekommen (2)

Frage von cramtroni zum Thema Exchange Server ...

Windows Server
gelöst SQLExpress Probleme bei Backup (4)

Frage von Alternativende zum Thema Windows Server ...

Linux
Probleme beim Autostart Icewiesel im Vollbildmodus (1)

Frage von Thomas91 zum Thema Linux ...

Neue Wissensbeiträge
Google Android

Cyanogenmod alternative Downloadquelle

(2)

Tipp von Lochkartenstanzer zum Thema Google Android ...

Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(5)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Heiß diskutierte Inhalte
Windows 7
gelöst Lokales Adminprofil defekt (25)

Frage von Yannosch zum Thema Windows 7 ...

Server
gelöst Wie erkennen, dass nur deutsche IPs Zugang zu einer Website haben? (22)

Frage von Coreknabe zum Thema Server ...

LAN, WAN, Wireless
gelöst Statische Routen mit ISC-DHCP Server für Android Devices (22)

Frage von terminator zum Thema LAN, WAN, Wireless ...

Exchange Server
gelöst Migration Exchange 2007 zu 2013 - Public Folder teilweise weg (16)

Frage von Andy1987 zum Thema Exchange Server ...