Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Probleme mit Shop Optimierung

Frage Internet

Mitglied: charinfo

charinfo (Level 1) - Jetzt verbinden

11.01.2009, aktualisiert 11:20 Uhr, 3008 Aufrufe, 2 Kommentare

Hi Leute,

ich habe ein Problem bei der Optimierung von Homepage / Shopsystem. Bei der Veränderung handelt es sich um zusätzliche Einträge in der htaccess.

Mit dem Eintrag sollte erreicht werden, das der Benutzer das Shopsystem bzw. Homepage mit und ohne www aufrufen kann, aber für die Suchmaschinen nur die URL ohne www (http:\\domain.de) existiert.

Bei Suchmaschinen wird der Eintrag ohne und mit www gelistet. Somit sind f. die Suchmaschine die Domain "zweimal" vorhanden und als Kopie erkannt. Das ganze legt sich negativ auf ein gutes Ranking z.B. bei Google.

Ich habe folgenden Eintrag in der htaccess vorgenommen. Kennt sich jemand mit diesen Sachen aus? Wo könnte der Fehlerteufel liegen?

Auszug aus der htaccess:

RewriteEngine on
RewriteCond %{HTTP_HOST} !^www\.domain\.de$
RewriteRule ^(.*)$ http://www.domain.de/$1 [L,R=301]


Bitte helft mir. Danke
Mitglied: dog
12.01.2009 um 07:58 Uhr
Hallo,

Wo könnte der Fehlerteufel liegen?

Was denn für ein Fehler? Du sagt ja nicht, was nicht geht.

nur die URL ohne www (http:\\domain.de) existiert.

nach deinem Beispiel wird aber domain.de auf www.domain.de umgeschrieben.

Somit sind f. die Suchmaschine die Domain "zweimal" vorhanden

Was Google angeht kannst du das Problem ganz einfach lösen:

1. Melde dich für die Webmaster Tools an: https://www.google.com/webmasters/tools/
2. Füge die Seite dort hinzu
3. Dann kannst du unter Einstellungen für die Domain einstellen ob sie mit oder ohne www in Google gezeigt werden soll.

Grüße

Max
Bitte warten ..
Mitglied: charinfo
12.01.2009 um 10:05 Uhr
HI Max,

wie recht du hast. Frage euch nach einer Lösung und schreibe nichts vom Problem.

Das Problem ist,

Not Found

The requested URL /shop/index.php was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Das Shopstat Modul schreibt die Links um, also anstatt http://www.domain.de/index.php?cat=18 wir daraus http://www.domain.de/shop/Seite:.:1.html .

Werde mir auch mal google anschauen, aber vielleicht können wir auch das Problem lösen.

Danke
Bitte warten ..
Neuester Wissensbeitrag
Router & Routing

192.168er Adresse im öffentlichen Netz

(1)

Erfahrungsbericht von visco-c zum Thema Router & Routing ...

Ähnliche Inhalte
SAN, NAS, DAS
Fujitsu Q800 Probleme bei Domäneneinbindung

Frage von galnar zum Thema SAN, NAS, DAS ...

Mac OS X
Adobe Acrobat Probleme (6)

Frage von uridium69 zum Thema Mac OS X ...

Exchange Server
Exchange 2010 SMART Host SMTP Relay Probleme (6)

Frage von dawdad zum Thema Exchange Server ...

Windows Server
Active Directory-Verwaltungscenter macht Probleme (1)

Frage von MrFuzz zum Thema Windows Server ...

Heiß diskutierte Inhalte
Zusammenarbeit
Als Administrator im Großraumbüro (23)

Frage von Dopamin85 zum Thema Zusammenarbeit ...

Exchange Server
Test-ActiveSyncConnectivity Error nach neuem Zertifikat (19)

Frage von Driphex zum Thema Exchange Server ...

Hyper-V
HYPER V und USB (16)

Frage von Hendrik2586 zum Thema Hyper-V ...

Batch & Shell
gelöst Batch xls nach aktuellem Datum auslesen und email senden (14)

Frage von michi-ffm zum Thema Batch & Shell ...