Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Probleme beim Start von Apache2

Frage Linux Apache Server

Mitglied: pierronsky

pierronsky (Level 1) - Jetzt verbinden

28.10.2006, aktualisiert 29.10.2006, 5497 Aufrufe, 16 Kommentare

Hallo!

Ich habe folgendes Problem mit meinem Server, der mit Suse Linux 10.0 läuft.

Ich hatte in der vergangenen Woche YAST gestartet und das Online-Update gestartet, ich habe jedoch während des Updates abgebrochen (mit der Button "Abbrechen")

wenn ich nun Apache2 starten möchte (mit etc/init.d/apache2 start), so erscheint folgende Fehlermeldung:

"Starting httpd2 (prefork) httpd2-prefork: Syntax error on line 112 of /etc/apach e2/httpd.conf: Syntax error on line 8 of /etc/apache2/sysconfig.d/loadmodule.con f: API module structure `access_module' in file /usr/lib/apache2/mod_access.so i s garbled - perhaps this is not an Apache module DSO?

The command line was:
/usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf
failed
"

ebenso erscheint folgende Fehlermeldung beim Versuch Yast zu starten:

"Error loading language plugin /usr/lib/YaST2/plugin/libpy2lang_perl.so: libzypp.so.0: cannot open shared object file: No such file or directory
/sbin/yast: line 207: 27453 Speicherzugriffsfehler $ybindir/y2base menu ncurses
"

Es wäre schön wenn mir jemand helfen könnte.
Mitglied: 27119
28.10.2006 um 21:29 Uhr
Da ist wohl beim Update was schiefgegangen.
Wie wärs mit nem neuen Update Versuch - und diesmal durchlaufen lassen?

Prinzipiell sind die Updates - wie bei Windows Produktionsmaschinen auch - erstmal auf ner Testmaschine zu testen, bevor man sie auf ein Produktionssystem loslässt.
Da kann immer was schiefgehen, das nicht vorhersehbar ist.
Bitte warten ..
Mitglied: pierronsky
28.10.2006 um 22:28 Uhr
Ich kann das Update aber nicht mehr starten, da er den Start von YAST nicht zulässt.
Bitte warten ..
Mitglied: 27119
28.10.2006 um 22:47 Uhr
Bestimmt gibts nen Profi-Trick wie man das wieder hinkriegt - jahrelange Erfahrung und viel Fummellust vorrausgesetzt.
Ich würde jedenfalls mir so behelfen, dass du eine Reparatur Installation mit der SUse CD oder DVD machst.
Einfach von CD booten und auf Installation klicken. Er merkt dann dass SUse bereits installiert ist u. bietet eine Reparatur an. Dann kriegst (mit etwas Glück) wieder ein funktionierendes System hin. Bei der Re´paraturinstallation kannst auch genau wählen, WAS repariert werden soll.

Vorher am besten Konfigurationsdateien sichern, bzw. vhost Dateien u. alles was bei Neuinstallation Arbeit machen könnte...

Vielleicht hat ein grösserer Profi als ich aber auch noch nen besseren Tip parat.
Bitte warten ..
Mitglied: primusvs
28.10.2006 um 23:39 Uhr
Guten Abend, pierronsky,

ich hatte damals das Pesch, das mir die Online Aktualiesierung mit Yast Online zwischendurch abgebrochen ist.
Das machte sich genau wie bei dir so bemerkbar, das man Yast nicht mehr aufrufen konnte.

Vielleicht kannst du ja mit dem Linux Tool APT "Advanced Package Tool" noch was retten.

HP: http://linux01.gwdg.de/apt4rpm/

Sobald du APT von CD installiert und die sources.list editiert hast, kannst du mit dem Befehl

apt-get upgrade

dein System aktualisieren.



source.list sollte so aussehen:

ab hier

  1. Repository created by: aptate (version 0.69.3)
  2. At: Sat Oct 28 17:48:27 MEST 2006
  3. More info about aptate at: http://apt4rpm.sourceforge.net
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/10.0-i386 packman packman-i686 wine rpmkeys base java update-drpm update-prpm update extra gnome xorg mozilla openoffice ximian suser-agirardet suser-hthen suser-liviudm suser-rbos suser-crauch suser-jengelh jacklab suser-oc2pus suser-guru suser-gbv usr-local-bin suser-tcousin suser-scorot suser-sbarnin suser-scrute suser-jogley suser-ollakka suser-raoul funktronics kolab kernel-of-the-day kraxel suse-people suse-projects kde3-stable kde-unstable security-prpm security
rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/10.0-i386 packman packman-i686 wine rpmkeys base java update-drpm update-prpm update extra gnome xorg mozil


bis hier


Sollte dies nicht funktionieren, dann führe anschließend wie mein vorredner empfiehl eine Reparaturinstallation durch.


Viel Erfolg

Gruss

primusvs
Bitte warten ..
Mitglied: pierronsky
29.10.2006 um 09:20 Uhr
Hallo primusvs !

Wie kann ich denn dieses Tool ohne Yast installieren?
Bitte warten ..
Mitglied: pierronsky
29.10.2006 um 09:34 Uhr
wenn ich die Installation starte erscheint folgende Meldung:

"Downloading apt and apt-libs packages...
.listing has sprung into existence.
09:33:48 URL: ftp://ftp4.gwdg.de/pub/linux/suse/apt/SuSE/10.0-i386/RPMS.base/apt-0*.i586.rpm [357] -> "apt-0*.i586.rpm" [2]
Q(@Q(@: No such file or directory
unlink: No such file or directory
.listing has sprung into existence.
09:33:50 URL: ftp://ftp4.gwdg.de/pub/linux/suse/apt/SuSE/10.0-i386/RPMS.base/apt-lib ...*.i586.rpm [357] -> "apt-libs-0*.i586.rpm" [2]
Q(@Q(@: No such file or directory
unlink: No such file or directory

Done.
error: open of lrwxrwxrwx failed: No such file or directory
error: open of 1 failed: No such file or directory
error: open of 0 failed: No such file or directory
error: open of 0 failed: No such file or directory
error: open of 19 failed: No such file or directory
error: open of Mar failed: No such file or directory
error: open of 07 failed: No such file or directory
error: open of 2006 failed: No such file or directory
error: open of FOSDEM failed: No such file or directory
"
Bitte warten ..
Mitglied: primusvs
29.10.2006 um 10:03 Uhr
Guten morgen,


lade dir mal von hier in ein Verzeichnis deiner Wahl "apt mit seinen Abhängigkeiten herunter.

HP: http://rpmseek.com/ByDistribution.html?hl=de

Sollten alle Packete in dein Verzeichnis sein, dann führe im Verzeichnis

rpm -uvh *.rpm

So werden alle Packete mit Abhängigkeiten geprüft und installiert.


Viel Erfolg

Gruss

primusvs
Bitte warten ..
Mitglied: pierronsky
29.10.2006 um 13:56 Uhr
Was muss ich da genau von der Seite laden?
Bitte warten ..
Mitglied: 27119
29.10.2006 um 14:00 Uhr
Was muss ich da genau von der Seite laden?

Eben apt mit den abhänigigen paketen. Damit man apt (oder was auch immer) installieren kann, müssen erstmal diverse libs und anderes installiert werden, auf denen apt (oder was auch immer) aufbaut.

Willkommen im Linux Abhängigigkeits-Dschungel! Muhaha.
Stell schonmal den Baldrian kalt.
Bitte warten ..
Mitglied: pierronsky
29.10.2006 um 14:12 Uhr
Also im Moment verstehe ich nur Bahnhof.
Bitte warten ..
Mitglied: primusvs
29.10.2006 um 18:05 Uhr
Hallo pierronsky,

wie schon duno es so schon sagt "Willkommen im Linux Abhängigigkeits-Dschungel"

Alo wenn du als erstes APT herunterlädst und versucht zu installieren, erhällst du wie du oben beschrieben hast eine Fehlermeldung weil:

z.B. apt-libs-0*.i586.rpm diese in Abhängigkeit zu APT dem Programm fehlt.

Diese Meldung werden so lange kommen bis du alle Abhängigkeiten für APT installiert hast.

Mann kann es so vergleichen du besorgst dir für Windows ein Programm und es fehlen zur fertigen installation irgendwelche *.dll (Bibliotheken).

Also solange rpm -uvh apt ........rpm oder rpm -uvh *.rpm ausführen bis keine Fehlermeldung mehr erscheint.


Ich hoffe ich konnte dir das Abhängigkeitsproblem etwas näher bringen.

Gruss

primusvs
Bitte warten ..
Mitglied: 27119
29.10.2006 um 18:45 Uhr
Wenn du apt installieren willst, meldet dir die Shell, welche libs und Pakete fehlen.
Diese musst du eben suchen (online) und nach und nach installieren. Nachdem alle abhängigen Pakete installiert sind, kann man erst apt installieren.

Die als fehlend bemängelten Pakete haben meist jedoch noch andere Abhängigkeiten, so dass dies schon etwas komplizierter ist eine Anwendung unter Linux zu installieren, als unter Windows, wo man nur eine setup.exe ausführt und alles ist gebongt.

Dafür gibts dann die Paketmanager (wie yast oder auch apt) die diese Abhängigkeiten automatisch auflösen können. Damit das bei dir geht, musst du aber wie gesagt erstmal apt installieren, bzw. erstmal alle Pakete installieren, von denen apt abhängt.

Der oft gepriesene Vorteil von Linux Software, dass die Software frei ist und man den Quellcode einsehen kann und bei Bedarf ändern kann ist auch so ne Sache. Klar kann man das - doch welcher normalsterbliche Admin kann schon C++ Quellcode verstehen, geschweigedenn umprogrammieren, bis die Software seine Bedürfnisse deckt?
Doch das ist ein anderes Thema.

Ich glaube mit der Suse CD Reparatur Installation klappts am einfachsten dass dein apache wieder läuft.
Bitte warten ..
Mitglied: pierronsky
29.10.2006 um 19:44 Uhr
Sorry, aber ich glaube ich bin ein wenig überfordert. Wo finde ich die Paketnummern, welche ich noch installieren muss?

Hier die Meldung:

"
Server:/humboldt/files/apt4suse # install-apt4suse
apt-0*.i586.rpm package allready present in working dir.
Remove it...
apt-libs-0*.i586.rpm package allready present in working dir.
Remove it...
Setup apt for SuSE Linux 10.0 on i386...

Downloading apt and apt-libs packages...
.listing has sprung into existence.
19:39:11 URL: ftp://ftp4.gwdg.de/pub/linux/suse/apt/SuSE/10.0-i386/RPMS.base/apt-0*.i586.rpm [357] -> "apt-0*.i586.rpm" [2]
Q(@Q(@: No such file or directory
unlink: No such file or directory
.listing has sprung into existence.
19:39:14 URL: ftp://ftp4.gwdg.de/pub/linux/suse/apt/SuSE/10.0-i386/RPMS.base/apt-lib ...*.i586.rpm [357] -> "apt-libs-0*.i586.rpm" [2]
Q(@Q(@: No such file or directory
unlink: No such file or directory

Done.
error: open of lrwxrwxrwx failed: No such file or directory
error: open of 1 failed: No such file or directory
error: open of 0 failed: No such file or directory
error: open of 0 failed: No such file or directory
error: open of 19 failed: No such file or directory
error: open of Mar failed: No such file or directory
error: open of 07 failed: No such file or directory
error: open of 2006 failed: No such file or directory
error: open of FOSDEM failed: No such file or directory
"
Bitte warten ..
Mitglied: 27119
29.10.2006 um 19:52 Uhr
Das sieht nach einem anderen Problem aus.
Wenn Pakete oder libs fehlen, kommt die Meldung

Failed Dependencies blah.
Install lib-glib-so.blah.so
lib-blahblubb.so

usw.

Sichere deine Dateien von dem Rechner, die dir wichtig sind (beispielsweise mit SCP) und mach eine Reparaturinstallation.
Bitte warten ..
Mitglied: primusvs
29.10.2006 um 20:07 Uhr
Hallo pierronsky,

nichts für Ungut, aber sichere die Dateien wie duna schon sagt und versuche es erst mit der Reparatur, sollte dies nicht hinhauen dann können wir uns ja weiter um das "APT" Problem kümmern.


Gruss

primusvs
Bitte warten ..
Mitglied: 27119
29.10.2006 um 20:20 Uhr
Jo. Das System ist einfach aus dem Tritt, da beim Update offensichtlich teilweise Systemdateien aktualisiert wurden, und zum teil eben nicht.
Bitte warten ..
Ähnliche Inhalte
Apache Server
Probleme mit Apache2 und SSL bzw getssl
gelöst Frage von HenereApache Server1 Kommentar

Hallo zusammen, Umgebung ist ein Ubuntu 14.04 LTS mit Apache2 Ich habe dort verschiedene Webseiten am laufen, unter anderem ...

Apache Server
Apache2 PHP 5.4 Probleme beim Anzeigen der Webseite
gelöst Frage von darkonrwApache Server9 Kommentare

Hallo, ich habe aktuell ein Problem mit einem Rootserver auf diesem läuft Apache 2 PHP 5.4 und mySQL. Html ...

Apache Server
Probleme mit Apache2 beim Versuch auf SSL umzustellen
gelöst Frage von HenereApache Server5 Kommentare

Hallo zusammen, Umgebung Apache2 unter Ubuntu 14.04 LTS Ich habe gestern mich mit Lets Encrypt beschäftigt. Ziel ist es, ...

Java
Probleme beim Start von Eclipse
gelöst Frage von manuel1985Java2 Kommentare

Hallo Gemeinde, ich benötige mal wieder Unterstützung ;-) Im aktuellen Semester steht "objektorientierte Programmierung" mittels Java an. Compiler-Empfehlung der ...

Neue Wissensbeiträge
Batch & Shell

Open Object Rexx: Eine mittlerweile fast vergessene Skriptsprache aus dem Mainframebereich

Information von Penny.Cilin vor 16 StundenBatch & Shell8 Kommentare

Ich kann mich noch sehr gut an diese Skriptsprache erinnern und nutze diese auch heute ab und an noch. ...

Humor (lol)

"gimme gimme gimme": Automatischer Test stolpert über Easter Egg im man-Tool

Information von Penny.Cilin vor 18 StundenHumor (lol)6 Kommentare

Interessant, was man so alles als Easter Egg implementiert. Ist schon wieder Ostern? "gimme gimme gimme": Automatischer Test stolpert ...

MikroTik RouterOS

Mikrotik - Lets Encrypt Zertifikate mit MetaROUTER Instanz auf dem Router erzeugen

Anleitung von colinardo vor 1 TagMikroTik RouterOS8 Kommentare

Einleitung Folgende Anleitung ist aus der Lage heraus entstanden das ein Kunde auf seinem Mikrotik sein Hotspot Captive Portal ...

Sicherheit

Sicherheitslücke in HP-Druckern - Firmware-Updates stehen bereit

Information von BassFishFox vor 1 TagSicherheit1 Kommentar

Ein weiterer Grund, dass Drucker keinerlei Verbindung nach "auswaerts" haben sollen. Unter Verwendung spezieller Malware können Angreifer aus der ...

Heiß diskutierte Inhalte
Windows Server
RDP macht Server schneller???
Frage von JaniDJWindows Server17 Kommentare

Hallo Community, wir betrieben seit geraumer Zeit diverse virtuelle Maschinen und Server mit Windows Server 2012. Leider haben wir ...

Windows 10
Windows 10 dunkler Bildschirm nach Umfallen
Frage von AkcentWindows 1015 Kommentare

Hallo, habe hier einen Windows 10 Rechner der von einem User umgefallen wurde (Beine übers Knie, an den PC ...

Windows 10
Bitlocker nach Verschlüsselung nicht mehr aufrufbar!
gelöst Frage von alexlazaWindows 1013 Kommentare

Hallo, ich besitze ein HP ZBook 17 G4 mit einem Windows 10 Pro Betriebssystem. Bei diesem Problem handelt sich, ...

Batch & Shell
Neuste Datei via PowerShell kopieren
gelöst Frage von kaiuwe28Batch & Shell11 Kommentare

Hallo zusammen, ich hatte mir mit Hilfe der Suche im Forum einen kleinen Code von colinardo rausgesucht und versucht ...