Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Probleme bei täglicher Bandsicherung mit Taper unter Linux 9.3

Frage Linux

Mitglied: Janne226

Janne226 (Level 1) - Jetzt verbinden

30.03.2006 um 13:07 Uhr, 3641 Aufrufe

Cronjobs funktionieren nicht

Hallo zusammen,

ich habe einen Linuxserver 9.3 und zur Datensicherung taper eingerichtet.

Taper funktioniert, wenn ich es manuel starte ohne Probleme, die ausgesuchten Verzeichnisse /daten, /home /bin /etc /lib /root /sbin /usr /var/adm /var/cron /var/lib /var/log /var/spool werden korrekt gesichert. Die Zusammenstellung wurde von taper unter dem Namen system gespeichert und kann auch mit taper restoremodul wieder eingelesen werden. Auf die geschriebenen Daten kann ich dann problemlos zugreifen.

Meine Wunschvorstellung:
Die Bandsicherung soll jede Nacht um Mitternacht durchgeführt werden, die Bänder sollen überschrieben und nichts angehängt werden.


Jetzt kommt mein eigentliches Problem. Egal ob ich einen Cronjob über webmin oder crontab -e anlege, er wird einfach nicht gestartet. Mit crontab -l kann ich den cronjob zwar sehen, aber eine regelmäßige Sicherung erfolgt nicht.

Ich habe mit Vi folgendes Script geschrieben und als taper-backup unter /root/bin gespeichert (dort ist es auch zu finden !!!)

#! /bin/bash

PATH=/sbin:/root:$PATH

taper --tape-overwrite-on --append-off -U @system

Das Script habe ich mit chmod a+x ausführbar gemacht.


in der crontab habe ich es mit folgenden Anweisungen versucht:

Cronjob 1 (webmin)

@daily /root/bin/taper-backup

Cronjob 2 (webmin)

@daily /usr/bin/local/taper-backup

Cronjob 3 (crontab -e)

0 23 * * * /root/bin/taper-backup

Selbstverständlich habe ich jeden Job einzeln getestet und die anderen währenddessen gestoppt (bzw. mit # auskommentiert)


Ich hoffe, ich habe mich deutlich ausgedrückt und mir kann jemand mit taper- und cronjoberfahrung helfen.

Vielen Dank im Voraus

Janne
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
Linux Netzwerk
Linux DNS Probleme (8)

Frage von winlin zum Thema Linux Netzwerk ...

Switche und Hubs
gelöst LAG zwischen SG300-Switches macht Probleme. Wer weiß Rat? (26)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...

SAN, NAS, DAS
gelöst Synology Version 6.1 Probleme (18)

Frage von Hendrik2586 zum Thema SAN, NAS, DAS ...

Heiß diskutierte Inhalte
Linux Netzwerk
gelöst DHCP vergibt keine Adressen (32)

Frage von Maik82 zum Thema Linux Netzwerk ...

CPU, RAM, Mainboards
Kaufberatung für mind. 8 verschiedene HighEnd-Mainboards (20)

Frage von yperiu zum Thema CPU, RAM, Mainboards ...

Mac OS X
Mac kann nicht im LAN pingen alle anderen schon (16)

Frage von smartino zum Thema Mac OS X ...

Hardware
gelöst PCI-Express-Adapterfrage (14)

Frage von DerWoWusste zum Thema Hardware ...