Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Probleme mit Umlaute aus der URL

Frage Internet Hosting & Housing

Mitglied: wundii

wundii (Level 1) - Jetzt verbinden

17.04.2008, aktualisiert 26.04.2008, 3556 Aufrufe, 1 Kommentar

Hallo,

ich bin seit gestern auf der Suche nach einer Lösung des Problems, leider ohne Erfolg.

Eigener Server
Windows Server 2003, mit IIS.
PHP 5.2.3

Zum Problem,
wenn ein Umlaut über die URL als Parameter einer Variable mitgeben wird, wird diese bei der Übergabe entfernt.

www.domain.de/index.php?var=123ä456

In diesem Fall wird das "ä" komplett bei der Übergabe zum Script/Seite geblockt/entfernt und bei der Auslese wird nur "123456" angezeigt. Somit hat urldecode()/urlencode() keine Wirkung das der Umlaut fehlt. Ich habe mit "charset" und diversen anderen Befehle probiert, ohne Erfolg.

Jetzt stelle ich mir die ganze Zeit die Frage wo da der Fehler liegt. Leider habe ich so ein Problem noch nie gehabt und jede Suche mit meiner Vermutung und Wissen war erfolglos.

Vielen dank schon einmal im Voraus.

MfG
Andi
Mitglied: mymazl
26.04.2008 um 10:52 Uhr
Hi Andi,

komisches Problem. Hab grad mal ein Testscript unter Linux gebastelt und da funktioniert es ohne Probleme.

Probier es mal mit:
www.domain.de/index.php?var=123%E4567

E4 ist ASCII für ä.

Wenn du das ganze mal über mein Script auf LINUX testen willst, hier der Link:
http://www.mymazl.de/test.php?test=123%E4567

Es wird einfach nur die Variabe test ausgegeben.

Gruß
Marcel
Bitte warten ..
Ähnliche Inhalte
Windows 7
Performance Probleme bei Programmen und Windows (10)

Frage von Kunzi333 zum Thema Windows 7 ...

PHP
Je nach angefragter Url einen anderen Titel einfügen (11)

Frage von Snowboarder1994 zum Thema PHP ...

Windows 10
gelöst Win10 Creators Update - Probleme mit Netzwerkkarten (13)

Frage von Fenris14 zum Thema Windows 10 ...

Neue Wissensbeiträge
Tipps & Tricks

Wie Hackt man sich am besten in ein Computernetzwerk ein

(29)

Erfahrungsbericht von Herbrich19 zum Thema Tipps & Tricks ...

Humor (lol)

Bester Vorschlag eines Supporttechnikers ever: APC

(15)

Erfahrungsbericht von DerWoWusste zum Thema Humor (lol) ...

Windows Server

Exchange 2010 Active Directory und Windows Server 2016

(4)

Erfahrungsbericht von Herbrich19 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Internet
gelöst Mitarbeiter surft auf unerwünschter Seite - Wie damit umgehen? (38)

Frage von sabines zum Thema Internet ...

Netzwerke
Wie erstelle ich ein Intranet (19)

Frage von Leonardnet zum Thema Netzwerke ...

LAN, WAN, Wireless
gelöst Eintägige Netzwerkunterbrechung trotz Backupleitung (15)

Frage von iAmbricksta zum Thema LAN, WAN, Wireless ...

Netzwerke
VPN-Server einrichten PPTPD-Einrichtung gescheitert (15)

Frage von MIlexx zum Thema Netzwerke ...