Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Probleme mit Umlauten in einem SQL String

Frage Entwicklung PHP

Mitglied: DORNI

DORNI (Level 1) - Jetzt verbinden

11.06.2007, aktualisiert 11:40 Uhr, 6188 Aufrufe, 2 Kommentare

Bei zusammenbau aus POST Variablen problem
Bei Händisch reinschreiben Funktion

Hallo habe folgendes Problem ich will ein Update in einer Datenbank vornehmen soweit kein Thema. Es klappt auch solange ich im Tabellennamen keinen Umlaut habe.

Code:
01.
$sql = "UPDATE `" . $_POST[tabelle] . "` SET `" . $_POST[feld] . "` = " . $wert . " WHERE `name` = '" . $_POST[name] . "' LIMIT 1;"
02.
 
03.
echo $sql
04.
 
05.
mysql_query($sql); 
06.
$num = mysql_affected_rows(); 
07.
		if ($num>0) 
08.
			echo "<p>Es wurde 1 Datensatz hinzugef&uuml;gt</p>"
09.
		else 
10.
11.
			echo "<p>Es ist ein Fehler aufgetreten, "
12.
			echo "es wurde kein Datensatz hinzugef&uuml;gt</p>"
13.
		}
Anzeige bei Tabelle mit Umlaut:
01.
UPDATE `elite` SET `Ätherwunder` = 1 WHERE `name` = 'Test Ritualist' LIMIT 1; 
02.
 
03.
Es ist ein Fehler aufgetreten, es wurde kein Datensatz hinzugefügt
Wenn ich jetzt händisch hergehe und den angezeigten UPDATE-Befehl der Variablen $sql zuweise also so:
01.
$sql = "UPDATE `elite` SET `Ätherwunder` = 1 WHERE `name` = 'Test Ritualist' LIMIT 1;"
02.
 
03.
echo $sql
04.
 
05.
mysql_query($sql); 
06.
$num = mysql_affected_rows(); 
07.
		if ($num>0) 
08.
			echo "<p>Es wurde 1 Datensatz hinzugef&uuml;gt</p>"
09.
		else 
10.
11.
			echo "<p>Es ist ein Fehler aufgetreten, "
12.
			echo "es wurde kein Datensatz hinzugef&uuml;gt</p>"
13.
		}
werde ich mit einer Erfolgsmeldung belohnt:
01.
UPDATE `elite` SET `?therwunder` = 1 WHERE `name` = 'Test Ritualist' LIMIT 1; 
02.
 
03.
Es wurde 1 Datensatz hinzugefügt
Ich weis es liegt am Umlaut. Ich weis nur nicht wie ich das lösen kann. Grübel und Google schon das ganze Wochenende darüber. Vielleicht hat ja jemand von euch das Problem schon gehabt und weis eine Lösung.
Mitglied: 7ImeI7
11.06.2007 um 10:24 Uhr
Fuer Dein Problem gibt es mehhrere Loesungen.
Eines davon ist es die Texte ins HTML Format zu bringen (URL-Encode).
Anderes die Scripte als auch die DB-Connection ins UTF-8.
usw
Bitte warten ..
Mitglied: DORNI
11.06.2007 um 11:40 Uhr
Danke das mit dem URL-Encode hat mich weitergebracht
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(1)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
Windows Server
Sql server 2014 probleme

Frage von meister00 zum Thema Windows Server ...

Datenbanken
gelöst SQL - mehrere UPDATE-Anweisungen in einem String per vbs (4)

Frage von goodbytes zum Thema Datenbanken ...

Datenbanken
SQL Express - der Benutzer war nicht autorisiert (3)

Frage von adm999 zum Thema Datenbanken ...

Switche und Hubs
LAG zwischen SG300-Switches macht Probleme. Wer weiß Rat? (15)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...

Heiß diskutierte Inhalte
Hyper-V
gelöst Reiner Hyper- V Server oder lieber Rolle (28)

Frage von Winuser zum Thema Hyper-V ...

Exchange Server
gelöst Bestehende eMails autoamatisch weiterleiten (22)

Frage von metal-shot zum Thema Exchange Server ...

Apache Server
gelöst Lets Encrypt SSL mit Apache2 (20)

Frage von banane31 zum Thema Apache Server ...

SAN, NAS, DAS
gelöst Synology Version 6.1 Probleme (18)

Frage von Hendrik2586 zum Thema SAN, NAS, DAS ...