Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Probleme mit Umlauten in einem SQL String

Frage Entwicklung PHP

Mitglied: DORNI

DORNI (Level 1) - Jetzt verbinden

11.06.2007, aktualisiert 11:40 Uhr, 6194 Aufrufe, 2 Kommentare

Bei zusammenbau aus POST Variablen problem
Bei Händisch reinschreiben Funktion

Hallo habe folgendes Problem ich will ein Update in einer Datenbank vornehmen soweit kein Thema. Es klappt auch solange ich im Tabellennamen keinen Umlaut habe.

Code:
01.
$sql = "UPDATE `" . $_POST[tabelle] . "` SET `" . $_POST[feld] . "` = " . $wert . " WHERE `name` = '" . $_POST[name] . "' LIMIT 1;"
02.
 
03.
echo $sql
04.
 
05.
mysql_query($sql); 
06.
$num = mysql_affected_rows(); 
07.
		if ($num>0) 
08.
			echo "<p>Es wurde 1 Datensatz hinzugef&uuml;gt</p>"
09.
		else 
10.
11.
			echo "<p>Es ist ein Fehler aufgetreten, "
12.
			echo "es wurde kein Datensatz hinzugef&uuml;gt</p>"
13.
		}
Anzeige bei Tabelle mit Umlaut:
01.
UPDATE `elite` SET `Ätherwunder` = 1 WHERE `name` = 'Test Ritualist' LIMIT 1; 
02.
 
03.
Es ist ein Fehler aufgetreten, es wurde kein Datensatz hinzugefügt
Wenn ich jetzt händisch hergehe und den angezeigten UPDATE-Befehl der Variablen $sql zuweise also so:
01.
$sql = "UPDATE `elite` SET `Ätherwunder` = 1 WHERE `name` = 'Test Ritualist' LIMIT 1;"
02.
 
03.
echo $sql
04.
 
05.
mysql_query($sql); 
06.
$num = mysql_affected_rows(); 
07.
		if ($num>0) 
08.
			echo "<p>Es wurde 1 Datensatz hinzugef&uuml;gt</p>"
09.
		else 
10.
11.
			echo "<p>Es ist ein Fehler aufgetreten, "
12.
			echo "es wurde kein Datensatz hinzugef&uuml;gt</p>"
13.
		}
werde ich mit einer Erfolgsmeldung belohnt:
01.
UPDATE `elite` SET `?therwunder` = 1 WHERE `name` = 'Test Ritualist' LIMIT 1; 
02.
 
03.
Es wurde 1 Datensatz hinzugefügt
Ich weis es liegt am Umlaut. Ich weis nur nicht wie ich das lösen kann. Grübel und Google schon das ganze Wochenende darüber. Vielleicht hat ja jemand von euch das Problem schon gehabt und weis eine Lösung.
Mitglied: 7ImeI7
11.06.2007 um 10:24 Uhr
Fuer Dein Problem gibt es mehhrere Loesungen.
Eines davon ist es die Texte ins HTML Format zu bringen (URL-Encode).
Anderes die Scripte als auch die DB-Connection ins UTF-8.
usw
Bitte warten ..
Mitglied: DORNI
11.06.2007 um 11:40 Uhr
Danke das mit dem URL-Encode hat mich weitergebracht
Bitte warten ..
Ähnliche Inhalte
Windows Server
Sql server 2014 probleme

Frage von meister00 zum Thema Windows Server ...

Microsoft
gelöst Licensing Server SQL 2014 (6)

Frage von TECHGENE zum Thema Microsoft ...

Windows Server
gelöst SQLExpress Probleme bei Backup (4)

Frage von Alternativende zum Thema Windows Server ...

Windows Server
Netzwerkdrucker Probleme mit Windows Server 2012 R2 in RDP-Farm (7)

Frage von TiTux zum Thema Windows Server ...

Neue Wissensbeiträge
Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(9)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Windows 10

Das Windows 10 Creators Update ist auf dem Weg

(6)

Anleitung von BassFishFox zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Batch & Shell
gelöst ZIP-Archive nach Dateien durchsuchen und Pfade ausgeben (33)

Frage von evinben zum Thema Batch & Shell ...

Router & Routing
Routingproblem in Homerouter-Kaskade mit Raspi (19)

Frage von Oldschool zum Thema Router & Routing ...

Server
Freenas schlechte Schreib Performance bei NFS (16)

Frage von janosch12 zum Thema Server ...

LAN, WAN, Wireless
Buffolo AccessPoint IP vergessen - herausfinden (9)

Frage von staybb zum Thema LAN, WAN, Wireless ...