Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Probleme mit userid

Frage Internet Server

Mitglied: Trubadix

Trubadix (Level 1) - Jetzt verbinden

31.07.2006, aktualisiert 23.08.2006, 3867 Aufrufe, 3 Kommentare

Hallo,
bei mir tritt beim Aufruf des BackupPC CGI Skripts folgender Fehler auf:

Error: Wrong user: my userid is 48, instead of 502(backuppc)

This script needs to run as the user specified in $Conf{BackupPCUser}, which is set to backuppc.

This is an installation problem. If you are using mod_perl then it appears that Apache is not running as user backuppc. If you are not using mod_perl, then most like setuid is not working properly on BackupPC_Admin. Check the permissions on /var/www/cgi-bin/BackupPC_Admin and look at the documentation.

Die aufgeführten Punkte habe ich schon alle abgearbeitet. -> Leider brachte dies nicht den gewünschten Erfolg. Gibt es eigentlich die Möglichkeit die userid für einen Prozeß so zu ändern???


Gruß

Daniel
Mitglied: 6890
31.07.2006 um 17:59 Uhr
hallöchen,

meine erste frage, is die variable $Conf{BackupPCUser} wirklich auf backuppc gesetzt in der config. vieleicht hast du ja die möglichkeit die Variable ausgeben zu lassen??!!

ansonsten wäre mein vorschlag das du dem script wie sie es auch schon beschreiben mit dem setuid bit zu versehen.

mfg godlike P
Bitte warten ..
Mitglied: Trubadix
06.08.2006 um 21:05 Uhr
Die Variable wurde auf den User backuppc gesetzt. Den Fehler habe ich gefunden. Der Apache wurde nicht unter der ID des Benutzers bacluppc ausgeführt. Läuft jedtzt alles bestens. Vielen Dank für die Hilfe
Bitte warten ..
Mitglied: michaXXL
23.08.2006 um 20:12 Uhr
Hallo,
ich habe das selbe Problem und ich bin noch ziemlich neu im Linuxbereich.
Wie hast du den Apache dazu bewegt, unter der ID backuppc zu laufen.
Wäre für Hilfe sehr dankbar.
Gruß Michael

PS: hat sich erledigt, habe das setuid-bit gesetzt. Manchmal dauert es halt ein bischen.
Danke !!!
Bitte warten ..
Ähnliche Inhalte
Exchange Server
Probleme mit Exchange-Dienste, E-Mails sind nicht angekommen (2)

Frage von cramtroni zum Thema Exchange Server ...

Windows Server
gelöst SQLExpress Probleme bei Backup (4)

Frage von Alternativende zum Thema Windows Server ...

Linux
Probleme beim Autostart Icewiesel im Vollbildmodus (1)

Frage von Thomas91 zum Thema Linux ...

Neue Wissensbeiträge
Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(4)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(9)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Heiß diskutierte Inhalte
Exchange Server
Exchange 2016 Standard Server 2012 R2 Hetzner Mail (41)

Frage von Datsspeed zum Thema Exchange Server ...

Windows 7
gelöst Lokales Adminprofil defekt (25)

Frage von Yannosch zum Thema Windows 7 ...

LAN, WAN, Wireless
gelöst Statische Routen mit ISC-DHCP Server für Android Devices (20)

Frage von terminator zum Thema LAN, WAN, Wireless ...