Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Probleme mit vHosts unter Debian

Frage Linux Debian

Mitglied: novedad

novedad (Level 1) - Jetzt verbinden

27.09.2011, aktualisiert 15:45 Uhr, 2185 Aufrufe, 4 Kommentare

Habe 2 Domains die ich per vHosts in 2 unterschiedliche Verzeichnisse leiten will.
Also vHosts geschrieben, aktiviert und apache neu gestartet

und trotzdem lande ich nur auf der Testseite von apache sowohl mit www als auch ohne

meine vHosts sehen so aus:

01.
<VirtualHost * > 
02.
ServerAdmin info@domain1.de 
03.
ServerName www.domain1.de 
04.
ServerAlias domain1.de *.domain1.de 
05.
DocumentRoot /var/www/domain1 
06.
<Directory /var/www/domain1> 
07.
Order Deny,Allow 
08.
Allow from all 
09.
Options -Indexes 
10.
</Directory> 
11.
</VirtualHost> 
12.
 
13.
<VirtualHost * > 
14.
ServerAdmin info@domain2.de 
15.
ServerName www.domain2.de 
16.
ServerAlias domain2.de *.domain2.de 
17.
DocumentRoot /var/www/domain2 
18.
<Directory /var/www/domain2> 
19.
Order Deny,Allow 
20.
Allow from all 
21.
Options -Indexes 
22.
</Directory> 
23.
</VirtualHost>
Mitglied: dog
27.09.2011 um 16:33 Uhr
Wo ist die NameVirtualHost-Anweisung?
Bitte warten ..
Mitglied: novedad
27.09.2011 um 16:46 Uhr
hab ich jetzt noch eingefügt

01.
 NameVirtualHost *:80
außerdem hab ich in die VirtualHost-Blöcke noch ein :80 eingefügt

01.
 <VirtualHost *:80> 
nun komme ich per www.domain1.de auf die Haupseite, wenn ich aber http://domain1.de eingebe erscheint immer noch die apache testseite

bei domain2 funktioniert nun sowohl http als auch www
Bitte warten ..
Mitglied: novedad
02.10.2011 um 17:22 Uhr
hat denn keiner noch eine idee?
Bitte warten ..
Mitglied: dog
02.10.2011 um 18:22 Uhr
Du hast irgendwo noch einen anderen VirtualHost definiert.
Bei der Einstellung NameVirtualHost *:80 wird der Standardserver deaktiviert und ausschließlich die VirtualHosts ausgewertet (und davon der erste genommen, wenn keiner auf den Namen passt)
Bitte warten ..
Ähnliche Inhalte
Exchange Server
Probleme mit Exchange-Dienste, E-Mails sind nicht angekommen (2)

Frage von cramtroni zum Thema Exchange Server ...

Windows Server
gelöst SQLExpress Probleme bei Backup (4)

Frage von Alternativende zum Thema Windows Server ...

Linux
Probleme beim Autostart Icewiesel im Vollbildmodus (1)

Frage von Thomas91 zum Thema Linux ...

Neue Wissensbeiträge
Google Android

Cyanogenmod alternative Downloadquelle

(5)

Tipp von Lochkartenstanzer zum Thema Google Android ...

Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(5)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Heiß diskutierte Inhalte
Server
gelöst Wie erkennen, dass nur deutsche IPs Zugang zu einer Website haben? (22)

Frage von Coreknabe zum Thema Server ...

Hardware
16-20 Port POE Switch mit VLAN (19)

Frage von thomasreischer zum Thema Hardware ...

Windows Server
gelöst Exchange HyperV Prozessorlast (19)

Frage von theoberlin zum Thema Windows Server ...

Windows Userverwaltung
Nicht Administratoren Installation von Software erlauben (14)

Frage von WinLiCLI zum Thema Windows Userverwaltung ...