Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Probleme mit VPN beim Draytek Vigor 2710

Frage Netzwerke Router & Routing

Mitglied: Thomas67

Thomas67 (Level 1) - Jetzt verbinden

12.08.2011, aktualisiert 18.10.2012, 8947 Aufrufe, 11 Kommentare

Hallo,
Ich versuche verzweifelt mit Win XP, Win7 oder Server 2003 einen VPN Tunnel zu meinem 2710 aufzubauen. Die Verbindung kommt zwar an meinem Router an, aber es wird kein Tunnel aufgebaut. Ich habe den Router nach der FAQ bei Drytek konfiguriert und auch das XP nach der Faq. Es ist weder eine Verbindung mit dem Draytek small Client möglich noch mit den Bordmitteln von Windows. Folgendes kann ich dem Vigor per Syslog entlocken:

08-11-2011 17:42:27 Local1.Notice 192.168.0.254 Aug 11 17:42:26 TPC_Vigor: PPTP (VPN-0) ==> Protocol:LCP(c021) ConfReq Identifier:0x0C Authentication Type: CHAP 81 Magic Number: 0x1 ##
08-11-2011 17:42:24 Local1.Notice 192.168.0.254 Aug 11 17:42:23 TPC_Vigor: PPTP (VPN-0) ==> Protocol:LCP(c021) ConfReq Identifier:0x0B Authentication Type: CHAP 81 Magic Number: 0x1 ##
08-11-2011 17:42:21 Local1.Notice 192.168.0.254 Aug 11 17:42:20 TPC_Vigor: PPTP (VPN-0) ==> Protocol:LCP(c021) ConfReq Identifier:0x0A Authentication Type: CHAP 81 Magic Number: 0x1 ##
08-11-2011 17:42:18 Local1.Notice 192.168.0.254 Aug 11 17:42:17 TPC_Vigor: PPTP (VPN-0) ==> Protocol:LCP(c021) ConfReq Identifier:0x09 Authentication Type: CHAP 81 Magic Number: 0x1 ##
08-11-2011 17:42:15 Local1.Notice 192.168.0.254 Aug 11 17:42:14 TPC_Vigor: PPTP (VPN-0) ==> Protocol:LCP(c021) ConfReq Identifier:0x08 Authentication Type: CHAP 81 Magic Number: 0x1 ##
08-11-2011 17:42:12 Local1.Notice 192.168.0.254 Aug 11 17:42:11 TPC_Vigor: PPTP (VPN-0) ==> Protocol:LCP(c021) ConfReq Identifier:0x07 Authentication Type: CHAP 81 Magic Number: 0x1 ##
08-11-2011 17:42:09 Local1.Notice 192.168.0.254 Aug 11 17:42:08 TPC_Vigor: PPTP (VPN-0) ==> Protocol:LCP(c021) ConfReq Identifier:0x06 Authentication Type: CHAP 81 Magic Number: 0x1 ##
08-11-2011 17:42:06 Local1.Notice 192.168.0.254 Aug 11 17:42:05 TPC_Vigor: PPTP (VPN-0) ==> Protocol:LCP(c021) ConfReq Identifier:0x05 Authentication Type: CHAP 81 Magic Number: 0x1 ##
08-11-2011 17:42:03 Local1.Notice 192.168.0.254 Aug 11 17:42:02 TPC_Vigor: PPTP (VPN-0) ==> Protocol:LCP(c021) ConfReq Identifier:0x04 Authentication Type: CHAP 81 Magic Number: 0x1 ##
08-11-2011 17:42:00 Local1.Notice 192.168.0.254 Aug 11 17:41:59 TPC_Vigor: PPTP (VPN-0) ==> Protocol:LCP(c021) ConfReq Identifier:0x03 Authentication Type: CHAP 81 Magic Number: 0x1 ##
08-11-2011 17:41:57 Local1.Notice 192.168.0.254 Aug 11 17:41:56 TPC_Vigor: PPTP (VPN-0) ==> Protocol:LCP(c021) ConfReq Identifier:0x02 Authentication Type: CHAP 81 Magic Number: 0x1 ##
08-11-2011 17:41:54 Local1.Notice 192.168.0.254 Aug 11 17:41:53 TPC_Vigor: PPTP (VPN-0) ==> Protocol:LCP(c021) ConfReq Identifier:0x01 Authentication Type: CHAP 81 Magic Number: 0x1 ##
08-11-2011 17:41:51 Local1.Notice 192.168.0.254 Aug 11 17:41:50 TPC_Vigor: PPTP (VPN-0) ==> Protocol:LCP(c021) ConfReq Identifier:0x00 Authentication Type: CHAP 81 Magic Number: 0x1 ##
08-11-2011 17:41:51 Local1.Notice 192.168.0.254 Aug 11 17:41:50 TPC_Vigor: PPP Start ()


Es funktioniert auch nicht wenn ich anstatt über Dyndns die IP direkt eingebe.

Was funktioniert hier nicht ? Ich möchte nur einen einfachen Tunnel aufbauen, um per RDP auf meine Server zugreifen zu können. Das komische ist noch das der Zugang mit meinem Galaxy TAB unter Android FUNKTIONIERT !


Im Anhang ist ein Bild mit den Einstellungen am Vigor.

Ich hoffe, das ihr mir helfen könnt.

Thomas

fc100e8fef3854df92a2190aaeb347d3 - Klicke auf das Bild, um es zu vergrößern
Mitglied: Sierjoerg
12.08.2011 um 08:54 Uhr
Hallo Thomas,
hast du mal versucht deinen Server zu Pingen? Ich meine damit von deinem Remote Desktop zum Server! Es könnte doch sein das der Tunnel funktioniert aber der RDP Port gesperrt ist! Da fählt mir ein, willst du per Remote Desktop von Windows auf deinen Server zugreifen oder über eine Software eines Drittanbieters?
Bitte warten ..
Mitglied: aqui
12.08.2011, aktualisiert 18.10.2012
Wenn du PPTP verwendest benötigst du den Small Client nicht, der ist dann überflüssig und solltest du besser entfernen, damit er sich nicht beharkt mit dem PPTP Client den alle Betriebssysteme an Bord haben !
Die exakte Konfiguration findest du hier:
http://alt.draytek.de/Beispiele_html/VPN/XP-Vigor-PPTP.htm
Diese funktioniert auf Anhieb mit allen Winblows on Board Clients wenn man die folgenden Punkte zwingend beachtet:
http://www.administrator.de/wissen/vpns-einrichten-mit-pptp-117700.html ...
Wichtig ist den "VPN Typ" NICHT auf Auto stehen zu lassen !
Das die neueste und aktuellste Firmware auf dem Vigor geflasht ist sollte dir auch klar sein ! 3.3.61 http://www.draytek.de/downloads/firmware.html
Bitte warten ..
Mitglied: Thomas67
12.08.2011 um 17:29 Uhr
Hallo aqui,
Vielen Dank für Deine ausführliche Antwort. Das Dokument von Draytek habe ich schon gekannt. Trotzdem habe ich alles nochmals streng kontrolliert.
Die Einstellungen für die OnBoard Clients habe ich auch gemacht, die kannte ich noch nicht. Ich habe es jetzt von einem W2003 Server aus versucht,
der keinen Client drauf hat. Auch nach der Anleitung von Drytek und den Änderungen die Du verlinkt hast. Alles ohne Erfolg Es hat sich nichts geändert.
Auch die Firmware habe ich kontrolliert, sie stimmt überein. Die Anfrage sehe ich weiterhin im Syslog, aber der Router macht keine Anstalten das Tznnel aufzubauen.
Noch einen Rat ?

Gruß,
Thomas
Bitte warten ..
Mitglied: Thomas67
12.08.2011 um 17:31 Uhr
Hallo Sirjoerg,
der Router baut die Verbindung gar nicht auf. Deshalb kann ich auch nicht pingen.
Ich werd echt noch zum Hirsch.

Gruss,
Thomas
Bitte warten ..
Mitglied: aqui
12.08.2011 um 17:59 Uhr
Ein Kardinalsfehler hast du noch gemacht, denn was soll der Sinn sein wenn du im Vigor Setting (Screenshot) auch IPsec und L2TP angehakt hast. Das ist ja unsinnig wenn du nur PPTP machst ! Besser entfernst du das also.
Leider zeigt dein Syslog keine vollständige PPTP Session bzw. deren Aufbau so das man den Fehler nicht erkennen kann. Ist vor dem Router noch irgend was anderes (Kaskadierter Router) oder hängt der Vigor direkt am Internet ?
Win 7, XP und OS-X funktionieren hier fehlerlos damit !
Bitte warten ..
Mitglied: Thomas67
12.08.2011 um 18:53 Uhr
Die Häckchen habe ich raus gemacht. Ohne Erfolg.
Die PPTP Session wird ja auch nicht aufgebaut. Das ist das Protokoll das der Router schreibt wenn der VPN Client "anklopft". Der Router hängt direkt am Internet.
Und mit Android funktioniert ja alles !
Bitte warten ..
Mitglied: aqui
12.08.2011 um 19:01 Uhr
Hast du testweise in den PPTP Client Settings im Protokoll einmal die verschlüsselung auf Optional gesetzt und mal alle 3 Varianten des Handshaking Protokolls ausprobiert.
Wenn es mit dem Android fehlerfrei funktioniert bleibt die Frage offen ob der Android sich im selben Netzwerk befindet wie der MS Client oder ob die unterschiedliche Zugänge nutzen wie UMTS/GSM Netz und der andere ein remotes LAN über NAT Router.
Wenn das nicht der Fall ist und beide das exakt gleiche Zugangsnetz benutzen, dann liegt der Fehler klar in den verwendeten Protokollen beim PPTP !
Du musst dann mal etwas härtere Geschütze auffahren:
Sniffer mit dem Wireshark einmal einen erfolgreichen PPTP Verbindungsaufbau mit dem Android mit.
Dasgleiche machst du dann mit dem MS Client.
Anhand der Sniffer Traces kannst du dann sofort sehen wo der Hase im Pfeffer liegt.
Bitte warten ..
Mitglied: Thomas67
12.08.2011 um 19:13 Uhr
Ich habe mit der Verschlüßelung und den Protokollen rumgespielt. Ohne Erfolg.
Das Android hängt im Telekom UMTS Netz.
Meine Testclients hängen entweder im Vodaphone UMTS Netz (N24 Stick)
Oder der W2003 Server hängt direkt an einem Business DSL Anschluss der Telekom.
Bitte warten ..
Mitglied: aqui
12.08.2011, aktualisiert 18.10.2012
Gut, bei den UMTS Clients besteht die Gefahr das du dort einen billigen Surf Account benutzt. Da kann es dann zu 2 Problemen kommen:
1.) Der Mobilprovider vergibt RFC 1918 IPs und macht zentrales NAT. Da können PPTP Pakete die NAT Firewall nicht passieren:
http://www.administrator.de/forum/vpn-per-umts-karte-tunnel-steht-aber- ...
2.) Bei Surf Accounts werden in der Regel oft alle oder einzelne VPN Prokolle gefiltert, da sie nur den Business Accounts vorbehalten sind.
Da der Android das aber klaglos erledigt scheint das sich auszuschliessen.
Vom DSL Account sollte es immer klappen. Es sei denn.....
Vor dem W2k3 Server hängt ein dummer NAT Router der kein VPN Passthrough supportet. Dann scheitert die PPTP Verbindung !
Auch wenn er VPN Passthrough supportet und kein sauberes Session Reset macht der gecachten GRE Session im PPTP blockiert er alle weiteren GRE Sessions.
Ggf. hilft hier also ein Kaltstart des Routers. Bzw. wenn der Router kein VPN Passthrough supportet dann klappt PPTP nur mit 2 statischen Port Forwarding Einträgen für TCP 1723 und das GRE Protokoll auf die lokale IP des VPN Clients.
Das könnte ein möglicher Fehler sein, da der Android funktioniert. Zusätzlich sieht man oben im Syslog nur einzig LCP Pakte kein einziges GRE Paket was diesen Verdacht erhärtet !
Wie gesagt: Sniffer anschliessen und nachsehen was bei beiden Varianten am Vigor reinkommt. Das klärt das Problem in Sekunden.
Bitte warten ..
Mitglied: Thomas67
12.08.2011 um 19:27 Uhr
Vielen Dank für Deine Ausführungen erstmal. Ich werde den Sniffer probieren.
Ich werde morgen mal mein Notebook schnappen und an einen Telekom Hotspot fahren und es von dort aus ohne den UMTS Stick versuchen.
Bin gespannt ob das geht.

DANKE !

Gruß,
Thomas
Bitte warten ..
Mitglied: aqui
13.08.2011 um 11:02 Uhr
Birgt aber auch den Fehler das du dort den Router nicht kennst. Ist das einer der VPN Passthrough nicht kann sitzt du in derselben Falle ! Allerdings ist das recht ungewöhnlich bei einem Telekom Hotspot. Die Chance das es damit klappt ist also einigermaßen sicher...zumal wenn es am gleichen Hotsport mit dem Android klappt !
Bitte warten ..
Ähnliche Inhalte
Router & Routing
VPN DrayTek Vigor 2960
Frage von ZappBrannigenRouter & Routing

Hallo, ich bin dabei einen Router einzurichten, es handelt sich um einen DrayTek Vigor 2960. Es funktioniert soweit fast ...

Router & Routing
DrayTek 2960 VPN Probleme
gelöst Frage von Rolf-Hanka.ITDRouter & Routing9 Kommentare

Hallo Leute, ich habe mal ein Problem. Zum Setup: 1x DrayTek Vigor 2960 Router ( aktuellste Firmware ) 1x ...

Router & Routing
Routing Draytek VIGOR 2960
Frage von bastij1507Router & Routing10 Kommentare

Hallo zusammen, ich habe ein Problem mit dem Routing an meinem Draytek Vigor 2960 Router. Ich habe zwei Netze ...

Router & Routing
VPN Konfiguration für Draytek Vigor direkt an SBS 2011
gelöst Frage von KLinnebankRouter & Routing4 Kommentare

Hallo zusammen, ich habe die Suchfunktion benutzt, leider kein Erfolg, deswegen traue ich mich mal meine Frage zu stellen: ...

Neue Wissensbeiträge
Internet

Was nützt HTTPS, wenn es auch von Phishing Web-Seiten genutzt wird

Information von Penny.Cilin vor 2 TagenInternet17 Kommentare

HTTPS richtig einschätzen Ob man eine Webseite via HTTPS aufruft, zeigt ein Schloss neben der Adresse im Webbrowser an. ...

Webbrowser

Bugfix für Firefox Quantum released - Installation erfolgt teilweise nicht automatisch!

Erfahrungsbericht von Volchy vor 4 TagenWebbrowser8 Kommentare

Hallo zusammen, gem. dem Artike von heise online wurde mit VersionFirefox 57.0.1 sicherheitsrelevante Bugs behoben. Entgegen der aktuellen Veröffentlichung ...

Sicherheit

Teamviewer Sessions können gekapert werden - Update tw. verfügbar

Information von sabines vor 4 TagenSicherheit6 Kommentare

In bestimmten Konstellationen können Teamviewer Sessions gekapert werden, wahrscheinlich aber ein recht unwahrscheinliches Szenario. Da der Teamviewer gerne für ...

Digitiales Fernsehen

Apple TV: Amazon Prime App ist verfügbar

Information von Frank vor 4 TagenDigitiales Fernsehen4 Kommentare

Die Amazon Prime Video App kann ab sofort auf einem Apple TV ab der 3 Generation installiert werden. Einfach ...

Heiß diskutierte Inhalte
Vmware
Installation Windows 10 VMware
Frage von Ghost108Vmware17 Kommentare

Hallo zusammen, versuche gerade mit Hilfe des vshpere clients eine virtuelle Windows 10 maschine aufzusetzen. 1. virtuelle Maschine erstellt ...

Exchange Server
SBS 2011 E-Mails können gesendet werden, aber nicht von extern empfangen
Frage von andreas1234Exchange Server14 Kommentare

Hallo Community, ich habe das Problem, dass seit knapp zwei Wochen die E-Mails von meinem SBS 2011 einwandfrei gesendet ...

Voice over IP
Telefonstörung - Ortsrufnummern kein Verbindungsaufbau
Frage von Windows10GegnerVoice over IP10 Kommentare

Hallo, sowohl bei uns als auch beim Opa ist es über VoIP nicht möglich Ortsrufnummern anzurufen. Es kommt nach ...

Windows Server
Server 2012 über Eingabeaufforderung devmgmt.msc geht nicht
gelöst Frage von achim222Windows Server9 Kommentare

Hallo, ich habe hier einen Server 2012 der im Reparaturmodus startet. Es liegt an einem falschen VirtIO Treiber für ...