Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Probleme mit VPN-Zugriff Windows 7 auf SBS 2003

Frage Microsoft Windows Server

Mitglied: fritz-r

fritz-r (Level 1) - Jetzt verbinden

25.11.2009 um 15:29 Uhr, 10874 Aufrufe, 7 Kommentare

Kleines Netzwerk, SBS 2003, intern 4 Arbeitsplätze (Windows XP), Internet-Anbindung über Router Linksys AG241, läuft problemlos. Jetzt möchte ich extern per VPN auf den Server zugreifen. Das geht einwandfrei, getestet mit mehreren Rechnern unter Windows XP Home, hinter Fritzbox als Router.

Mache ich exakt das Gleiche mit einem Rechner, auf dem Windows 7 Home Premium (heißt glaube ich so) installiert ist, dann habe ich folgendes Ergebnis:

1. Verbindungsaufbau (über "Verbindung mit Small Business Server herstellen") klappt ohne Fehlermeldung.

2. Zugriff auf den Server (über Remotedesktopverbindung) klappt ebenfalls.

3. Netzlaufwerk verbinden (auf Server) klappt ebenfalls.

4. Auf dem Netzlaufwerk kann ich Directories listen, ich kann davon lesen.

5. Schreibzugriffe (im Windows Explorer Datei vom lokalen Rechner auf Netzlaufwerk kopieren) enden mit der nichtssagenden Fehlermeldung:

"Beim Zugriff auf Z:\Test\ ist ein Problem aufgetreten. Stellen Sie sicher, dass eine Verbindung mit dem Netzwerk besteht und wiederholen Sie den Vorgang."

Die Verbindung zum Netzwerk besteht natürlich, und wiederholen löst das Problem nicht.

Frage: was kann ich tun, um das Problem einzugrenzen, und wie kann ich es lösen?
Mitglied: lfehly
25.11.2009 um 15:35 Uhr
Besteht das Problem generell bei Schreibzugriffen auf Netzlaufwerken oder nur bei dem einen Laufwerk "Z:\Test\"?
Wie siehts mit dem Bearbeiten von Dateien auf dem Laufwerk aus?
Bitte warten ..
Mitglied: fritz-r
25.11.2009 um 18:15 Uhr
Das Problem ist nur beim Zugriff auf den Server (über VPN). Auf Freigaben anderer Rechner im lokalen Netzwerk (Windows-Arbeitsgruppe) kann problemlos zugegriffen werden, in allen Richtungen.

Bearbeiten von Dateien auf dem Netzlaufwerk:

PDF-Datei (also nur Lese-Zugriff) lässt sich öffnen.

Excel-Datei TEST1.XLS direkt im Windows Explorer (auf dem Netzlaufwerk) doppelgeklickt, lässt sich öffnen, unter anderem Namen TEST2.XLS wieder abgespeichert, keine Fehlermeldung. Die neue Datei TEST2.XLS lässt sich wieder öffnen und ist augenscheinlich fehlerfrei.

TEST2.XLS per Windows-Explorer vom Netzlaufwerk zum Client kopiert: kein Problem. Auf dem Client umbenannt in TEST3.XLS.

Kopieren von TEST3.XLS zum Netzlaufwerk (Server): kein Problem (!!!)

IRGENDEINE andere Datei vom Client zum Server kopiert: da ist sie wieder, die Fehlermeldung.

Ich habe den Eindruck, es hat etwas mit Attributen oder Benutzerrechten zu tun, die die Dateien mitbringen. Bloß wo kann ich daran etwas ändern?
Bitte warten ..
Mitglied: Pjordorf
25.11.2009 um 18:51 Uhr
Zitat von fritz-r:
Das Problem ist nur beim Zugriff auf den Server (über VPN). Auf
Freigaben anderer Rechner im lokalen Netzwerk (Windows-Arbeitsgruppe)
kann problemlos zugegriffen werden, in allen Richtungen.

Bearbeiten von Dateien auf dem Netzlaufwerk:

PDF-Datei (also nur Lese-Zugriff) lässt sich öffnen.

Excel-Datei TEST1.XLS direkt im Windows Explorer (auf dem
Netzlaufwerk) doppelgeklickt, lässt sich öffnen, unter
anderem Namen TEST2.XLS wieder abgespeichert, keine Fehlermeldung. Die
neue Datei TEST2.XLS lässt sich wieder öffnen und ist
augenscheinlich fehlerfrei.

TEST2.XLS per Windows-Explorer vom Netzlaufwerk zum Client kopiert:
kein Problem. Auf dem Client umbenannt in TEST3.XLS.

Kopieren von TEST3.XLS zum Netzlaufwerk (Server): kein Problem (!!!)

IRGENDEINE andere Datei vom Client zum Server kopiert: da ist sie
wieder, die Fehlermeldung.

Ich habe den Eindruck, es hat etwas mit Attributen oder
Benutzerrechten zu tun, die die Dateien mitbringen. Bloß wo kann
ich daran etwas ändern?

Einmal dort wo die Fregabe erstellt wurde. Freigabeberechtigung
Dann in jedem Ordner und oder an jeder Datei. Entweder vom obersten Ordner mit Vererbung oder das ganze individuell. NTFS Sicherheit

Dazu Rechtsklick auf den Ordner und Eigenschaften wählen. Dort die reiter Freigabe und oder Sicherheit.

Peter
Bitte warten ..
Mitglied: fritz-r
26.11.2009 um 11:48 Uhr
Neuer Statusbericht, leider noch keine Lösung:

Mit Benutzerrechten hat es wohl nichts zu tun. Sonst würde es ja auch vom XP-Rechner aus nicht gehen. Es geht vom Win-7-Rechner aus auch nicht, wenn man die Dateien vorher auf ein FAT32-Laufwerk kopiert (und sie damit rechtlos macht). Auf dem Server sind natürlich die richtigen Freigaben und Zugriffsrechte gesetzt, sonst könnte ich ja überhaupt nicht (vom XP-Rechner, gleicher Benutzer) darauf zugreifen.

ABER: gestern Abend funktionierte plötzlich alles. Heute früh nicht mehr. Systematischer Test mit diversen Dateien ergibt, dass sich (heute früh) nur Dateien bis ca. 15 kByte kopieren lassen, darüber gibt es die Fehlermeldung. Die selben Test-Dateien lassen sich vom (parallel über VPN mit anderem Benutzer eingeloggten) XP-Rechner kopieren, auch wenn sie mehrere MByte groß sind.

Versuch einer Erklärung: das Zeitverhalten ist anders, Windows 7 bricht ab, wenn irgendein (offenbar extrem kurzes) Timeout überschritten wird.

Frage: woran kann ich denn da drehen?
Bitte warten ..
Mitglied: fritz-r
07.12.2009 um 08:28 Uhr
Es ist zum Mäusemelken.

Vor drei Tagen ging es wieder, einen halben Tag lang. Danach nicht mehr. Ich habe stundenlang alle möglichen Foren durchforstet, ohne Erfolg. Ähnliche Probleme sind anscheinend auch bei Anderen aufgetreten. Sofern das Thema überhaupt weiterverfolgt wurde, waren es wohl Hardwareprobleme (defekte Netzwerkkarte, Wackelkontakt im Netzwerkstecker). Sowas kann ich mit großer Wahrscheinlichkeit ausschließen: der betroffene Rechner ist zwar über den Linksys-Router als Bridge angeschlossen, hat aber auch eingebautes WLAN. Wenn es nicht geht, geht es aber auch direkt über den WLAN-Adapter des Rechners nicht.

Testweise habe ich mal RAS-Logs eingeschaltet. In Explorer_RASDLG.LOG finde ich bei Auftreten des Fehlers:

StringCchCopy failed due to error 0x8007007a

Googeln dazu hat mich nicht weitergebracht. Hat jemand eine Idee?
Bitte warten ..
Mitglied: smirga
10.04.2010 um 17:02 Uhr
Hi,
habe genau das gleiche Problem (Win7 pro) mit der VPN-Verbindung.
Einmal geht alles bestens, dann geht wieder gar nichts (RAS-Diagnose-Bericht: StringCchCopy failed due to error 0x8007007a).
Hast du das Problem noch oder hast du es gelöst und wenn ja: wie???
Bitte warten ..
Mitglied: fritz-r
10.04.2010 um 22:56 Uhr
Ja, ich habe es gelöst. Die Situation stellte sich aber als so speziell heraus, dass ich es hier nicht gepostet habe. Leider habe ich die Unterlagen dazu (wenn überhaupt noch) an meinem Arbeitsplatz und jetzt hier nicht verfügbar. Also allgemein aus der Erinnerung:

1. Auf dem Rechner war vorher Vista installiert, Windows 7 wurde danach als Upgrade installiert.

2. Schon unter Vista ging der VPN-Zugriff nicht.

3. Vista stellt diverse Netzwerkparameter anders als XP/2003 ein, so dass diese inkompatibel sind.

4. Beim Upgrade auf Windows 7 lässt dieses aber die unpassenden Einträge in der Registry stehen.

5. Abhilfe war, alle Netzwerkparameter, die von Vista in der Registry übriggeblieben waren, von Hand zu löschen. Dann nochmals Netzwerk und VPN installieren, und es ging. Was ich jetzt GENAU gemacht habe, weiß ich aber leider ohne Blick in meine Aufzeichnungen nicht. Tut mir leid, ist leider keine wirkliche Hilfe.
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
LAN, WAN, Wireless
Keine RDP-Sitzung über VPN mit Windows 10 möglich (4)

Frage von Wonderland zum Thema LAN, WAN, Wireless ...

Netzwerke
gelöst VPN Verbindung WIndows Rechner via FritzBox Fernzugang - Kein Internet

Frage von garack zum Thema Netzwerke ...

Netzwerke
Client VPN Zugriff auf Remote Subnet (2)

Frage von niklas.kasper zum Thema Netzwerke ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (17)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

DSL, VDSL
DSL-Signal bewerten (14)

Frage von SarekHL zum Thema DSL, VDSL ...