Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Probleme bei Weiterleitung und namensbasierten virtuellen Webservern

Frage Internet Server

Mitglied: BADADMIN

BADADMIN (Level 1) - Jetzt verbinden

29.09.2006, aktualisiert 15:17 Uhr, 2873 Aufrufe, 1 Kommentar

bei einem vServer/Plesk 8.0/SuSE 10/Apache2 beim Anbieter 1blu:


Ich habe über die "Pleskkonsole" mehrere Domains eingerichtet. Das führt zur automatischen Erzeugung einer bestimmten Ordnerstruktur für jede dieser Domains. Des weiteren wird für jede Domain eine Konfigurationsdatei angelegt, die die virtuellen Hosts konfiguriert. Zusätzlich werden diese Dateien letztendlich in der httpd.conf, der eigentlichen apache2 Konfigurationsdatei eingebunden.

mit /usr/sbin/httpd2 -S
läßt sich die Einstellung der virtuellen Hosts nachvollziehen, alles scheint korrekt

Ich besitze mehrere Domains bei 1und1, ich nutze die dortige Weiterleitungsfunktion und verweise auf die IP Adresse meines 1blu vServers. Problem: Bei einer Anfrage (domainA.de) wird leider immer auf das default Verzeichnis aufgelöst und nicht auf das domainA.de verzeichnis. Also genau das, was man durch die virtuellen Hosts umgehen wollte.

Vielleicht ist die Weiterleitungsfunktion derartiger Provider schuld?


Ich kann mir den Fehler nicht erklären, hat jemand ähnliche Erfahrungen (und Lösungen) gemacht? Danke.
Mitglied: 11078
29.09.2006 um 15:17 Uhr
Hallo,

hast Du mal in die vhosts-Datei reingeschaut, die Plesk für jeden vhost anlegt?

Da muss ja mindestens so etwas drin stehen:

01.
NameVirtualHost 192.168.0.2 
02.
<VirtualHost 192.168.0.2> 
03.
  ServerName www.meine.DomainA.de 
04.
  DocumentRoot "/var/www/DomainA" 
05.
</VirtualHost>

Ich habe die Erfahrung gemacht, dass es sinnvoll ist, die vserver auch in die hosts-Datei einzutragen (/etc/hosts):

01.
127.0.0.1     localhost 
02.
 
03.
123.456.789.10   www.meine.DomainA.de   www.meine
Vielleicht hilft das ja!


Gruß,
Tim
Bitte warten ..
Ähnliche Inhalte
Exchange Server
Probleme mit Exchange-Dienste, E-Mails sind nicht angekommen (2)

Frage von cramtroni zum Thema Exchange Server ...

Windows Server
gelöst SQLExpress Probleme bei Backup (4)

Frage von Alternativende zum Thema Windows Server ...

Neue Wissensbeiträge
Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(4)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(9)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Heiß diskutierte Inhalte
Exchange Server
Exchange 2016 Standard Server 2012 R2 Hetzner Mail (41)

Frage von Datsspeed zum Thema Exchange Server ...

Windows 7
gelöst Lokales Adminprofil defekt (25)

Frage von Yannosch zum Thema Windows 7 ...

LAN, WAN, Wireless
gelöst Statische Routen mit ISC-DHCP Server für Android Devices (18)

Frage von terminator zum Thema LAN, WAN, Wireless ...

Exchange Server
gelöst Migration Exchange 2007 zu 2013 - Public Folder teilweise weg (16)

Frage von Andy1987 zum Thema Exchange Server ...