Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Probleme mit meinem zähler...

Frage Entwicklung Batch & Shell

Mitglied: Kirus22

Kirus22 (Level 1) - Jetzt verbinden

17.11.2008, aktualisiert 18.11.2008, 3378 Aufrufe, 2 Kommentare

Hallo zusammen,

ich habe folgendes Problem mit meinen Skript und zwar beendet das Skript nicht wenn er 5 mal versucht hat das (Netzlaufwerk) zu erreichen!? Warum!?

Anbei das Skript:

for /f "Tokens=1 Delims= " %%i in ('date /t') do set dt=%%i
for /f "Tokens=1" %%i in ('time /t') do set tm=-%%i
set tm=%tm::=-%
set dtt=%dt%%tm%

SET ziel=D:\MP3-Install\Programme
SET LOGFILE=%ziel%\MP3-Update\LogDateien\WAN-IP-%computername%-%dtt%.TXT

rem IP wird ausgelesen
WGET.EXE -O "%Temp%.\index.html" http://checkip.dyndns.org/index.html >NUL 2>&1
FOR /F "tokens=8 delims=<>" %%A IN ('TYPE "%Temp%.\index.html" ^| FIND /I "Current IP Address:"') DO FOR %%B IN (%%A) DO SET WAN_IP_NEW=%%B
DEL "%Temp%.\index.html"
@echo Am %date% um %time% wurde die IP %WAN_IP_NEW% registriert>> %LOGFILE%


:Netzlaufwerk
for /F "tokens=1" %%a IN ('ping 10.1.1.1 ^| FIND "Antwort"') do IF "%%a" == "Antwort" goto copy

set counter=0
set maxcount=5
echo Das Netzlaufwerk ist noch nicht verbunden!
set /a counter=%counter% + 1
if "%counter%" EQU "%maxcount%" goto ERRMAX
goto Netzlaufwerk

:copy
rem Computerbeschreibung in eine Variable schreiben (Computerbs)
FOR /F "tokens=2* delims= " %%A IN ('REG QUERY "HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\lanmanserver\parameters" /v srvcomment') DO SET Computerbs=%%B
xcopy %ziel%\MP3-Update\LogDateien\*.txt U:\LogDateien\"%Computerbs%"-%computername% /Y
xcopy %ziel%\MP3-Update\LogDateien\*.txt D:\MP3-Install\LogDateien /Y
eventcreate /t INFORMATION /SO WAN-IP /L Application /ID 11 /D "Die IP Adresse wurde an dem Server übermittelt! Am %date% um %time% Uhr."
goto eof

:ERRMAX
eventcreate /t WARNING /SO WAN-IP /L Application /ID 11 /D "Die IP Adresse wurde nicht an dem Server übermittelt! Das Netzlaufwerk ist nicht verfügbar"
Folgende Hintergrundinfos, ich baue im Hintergrund eine VPN Verbindung zu einem Server auf (auch per batch). Wenn das Netzlaufwerk U:\ verbunden ist bzw. die IP 10.1.1.1 erreichbar, dann soll die IP Adresse an den Server übermittelt werden.

Wäre Euch dankbar wenn mir jemand einen Tipp geben könnte.

Gruß Kirus22
Mitglied: bastla
17.11.2008 um 17:15 Uhr
Hallo Kirus22!

Vielleicht solltest Du doch die Zeile
set counter=0
vor der Zeile
:Netzlaufwerk
platzieren ...

Grüße
bastla
Bitte warten ..
Mitglied: Kirus22
18.11.2008 um 11:49 Uhr
...
Bitte warten ..
Neuester Wissensbeitrag
Router & Routing

192.168er Adresse im öffentlichen Netz

(2)

Erfahrungsbericht von visco-c zum Thema Router & Routing ...

Ähnliche Inhalte
SAN, NAS, DAS
Fujitsu Q800 Probleme bei Domäneneinbindung

Frage von galnar zum Thema SAN, NAS, DAS ...

Mac OS X
Adobe Acrobat Probleme (6)

Frage von uridium69 zum Thema Mac OS X ...

Exchange Server
Exchange 2010 SMART Host SMTP Relay Probleme (6)

Frage von dawdad zum Thema Exchange Server ...

Windows Server
Active Directory-Verwaltungscenter macht Probleme (1)

Frage von MrFuzz zum Thema Windows Server ...

Heiß diskutierte Inhalte
Zusammenarbeit
Als Administrator im Großraumbüro (29)

Frage von Dopamin85 zum Thema Zusammenarbeit ...

Exchange Server
Test-ActiveSyncConnectivity Error nach neuem Zertifikat (22)

Frage von Driphex zum Thema Exchange Server ...

Hyper-V
HYPER V und USB (16)

Frage von Hendrik2586 zum Thema Hyper-V ...

SAN, NAS, DAS
Backupserver für KMU (14)

Frage von Leo-le zum Thema SAN, NAS, DAS ...