Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Probleme mit meinem zähler...

Frage Entwicklung Batch & Shell

Mitglied: Kirus22

Kirus22 (Level 1) - Jetzt verbinden

17.11.2008, aktualisiert 18.11.2008, 3383 Aufrufe, 2 Kommentare

Hallo zusammen,

ich habe folgendes Problem mit meinen Skript und zwar beendet das Skript nicht wenn er 5 mal versucht hat das (Netzlaufwerk) zu erreichen!? Warum!?

Anbei das Skript:

for /f "Tokens=1 Delims= " %%i in ('date /t') do set dt=%%i
for /f "Tokens=1" %%i in ('time /t') do set tm=-%%i
set tm=%tm::=-%
set dtt=%dt%%tm%

SET ziel=D:\MP3-Install\Programme
SET LOGFILE=%ziel%\MP3-Update\LogDateien\WAN-IP-%computername%-%dtt%.TXT

rem IP wird ausgelesen
WGET.EXE -O "%Temp%.\index.html" http://checkip.dyndns.org/index.html >NUL 2>&1
FOR /F "tokens=8 delims=<>" %%A IN ('TYPE "%Temp%.\index.html" ^| FIND /I "Current IP Address:"') DO FOR %%B IN (%%A) DO SET WAN_IP_NEW=%%B
DEL "%Temp%.\index.html"
@echo Am %date% um %time% wurde die IP %WAN_IP_NEW% registriert>> %LOGFILE%


:Netzlaufwerk
for /F "tokens=1" %%a IN ('ping 10.1.1.1 ^| FIND "Antwort"') do IF "%%a" == "Antwort" goto copy

set counter=0
set maxcount=5
echo Das Netzlaufwerk ist noch nicht verbunden!
set /a counter=%counter% + 1
if "%counter%" EQU "%maxcount%" goto ERRMAX
goto Netzlaufwerk

:copy
rem Computerbeschreibung in eine Variable schreiben (Computerbs)
FOR /F "tokens=2* delims= " %%A IN ('REG QUERY "HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\lanmanserver\parameters" /v srvcomment') DO SET Computerbs=%%B
xcopy %ziel%\MP3-Update\LogDateien\*.txt U:\LogDateien\"%Computerbs%"-%computername% /Y
xcopy %ziel%\MP3-Update\LogDateien\*.txt D:\MP3-Install\LogDateien /Y
eventcreate /t INFORMATION /SO WAN-IP /L Application /ID 11 /D "Die IP Adresse wurde an dem Server übermittelt! Am %date% um %time% Uhr."
goto eof

:ERRMAX
eventcreate /t WARNING /SO WAN-IP /L Application /ID 11 /D "Die IP Adresse wurde nicht an dem Server übermittelt! Das Netzlaufwerk ist nicht verfügbar"
Folgende Hintergrundinfos, ich baue im Hintergrund eine VPN Verbindung zu einem Server auf (auch per batch). Wenn das Netzlaufwerk U:\ verbunden ist bzw. die IP 10.1.1.1 erreichbar, dann soll die IP Adresse an den Server übermittelt werden.

Wäre Euch dankbar wenn mir jemand einen Tipp geben könnte.

Gruß Kirus22
Mitglied: bastla
17.11.2008 um 17:15 Uhr
Hallo Kirus22!

Vielleicht solltest Du doch die Zeile
set counter=0
vor der Zeile
:Netzlaufwerk
platzieren ...

Grüße
bastla
Bitte warten ..
Mitglied: Kirus22
18.11.2008 um 11:49 Uhr
...
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
Switche und Hubs
gelöst LAG zwischen SG300-Switches macht Probleme. Wer weiß Rat? (26)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...

SAN, NAS, DAS
gelöst Synology Version 6.1 Probleme (18)

Frage von Hendrik2586 zum Thema SAN, NAS, DAS ...

Exchange Server
gelöst Probleme mit Active Sync (6)

Frage von Henere zum Thema Exchange Server ...

Heiß diskutierte Inhalte
CPU, RAM, Mainboards
Kaufberatung für mind. 8 verschiedene HighEnd-Mainboards (24)

Frage von yperiu zum Thema CPU, RAM, Mainboards ...

Netzwerke
Abisolierwerkzeug (11)

Frage von SarekHL zum Thema Netzwerke ...

Hyper-V
Langsames Netzwerk i210 LAN Karte (11)

Frage von Akcent zum Thema Hyper-V ...

Windows Server
Server 2016 - Kuriositäten (8)

Frage von certifiedit.net zum Thema Windows Server ...