Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Programm kann Daten vom Netzlaufwerk erst nach manuellem Zugriff auf Laufwerk finden

Frage Microsoft

Mitglied: MartinAD

MartinAD (Level 1) - Jetzt verbinden

18.12.2009, aktualisiert 11.01.2010, 5214 Aufrufe, 3 Kommentare

Hallo Community,

folgendes Problem.

Ein Programm liegt am Rechner im Autostart, das Programm benötigt zum Starten Daten von Laufwerk Q:\ - in dem Fall irgendein Netzlaufwerk auf einem Windows 2003 Server, Benutzer hat entsprechende Rechte, Laufwerk ist fest verbunden.

Das Programm meldet beim Start, das es die Daten von Q:\ nicht finden kann, also schließe ich das Programm. Ich öffne meinen Explorer, klicke einmal auf Q:\ - der Explorer schafft problemlos Zugriff. Ich Starte mein Programm, das Daten von Q:\ benötigt, erneut. Das Programm startet problemlos!

Wie kann das sein? Ist jemandem so ein Problem bekannt? Ich hatte das noch nie.
Kann mir jemand sagen woran das liegen könnte?

Danke + beste Grüsse
Martin
Mitglied: Biber
18.12.2009 um 09:24 Uhr
Moin MartinAD,

ich denke, deine Schlussfolgerung mit dem "es ist zuerst manueller Zugriff nötig" ist voreilig.
Vermutlich ist nur "das Netzwerk noch nicht bereit", wenn dieser Autostart-Krams ausgeführt wird (lässt sich über GPO oder Registry ändern; mehrfach auch hier im Forum gepostet).

Aber bevor du die Forumssuche anwirfst, mache doch erstmal den Versuch einer Verifizierung/Falsifizierung meiner Ferndiagnose.
Nimm die zu erwartenden Fehlermeldungen beim Hochfahren in Kauf und öffne danach nicht den Explorer auf Q:, sondern doppelklicke nochmal auf dieses Autostart-Skript.

Ergebnis?

Grüße
Biber
Bitte warten ..
Mitglied: MartinAD
21.12.2009 um 06:37 Uhr
Genau das war mein erster Gedanke.

Ergebnis? Ich hab einen kleinen Autostart-Delay mittels VBS eingebaut, 20 Sekunden wartezeit, selbes Ergebnis. Die Laufwerke sind definitiv schon im explorer und ich kann sie definitiv auch anklicken - aber Programme die auf die Daten zugreifen wollen erst funktionieren wenn ich das Laufwerk "von Hand" angefasst hab.

Ich sage ja, sehr paradox. Mein erster Gedanke ware Samba, Kollegen berichten mir, das es aber auch angeblich auf Windows 2003 shares auftritt.
Bitte warten ..
Mitglied: MartinAD
11.01.2010 um 11:01 Uhr
Also scheinbar waren die Informationen meinen Kollegen doch nicht korrekt.
Ich habe nun etliche Shares auf Windows Umgezogen, dort arbeite ich mit klassischen Shares als auch mit Domainbasierenden DFS-Shares. Bei beiden Varianten funktioniert die Freigabe problemlos.

Scheinbar ist es in diesem Fall ein Problem das auf den Einsatz des Samba-Servers für Linux zurückzuführen war/ist.

Danke für eure Mühen!
Bitte warten ..
Ähnliche Inhalte
Windows Netzwerk
gelöst Anonymer Zugriff auf Netzlaufwerk für WSUS Offline (5)

Frage von hannsgmaulwurf zum Thema Windows Netzwerk ...

Windows Server
gelöst Serverabsturz nach Zugriff auf Programme auf Netzlaufwerk - Fehler 0x0000003b (5)

Frage von heisenberg4 zum Thema Windows Server ...

Windows 10
gelöst W10 kein Zugriff auf gemapptes Laufwerk als Admin (4)

Frage von leknilk0815 zum Thema Windows 10 ...

Neue Wissensbeiträge
Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(9)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Heiß diskutierte Inhalte
Exchange Server
Exchange 2016 Standard Server 2012 R2 Hetzner Mail (36)

Frage von Datsspeed zum Thema Exchange Server ...

Verschlüsselung & Zertifikate
Mit Veracrypt eine zweite interne (non-system) Festplatte verschlüsseln (10)

Frage von Bernulf zum Thema Verschlüsselung & Zertifikate ...

Internet Domänen
Nameserver ein Geist? (7)

Frage von zelamedia zum Thema Internet Domänen ...

Microsoft Office
Übertrag in eine andere Tabelle (6)

Frage von charmeur zum Thema Microsoft Office ...