Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Programm hängt sich nach Schleife auf....

Frage Entwicklung Assembler

Mitglied: supernicky

supernicky (Level 1) - Jetzt verbinden

30.05.2011, aktualisiert 16:12 Uhr, 3199 Aufrufe, 5 Kommentare

Windowsanwendung mit SetPixel Funktion

Hallo,

vielleicht kann mir hier jemand helfen...

ich habe ein Fenster (leer) und dort sollen vor der Funktion ShowWindow, ein paar schwarze Punkte gezeichnet werden.
Dafür habe ich eine Schleife erstellt die 100 mal durchlaufen werden soll.

invoke ShowWindow,hWnd, SW_SHOWNORMAL
invoke GetDC, hWnd ;Handle des DC der Form holen und in formdc speichern
mov formdc, eax

xor ecx,ecx ;ecx löschen
mov ecx, 220 ;ecx mit 220 belegen
mov tmp, ecx ;ecx in die Variable tmp kopieren
mov ecx, 100 ;ecx mit 100 belegen (für die Schleife)
malen:
invoke SetPixel, formdc,tmp,1, colr ;tmp sollte bei 220 beginnen und bei 120 enden

dec tmp ;immer eins subtrahieren
loop malen ;Schleife wiederholen solange ecx ungleich Null ist


invoke UpdateWindow,hWnd ;Fenster nach dem Zeichnen anzeigen


Was herauskommt ist ein schwarzer Strich am oberen Fensterrand...(wie gewünscht)
aber dannach hängt sich das Programm auf... Woran liegt das?

Die Linie geht bis zum Rand.. also hätte tmp ja den Wert 0 oder sogar kleiner...
Da ecx aber nur 100 hat (=100 Schleifendurchgänge) sollte tmp an Ende auch nur 220 - 100 = 120 haben... und demnach noch 120 Pixel vom Rand entfernt sein.

Wo ist denn hier der Fehlerteufel????

Gruß, Nicky
Mitglied: 76109
30.05.2011 um 16:13 Uhr
Hallo supernicky!

Kommentar wieder entfernt, da sich der Beitragstext während des Schreibens vollständig geändert hat

Gruß Dieter
Bitte warten ..
Mitglied: supernicky
30.05.2011 um 16:16 Uhr
Hallo,

ich habe den Beitrag geändert... mein Edit-Feld geht jetzt... auch wenn noch keine Änderungen (außer über Funktionen) möglich sind...

Vielleicht kannst du mir bei dem oberen Problem auch helfen...

Gruß, Nicky
Bitte warten ..
Mitglied: 76109
30.05.2011 um 16:50 Uhr
Hallo supernicky!

Bezugnehmend auf den vorhergehenden Beitragstext. Hast Du für die Variable 'formdc' und 'tmp' anstelle von
01.
formdc db ? 
02.
tmp db ?
jeweils ein DWord für EAX/ECX reserviert ?
01.
formdc dd ? 
02.
tmp dd ?
Gruß Dieter
Bitte warten ..
Mitglied: supernicky
30.05.2011 um 23:28 Uhr
Hallo Dieter,

ja das habe ich bei allen Variablen gemacht..

sobald ich die Zeile
"invoke SetPixel, formdc,tmp,1, colr "
ungültig mache, läuft das Programm fehlerfrei... nur die Linie oben fehlt dann.

Ich habe diese Schleife direkt hinter der CreateWindow - Funktion zum erstellen des Fensters.. und noch vor der UpdateWindow-Funktion, ist es vielleicht der falsche Ort dafür??

Nicky
Bitte warten ..
Mitglied: supernicky
05.06.2011 um 07:19 Uhr
Es war wohl tatsächlich der falsche Ort für die Zeichenfunktion.
Ich habe die Schleife hinter den BN_CLICK in der Nachrichtenschleife gelegt und dann geht es...
Bitte warten ..
Ähnliche Inhalte
Router & Routing
gelöst Fritz!Box 6490 Cable hängt in Dauerreboot Schleife (5)

Frage von ketanest112 zum Thema Router & Routing ...

Batch & Shell
gelöst Verschachtelte FOR-Schleife mit einem Argument (3)

Frage von mp-home zum Thema Batch & Shell ...

Batch & Shell
gelöst Fehler in Schleife (2)

Frage von miczar zum Thema Batch & Shell ...

Batch & Shell
For Schleife in einer .sh Datei (4)

Frage von CrystalFlake zum Thema Batch & Shell ...

Neue Wissensbeiträge
Windows Server

Umstellung SHA 1 auf SHA 2 - Migration der CA von CSP auf KSP

Tipp von Badger zum Thema Windows Server ...

Windows 10

Quato DTP94 unter Windows 10 x64 installieren und verwenden

Anleitung von anteNope zum Thema Windows 10 ...

Windows 10

Win10 1703 und Nutzerkennwörter bei Ersteinrichtung - erstaunliche Erkenntnis

(15)

Erfahrungsbericht von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Festplatten, SSD, Raid
gelöst Raid-Controller (Areca) Datenverlust trotz R5 (14)

Frage von sebastian2608 zum Thema Festplatten, SSD, Raid ...

Webentwicklung
Aktuellen Mitarbeiter auf Homepage anzeigen (13)

Frage von alemanne21 zum Thema Webentwicklung ...

Microsoft Office
gelöst Office 365 Pro Domäne einrichten OHNE Webseite (9)

Frage von thklemm zum Thema Microsoft Office ...

Server-Hardware
HP ProLiant DL380 G7, POST Error: 1785-Drive Array not Configured (9)

Frage von Paderman zum Thema Server-Hardware ...