Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Programm meldet Pfad nicht verfügbar obwohl Netzlaufwerk verbunden (Behebung oder Script zur Umgehung gesucht)

Frage Microsoft

Mitglied: Devilx

Devilx (Level 1) - Jetzt verbinden

27.07.2010 um 13:09 Uhr, 16256 Aufrufe, 5 Kommentare

Hallo,

Habe ein nicht lösbares Problem mit einem Dateizugriff auf einem Netzlaufwerk und hoffe auf eure Hilfe.

Das Problem stellt sich wie folgt dar:

Der Mitarbeiter startet seinen PC und bekommt beim Anmelden per kix-Script Netzlaufwerke zugewiesen. Dies funktioniert tadelos und die Laufwerke sind problemlos im Explorer nutzbar.
Soweit so gut.

Startet der Mitarbeiter jedoch unser Warenwirtschaftssystem (Navision 4 SP3 - lokal ausgeführt) oder ein anderes Programm was direkte Dateiaufrufe nutzt und ruft dort eine Verknüpfung auf eine Datei auf einem der Netzlaufwerke auf ohne den Pfad vorher im Explorer "besucht" zu haben, meldet Navision (oder das Programm), dass der Pfad nicht verfügbar ist.
Nutzt man nun den "Datei suchen"-Dialog oder klickt sich im Explorer auf dem Netzlaufwerk eben bis zum Ablageort der Datei durch (was problemlos funktioniert) dann funktioniert auch der direkte Link im Navision (oder einem anderen Programm) anschließend.
Es geht aber halt nicht ohne den Ort vorher mit dem Explorer geöffnet zu haben.

Habe dann mit den verschiedenen "Offline-Dateien"-Einstellungen der Freigabe etwas rumgespielt aber das ändert nichts an dem Problem.

An anderen PC's tritt das Problem, obwohl sie das gleiche Netzlaufwerk, das gleiche Betriebssystem und die gleiche Funktion nutzen, in der Form auch nicht auf.

PC ist via GB-LAN angebunden, Server ist 2003 R2 x64, Betriebssystem des PC's XP SP3, beides aktueller Patchstand.

Kann mir jemand weiterhelfen?

Wenn das Problem direkt nicht bekannt ist hatte ich mir schonmal überlegt die häufig genutzen Pfade per Script eben im Explorer zu öffnen und diesen nachher wieder zu schließen aber außer ner Batch-Datei oder als Shell-Befehl im kix-script fällt mir da wenig ein und dann hat der Mitarbeiter dann erstmal die ganzen Fenster offen und muss die schließen. Bin allerdings auch nicht wirklich versiert mit Scripten.
Vielleicht kennt von euch wenigsten jemand ne Möglichkeit die Pfade auf diese Weise zu "initialisieren" ohne das der Mitarbeiter was machen muss.

Vielen Dank schon einmal vorab.
Mitglied: MaryLong
27.07.2010 um 14:51 Uhr
Hallo Devilx

kenne das Problem aus eigener Erfahrung mit fast gleichen Voraussetzungen. Fileserver -> 2k3 R2 32bit, Clients -> WinXP SP3, akt. Patchstand.
Sämtliche Versuche, das Problem zu lösen sind gescheitert. Habe jetzt in Zusammenarbeit mit MS scheinbar das Problem in den Griff bekommen...

Hier die von MS vorgeschriebenen Aktionen:

1. Autodisconnect (auf den Server mit den Freigabe)
net config server /autodisconnect:-1

2. KeepConn
Folgende Änderung auf dem Client vornehmen:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanworkstation\parameters
Name = KeepConn
Typ = REG_DWORD
Wert = 65535 (Dezimal)
Die beiden Einstellungen sind in der englischen Version des folgenden Artikels beschrieben:
Mapped Drive Connection to Network Share May Be Lost
http://support.microsoft.com/kb/297684/en-us
KeepConn
http://technet.microsoft.com/en-us/library/cc960471.aspx

3. SNP Features (auf dem Server mit der Freigabe)
Für Windows Server 2003-basierte und Small Business Server 2003-basierte Computer steht ein Update zum Deaktivieren von SNP-Standardfeatures zur Verfügung:
http://support.microsoft.com/kb/948496/de
Hier die Schritte:
1. Start und auf Ausführen, regedit eingeben, OK.
2. Navigieren zum folgenden Registrierungsunterschlüssel:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
3. Mit rechter Maustaste auf EnableTCPChimney und Ändern.
4. Im Feld Wert den Wert 0 eingeben und OK.
5. Mit rechter Maustaste auf EnableRSS und Ändern.
6. Im Feld Wert den Wert 0 eingeben undOK.
7. Mit rechter Maustaste auf EnableTCPA und Ändern.
8. Im Feld Wert den Wert 0 eingeben und OK.
9. Beenden von regedit und Neustart des Computers

4. Reihenfolge der Anbieter und Bindungen (auf den Servern)
Öffnen der „Netzwerkverbindungen“ auf dem Server, Option „Erweiterte Einstellungen“ im Menü „Erweitert“ auswählen
Überprüfen der LAN-Verbindung im Fenster „Netzwerkkarten und Bindungen“ unter „Verbindungen“. Die aktive LAN-Verbindung sollte als erste in der Liste erscheinen. Falls das nicht der Fall ist, Reihenfolge wechseln.
Im Fenster „Reihenfolge der Anbieter“ sollte Microsoft Windows Netzwerk als erster Eintrag aufgelistet sein.

5. SMB signaturenÜberprüfen, ob die SMB Signing korrekt eingestellt ist. (Info: "Dateifreigaben oder Gruppenrichtlinien-Snap-Ins können nicht geöffnet werden, wenn die SMB-Signatur für die Arbeitsstation oder Server-Dienst auf einem Domänencontroller deaktiviert ist" -> http://support.microsoft.com/kb/839499/de und "Überblick über SMB-Signaturen" -> http://support.microsoft.com/kb/887429/de)
Bestpraxis: Default Domain Policy + Default Domain Controllers Policy
Microsoft-Netzwerk (Client): Kommunikation digital signieren (immer) Deaktiviert
Microsoft-Netzwerk (Client): Kommunikation digital signieren (wenn Server zustimmt) Aktiviert
Microsoft-Netzwerk (Server): Kommunikation digital signieren (immer) Deaktiviert
Microsoft-Netzwerk (Server): Kommunikation digital signieren (wenn Client zustimmt) Aktiviert

6. Neustart des Servers und des Clients, damit die Änderungen wirksam werden.

Hat bei mir geholfen, 4 Server und 200 Clients arbeiten jetzt friedlich ohne Probleme miteinander , Fehler seither nicht mehr aufgetreten.

Wie gesagt, Server sind 32bit 2k3, eventuell deshalb zuerst die Dokus bei MS Support durchlesen, vielleicht für x64 etwas andere Einstellungen.

Bitte um Feedback bei Erfolg, danke.

Gruss MaryLong
Bitte warten ..
Mitglied: Devilx
27.07.2010 um 14:57 Uhr
Danke schon mal soweit. Werde mir das dann erstmal genauer ansehen und ausprobieren.
Rückmeldung gibts dann wenns was Neues gibt.
Bitte warten ..
Mitglied: Devilx
29.07.2010 um 08:14 Uhr
Also der Großteil der Einstellungen (vor allem SNP) war schon so gesetzt.
Das Signing war deaktiviert. Habe das jetzt per GPO auf immer=deaktiv und mit zustimmung=aktiv gesetzt.
Dazu Schritt1 am betroffenen Server und Schritt 2 am betroffenen Client.
Server kann ich erst am WE neu starten. Mal sehen was dann passiert.
Bitte warten ..
Mitglied: Devilx
03.08.2010 um 14:48 Uhr
Also bei einem Nutzer hat es geholfen, bei einem weiteren der zwischenzeitlich aufgetaucht ist, nicht.
Wenn keinem mehr was einfällt, würde ich gerne nochmal die Script-Idee aufgreifen. Hat da jemand ne Ahnung wie man mit Batch oder kix nen Pfad wie oben geschrieben "initialisieren" kann?
Bitte warten ..
Mitglied: Devilx
11.08.2010 um 11:08 Uhr
Also habe jetzt ein wenig geforscht und folgendes Mini-Script geschrieben:

explorer.exe V:\DATENAUSTAUSCH\Zahlungsverkehr
ping /n 3 localhost
taskkill /im explorer.exe /FI "windowtitle eq Zahlungsverkehr" /F

Bedeutet er öffnet den Pfad in Zeile1, dann macht er, um den PC genug Zeit zu geben, 3 Pings auf den eigenen PC (dauert ~3 Sekunden), und dann killt er den Prozess "explorer.exe" mit dem Fenstertitel="Zahlungsverkehr".
Normalerweise entspricht der Fenstertitel dem Namen des geöffneten Ordners.

Wenn man sich im Fenstertitel den kompletten Pfad anzeigen lässt (Ordneroptionen in Windows), dann ist der Titel des Fensters auch der komplette Pfad.
Mit tasklist /v kann man sich das aber auch anzeigen lassen.

Wenn man das nicht beschränkt, killt er alle explorer.exe-Prozesse und damit auch den der für Startleiste und Desktop zuständig ist.

Jetzt kann man das entweder per Autostart beim Anmelden des Benutzers laufen lassen oder man schreibt unter die 3 Zeilen noch die EXE des Programms mit dem der Fehler auftritt, benutzt die Batch zum Starten des Progs und dann hat sich das erledigt.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Netzwerk
Netzlaufwerk offline verfügbar für Mac

Frage von PharIT zum Thema Windows Netzwerk ...

Windows 10
Fehlermeldung Pfad nicht verfügbar (2)

Frage von Stefan.Brandl zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...