Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Frage Hardware Festplatten, SSD, Raid

GELÖST

ProLiant ML115 (Soft)raid1 auflösen möglich?

Mitglied: keine-ahnung

keine-ahnung (Level 5) - Jetzt verbinden

05.11.2009 um 17:58 Uhr, 8305 Aufrufe, 9 Kommentare

Hallo, Gemeinde, wäre nett, wenn mir jemand helfen könnte.

Folgendes Problem: HP ProLiant ML 115, nvidia-Softraid eingerichtet (Level1, mirroring) [ich stand da wohl unter massivem Drogeneinfluß?], darauf SBS2003R2.

Das RAID macht immense Probleme, insbesondere beim Einspielen von Daten größer 10MB (!) scheint sich der raid-controller zu verabschieden (Ereigniskennung 9, Quelle nvgts, Das Gerät \Device\Scsi\nvgts2 hat innerhalb der Fehlerwartezeit nicht geantwortet), in solchen Situationen kann ich dann von Glück reden, wenn sich die Büchse überhaupt wieder findet. Der HP-Support rät zum Kauf eines Hardeware-Controllers - Klasse!

In Zeiten von Imagesicherungen kann ich m.E. auf die RAID-Funktion verzichten, nicht aber auf das Einspielen großer Datenmengen (Quartalsupdates meiner Praxissoftware!).

Meine Frage: Kann ich das RAID ohne Datenverlust auflösen und wie? TrueImage 9 Server ist vorhanden, allerdings macht die Software bei der Wiederherstellung von Zeit zu Zeit Späne, da der ML 115 keine seriellen Schnittstellen für Tastatur und Maus hat.

Wäre nett, wenn jemand einen sicheren Weg weiß,

Herzlichen Dank, Thomas
Mitglied: jonny83
05.11.2009 um 20:16 Uhr
Mir ist nicht bekannt ein RAID sicher "lösen" zu können.
Also kein RAID 1 - Eine Platte von zwei kaputt - RAID kaputt ...

Vorschlag:

du installierst VMWare Server (kostenlos) auf einem autonomen System (z.B.: dein PC)

zieh dir ein komplettes Image von dem Server wie er jetzt ist mit deinem TureImage 9!
Pack das Image auf eine virtuelle Maschine (im VMWare Server) und teste ob alles funktioniert. Wenn dem so ist und du auch definitiv ein zusätzliches Backup hast mach den Server platt - Bau dir wirklich nen physikalischen RAID Adapter ein und setz die Platten als "Mirror".

Dann schnappst du dir von VMWare "P2V" (Physikalisch zu virtuell) - damit kannst du auch die virtuelle Maschine zurück auf eine physikalische Instanz ziehen!

Wenn dann alles geklappt hat läuft der Server wieder.

Besser ist aber - zumal ich auch annehme das es ein DC ist und der Exchange auch konfiguriert ist den Server sauber in ein Backup zu packen (MDB vom Exchange - Systemstate usw...) und komplett den Server neu aufsetzen! (Doch versuch erstmal die oberen Schritte - wenn du glück hast sparst du viel Konfigurationszeit)
Bitte warten ..
Mitglied: wiesi200
05.11.2009 um 21:40 Uhr
Und dann startet der Server nicht weil dir die Treiber für den Raidcontroller fehlen.
Den Controller sollte man als aller erstes einbauen und selbst dann glaube ich das dem System die 2te Festplatte immer noch fehlen wird wenn man es so umbaut.
Bitte warten ..
Mitglied: keine-ahnung
06.11.2009 um 12:12 Uhr
Meine Idee war folgende: Systemimage vom SBS ziehen, dann mit TrueImage auf eine ähnliche Büchse OHNE Raid aufspielen (habe noch meinen alten ML 110 in der Ecke stehen), und gucken, ob das läuft! Wenn ja, sollte man doch den nvidia-Raid deaktivieren können und das Image in den ML 115 wieder auf eine einzelne Platte aufspielen?
Die Frage für mich ist, ob der nvidia-"controller" eine eigene FAT oder ähnliches in den MBR schreibt, welche die Platte als einzelnes device unter Windows was auch immer unleserlich macht. Gibt es da Erfahrungen? Dann würde letztlich auch die Idee mit dem Hardware-Raid scheitern, wenn dieser die nvidea-geprägten Platten nicht interpretieren kann. Und letztlich würde ich gern komplett auf das Plattenspiegeln verzichten, wozu braucht man das heute noch in einem kleinen und überschaubaren System?

Danke für Eure Ideen, Thomas
Bitte warten ..
Mitglied: jonny83
06.11.2009 um 19:24 Uhr
Das RAID schiebt einfach gesagt den Serverausfall auf.
Wenn du nur auf eine HDD pledierst ist die Auswirkung im Falle eines Defektes der sofortige Serverausfall.

Der nächste Punkt ist dann noch die Geschwindigkeit der Platten - wenn du vier stück hast und (z.B.) eine DB laufen hast macht es Sinn die ersten beiden Platten zu Spiegeln <-- so hast du in der Summe (fast) doppelte Zugriffsgeschwindigkeit einer einzelnen Platte! Darüber legst du mit den anderen beiden Platten wieder nen Spiegel an und Spiegelst die zwei theoretisch einzelnen Platten.

Also:

HDD1 und HDD2 <-- Spiegel1 > diese beiden "HDDs"
HDD3 und HDD4 <-- Spiegel2 > spiegelst du jetzt wieder .. damit hast du im OS EINE HDD die effektiv schneller ist als eine einzelne Platte (fast doppelt so schnell) und dabei aber 100%ige Sicherheit hast wenn eine Platte ausfällt.

So nun eine Frage von mir:

Warum probierst du es nicht einfach aus? Zieh doch einfach mal nen Image und spiel das auf den anderen (alten) Server auf - du hast ja nichts zu verlieren - ausser etwas Zeit ...
Bitte warten ..
Mitglied: keine-ahnung
20.11.2009 um 10:28 Uhr
Achtung: neue Treiber und Firmware im Netz!

Raid-Treiber, BIOS- und BMC-Firmware aktualisieren! Problem ist gelöst. Danke, HP, das Du über ein Jahr diesen Mist hast laufen lassen!
Bitte warten ..
Mitglied: keine-ahnung
01.12.2009 um 15:53 Uhr
Falls noch jemand so ein Problem hat: ich habe erst einmal komplette images aller Partitionen mit TrueImage 9 Server gezogen. Dann habe ich noch mal kurz auf der Homepage von HP nachgeschaut und siehe da: auf einmal waren neue Versionen des Platinen-BIOS und der nvidia-raid-Treiber verfügbar (Oktober 09). Runtergeladen. Dann zweigleisig gefahren:
1. meinen alten Server (ProLiant ML110 mit Intel-Plattform !!) ohne aktiviertes RAID das Image der Systempartition meines 115 (AMD-Plattform, nvidia-raid) über die True-Image-Wiederherstellung untergeschoben und man höre und staune: die Büchse startet tatsächlich den SBS an. Einige Fehlermeldungen bei der Konfiguration wegklicken - ist bei mir nichts passiert, hängt vermutlich mit der engen WSUS-IE-Beziehung zusammen, aber immerhin, ich hätte mit einiger Nacharbeit mit dem vermutlich arbeiten können, bin aber nicht zum Ausprobieren gekommen, weil:
2. ich das BIOS des 115 geflasht habe und die nvidia-raid-Treiber neu installiert habe. Lief problemlos durch, allerdings war der Gehäuselüfter permanent auf Volllast - Geräusche wie auf einem US-Flugzeugträger kurz vor Beginn von desert storm! Gegoogelt - nicht Wesentliches gefunden. Noch mal auf die HP-Homepage gegangen und das Kleingedruckte beim BIOS-Download durchgelesen: der BIOS-flash setzt das flashen des BMC (board management configurator ???) vorraus. Das Teil eingespielt, und alles war wieder paletti: Lüfterregulierung und vor allem war das raid belastbar. Läuft bei mir jetzt seit fast zwei Wochen ohne Probleme.

Also: nochmals danke, HP, sehr suffizienter support! Wenn man keine low-cost-Server supportieren kann, soll man auch keine vertreiben. Dies war wohl mein letzter Ausflug als zertifizierter HP-Beta-Tester!
Bitte warten ..
Mitglied: ThomasBraun
15.04.2010 um 13:03 Uhr
Hallo,

ich hoffe, ich bekomme noch eine Antwort, da das ja schon eine Weile her ist.

Ich bekomm auf dem ML115 G5 kein Windows installiert. Ich nehme an es liegt an diesem blöden Kontroller.

Deshalb: Wo hast du den nvidia-Raid-Treiber gefunden? Bei HP finde ich den auf keiner Seite.

Danke & viele Grüße
Thomas
Bitte warten ..
Mitglied: keine-ahnung
15.04.2010 um 16:59 Uhr
Hallo,

der Link für den nvidia-Treiber:

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.js ...

Ich empfehle Dir, den kompletten Kasten zunächst up to date zu bringen: s.o. An die Treiberdateinen kommst Du recht einfach, wenn Du auf der support-Seite von HP nach ML 115 G5 suchst und Dir dort als Sprache english international einstellst.

Dann das raid im BIOS aktiv schalten und dann konfigurieren, danach kannst Du Deine Windows-Version wahrscheinlich problemlos aufspielen. Trotzdem, ich bleibe dabei: ich würde kein software-raid mehr installieren (welchen Nutzen hast Du von Raid 0 oder 1?). Wenn eine Platte wegschmiert, hast Du wahrscheinlich Probleme, diese im raid zu ersetzen, hatte einige google-Treffer zu diesem Thema. Ich betreibe meine Server jetzt seit 4 JAhren, ein Plattencrash ist m.E. das unwahrscheinlichste Problem, was mich erwischen wird und der Ärger, den ich mit dieser raid-Lösung hatte, sollte wesentlich größer gewesen sein. Statt dessen: mehrfach am Tag ein backup, besser ein Partitionsimage schreiben lassen, und wirklich schmerzhafter Datenverlust ist so gut wie ausgeschlossen!

Viel Spass beim Basteln!
Bitte warten ..
Mitglied: ThomasBraun
15.04.2010 um 17:14 Uhr
Cool ;) Danke für die Antwort.

Leider hab ich den auch gefunden, aber ich will ja Windows 2008 SBS installieren ;(
HP schreibt dazu: Hamma net. Benutzen sie das normale Windows Setup - nur das dass eben Probleme mit dem Controller hat.
Anyway hab auf dein post hin den 2003x64 Treiber gefunden. Werde es nachher ausprobieren.

Gegenwärtig installiert er ihn, nachdem ich einen Kontroller (SmartArray) für 600 € eingebaut habe. Kostet fast doppelt soviel wie der ganze Server.

Ich zieh dann ein Image uns versuchs wieder auf das ürsprügnliche System zu ziehen.

Basteln ist gut gesagt, das Ding muss morgen zum Kunden und ich hab a) keine Zeit und b) zahlt mir das auch niemand. Aber man lernt nie aus - Ich liebe meinen Job ;)

Auf jeden Fall finde ich es sehr blöd von HP, dass die einen Server rausgeben der hinten und vorne solche Probleme macht. Wenn sie schon einen LowCost Server anbieten, dann sollte er auch funktionieren. Jedenfalls war das der letzte der 110 Reihe. Die anderen ab 300 aufwärts laufen und liefen immer ohne irgendwelche Probleme.

Auf jeden Fall, vielen Dank für die Antwort - Echt klasse!

Viele Grüße
Thomas
Bitte warten ..
Ähnliche Inhalte
Server-Hardware
HPE ProLiant ML10 Gen9 - Booten nicht möglich
gelöst Frage von mc-edvServer-Hardware7 Kommentare

Hallo! Ich habe das Problem, dass egal was ich mache - weder von USB-DVD-ROM noch von SATA-DVD-ROM booten kann ...

Server-Hardware
ProLiant ML 350p Gen8 mit pcie-SSD - möglich?
gelöst Frage von keine-ahnungServer-Hardware7 Kommentare

Moin, hat zufällig jemand schon mal in o.g. Büchse eine pcie-SSD verbaut und wenn ja: - was für eine? ...

Linux
Befehle zum auflösen von Domains
gelöst Frage von winlinLinux14 Kommentare

Hallo Leute Habe eine Gesamtsituation mit mehreren Domains. Es gibt verschiedene DNS Server welche in unterschiedlichen netzwerkzonen liegen. Nun ...

Mac OS X
Host auflösen sehr langsam bei MAC
gelöst Frage von ModdryMac OS X9 Kommentare

Guten Abend! :) Ich habe hier ein MBP (Mid 2012) mit Google Chrome. Als DNS Server benutze ich meinen ...

Neue Wissensbeiträge
Tipps & Tricks

Solutio Charly Updater Fehlermeldung: Das Abgleichen der Dateien in -Pfad- mit dem Datenobject ist fehlgeschlagen

Tipp von StefanKittel vor 16 StundenTipps & Tricks

Hallo, hier einmal als Tipp für alle unter Euch die mit der Zahnarztabrechnungssoftware Charly von Solutio zu tun haben. ...

Sicherheit

Meltdown und Spectre: Wir brauchen eine "Abwrackprämie", die die CPU-Hersteller bezahlen

Information von Frank vor 17 StundenSicherheit11 Kommentare

Zum aktuellen Thema Meltdown und Spectre: Ich wünsche mir von den CPU-Herstellern wie Intel, AMD oder ARM eine Art ...

Sicherheit

Meltdown und Spectre: Realitätscheck

Information von Frank vor 18 StundenSicherheit9 Kommentare

Die unangenehme Realität Der Prozessorfehler mit seinen Varianten Meltdown und Spectre ist seit Juni 2017 bekannt. Trotzdem sind immer ...

Sicherheit

Meltdown und Spectre: Die machen uns alle was vor

Information von Frank vor 18 StundenSicherheit13 Kommentare

Aktuell sieht es in den Medien so aus, als hätten die Hersteller wie Intel, Microsoft und Co den aktuellen ...

Heiß diskutierte Inhalte
Windows 10
Netbook erkennt Soundkarte nicht - keinerlei Info zum Hersteller und Modell vom Netbook und Hardware bekannt
Frage von 92943Windows 1031 Kommentare

Guten Tag, meine Schwester reist in einigen Wochen für ein paar Monate ins Ausland und hat sich dafür ein ...

Batch & Shell
Anmeldevorgang für Informatikraum (Schule) unter Windows
gelöst Frage von IngenieursBatch & Shell29 Kommentare

Hey zusammen, ich werde in naher Zukunft den Informatik Raum meiner jetzigen Schule von dem aktuellen Betreiber übernehmen (Vertrag ...

Netzwerkgrundlagen
Welches Modem für VDSL 50000 der T-Com
gelöst Frage von Windows10GegnerNetzwerkgrundlagen21 Kommentare

Hallo, ein Kollege von mir will sich VDSL50000 von der T-Com holen, um daran einen Server zu betreiben. Ich ...

Batch & Shell
AD-Abfrage in Batchdatei und Ergebnis als Variable verarbeiten
gelöst Frage von Winfried-HHBatch & Shell19 Kommentare

Hallo in die Runde! Ich habe eine Ergänzungsfrage zu einem alten Thread von mir. Ausgangslage ist die Batchdatei, die ...