Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Proramm hängt sich nach 30 Min. Inaktivität auf

Frage Microsoft Windows Tools

Mitglied: Bino1988

Bino1988 (Level 1) - Jetzt verbinden

17.08.2011 um 07:17 Uhr, 4393 Aufrufe, 7 Kommentare

Hallo zusammen,
wir haben bei einem Kunden ein Programm im Einsatz, welches sich nach ca. 30 Minuten Inaktivität aufhängt. Das heißt der User arbeitet schon noch am PC, allerdings nicht direkt in dem Programm. Sobald er dann das Programm wieder aufrufen will, hängt sich die Anwendung auf.

Das ganze passiert nur auf Windows 7 Rechnern (64bit), nicht auf XP (32bit). Die Anwendung ist eine 32bit-Anwendung.

Habt ihr eine Idee, womit ich der Ursache näher auf den Grund rücken kann?
Der ProcMon zeigt an sich nicht viel an - einzige Auffälligkeit ist, dass in dem Moment, wo die ax.exe wieder angesprochen wird, zwei TCP/IP-Pakete gesendet werden, allerdings keine zwei neuen ankommen.

Vorher gab es immer 2x send und 2x receive.

Bin derzeit für jede Anregung dankbar. Netzwerkprobleme würde ich an sich erstmal ausschließen, da die XP-Rechner vor Ort keine Probleme machen.

Danke!
Bino
Mitglied: dan0ne
17.08.2011 um 08:04 Uhr
Morgen,

waere schon hilfreich wenn du sagen wuerdest was das Programm macht! Ich mein, so kann das ALLES sein..

Gruss
Bitte warten ..
Mitglied: 32067
17.08.2011 um 09:01 Uhr
Hallo,

keine Ahnung, ob das bei dir irgendwie passt, aber bei "30 Minuen Inaktivität" klingeln bei mir immer Firewall-Timeout-Alarmglocken ...

(Verbindung zwischen Rechner A und Rechner B läuft durch eine Firewall. Damit die Firewall-Tables nicht überlaufen, werden Verbindungen ohne Datenverkehr irgendwann aus der Tabelle rausgeworfen, 30 min sind durchaus ein üblicher Wert. Wenn dann doch noch ein Paket irgendwann kommt, wird es gedroppt. Wie die Anwendungen damit umgehen ist durchaus unterschiedlich, Hänger, Abstürze, alles schon gesehen ... )
Bitte warten ..
Mitglied: Bino1988
17.08.2011 um 09:31 Uhr
Hallo,

danke schonmal für die Antwort - das werde ich mal prüfen.
Andere Ideen waren jetzt noch folgende:

- Windows Firewall
- IPv6 ist aktiviert, dadurch steht IPv4 an zweiter Stelle. Das könnte es zu Problemen führen
- Die Anwendung führt nach 30 Min. keinen erneuten Handshake durch

- außerdem habe ich davon gehört, dass Windows 7 Anwendungen, die länger inaktiv sind, in eine Art "Wartemodus" versetzen kann.
Hat da jemand weitere Infos zu, bzw. wie man so etwas prüfen oder verhindern kann?

Des weiteren werde ich mal die Windows-Firewall ausschalten und IPv6 deaktivieren.

Für weitere Ideen wäre ich aber noch dankbar!

Bino

Update: Habe gerade einen Windows 7-Rechner im eigenen Netzwerk (nicht beim Kunden) getestet. Hier tritt der Fehler nicht auf.
Die Verbindung zum Kunden ist eine 6mbit-Leitung, an beiden Seiten eine Firewall.
Bitte warten ..
Mitglied: Anton28
17.08.2011 um 10:52 Uhr
Hallo Bino,

was sagt die Firewall zum Zeitpunkt des Fehlers der Anwendung ?
Werden da Pakete gedropt ?

Welche Firewall ist im Einsatz ?

Gibt es auf der FW irgendwelche Timeouts für offene Verbindungen ?
Oder ?
Oder ?

Was sagen die Firewall Logs auf beiden Seiten ?

Was ist das für eine Anwendung ?
Was macht die Anwendung ?
Spricht die Anwendug mit einer DB ?
Gibt es bei der Anwendung eine Time Out um Ressourcen zu schonen ?

Ein paar mehr Details würden schon sehr hilfreich sein !
Mein Feenstaub ist leider ausgegangen und meine magische Glaskugel ist zerbrochen

Gruß

Anton
Bitte warten ..
Mitglied: mrtux
17.08.2011 um 12:34 Uhr
Hi !

Da das nur bei Win 7-64 passiert wäre ich mir nicht sicher, ob das mit der Firewall zusammenhängt, denn wenn die XP Rechner an der gleichen Firewall hängen.....Testweise kannst Du die Windows Firewall (und evt. den Windows Defender) mal komplett abschalten. Ansonsten würde ich mich an deiner Stelle mal mit dem Hersteller des Programmes in Verbindung setzen und deine obige Frage eben diesem stellen.

Wir arbeiten (bei unseren Kundenterminen) auch immer wieder mit Applikationen, die speziell entwickelt wurden oder mit Branchenlösungen und da gibt es immer mal solche Probleme und wenn das besagte Programm noch weiterentwickelt wird, wird der Hersteller auch einen Support haben und der weiss meist schon, wo sich das Byte verklemmt hat....

mrtux
Bitte warten ..
Mitglied: Bino1988
30.08.2011 um 14:37 Uhr
Hallo zusammen,

es gibt neue Infos:
Das Problem hängt tatsächlich mit der Firewall zusammen.
Diese verwirft TCP-Sessions, falls 30 Minuten kein Traffic gelaufen ist.

Das Log der FW sieht bei einem Windows XP-Client (kein Absturz) folgendermaßen zum Ende hin so aus:

(source-IP) - (destination-IP) - (Port) - (time) - (note)
1.1.1.1 - 2.2.2.2. - 1111 - 1924 sec - Close TCP Fin
1.1.1.1 - 2.2.2.2. - 1111 - 1924 sec - Close TCP Fin
1.1.1.1 - 2.2.2.2. - 1111 - 1922 sec - Close TCP Fin

Das Log der FW sieht bei einem Windows 7-Client (Absturz) folgendermaßen aus:

(source-IP) - (destination-IP) - (Port) - (time) - (note)
1.1.1.1 - 2.2.2.2. - 1111 - 1907 sec - Close AGE Out
1.1.1.1 - 2.2.2.2. - 1111 - 1907 sec - Close AGE Out
1.1.1.1 - 2.2.2.2. - 1111 - 1805 sec - Close AGE Out

Man sieht also, dass die Sessions von der FW abgebrochen werden.

Ich frage mich jetzt nun, wo man ansetzen soll. Wir haben nun erstmal den Timer hochgesetzt, dass der betroffene Port länger als 30 Min. offen bleiben darf.
Das hilft vorerst auch soweit, sollte aber auf Dauer ja keine Lösung sein.

Wo muss man hier ansetzen, zu suchen? Bei Windows 7? Die Netzwerkkarte? Das abstürzende Programm?

Danke für eure Hilfe!
Bino
Bitte warten ..
Mitglied: 99045
30.08.2011 um 15:36 Uhr
Hi,

sieh mal nach, ob bei deiner Windows-Version etwas zum nachfolgenden Registry-Key eingetragen ist, evtl. liegt da der Hund begraben.
http://technet.microsoft.com/en-us/library/cc783940(WS.10).aspx

Ob der Eintrag bei Win7-x64 aber überhaupt relevant ist, kann ich nicht sagen.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows 10
Anmeldung bei Notebook funktionietr nur nach ca 30 min (2)

Frage von GrauerStar zum Thema Windows 10 ...

Server-Hardware
gelöst Supermicro 813-4 Server - hängt bei Neustarts (4)

Frage von NetzwerkDude zum Thema Server-Hardware ...

Windows 7
gelöst Automatische User Abmeldung nach Inaktivität (30s) (10)

Frage von IT-Blondi zum Thema Windows 7 ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...