Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

PSExec - kann keine Prozesse auf Windows 2003 Server starten

Frage Microsoft

Mitglied: Der-Phil

Der-Phil (Level 2) - Jetzt verbinden

15.06.2009, aktualisiert 15:25 Uhr, 7464 Aufrufe, 6 Kommentare

Hallo,

ich komme hier einfach nicht weiter....

Von einem Windows 2003 Server möchte ich per PSExec auf einem anderen 2003-Server eine Batch-Datei starten.

Aus welchen Gründen auch immer, kann ich zwar ohne Probleme auf meinen alten Servern und XP-Clients per PSexec Prozesse starten, möchte ich auf den Servern jedoch etwas starten erhalte ich immer Fehlermeldungen:

Beispiel 1: Taschenrechner entfernt starten:

c:\psexec> psexec \\Server -d -i "C:\Windows\system32\calc.exe"

PsExec could not start C:\Windows\system32\calc.exe on SERVER:
Falscher Parameter

Beispiel 2: Kommandozeile
c:\psexec> psexec \\SERVER cmd.exe

cmd.exe exited on DUGSERVER with error code 1.


Habt ihr eine Idee, woran das liegen konnte? Ich versuche das ganze von einem Domänen-Administratoren-Account. Auch das übergeben der Benutzerdaten mit -u -p änderte nichts. Starte ich den gleichen Befehl auf dem Server selbst, läuft er.


Vielen Dank für euere Hilfe

Phil
Mitglied: Der-Phil
15.06.2009 um 15:45 Uhr
Ich befürchte, ich weiß schon, woran es liegt....

PsExec scheint ein Problem damit zu haben, wenn kein User auf der Konsole angemeldet ist...

Kennt ihr eine Möglichkeit, das Problem zu umgehen?

Gruß
Phil Stricker
Bitte warten ..
Mitglied: DerWoWusste
16.06.2009 um 00:26 Uhr
Hatte ich auch mal. Ursache war bei mir: ich hatte Monate vorher schon mit einer alten psexec-Version gearbeitet - mit dieser lief auch noch alles weiterhin, mit der aktuellen kam "falscher Parameter". Fehler wurde von Sysinternals bestätigt.
Bitte warten ..
Mitglied: Der-Phil
16.06.2009 um 09:07 Uhr
Hallo,

bist Du dann wieder auf die alte Version, oder wie hast Du das Problem gelöst bzw. umgangen?

Gruß
Phil
Bitte warten ..
Mitglied: DerWoWusste
16.06.2009 um 11:07 Uhr
Die alte ging, ja. Um mit der neuen zu arbeiten muss der psexec-Dienst per sc.exe entfernt werden, dann ging auch die neue wieder, meine ich.
Bitte warten ..
Mitglied: UHAG
18.06.2009 um 00:56 Uhr
hallo, habe das gleiche problem

nur wie soll ich das "psexec-Dienst per sc.exe entfernt werden" machen?
einen dienst mit psexec ... gibts bei mir nicht...

eröffnet die psexecsvc.exe auf der remote maschine und dann kommt

cmd exited on *server* with error code 1. zurück

vielen danke für die antwort
Bitte warten ..
Mitglied: DerWoWusste
18.06.2009 um 09:14 Uhr
hallo, habe das gleiche problem
cmd exited on *server* with error code 1
Ist das das gleiche Problem? Kommt die Meldung mir parameters nicht? Dann ist es nicht das gleiche Problem.

Zum enrfernen des Dienstes: Psexec legte in alten Versionen auf dem Zielsystem einen Dienst mit dem Namen PS-irgendwas an (falls Du eine alte Version nutzt). mit sc /delete kann man Dienste löschen, genaue Syntax siehe sc /?
sc.exe gehört zu Vista und xp dazu.
Bitte warten ..
Ähnliche Inhalte
Exchange Server
gelöst Exchange 2003 von Windows 2003 Server lösen bzw. entfernen (5)

Frage von plexxus zum Thema Exchange Server ...

Windows Server
Windows Nano Server 2016 Domain Join

Link von Mvinogradac zum Thema Windows Server ...

Windows Server
Installation Windows Nano Server für Hyper-V

Link von Mvinogradac zum Thema Windows Server ...

Heiß diskutierte Inhalte
Verschlüsselung & Zertifikate
gelöst Festplattenverschlüsselung im Ausland (13)

Frage von Nicolaas zum Thema Verschlüsselung & Zertifikate ...

Windows Server
gelöst Microsoft-Lizenz CALs und passendes Server-Betriebssystem (12)

Frage von planetIT2016 zum Thema Windows Server ...

Festplatten, SSD, Raid
gelöst Fehlerhafte Blöcke im RAID 10 (12)

Frage von Kojak-LE zum Thema Festplatten, SSD, Raid ...

Netzwerkgrundlagen
gelöst Cisco SG500 Series LAG hat sich von selbst umgestellt (11)

Frage von Ex0r2k16 zum Thema Netzwerkgrundlagen ...