Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Psexec Windows7 und Windows Server 2008

Frage Microsoft Windows Server

Mitglied: dark.cube

dark.cube (Level 1) - Jetzt verbinden

28.02.2011 um 10:43 Uhr, 9758 Aufrufe, 8 Kommentare

Hallo allerseits,

ich möchte mittels psexec eine Batchdatei ausführen die auf einem Server im Netzwerk in der Domäne liegt. Sachverhalt ist folgender:
Benutzer ruft über Access die Datei: "get_single_profile.cmd" auf, diese halt folgenden Inhalt:
01.
 "V:\006_Personal\100 Bewerber\Bewerberliste\Bewerberportal\PsTools\psexec" -u user -p passwort \\Server "D:\venitecdata\002_daten\006_Personal\100 Bewerber\Bewerberliste\Bewerberportal\get_single_profile.cmd" %1 
Hier liegt auch das Problem, die psexec wird meines Erachtens nach nicht ausgeführt und zwar nur bei Benutzern mit Windows 7(sowohl bei der 32 als auch der 64bit Prof. Version), Benutzer mit Windows XP haben keine Probleme.
Ich habe den obigen Inhalt manuell über die cmd, welche ich als Administrator gestartet habe, ausgeführt und erhalte als Fehlermeldung:
01.
  "Could not start PsExec service on 192.168.2.200:  Zugriff verweigert"
Der Service läuft auf dem Server - Windows Server 2008.
Folgendes habe ich schon ausprobiert:
-Beim Aufruf von psexec noch ein -h dran gehängt
-Die Windows Firewall abgeschaltet
-Etliche Threads nach ähnlichen Problemen durchsucht, allerdings keine Lösung gefunden.

Hintergrund von dem Ganzen ist es, Unterlagen von Bewerbern die er im Internet auf einen FTP-Server geladen hat lokal verfügbar zu machen. Und zwar von einem gerade ausgewählten Benutzer.
Hat irgend jemand eine Idee was ich noch tun könnte oder gibt es Alternativen zu psexec?
Mitglied: DerWoWusste
28.02.2011 um 19:57 Uhr
Mir leuchtet noch nicht ein, warum es sich bei win7 und xp unterschiedlich verhält. Teste bitte von win7 aus den Zugriff auf admin$ auf dem Server.
Bitte warten ..
Mitglied: dark.cube
28.02.2011 um 20:04 Uhr
Den Test auf den admin$ teste ich mit net use wenn ich es gerade recht im Kopf habe. Wenn ich mich recht entsinne hatte ich das auch schon getestet, Zugriff von Windows 7 aus war möglich. Aber ich werde es morgen nochmal testen und nochmals bescheid geben.
Bitte warten ..
Mitglied: dark.cube
01.03.2011 um 09:38 Uhr
http://www.abload.de/image.php?img=netshareagvh.jpg

PsTools ist das Benutzerkonto mit dem psexec ausgeführt werden soll und sdunstone ist der aktuelle Benutzer des Systems, sprich ich.
Passwörter sid übermalt. Kann ich Bilder auch einbinden?
Bitte warten ..
Mitglied: DerWoWusste
01.03.2011 um 09:51 Uhr
Zugriff auf admin$ ist das Problem. Lies http://www.jimmah.com/vista/content.aspx?id=6 führ's am Ziel-PC durch und starte den ZielPC neu.
Bitte warten ..
Mitglied: dark.cube
01.03.2011 um 10:37 Uhr
Hattest du mit Ziel-PC den Server gemeint oder meinen lokalen PC?
Ich habe den DWORD jetzt an meinem Rechner in der Registry gesetzt und habe den Rechner neu gestartet, dass alleine brachte nichts. Erst als ich meinen User-Account noch der
Gruppe der Organisations-Admins hinzugefügt habe konnte ich psexec ausführen. Gibt es denn noch irgendwelche Alternativen, weil ich möchte die Nutzer, die mit Windows 7 arbeiten und psexec brauchen nur ungerne der Gruppe der Organisations-Admins hinzufügen.
Bitte warten ..
Mitglied: DerWoWusste
01.03.2011 um 10:45 Uhr
Ziel-PC ist der Server.
Wenn es bei xp geht und Du da das selbe Konto benutzt, dann frage ich Dich, was die Gruppenmitgliedschaft bewirkt haben soll (auch wenn es so ist) - verstehe ich nicht.
Fakt ist, dass psexec von einem Konto aufgerufen werden muss, dass auf der Gegenstelle Adminrechte hat.
Bitte warten ..
Mitglied: dark.cube
01.03.2011 um 11:21 Uhr
Also ich habe mich bei XP mit dem selben Benutzerkonto angemeldet. Nachdem ich mein Benutzerkonto jetzt zu den Organisations-Admins hinzugefügt habe ging es.
Ich kann dann aber nicht nachvollziehen, wieso es bei XP ging. Naja ich muss beim Server noch die Registry verändern und dann mal testen ob es auch ohne Mitgliedschaft
bei den Organisations-Admins geht. Für mich ist das Ganze somit nicht ganz nachvollziehbar aber dir geht es ja anscheinend ähnlich. Seltsam das Ganze.
Muss bis zur Mittagspause warten ehe ich den Server neu starten kann.
Bitte warten ..
Mitglied: dark.cube
01.03.2011 um 13:00 Uhr
Also beim Server "LocalAccountTokenFilterPolicy" in der Registry auf eins gesetzt und Server neu gestartet. Mich selbst wieder aus der Gruppe der Organisations-Admins entfernt, Ergebnis: Zugriff verweigert.
Ich kanns nicht nachvollziehen wieso es bei XP dennoch geht. Aufruf sah wie folgt aus:
01.
 psexec \\192.168.2.200 -u sdunstone -p passwort -h cmd
Also wenn es anders nicht gehen sollte, werde ich es entweder lokal lösen müssen oder die betroffenen Personen der Admingruppe hinzufügen.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(1)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...