Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

QJuery - Lightbox

Frage Entwicklung JavaScript

Mitglied: ottscho

ottscho (Level 2) - Jetzt verbinden

28.03.2012, aktualisiert 07:37 Uhr, 3997 Aufrufe, 11 Kommentare

Guten Morgen,

bei meinem Testshop wird eine Lightbox (class="modal_open") vwerwendet um die Versandkosten in einem kleinen Fenster darzustellen.
Vorerst funktioniert das auch wunderbar, solange keine Artikelvariante ausgewählt ist.

Beispiel: http://testshop.ottscho.de/mode-fashion/schuhe/10/lunaracer?c=1119

Wird aber eine Artikelvariante ausgewählt, so funktioniert der Lightbox-Effekt nicht mehr.
Ich hoffe ihr könnt mir weiterhelfen. Bis jetzt konnte ich noch keine Lösung finden.

Ich denke es hat mit den verschiedenen disyplay:none DIV Boxen der anderen Varianten zu tun. Aber sicher bin ich mir auch nicht.

Besten Dank

MFG
Mitglied: mak-xxl
28.03.2012 um 08:09 Uhr
Moin ottscho,

es sollte reichen, wenn das Konstrukt
01.
<p class="tax_attention modal_open"> 
02.
... 
03.
</p>
nur einmal am Ende der Artikelliste erscheint.
Du hast es je Artikel einmal stehen (Zeile 449-451; 470-472, 491-493ff)

Freundliche Grüße von der Insel - Mario
Bitte warten ..
Mitglied: ottscho
28.03.2012 um 08:39 Uhr
Hallo Mario,

danke für deine AW.

Was heißt nur am Ende?
Die Funktion ist ja auf die a Tags gelegt, welche in einem Element mit class modal_open stehen müssen.

Es steht dort öfter, da die Zeilen ja je nach Artikelvariante eingeblendet/ausgeblendet werden.
Das macht das Templatesystem automatisch.

Soll ich mal ein DIV mit der Class modal_open machen, welches die Zeilen 449 - 493 etc. beinhalten und die zusätzlichen Classen mit modal_open entfernen?
Bitte warten ..
Mitglied: mak-xxl
28.03.2012 um 08:54 Uhr
Moin ottscho,

Zitat von ottscho:
Was heißt nur am Ende?

Am Ende aller Artikeldaten (-varianten), da der Link 'Versandkosten' immer erscheint (erscheinen muss).

Die Funktion ist ja auf die a Tags gelegt, welche in einem Element mit class modal_open stehen müssen.

Dieses Element gibt es aber dann pro Artikel im Quelltext - nur einmal ist notwendig.

Es steht dort öfter, da die Zeilen ja je nach Artikelvariante eingeblendet/ausgeblendet werden.
Das macht das Templatesystem automatisch.

Den Link 'Versandkosten' ausblenden?

Soll ich mal ein DIV mit der Class modal_open machen, welches die Zeilen 449 - 493 etc. beinhalten und die zusätzlichen
Classen mit modal_open entfernen?

Ja, und der Container muss in Zeile 495/496 (vor dem Relaunch gezählt)

Freundliche Grüße von der Insel - Mario
Bitte warten ..
Mitglied: ottscho
28.03.2012 um 09:38 Uhr
Hi,

so jetzt habe ich alle class modal_open entfernt und nur noch ein DIV (kompletter Mittelbereich des Artikels) damit bestückt.

Aber gleiches Probelm. Die Lightbox funktionert beim ersten Aufruf des Artikels. Wird eine Variante ausgewählt, so wechselt der Inhalt und die Lightbox geht nicht mehr.

Kann es sein, wenn die Seite z.B. so geladen wird:

01.
<div class="modal_open"> 
02.
 <div id="sichtbar"><a href="test.htm">Link</a> 
03.
 <div id="display_none"><a href="test.htm">Link2</a> 
04.
 <div id="display_none"><a href="test.htm">Link3</a> 
05.
</div>
Der erste Links mit der Lightbox funktioniert, die anderen Beiden sind ja nichts sichbar. Wird jetzt durch eine User-Interatkion (Auswahl der Variante) der erste Link ausgeblendet und der zeite Link eingeblendet. Dann sollte doch die Lightbox für den zweiten Link nun auch gehen...
Bitte warten ..
Mitglied: mak-xxl
28.03.2012 um 10:13 Uhr
Moin ottscho,

prinzipiell so:
01.
<div class="irgendeine"> 
02.
 <div id="Artikel-01">Artikeldaten</div> 
03.
 <div id="Artikel-02">Artikeldaten</div> 
04.
 ... 
05.
 <div id="Artikel-99">Artikeldaten</div> 
06.
 <div id="Versandkosten" class="modal_open">Versanddaten</div> 
07.
</div>
Die <div> mit der id="Artikel-##" werden jeweils mit der Artikelauswahl sichtbar gemacht (immer nur einer), der <div> mit der id="Versandkosten" ist so nur einmal vorhanden und immer sichtbar.
Bitte immer die Eindeutigkeit der IDs beachten!

Freundliche Grüße von der Insel - Mario

[Edit] Zeile 6 Klasse nachgetragen [/Edit]
Bitte warten ..
Mitglied: ottscho
28.03.2012 um 10:30 Uhr
Hallo Mario,

jetzt verstehe ich nicht ganz was du meinst.
Anbei ein Screenshot mit Markierungen.
http://www.myimg.de/?img=screenddbfb.jpg

Ich habe meinen Haupt DIV (blauer Bereich). Dieser hat die Class modal_open.
Darin gibt es mehrere DIV

- Für jede Variante ein DIV, welche ausgeblendet sind.
- Eine DIV, welche angezeigt wird wenn keine Variante ausgewählt ist.

Jeder der DIVs beinhaltet einen eigenen Versandkostentext.

Was meinst du nun mit ID Versandkosten? Kann ich nicht finden.
Mir fallen im Quellcode keine doppelten ID's auf!

Danke dir
Bitte warten ..
Mitglied: mak-xxl
28.03.2012 um 10:55 Uhr
Zitat von ottscho:
Jeder der DIVs beinhaltet einen eigenen Versandkostentext.

Was meinst du nun mit ID Versandkosten? Kann ich nicht finden.

Ich hatte geschrieben: prinzipiell.

Mir fallen im Quellcode keine doppelten ID's auf!

In Deinem letzten Post schon:

<div id="display_none"><a href="test.htm">Link2</a>
<div id="display_none"><a href="test.htm">Link3</a>

- Für jede Variante ein DIV, welche ausgeblendet sind.
- Eine DIV, welche angezeigt wird wenn keine Variante ausgewählt ist.

Das ist korrekt - nur warum das Nächste:

Jeder der DIVs beinhaltet einen eigenen Versandkostentext.

Macht er nicht - nur einen Link. Und hier liegt das Problem: Wenn der Aufruf der Lightbox immer dann klappt, wenn kein Artikel gewählt ist, gilt:

- Eine DIV, welche angezeigt wird wenn keine Variante ausgewählt ist.

Aus diesem <div> kommt der funktionierende Aufruf.

Also heißt ein Lösungsvorschlag: Nimm den redundanten Code raus und setze den 'Versandkosten-Div' im Quelltext dorthin, wo er im Browser auch optisch erscheint - an das Ende aller 'Artikel-Divs'.

Genau das meint das letzte Posting von mir.

Freundliche Grüße von der Insel - Mario

PS: Wenn Du wirklich unterschiedliche Versandkosten/-hinweise brauchst, gib dem Link die Artikelnummer mit ...
Bitte warten ..
Mitglied: ottscho
28.03.2012 um 11:07 Uhr
naja, leider kann ich das nicht so machen.
Was den Versandtext angeht schon. Dieser ist bei allen Artikel gleich.
(Der Shop bzw. Code ist ja original. Ist also leider von Shopware schon so programmiert!)

Ich will die Lightbox auch noch auf die Lieferzeit-Angabe anwenden. Diese ist definitiv bei jedem Artikel anderst. Daher bleibt mein Problem somit erhalten, weil ich den redudanzen Code brauche.
Zwar nicht für die Versandkosten, aber für die zukünftige Lieferzeit Einblendung.
Bitte warten ..
Mitglied: mak-xxl
28.03.2012 um 12:45 Uhr
Moin ottscho,

ich beziehe mich auf den von Dir geposteten FireBug-Auszug.

Wenn Du zu jedem Artikel einzelnen 'Versandcode' brauchst - nun gut.

Was aber bewirkt dann der Container ab Zeile 26 (<div id="article_details"> - Versandkosten für 'keinen' Artikel? (Ein Artikel wird doch immer angezeigt - zumindest in der mit obigem Link erreichbaren Testversion)

Nimm den Block einmal heraus und teste die Geschichte.

Freundliche Grüße von der Insel - Mario
Bitte warten ..
Mitglied: ottscho
28.03.2012 um 13:01 Uhr
der Container ab Zeile 26 <div id="article_details"> wird angezeigt wenn keine Variante des Artikels ausgewählt ist.
Sprich, beim öffnen der URL, welche ich im ersten Posting geschrieben habe.

Hier ist aber im Dropdown nichts ausgewählt und daher wird dieses <div id="article_details"> angezeigt.
Sobald ich aber eine Variante auswähle, wird dieses div ausgeblendet und die artikelspezifischen Informatuionen angezeigt.

Es muss sich hierbei ja auch um einen Bug vom Hersteller handeln, da das Template ein default Template ist.

Dann muss ich das wohl so hinnehmen.
Bitte warten ..
Mitglied: ottscho
28.03.2012 um 14:24 Uhr
So, nach dem das jQuery angepasst wurde, funktioniert es nun:

01.
/* 
02.
$('.modal_open a').click(function(event) { 
03.
			event.preventDefault(); 
04.
			$.post(this.href, function(data) { 
05.
				$.modal(data, '', {'position':'fixed'}).find('.close').remove();			 
06.
			}); 
07.
		}); 
08.
*/ 
09.
		 
10.
		$('.modal_open a').live('click', function(event) { 
11.
		  event.preventDefault(); 
12.
		  $.post(this.href, function(data) { 
13.
		  $.modal(data, '', {'position':'fixed'}).find('.close').remove(); 
14.
		  }); 
15.
		});
Bitte warten ..
Ähnliche Inhalte
Webentwicklung
Contao - Lightbox
Frage von Xaero1982Webentwicklung2 Kommentare

Tach Zusammen, ich hab nen Problem: Ich soll ne Webseite bearbeiten die auf Contao 2.10.4 basiert. Ich möchte einige ...

Entwicklung
Video Lightbox - Position Video container ändern (CSS - JS codes)
Frage von kesartEntwicklung

Hallo Ich entschuldige mich im Voraus für die Rechtschreiben Fehler aber ich bin Engländer wohne aber in Deutschland! FRAGE ...

Neue Wissensbeiträge
Internet

USA: Die FCC schaff die Netzneutralität ab

Information von Frank vor 4 StundenInternet2 Kommentare

Jetzt beschädigt US-Präsident Donald Trump auch noch das Internet. Der neu eingesetzte FCC-Chef Ajit Pai ist bekannter Gegner einer ...

DSL, VDSL

ALL-BM200VDSL2V - Neues VDSL-Modem mit Vectoring von Allnet

Information von Lochkartenstanzer vor 8 StundenDSL, VDSL1 Kommentar

Moin, Falls jemand eine Alternative zu dem draytek sucht: Gruß lks

Windows 10

Microsoft bestätigt DMA-Policy-Problem in Win10 v1709

Information von DerWoWusste vor 8 StundenWindows 10

Wer sein Gerät mit der DMA-Policy absichert, bekommt evtl. Hardwareprobleme in v1709 von Win10. Warum? Weil v1709 endlich "richtig" ...

Verschlüsselung & Zertifikate

Die Hölle friert ein weiteres Stück zu: Microsoft integriert OpenSSH in Windows

Information von ticuta1 vor 12 StundenVerschlüsselung & Zertifikate

Interessant Die Hölle friert ein weiteres Stück zu: Microsoft integriert OpenSSH in Windows SSH-Kommando in CMD.exe und PowerShell

Heiß diskutierte Inhalte
Netzwerkmanagement
Mehrere Netzwerkadapter in einem PC zu einem Switch zusammenfügen
Frage von prodriveNetzwerkmanagement21 Kommentare

Hallo zusammen Vorweg, ich konnte schon einige IT-Probleme mit Hilfe dieses Forums lösen. Wirklich klasse hier! Doch für das ...

Windows Server
RODC kann nicht aus Domäne entfernt werden
Frage von NilsvLehnWindows Server19 Kommentare

HAllo, ich arbeite in einem Universitätsnetzwerk mit 3 Standorten. Die Standorte haben alle ein ESXi Cluster und auf diesen ...

Hardware
Kein Bild mit nur einer bestimmten Grafikkarten - Mainboard Konfiguration
gelöst Frage von bestelittHardware18 Kommentare

Hallo zusammen, ich hatte schon einmal eine ähnliche Frage gestellt. Damals hatte ich genau das gleiche Problem. Allerdings lies ...

Hardware
Links klick bei Maus funktioniert nicht
gelöst Frage von Pablu23Hardware16 Kommentare

Hallo erstmal. Ich habe ein Problem mit meiner relativ alten maus jedoch denke ich nicht das es an der ...