Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

RAID 1 nachträglich einrichten?

Frage Hardware

Mitglied: maddoc

maddoc (Level 2) - Jetzt verbinden

05.03.2011, aktualisiert 20:41 Uhr, 10543 Aufrufe, 6 Kommentare

Hallo,

kurze Vorgeschichte. Bei uns läuft ein Windows Server 2003 mit RAID 1 (Spiegelung). Diesen machte ich gestern neu. Zuerst ließ ich das Raid wie es war und wollte nur das Windows neu aufspielen. Ging aber nicht da er nach dem Neustart nach dem ersten Installationsschritt nur von CD Bootete. Also löschte ich das RAID beim Booten, installierte den Server neu, und wollte das RAID wieder erstellen. Die Festplatten ließ ich wie sie waren.

Beim ersten Start meldete lsass.exe einen Fehler und der Server fuhr nicht hoch. Also löschte ich wieder das RAID und startete neu. Nun sagte er mir das der ntldr fehlt. Gut dachte ich schnelle die Server CD rein und fix rüber kopiert. Zu meinem Erschrecken war aber nur noch der Windows Ordner und der System Volume Informationsordner auf beiden gespiegelten Platten.. Nichts was ich versuchte klappte darauf hin wo ich das System erneut installieren musste.

Der Server läuft jetzt wieder soweit. Nun muss ich aber am Montag das mit dem RAID hin bekommen. Da es mein erstes RAID ist was ich einrichte hoffe ich auf ein paar gute Tipps von euch.. Muss ich denn vielleicht zuerst die Software auf den PC dazu installieren? Oder die zweite Festplatte löschen und die Partitionen entfernen? Blick da nicht durch.

Gruß Maddoc
Mitglied: Pjordorf
05.03.2011 um 20:47 Uhr
Hallo,

Zitat von maddoc:
Der Server läuft jetzt wieder soweit. Nun muss ich aber am Montag das mit dem RAID hin bekommen. Da es mein erstes RAID ist
was ich einrichte hoffe ich auf ein paar gute Tipps von euch.. Muss ich denn vielleicht zuerst die Software auf den PC dazu
installieren? Oder die zweite Festplatte löschen und die Partitionen entfernen? Blick da nicht durch.
Nun, im Prinzip gehst du folgenderweise vor.
1. RAID Verbund erstellen
2. Volumes auf RAID Kontroller erstellen falls gewünscht
3. System auf das Bootlaufwerk Installieren
4. Windows Einstellungen vornehmen
Fertig

Dein OS Windows sollte von dem RAID so nichts mitbekommen. Für Windows ist es nur ein Datenträger.

Jetz kommen wir zu den netten feinheiten die je nach Hersteller und Modell des RAID Kontrollers varieren. Aber sei nicht böse wenn ich jetzt frage: Was hast du überhaupt an hardware zur verfügung und was für Vo9lumes willst du wie haben?

Gruß,
Peter
Bitte warten ..
Mitglied: maddoc
05.03.2011 um 22:00 Uhr
Als Mainboard habe ich das A7N8X-E Deluxe von ASUS mit dem Silicon Image Sil3112A Chipsatz RAID Controller. (RAID0 und RAID1)
Hardware? Also zwei 120 GB Seagate S-ATAs gleichen Typs. 1GB RAM, 3GHz AMD CPU. Wie gesagt ist davor Problemlos gelaufen mit RAID1. Da das mein erstes RAID ist was ich mache und die Setup für Windows im Treiberpaket gesehen habe dachte ich es liegt daran das ich dies nicht davor installierte. Aber wenn du sagst das das RAID erstmal garnichts mit Windows zu tun hat fällt die Fehlerquelle auch weg..
Bitte warten ..
Mitglied: Pjordorf
06.03.2011 um 21:06 Uhr
Hallo,

Zitat von maddoc:
Als Mainboard habe ich das A7N8X-E Deluxe von ASUS mit dem Silicon Image Sil3112A Chipsatz RAID Controller. (RAID0 und RAID1)
Hardware?
Ein Server mit diesen art RAID (Chipsatz Onboard) zu betreiben ist fast schon Fahrlässige Firmenschädigung. Wenn es dir das Board abraucht hast du erst recht Probleme. Ein PCI/PCI-e RAID Kontroller kostet wirklich nicht viel wenn ich nur 2 HDD und RAID 1 haben will und ist dem Onboard haushoch überlegen und portable obendrein.

Wie gesagt ist davor Problemlos gelaufen mit RAID1.
Aber jetzt nicht mehr! Im BIOS alle Einstellungen geprüft, evtl. alles auf Default gesetzt / BIOS gelöscht und wieder neu eingestellt (Kann schon mal ein Bit klemmen)?
Wird eine Plat5te alleine am RAID Kontroller korrekt erkannt? Kann da ein Volume erstellt werden (BIOS RAID verwaltung, nix OS hochfahren und dann RAID Software verwenden)? Geht es mit der anderen Platte auch? Können beide Platten gemeinsam als einzelnes Volume im RAID eingerichtet werden? Laufen die dann sauber? Können beide Platte im RAID als ein Volume (RAID1) erstellt werdenh und läuft das dann sauber? Wenn nicht, ist wohl dein RAID Baustein nicht mehr in Ordnung.

Aber wenn du sagst das das RAID erstmal garnichts mit Windows zu tun hat fällt die Fehlerquelle auch weg..
Ein RAID sollte immer OS unabhängig sein, um im Fehlerfalle des OS oder einer defekten Platte auch ohne OS das RAID neu aufbauen zu können. Welches OS hinterher drauf läuft, sollte wurscht sein. es sieht nur den Datenträger. Das sich dahinter ein RAID befindet ist für das jeweilige OS belanglos.

Solltest du aber ein sogenanntes Software RAID verwendet haben dann sieht es wiedre anders aus. Da wären deine Platten im BIOS als ISE / SATA oder AHCI eingebunden und werden als seperate Platten dem OS zur verfügung gestellt. Dann ist es sache deines OS (hier Microsft Windows Server 2003) die Platten als RAID zusammen zu binden. Dazu wird serlbstverständlich die Rechenleistung des OS verwendet. Damit das geht sollten die Platten als Dynamische Platte eingebunden werden. Nach der Installation des OS Server 2003 mit dem Datenträgermanager die Platten in Dynamische wandeln (Achtung, ein zurück mit Boardmitteln ist ohne Datenverlust nicht möglich), dann die Platte welche gespiegelt werden soll auswählen und Spiegelung (RAID 1) aktivieren. Jetzt macht es dein OS. Dazu braucht es keinen RAID Chip weder4 Onboard noch in Form eines externen RAID Kontrollers.

Was du hast oder was du hattest kannst nur du wissen.

Alle oben geschilderten Arbeiten NUR DANN DURCHFÜHREN WENN EINE DATENSICHERUNG GEMACHT WURDE. Arbeiten am RAID, können, müßen aber nicht zum Datenverlust führen. Bei Korrekter Handhabung können Festplatten getauscht, Volumes vergrößert werden ohne das es zu Datenverlust kommt oder der Server dazu runter gefahren werden muss. Das geschieht Online und ohne das Anwender groß etwas bemerken.

Gruß,
Peter
Bitte warten ..
Mitglied: maddoc
07.03.2011 um 00:32 Uhr
Hallo,

ja beide Platten werden korrekt vom RAID Controller erkannt. Wenn ich ein Raid einrichte wird dies ebenfalls korrekt vom Controller angezeigt. Windows erkennt in diesem Fall was auch korrekt ist nur eine Platte. Was mich nur gewundert hat nachdem ich Windows installiert habe und das RAID einrichtete 1. kein Kopiervorgang der ja ziemlich lagne dauern kann statt fand 2.) danach nur die Partition C (es gibt noch D) angeglichen war und zwar alle Daten weg außer das Windows und System Volume Verzeichnis..

Denk mal habe heute ne ganz schöne Aufgabe vor mir. Hoffe ich bekomme das hin. Gesichert habe natürlich gleich alles

PS: Der Server steht in einer Firma die ich betreue. Mit der Hardware habe ich nichts zu tun.Gruß Oli
Bitte warten ..
Mitglied: Pjordorf
07.03.2011 um 11:44 Uhr
Hallo,

Zitat von maddoc:
ja beide Platten werden korrekt vom RAID Controller erkannt. Wenn ich ein Raid einrichte wird dies ebenfalls korrekt vom
Controller angezeigt. Windows erkennt in diesem Fall was auch korrekt ist nur eine Platte.
Das ist soweit dann OK.

Was mich nur gewundert hat nachdem ich Windows installiert habe und das RAID einrichtete
?!? Du willst hier nochmals ein RAID einrichten, nachdem du schon ein RAID angebunden hast?

1. kein Kopiervorgang der ja ziemlich lagne dauern kann statt fand
Hättest du nur in der Sofware RAID Variante. Beim Hardware RAID macht es deine Hardware und du siehst es en den Zustands LEDs deiner Festplatte(n) / Swap Cages oder in der RAID Software des Kontrollers. Ausserdem hast du doch das RAID neu aufgebaut und neue Volumes. Darauf hast du dein OS Installiert. Wieso soll jetzt noch kopiert werden? Das ist doch längst geschehen da du doch ein RAID 1 hast.

2.) danach nur die Partition C (es gibt noch D) angeglichen war und zwar alle Daten weg außer das Windows und System Volume
Verzeichnis..
Du hast doch neu gemacht. Sogar Windows mehrmals Installiert.

Du kannst danach doch nur noch deine Datensicherung nehmen und den alten Stand wiederherstellen.

Oder habe ich deine Antworten komplett falsch verstanden?

PS: Der Server steht in einer Firma die ich betreue. Mit der Hardware habe ich nichts zu tun.
Wie soll das sinnvoll getrennt werden? Du sagst ich brauche Hardware RAID, der Hardwarelieferant sagt, du brauchst es nicht. Was soll dabei sinnvolles rauskommen?

Gruß,
Peter
Bitte warten ..
Mitglied: maddoc
07.03.2011 um 15:30 Uhr
Nee, mal net so verbissen verstehen. Der Server steht so wie er ist schon seit Jahren da incl.dem Raid. Ich habe den Server nur neu aufgesetzt. Mit dem RAID habe ich es jetzt. Hatte da was falsches gedrückt da ich die Hinweistexte nicht gelesen hatte. Wie gesagt Windows war drauf und ich wollte nur die zweite Platte einbinden. Da hätte ich vom automatikmodus im RAID Bios in den manuellen gemusst dort habe ich die auswahl die Platte mit RAID 1 zu kopieren. Der Automatikmodus wäre gegangen hätte ich noch kein OS installiert gehabt.

Danke dir für deine ausführlichen Infos.

Gruß Maddoc
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(1)

Tipp von agowa338 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...