Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Raid 5 abgeraucht?

Frage Hardware Festplatten, SSD, Raid

Mitglied: osa

osa (Level 1) - Jetzt verbinden

20.04.2006, aktualisiert 01.07.2006, 4642 Aufrufe, 11 Kommentare

Hallo,

habe hier einen alten MAgnia 5100 mit einem Raid 5.
5 Platten. Mit einem Mal: FIEEEEEP, sprich irgendwas ist nicht in Ordnung ;=)

Bluescreen folgte inkl. Reboot.
Beim initialisieren des Megaraidcontrollers bzw. der Platten fängt es wieder an zu fiepen.
Ok kurz taucht was mit mismatch auf, dann bin ich bios vom controller.

Alarm deaktiviert
Gehe auf physical drives und sehe dann den Raidverbund, alle Platten stehen auf: failed
Eine davon war letzte Woche schon failed, hab ich dann mit rebuild wieder hinbekommen.

Welche Optionen habe ich, wenn alle auf failed stehen bzw. woher kommt dies?
Die können ja nicht alle tot sein ;=)

Vielen Dank für sachdienliche Hinweise.
Mitglied: leknilk0815
20.04.2006 um 19:39 Uhr
Wenn keine HotSpare im Spiel ist, kannst Du alle wieder auf online setzen, im Log versuchen, rauszubekommen, welche das Schlamassel verursacht hat (sieht man an der Zeit), die entweder ziehen (ist vermutlich das Beste, da die vermutlich den SCSI- Bus dichtgemacht hatte) oder auf failed setzen. Danach neue Platte dran und rebuilden.
Betriebssystem NICHT hochfahren, KEINESFALLS einen Checkdisk erlauben, sonst ist Feierabend. Wenn der Rebuild gelungen ist, OS ohne CHKDSK hochfahren und schauen, was noch alles OK ist.
Das ganze natürlich ohne Garantie, ich hoffe, Du hast nen Backup.
Gruß - Toni
Bitte warten ..
Mitglied: osa
20.04.2006 um 23:47 Uhr
Danke sehr.

Mir fehlt die Erfahrung was im Falle das alle Platten failed sind zu tun ist ;=)
Nach deiner Prozedur, hat das System sauber gebootet.

Die Frage ist nun noch, wo das logfile liegt?
Es ist ein altes System und backup war nie das Problem, sondern das System an sich.
Es gibt dafür nicht mehr so wirklich viele Ersatzteile ;/

Und ein anderes System kommt aufgrund der Hardwarestruktur nicht wirklich in Frage bzw.
die Treiber für gewisse Devices sind ausschließlich für NT vorhanden und zu bekommen.

Hatte bei dem 2. Gerät mal probiert win2k/xp keine chance ;/
Bitte warten ..
Mitglied: leknilk0815
21.04.2006 um 07:53 Uhr
Hi,
freut mich, daß er wieder tut, allerdings wird die Freude nicht lange währen, solange die defekte Platte nicht gefunden und getauscht wurde. Das Log ist im Menü des Kontrollers, nicht auf der Platte (wo sollte er beim Crash denn auch hinschreiben??).
W2K: geht, man muß aber die W2K- Install- CD modifizieren, indem man die Treiber einbindet. Ist hier zum beschreiben zu kompliziert, da man viel tricksen muß wegen der Reg- Einträge. Zumindest habe ich damit HP LXPro 200 und LH Pro 200 zum laufen gebracht.
Gruß - Toni
Bitte warten ..
Mitglied: osa
21.04.2006 um 11:48 Uhr
Ja, leider konnte ich wahrlich nicht lange Freude dran haben. Ich hätte gleich in die logs schauen sollen, war nur zu müde.

Ist wieder abgeraucht, allerdings gibt es keine response von den Platten mehr (im bios des RC), sodass ich sie auch nicht online stellen kann. Wie geh ich denn nun vor, ich hab die Kiste erstmal aus gemacht, damit sich ggf. vorhandene Puffer entleeren.

Das Problem mit den Treibern ist:

Die Treibr für die normalen Komponenten sind kein Problem, es gibt aber eine Spezialsoftware, die während der Installation die Treiber für die Spezialkarten installiert (überlange PCI dinger).
Und diese sind unter Win2k scheinbar unbrauchbar.

WÜrde einiges erleichtern unter Win2k, naja...
Bitte warten ..
Mitglied: leknilk0815
21.04.2006 um 12:05 Uhr
hatte ich mir fast gedacht! Du hast eine Platte drin, die den Bus totmacht. Lösung: platte für Platte ziehen, bis Du die defekte hast (Achtung: nix vertauschen, sonst ist Schluss!!!!). Wenn das Array mit der Platte nicht mehr online geht, ersetze sie durch eine neue und setz wieder alle auf online. Danach die neue auf failed, damit hast Du wieder ein funktionierendes Array, allerdeings degraded. Nun kannst Du auf diese failed Disk einen Rebuild starten.
Treiber einbinden: Ich hab bei W2K und XP alle möglichen SCSI- Raid- Treiber, SATA usw. eingebunden, ist halt etwas probieren und Geduld nötig.
Es gibt auf der W2K- CD eine Datei, ich glaube, sie heißt txtsetup.sif, in der die Einstellungen für die Devices hinterlegt sind. Die darin enthaltenen Reg- Einträge sind recht kryptisch, deshalb habe ich ähnliche Einträge verwendet und abgeändert. Beispiel: HP Netraid: Eintrag kopiert und durch einen aktuellen Treiber ersetzt. Treiber in das Verzeichnis kopieren (der Treiber muß gepackt sein, dazu reicht es aber, die Erweiterung vin .sys in .sy_ umzubenennen, das OS merkts nicht).
So gehts im groben, etwas Mühe mußt Du Dir dann schon selbst machen...
Gruß und viel Spaß - Toni
Bitte warten ..
Mitglied: osa
21.04.2006 um 12:48 Uhr
Paar Minuten vom Netz getrennt, sind die Platten auch wieder ansprechbar.
Die verursachende Platte habe ich entfernt, auch wenn unter info keine Fehler für die Platte angezeigt werden.

Problem ist: hab keine so ollen Platten mehr da, d.h. der Raid läuft nun ohne die 5. Platte, ist zwar schei*e, aber die Kiste MUSS laufen, order from above...

Ich kauf nun mal bei eBay einen Schwung und dann ist gut (hoffe ich)
Ich hab nur noch 1 Platte, die aber kleiner ist als die anderen verwendeten (sah ich erst im Bios, Aufkleber war schon abgeschabt...)

Vielen Dank auf jeden Fall für deine Hilfe.
Wenn ich mal wieder Luft haben sollte (und nicht jeden Tag irgendwas krepiert ;=)), werd ich mich mal an die Win2k setzen.

Ich wünsche ein schönes Wochenende.
Bitte warten ..
Mitglied: leknilk0815
21.04.2006 um 12:52 Uhr
da brennt aber die Zündschnur schon... SCSI- Platten haben die Eigenart, etwa zum gleichen Zeitpunkt abzufackeln, im Array sind die meist aus der gleichen Charge...
Schönes WE - Gruß - Toni
Bitte warten ..
Mitglied: osa
30.06.2006 um 14:19 Uhr
Neues Problem, altes System (neue Platten).

Rechner wurde eingeschaltet fährt nicht hoch.
Raid schreit: mismatch between NVRam and disc config.

Geh in das Menü vom Raidcontroller, alle failed. Keine Platte da.
Normalerweise waren die ja failed, aber zumindestens die Platten war noch da.

Auf den entsprechenden IDs vom Channel "no response" sprich nix da.
Platten sind aber drin und auch alle schön grün(also keine error led an).

Wo kann ich da ansetzen? Was ist sein Problem?
Bitte warten ..
Mitglied: leknilk0815
30.06.2006 um 14:46 Uhr
Hi,

definitiv ein Kabel- Problem (oder Plattenkäfig), denn wenn Du über den Kontroller die Platten nicht mehr ansprechen kannst, sind für den Kontroller auch keine vorhanden, auch wenn die laufen und grün sind (rot werden die bei HP erst, wenn Du sie schon riechen kannst...).
Bei Konfiguration mismatch gibts normalerweise 2 Lademöglichkeiten für die Konfig:

1. Kontroller liest Infos von Platten und schreibt die in sein NVRam
2. Kontroller liest Konfig aus seinem NVRam und schreibt diese auf die Platten

Wenn Du diese Auswahl nicht hast, kann der Kontroller nicht von den Platten lesen (weil.. siehe oben)

Eine andere Möglichkeit gibts noch, es ist eine Disk so geschrottet, daß der SCSI- Bus völlig dichtmacht, dann kann der Kontroller natürlich auch nicht mehr lesen. Das läßt sich nur Platte für Platte testen, Du mußt nur aufpassen, daß der Kontroller nix auf die Disk schreibt (z.B. Konfig speichern). - Am Besten auf einem normalen SCSI- Kontroller testen, ob die Platte ansprechbar ist.
Man kann zwar alles wieder hinbiegen, sofern man die genaue Konfig notiert hat und keine Platten in der Reihenfolge vertauscht, aber da wirds schwierig, da ich nicht weiß, was Du tust oder getan hast. Solange keine Initialisierung erfolgt, kann man fast alles machen...

Gruß und viel Glück - Toni
Bitte warten ..
Mitglied: osa
30.06.2006 um 15:14 Uhr
Vielen Dank.

Dann werd ich die Kiste mal rausnehmen und die Kabelverbindungen checken.

EDIT:

Tsss, keien Ahnung wie das passieren konnte. Die Kiste wurde seit Wochen nicht bewegt, der Stecker für die Platten aufm MB war nur halb drin. Kein Wunder das da nix kommt.

Leider ist die Konfiguration futsch, naja muss ich die halt neu machen.
Hauptsache das Ding lüppt. Daten waren gesichert Config halt nicht.
Bitte warten ..
Mitglied: leknilk0815
01.07.2006 um 11:58 Uhr
wenn Du nicht gemurkst hast, ist die Konfig auf den Platten gespeichert.
Du brauchst nur bei Konfig mismatch sagen "save Konfig from Disk to NVRam", und schon ist alles wieder im Lack. Wen Du statt dessen " save NVRam to Disk" auswählst, ist alles im Eimer... (scheinbar, denn auch das läßt sich wieder hinbiegen, man muß dann nur die Konfig komplett löschen (Platten und NVRam) und neu anlegen (wenn man noch genau weiß, wie die Konfig ursprünglich war), Initialisierung NICHT durchführen, Kiste läuft wieder mit allen Daten)!

Gruß - Toni
Bitte warten ..
Neuester Wissensbeitrag
Festplatten, SSD, Raid

12TB written pro SSD in 2 Jahren mit RAID5 auf Hyper-VServer

Erfahrungsbericht von Lochkartenstanzer zum Thema Festplatten, SSD, Raid ...

Ähnliche Inhalte
SAN, NAS, DAS
Storage RAID LUN Konfiguration - Wie macht ihr es (4)

Frage von Marco-83 zum Thema SAN, NAS, DAS ...

Hyper-V
gelöst Fehler auf Hyper-V nach Tausch eines Mainboard und Raid-Controllers (17)

Frage von Henere zum Thema Hyper-V ...

Festplatten, SSD, Raid
gelöst Wie erkenne ich ein RAID? (8)

Frage von Hendrik2586 zum Thema Festplatten, SSD, Raid ...

Festplatten, SSD, Raid
gelöst RAID 1 SATA durch SAS HDDs tauschen (8)

Frage von oce zum Thema Festplatten, SSD, Raid ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (34)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...