Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

RAID 6: Cluster zu klein

Frage Hardware Server-Hardware

Mitglied: KodaCH

KodaCH (Level 1) - Jetzt verbinden

03.09.2013 um 13:10 Uhr, 1859 Aufrufe, 6 Kommentare, 1 Danke

Hallo

Leider hab ich ein kleines Problem. Ich habe meinem RAID 6 weitere 3 Platten spendiert. Leider kann ich diese nicht mehr anhängen, da ausersehen die Dateizuordnung nicht vergrössert wurde.

Gibt es irgend eine Möglichkeit ohne Datenverlust den Cluster zu vergrössern? Ansonsten müsste ich wegen den NTFS Benutzerrechten die Daten verschieben, da soviel ich mitbekommen habe so die Rechte bleiben, dann Formatieren und die Daten wieder zurückschieben um anschliessend die Partition zu erweitern.

Ich hoffe ihr habt eine Idee ob es noch eine andere Möglichkeit gibt.

Gruss und Danke

Koda
Mitglied: ollioe
03.09.2013 um 14:35 Uhr
Hallo KodaCH,
magst du uns noch mitteilen welchen Controller du verwendest / wie das RAID aufgebaut ist?
Adaptec RAID oder Soft Raid oder oder oder.
Irgendwelche Tools für die Partitionierung vorhanden?
Bitte warten ..
Mitglied: KodaCH
03.09.2013 um 15:14 Uhr
Hallo ollioe

Vielen Dank für die Antwort. Entschuldige bitte. Ich dachte dies sei nicht so relevant.

Es ist ein Supermicro Servergehäuse mit Expander. Dazu hängt eine LSI MegaRaid SAS 9260-4i mit Windows Server 2012. Beim ersten mal hatte ich glaub 5 Platten, bei der ich bei der LSI Software das RAID 6 wählte. Nach dem Initialisieren und dem erstellen der GDP Partition funktionierte es. Danach habe ich eine weitere Platte verwendet. Nach der Reorganisation und Initialisierung musste ich den Server neustarten da er es nicht sofort annahm. Danach sah ich in der Computerverwaltung bei Datenträger 2 mein bisheriges RAID Volumen und dahinter den nicht zugeteilten bereich. Also ging ich auf den zugeteilten mit einem rechtsklick und wählte Partition erweitern.

Diesmal habe ich drei neue Platten eingefügt. Nach dem er 3 Tage benötigte für die Reorganisation und die Initialisierung habe ich heute morgen neugestartet und beim Erweitern kam dann eben der Fehler. Mit dem Standard Cluster geht wohl nur irgendwas um die 16 TB.

Gruss und Danke

Koda
Bitte warten ..
Mitglied: ollioe
03.09.2013 um 15:37 Uhr
Mit dem LSI Tool bin ich nicht vertraut, aber zu aller erst würde ich überprüfen ob die Firmware des LSI (4.10 P2) aktuell ist:
http://www.lsi.com/products/storagecomponents/Pages/MegaRAIDSAS9260-4i. ...

Jetzt erst habe ich das Problem kapiert. Du hast in Windows die Cluster Size der Partition auf 4 KB, dann ist bei 16 TB Schluss.
Da kenne ich nur ein Tool zur Abhilfe: Partition Magic.
Ändert die Cluster Size auch im laufenden Betrieb, Reboot ist natürlich notwendig und ein Backup sollte auch angelegt werden.
Bitte warten ..
Mitglied: KodaCH
03.09.2013 um 15:45 Uhr
Hallo ollioe

Vielen Dank. Dann schau ich mal ob mir Partition Magic helfen kann. Mit Acronis klappte es schon mal nicht. Weisst du grad wo in Partition Magic ich das finden könnte und welches Partition Magic? Es gibt ja eines von Norton und so viel ich weiss noch diverse andere mit dem selben Namen.

PS. Die Firmware habe ich vor kurzen aktualisiert. Ich denke dann ist es die aktuellste. Aber das Problem ist eben wegen dem Windows Cluster Size der Partition

Gruss

Koda
Bitte warten ..
Mitglied: KodaCH
03.09.2013 um 21:22 Uhr
Guten Abend

Ich hatte noch eine ältere Version von Paragon Partition Magic hier. Dort wirde gesagt er braucht alleinigen Zugriff auf die Platte. Also
Habe ich eine Recovery CD erstellt. Beim
versuch die Clustergrösse zu ändern hängte sich die Software auf. Danach habe ich noch Acronis Disc Direktor getestet. Der sagt mor jum aner fehlerhaftes Dateisystem. Chldsk /F findet kein fehler. Kann ich da noch was retten?

Gruss und Danke

Koda
Bitte warten ..
Mitglied: ollioe
03.09.2013 um 21:35 Uhr
Wie zuvor geschrieben hast du sicherlich ein Backup. Da die Partition nun hin ist würde ich gleich eine neue mit passender Cluster Sitze erstellen und das Backup auf die neue Partition. Dann ist alles im Lot
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(1)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
SAN, NAS, DAS
Storage RAID LUN Konfiguration - Wie macht ihr es (4)

Frage von Marco-83 zum Thema SAN, NAS, DAS ...

Hyper-V
gelöst Fehler auf Hyper-V nach Tausch eines Mainboard und Raid-Controllers (17)

Frage von Henere zum Thema Hyper-V ...

Festplatten, SSD, Raid
gelöst Wie erkenne ich ein RAID? (8)

Frage von Hendrik2586 zum Thema Festplatten, SSD, Raid ...

Heiß diskutierte Inhalte
DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (10)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...

Backup
Clients als Server missbrauchen? (9)

Frage von 1410640014 zum Thema Backup ...