Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Raid6 Debian OS Grub funktioniert nicht mehr nach fail

Frage Linux Debian

Mitglied: geforce28

geforce28 (Level 1) - Jetzt verbinden

25.01.2015 um 23:23 Uhr, 1223 Aufrufe, 9 Kommentare

Hallo Leute,

ich habe mal ein Testscenario aufgebaut mit einem debian System.

4 Disks, raid6 mit mdadm erstellt, alles super.
Anschließend habe ich auf allen Volumes grub installiert mit: "grub-install /dev/sda" "grub-install /dev/sdb", usw...

Nun habe ich mal das System heruntergefahren und eine Virtuelle Festplatte entfernt und versucht zu booten.
Der Bootloader (Grub) lädt auch, anscheinend von /dev/sdb/

Er sagt dann "Booting Debian GNU/Linux ......."
und dann direkt
error: out of memory.
error: out of memory.
error: out of memory.
error: out of memory.
error: out of memory.
error: out of memory.
error: out of memory.
error: out of memory.
assert: error stack overflow detected!
Linux 3.2.0-4-amd64 wird geladen
error: out of memory.
error: out of memory.
Initiale Ramdisk wird geladen
error: out of memory.
error: out of memory.
error: out of memory.
error: out of memory.
error: out of memory.
error: out of memory.

Press any key to continue...

Was nun ?
Wie kriege ich das System dazu wieder zu booten?
Mitglied: Pjordorf
26.01.2015 um 00:21 Uhr
Hallo,

Zitat von geforce28:
Nun habe ich mal das System heruntergefahren und eine Virtuelle Festplatte entfernt
Wie entfernt man eine Virtuelle Platte bei einen heruntergefahrenen System?

Wie kriege ich das System dazu wieder zu booten?
In dein Ausgeschalteten System (Heruntergefahren) die Virtuelle Platte wieder einbauen....

Was war denn dein Ziel deiner Bastelei?

Gruß,
Peter
Bitte warten ..
Mitglied: geforce28
26.01.2015 um 08:00 Uhr
Okay, sorry, dann werde ich mal die Unklahrheiten beseitigen:

Ziel meiner Bastelei war natürlich zu testen, was ist wenn die Platte in der Realität ausfallen würde.

Die Umgebung ist VMware Workstation, also Virtuell alles aufgesetzt.

Und wie man die Festplatte entfernt? Naja System heruntergefahren und bei der VM einfach die Festplatte entfernt
Bitte warten ..
Mitglied: Chonta
26.01.2015 um 12:23 Uhr
Hallo,

ist der Softwareraid denn auch über alle HDD also auch MIT /boot ? oder liegt /boot auf einer separaten Partition auf /dev/sda die Du anscheinend entfernt hast?

Gruß

Chonta
Bitte warten ..
Mitglied: geforce28
26.01.2015 um 13:01 Uhr
Also habe /boot nicht gesetzt bei der installation

Bei der Installation habe ich das Wurzelverzeichnis gesetzt also /
und Swap.
Vielleicht liegt ja da dann der Fehler, teste ich mal eben.
Bitte warten ..
Mitglied: geforce28
26.01.2015 um 13:34 Uhr
So habe ich nun so gemacht wie du gesagt hast.
Noch zusätzlich ein /boot im Raid angelegt.

Nach er installation auch wieder auf allen Platten im MBR den Grub bootloader installiert mit grub-install /dev/sdb, usw...

Nun erhalte ich folgenden Error beim booten nachdem ich sda entfernt habe:

error: fd0 read error.
error: invalid arch independent ELF magic.
Entering rescue mode...

grub rescue>

Was nu?
Bitte warten ..
Mitglied: Chonta
26.01.2015 um 13:52 Uhr
Hallo,

also wenn / im raid ist brauchts keine extra /boot.
Kannst Du mal Deine Konfiguration der partitionen und des RAID posten?
Und auch die /etc/fstab

Gruß

Chonta
Bitte warten ..
Mitglied: Vision2015
26.01.2015 um 17:02 Uhr
Zitat von geforce28:

Okay, sorry, dann werde ich mal die Unklahrheiten beseitigen:

Ziel meiner Bastelei war natürlich zu testen, was ist wenn die Platte in der Realität ausfallen würde.

Die Umgebung ist VMware Workstation, also Virtuell alles aufgesetzt.

Und wie man die Festplatte entfernt? Naja System heruntergefahren und bei der VM einfach die Festplatte entfernt

Verstehe ich das Richtig....

Also ein Software Raid 6, das ganze in einer VM mit 4 Virtuellen HDD´s Virtualisiert... *Kopf meets Tischplatte *

ok... das wäre also eine Fake Raid auf einem Fake PC.... *grübel*

hast du vmware tools installiert ?
ok, an deiner stelle würde ich mit der Supergrub ISO Booten, mir das Raid ansehen und Grub neu Installieren!
und gut ist....

nur noch eine frage: hast du 5 HDD´s im System, und auf 4 VMware Datastores, worauf du die 4 Virtuellen HDD´s erstellt hast für ein Raid 6
*kopfkratz*
oder ist da nur eine HDD in deinem System ?
*nochmal Kopfkratz*
lg
V
Bitte warten ..
Mitglied: Chonta
26.01.2015 um 17:14 Uhr
Hallo,

da er nur die Funktionsweise des Linux Softwareraid testen will ist das doch ok mit der VM.
Wenn die VM mit allen virtuellen Platten normal bottet sollte auch ein simulierter Ausfall des RAID funktionieren.
Das ganze wird dann zwar noch viel viel langsamer, aber wenn alles richtig eingerichtet ist, sollte die VM trozdem booten (außer das System wird dermaßen ausgebremst das irgendwelche Timeouts überschritten werden und deswegen nicht gebootet wird, was aber unwarscheinlich ist)

btw wieviel RAM hat die VM bekommen und kannst Du der mehr geben?

Gruß

Chonta
Bitte warten ..
Mitglied: Alchimedes
27.01.2015 um 23:20 Uhr
Hallo ,

/boot musst Du nicht setzen das macht das System selbst.

Beim booten greift das System auf die menue.lst zu.
Da Du hier Hardwaretechnisch etwas geaendert hast ohne die config anzupassen
kollabiert Dein System.
Hilfe hier: Supergrub !!

http://www.supergrubdisk.org/

Das scannt Dein System und repariert Dein Bootloader.
Hab ich schon oft genutzt und hat mir den Tag / Nacht gerettet.)


Gruss
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Router & Routing
Transparenter Proxy funktioniert nicht? (1)

Frage von mrserious73 zum Thema Router & Routing ...

Festplatten, SSD, Raid
Prüfung von HDDs - ohne installiertes OS (11)

Frage von quattroM-Techniker zum Thema Festplatten, SSD, Raid ...

Linux
LTSP: PXE Boot funktioniert nicht (23)

Frage von Fenris14 zum Thema Linux ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (18)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...