Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

RDC über 443 mit RD Gatewayserver schlägt fehl

Frage Virtualisierung Hyper-V

Mitglied: coplord

coplord (Level 1) - Jetzt verbinden

03.09.2014, aktualisiert 04.09.2014, 1233 Aufrufe, 10 Kommentare

Hallo zusammen,

also ich will über WebAccess einen RPC über das Internet machen. Auf https://externeIP/RDWeb/ kann ich zugreifen, mich registrieren und auf die Angebotenen Remotedesktops zugreifen. Beim Verbindungsversuch jedoch scheitert es mit der Fehlermeldung, dass der Gatewayserver temporär nicht erreichbar ist. Gestern noch lautete die Fehlermeldung, dass die Gatewayserveradresse falsch ist.
Auf dem Server an sich kann ich mit https://Server.domain/RDWeb/ auf die Seite zugreifen und hier funktioniert der Zugriff über das Gateway, obwohl die lokalen Adressen nicht am Gateway vorbei geleitet werden. Das heißt für mich, dass die Anfragen der RPC aus dem Internet gar nicht erst zum Gateway kommen, oder? - Liegt das daran, dass ich in einer "local"Domäne versuche zu arbeiten? - Oder evtl an der Portweiterleitung?

Beim Verbindungsaufbau stehen die folgenden Informationen:

publisher: RDServer.Domain.local
type: RemoteApp Program
Path:
Name:
Remote computer: RDSERVER.Domain.LOCAL
Gateway server: RDServer.Domain.local

Ich habe alle RD Dienste auf einem Server laufen, einfach weil es nur ein Test ist und mir nicht mehr zur Verfügung gestellt wurde.

Im Router ist ein Portforwarding des Ports 443 auf meinen Server eingestellt.

Momentan bin ich etwas ratlos, ich habe viel rumprobiert, was ich bei Google gefunden habe, aber bisher führte nichts zum gewünschten Ergebnis.

Vielen Dank schon mal für Antworten,
Riccardo
Mitglied: Dani
03.09.2014 um 18:54 Uhr
Guten Abend Riccardo,
auf welchen Betriebssystem läuft der RDS-Host denn?
Nachdem du nicht schreibst, wie du die Services eingerichet hast, hier ein Blogartikel als Vergleich.


Gruß,
Dani
Bitte warten ..
Mitglied: coplord
04.09.2014, aktualisiert um 11:22 Uhr
Stimmt, das wäre sinnvoll gewesen zu ergänzen, sry ^^"

RDServer:
MS Win Server 2012 R2
RD-Sessionhost, -Virtualisierungshost, -ConnectionBroker, -Gatewayserver, -WebAccess
IIS usw. (wie auch in dem Blog beschrieben) wurde alles mit installiert.
Alle DomainUsers dürfen lt CAP & RAP auf alle Rechner zugreifen.
Ich nutze für den Server ein selbstsignierendes Zertifikat, das ist der einzige Unterschied, den ich zu dem Blogeintrag erkennen kann.


Wenn ich mir dir *.rdp anschaue, die ich zum Download auf meiner Seite bekomme, dann steht da, dass die Verbindung über Port 3389 erfolgen soll (server port:i:3389). Dort sollte meiner Meinung nach Port 443 stehen, sonst scheiterts ja schon an der Firewall. Eine Änderung der Zeile in server port:i:443 bringt allerdings auch keinen Erfolg.

Grüße,
Riccardo
Bitte warten ..
Mitglied: Chris-75
04.09.2014 um 07:56 Uhr
nein das mit dem RDP-Port 3389 passt schon, es wird ja vorher getunnelt.

Die dafür hinterlegten Einstellungen in der RDP sind:

gatewayusagemethod:i:1
gatewayprofileusagemethod:i:x
gatewaycredentialssource:i:x
gatewayhostname:s:domain.xxx

Mir kommt eher vor dass deine Domäneneinstellungen nicht stimmen, RDSERVER..LOCAL (2 Punkte????).
Bitte warten ..
Mitglied: Dani
04.09.2014 um 07:59 Uhr
Moin Chris,
Mir kommt eher vor dass deine Domäneneinstellungen nicht stimmen, RDSERVER..LOCAL (2 Punkte????).
Richtig lesen... RDServer._.local: Er hat die Domäne durch einen Unterstrich ersetzt.


Gruß,
Dani
Bitte warten ..
Mitglied: coplord
04.09.2014, aktualisiert um 08:12 Uhr
Ja, richtig. Die Domäne wurde nur ersetzt. Ich hab's mal abgeändert, dass es leichter erkenntlich ist.

Also ist die rdp wohl richtig.
Bitte warten ..
Mitglied: coplord
08.09.2014, aktualisiert um 10:25 Uhr
Hat keiner weiter eine Idee, was ich falsch mache?
Bitte warten ..
Mitglied: Dani
08.09.2014 um 21:30 Uhr
Guten Abend,
entschuldige, ich muss meinen Job ab und zu noch nachgehen.
Was passiert, wenn du im LAN per WebAccess einloggst du die Anwendung startest?


Gruß,
Dani
Bitte warten ..
Mitglied: coplord
08.09.2014 um 21:41 Uhr
Guten Abend Dani

Kein Ding, versteht sich ja von selbst :D
Also im LAN (trotz dessen, dass der Haken bei "Gateway im LAN nicht nutzen" raus ist) geht es seltsamer Weise.

Grüße,
Riccardo
Bitte warten ..
Mitglied: Dani
15.09.2014 um 17:50 Uhr
Guten Abend,
das klingt seltsam... ist dir evtl. deine Firewall/Router im Weg. Sprich wird da etwas geblockt?


Gruß,
Dani
Bitte warten ..
Mitglied: coplord
18.09.2014 um 07:24 Uhr
Das vermute ich ja auch, aber leider bekomme ich darauf keinen Zugriff und die Verantwortlichen meinen, es sei alles richtig konfiguriert.

bzw. ist im Router nur ein Portforwarding von 443 auf meinen RD-Server geschalten.

Grüße,
Riccardo
Bitte warten ..
Ähnliche Inhalte
Verschlüsselung & Zertifikate
Sperrprüfung für ein Zertifikat schlägt fehl (6)

Frage von MichaCon zum Thema Verschlüsselung & Zertifikate ...

Switche und Hubs
gelöst Cisco SG500 - Stacking schlägt fehl (6)

Frage von BirdyB zum Thema Switche und Hubs ...

Neue Wissensbeiträge
Windows 10

Windows 8.x oder 10 Lizenz-Key aus dem ROM auslesen mit Linux

(6)

Tipp von Lochkartenstanzer zum Thema Windows 10 ...

Tipps & Tricks

Wie Hackt man sich am besten in ein Computernetzwerk ein

(38)

Erfahrungsbericht von Herbrich19 zum Thema Tipps & Tricks ...

Heiß diskutierte Inhalte
Festplatten, SSD, Raid
POS Hardware und alternativen zu Raid 1? (21)

Frage von Brotkasten zum Thema Festplatten, SSD, Raid ...

Windows 10
gelöst Windows 10 Home "Netzlaufwerk nicht bereit" (19)

Frage von Oggy01 zum Thema Windows 10 ...

Viren und Trojaner
Verschlüsselungstrojaner simulieren (18)

Frage von AlbertMinrich zum Thema Viren und Trojaner ...

Exchange Server
Exchange Postfach leeren - nicht löschen (11)

Frage von AndreasOC zum Thema Exchange Server ...