Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Rechner mit öffentlicher IP, Router, Rechner mit privater IP alle Rechner in Domain

Frage Netzwerke

Mitglied: Hacke1

Hacke1 (Level 1) - Jetzt verbinden

30.12.2007, aktualisiert 14.01.2008, 7118 Aufrufe, 10 Kommentare

Hallo alle zusammen.

Am besten gebe ich mal an was ich habe und dann wo mein Problem liegt.

In der Firma haben wir mehrere Rechner die alle öffentliche IP Adressen haben, alle Rechner sind an einer Domain angemeldet,
dementsprechend ist auch ein DC vorhanden.
Die Rechner sind alle an einem Hub angeschlossen und der Hub ist über einen Cisco Router am Internet.
Der Netzwerkaufbau ist so vom Mutterkonzern vorgegeben.
Die Rechner haben jeweils folgende Netzwerkkonfiguration:

IP Adresse: 194.25.177.210 - 225
Subnet-Mask: 255.255.255.240
Gateway: 194.25.177.209
WINS: 194.25.177.210

Nun ist das Problem das noch weitere Rechner benötigt werden, aber keine IP Adressse mehr frei ist und weitere kaufen wollten wir
möglichst nicht.
Nun war die Idee, einen Rechner vom Hub zu nehmen (z.B. IP 194.25.177.211) und einen Router dazwischen zu setzen und die neuen Rechner
auch an den Router. Dem Router dann die IP Adresse von dem alten Rechner (die 194.25.177.211) geben und den Rechner
die Router sind private IP´s zu geben.

Netzwerkkonfiguration von den Rechner die am Router sind z.B.:

IP Adresse: 192.168.1.100 - 104
Subnet-Mask: 255.255.255.0
Gateway: 194.25.177.209
WINS: 194.25.177.210

Es funktioniert dahin gehend das alle Rechner die am Router sind ins Internet können und auch alle an die Domain
angemeldet werden. Ich kann auch die im alten Rechner vorhandenen Netzwerkverknüpfungen aufrufen und
bekomme dann die Ordner vom anderen Rechner angezeigt.
Doch leider kann ich die anderen Rechner nicht unter Netzwerkumgebung sehen, egal in welche Richtung.

Woran kann das liegen ?
Mitglied: runlevel2
30.12.2007 um 20:19 Uhr
Hy,

damit die Netzwerkumgebung über Router-Grenzen hinweg funktioniert, brauchst Du einen WINS-Server. Dieser muß auf allen Win-Clients eingetragen werden.

Gruss, runlevel2
Bitte warten ..
Mitglied: ITCHeinrichs
30.12.2007 um 20:30 Uhr
Hallo,

der Cisco-Router (Gateway) kennt die Route ins 192.168.1.0 er Netz nicht!
An einer Erweiterung deines IP-Adressbereiches wirst du wohl kaum vorbei kommen!

Das gleiche Problem hatte ich mal bei einem Kunden (Autohaus)!

Gruß
Markus
Bitte warten ..
Mitglied: aqui
30.12.2007 um 20:55 Uhr
Das ist Unsinn und hat mit Routen rein gar nichts zu tun ! Wie auch, denn am Router sind ja beide Netze direkt angeschlossen und somit kennt der Router alle Route ja sowieso von selber.
Deine Beschreibung der Loesung, die so generell nicht falsch ist, ist aber unvollstaendig, denn vermutlich machst du NAT (Network Adress Translation) auf dem Router vom 192.168.1.0er Netz zum bestehenden Netzwerk, richtig ? Leider kann man das nun nur raten
Ansonsten waere dann eine Integration von anderen IP Netzen ohne zusaetzliche statische Routen auf dem Internet Router in der Tat unmoeglich.
Ferner muesste dann auch zwangslaeufig der Internet Router dann NAT machen denn ein privates RFC 1918 Netzwerk wie die 192.168.1.0/24 ist im Internet nicht routebar !
Der Teil deiner Loesung ist also etwas diffus und undurchsichtig.
Das Problem sind aber keineswegs die Routen wie oben beschrieben (Deine Verbindungen funktionieren ja problemlos wie du schreibst..) sonderen dein Windows Name Service Broadcast, der ueber Routergrenzen nicht geforwardet wird, da UDP Broadcast.
Bei Cisco Routern gibt es dafuer das Kommando ip helper address x.x.x.x auf dem Ethernet Interface um das Problem elegant zu loesen.
Als x.x.x.x gibst du den DNS/WINS Server oder Domain PDC (oder Netzwerk Broadcast mit .255 wenn du keinen DNS/WINS oder PDC hast) an und dann sollte es auch mit der Netzwerkumgebung problemlos klappen !
Leider schreibst du nicht ob dein Router ein Cisco ist so das man dir in Bezug auf spezifische Kommandos etc. somit nur bedingt helfen kann.
Bitte warten ..
Mitglied: Hacke1
31.12.2007 um 13:10 Uhr
Erstmal recht herzlichen Dank für die bisherigen Antworten.
Habe ich ganz vergessen zu erwähnen sorry, also der Router den ich jetzt zwischen dem Hub den neuen Rechnern laufen habe ist ein TP-Link TL-WR542G.
Ich hatte es mit NAT und ohne probiert.
Einen WINS habe ich, der läuft dem dem Server auf dem auch die Domain läuft, der hat die IP 194.25.177.210.
Der Router die direkt am Internet ist ist ein Cisco, an dem ich aber sehr wahrscheinlich keine Änderungen vornehmen kann.
Verbindungen aus dem 192.168.1.0er Netz ins 194.25.177er Netz funktionieren auch, allerdings kann ich die Rechner aus dem 194.25.177er im 192.168.1.0er nicht sehen.
Verbindungen aus 194.25.177er in das 192.168.1.0er gehen anscheinend nicht.
Kann es sein das ich im Router TP-Link Routen einrichten muss ?
Kenne mich mit dem Routing nicht so aus.
Bitte warten ..
Mitglied: ITCHeinrichs
31.12.2007 um 14:07 Uhr
Auf dem Cisco Router fehlt die Route ins 192.168.1.0er Netz, und die kannst du leider nicht eintragen. Teste doch einfach mal einen lokalen Eintrag in die Routing Tabelle eines einzelnen Rechner aus dem Netz 194.25.177.0.

Bsp.:
Auf Rechner 194.25.177.212 die Route ins 1192.168.1.0er Netz eintagen:
route add 192.168.1.0 mask 255.255.255.0 194.25.177.211
eintagen.

Jetzt auf Rechner 194.25.177.212 ping ins 192.168.1.0er Netz z.B.:
ping 192.168.1.100

Wenn's nicht funktioniert, dann brauche ich auch Nachhilfe (aqui)!

Gruß
Markus
Bitte warten ..
Mitglied: aqui
31.12.2007 um 16:44 Uhr
Nein, Markus hat Recht ! Das Problem ist das alle Rechner im 194.25.177er Netz als Default Gateway den Cisco eingetragen haben, folglich gehen alle Packete zu diesem Router auch natürlich Packete die das 192.168.1.0er netz als Ziel haben.
Kommen solche Packete am Cisco an sieht der in seine Routing Tabelle wie er dieses Netz erreichen kann. Er hat dafür keinen spezifischen Eintrag und routet dieses Netz dann ins Internet.
Damit geht das Packet dann verloren denn 192.168er Adressen sind private Netze die im Internet nicht gerouet werden (RFC 1918) und jeder Provider schmeisst die bei seinen Eingangsroutern sofort in den Datenmülleimer !

Du hast also nur 2 Chancen:

1.) Du bittest den Admin des Cisco Routers dort eine Route einzutragen die so aussieht:
ip route 192.168.1.0 255.255.25.0 194.25.177.211 (wenn die 194.25.177.211 die IP deines TP-Link TL-WR542G im Altnetz ist.)

2.) Kannst du keine Route am Cisco eintragen musst du auf sämtlichen Rechnern im 194.25.177er Altnetz die mit dem 192.168.1er Netz kommunizieren sollen manuell eine statische Route zusätzlich konfigurieren über die Eingabeaufforderung.
Die muss dann lauten:
route add 192.168.1.0 mask 255.255.255.0 194.25.177.211 -p
Markus hatte das -p vergessen, was aber essentiell wichtig ist um die Route permanent zu machen. Fehlt das -p ist die Route nach dem nächsten Reboot verschwunden und nichts geht mehr.
Du kannst alternativ auch eine kleine Batch Datei mit dem Kommando über den Autostart Ordner aufrufen. Dann natürlich ohne -p denn sie wird nach jedem Start ausgeführt. Mit der Batch Lösung verbiegst du die Routen direkt im System nicht
Bitte warten ..
Mitglied: Hacke1
01.01.2008 um 17:51 Uhr
Recht herzlichen Dank für eure Hilfe, werde das mit den Route die Tage mal probieren.
Ich hätte da noch zwei Fragen:
1. Im TP-Link Router kann ich ja auch direkt Routen eintragen, würde es nicht gehen wenn ich die Route 192.168.1.0 mask 255.255.255.0 194.25.177.211 direkt dort eintrage ?

2. Wenn ich die Route auf allen Rechnern eintrage, kann ich von dem 194er auf dem 192er Netz zugreifen, aber kann ich auch eine Router auf dem 192er Rechner eintragen um auf dem 194er zuzugreifen ? Oder geht das nicht weil das 194er öffentlich ist ?

THX im vorraus.
Bitte warten ..
Mitglied: ITCHeinrichs
01.01.2008 um 21:13 Uhr
1. Im TP-Link Router kann ich ja auch direkt
Routen eintragen, würde es nicht gehen
wenn ich die Route 192.168.1.0 mask
255.255.255.0 194.25.177.211 direkt dort
eintrage ?

Geht nicht, die Rechner aus dem 194er Netz haben als GW den Cisco Router eingetragen, danach wird ins Internet geroutet (siehe auqi) und nicht zum TP-Link Router!


2. Wenn ich die Route auf allen Rechnern
eintrage, kann ich von dem 194er auf dem
192er Netz zugreifen, aber kann ich auch eine
Router auf dem 192er Rechner eintragen um auf
dem 194er zuzugreifen ? Oder geht das nicht
weil das 194er öffentlich ist ?

Der TP-Link Router routet ja bereits ins 194er Netz, du brauchst nichts mehr einzutragen!

Gruß
Markus
Bitte warten ..
Mitglied: Hacke1
11.01.2008 um 18:33 Uhr
So, nun bin ich endlich dazu gekommen Eure Tipps mal umzusetzen, doch leider ohne Erfolg.
Ich habe die Route auf den Rechnern im 194er Netz eingetragen, bekomme aber trotzdem keinen Zugriff auf den Rechnern des 192er Netzes.
Einen Fehler habe ich allerdings in meinem ersten Post, den Gateway den ich auf dem Rechner der am TP-Link sitzt eingetragen habe ist 192.168.1.0, mit 194.25.177.209 geht es nicht.
Aber der TP-Link selber hat den Gateway 194.25.177.209 bei sich eingetragen.
Was mir noch aufgefallen ist, wenn ich mit dem Rechner aus dem 192er Netz an der domain angemeldet bin, kann ich nicht auf den Router (TP-Link 192.168.1.1) zugreifen. Geht nur wenn ich lokal am Rechner angemeldet bin.
Falls das jetzt alles ein wenig unübersichtlich geworden ist, kann ich mein Probelm ja nochmal ausführlich darlegen.
Gruß
Michael
Bitte warten ..
Mitglied: aqui
14.01.2008 um 10:48 Uhr
Dein Netzwerk sollte dann eigentlich so aussehen:

43590fd548204cd3aea0233332611b0e-firmalsg - Klicke auf das Bild, um es zu vergrößern

Wichtig sind folgende Tests:

  • Ein Ping vom PC im 192.168.1.0er Netz egal ob eingeloggt in Domain oder nicht muss in jedem Falle erfolgreich sein auf den Router 192.168.1.1
  • Der Router darf niemals NAT machen sondern muss transparent zwischen den Netzen 194.25.177.208/28 und 192.168.1.0/24 routen, das ist unbedingt sicherzustellen ! Die evtl. vorhandene NAT Funktion auf dem WAN/DSL Interface muss ausgeschaltet sein !
  • Ein Ping vom PC im 194.25.177.209er Netz egal ob eingeloggt in Domain oder nicht muss in jedem Falle erfolgreich sein auf den Router 194.25.177.211 (auf die 209 sowieso)
  • Damit Ping etc. funktioniert muss in der loakeln Firewall ICMP echo freigeschaltet sein !
  • Stimmen alle Routen auf dem PC im 194er Netz (Check mit "route print") ?
  • Ist dem so muss ein Ping egal ob eingeloggt oder nicht von einem PC aus dem 194er netz in das 192er Netz in jedem Falle funktionieren. ! Im Zweifesfall machst du mal einen Tracreroute (tracert) um den Weg des Packetes zu verfolgen !

Wenn ein gegenseitiger Ping zwischen den PCs funktioniert wird auch das gesamte Design funktionieren.
Sehr wichtig ist das der Zusatzrouter natürlich niemals NAT also eine Adress Translation zwischen den 194er Netz und/oder dem 192er Netz macht. Also ein ggf. vorhandenes NAT muss in jedem Falle abgeschaltet werden sonst funktioniert das gesamte Konstrukt so oder so nicht da sonst die NAT Firewall überwunden werden muss was in dem Umfeld so nicht funktioniert !
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Router & Routing
gelöst Zugangsdaten Router bei All-Ip Anschluss (8)

Frage von Firewire zum Thema Router & Routing ...

DSL, VDSL
gelöst IP-Umstellung Deutsche Telekom: Wie den bisherigen Router weiternutzen? (14)

Frage von da-michi zum Thema DSL, VDSL ...

Router & Routing
gelöst Router für Telekom All IP Anschluss (40)

Frage von Tjelvar zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...