Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Recursion no DNS Server einfluss auf MAIL Server

Frage Linux Linux Netzwerk

Mitglied: rotewolke

rotewolke (Level 1) - Jetzt verbinden

26.02.2010, aktualisiert 21.04.2010, 4190 Aufrufe, 8 Kommentare

Hallo zusammen
Habe einen Debian Lech Server mit DNS ( BIND 9 ) und Postfix als Mailserver.
Die Server Einstellungen sind Standard. Keine Speziellen Sachen.

Mein Problem ist,

ich muss in BIND eine Einstellung vornehmen die den Mailserver beeinflusst, und zwar in der config.

recursion no;

Wenn ich dies einstelle geht der Mail Server nicht mehr. Er läuft zwar aber ich kann dann keine Mails verschicken. Die Mails kommen dann immer zurück und teilen mir mit das Domain nicht gefunden oder nicht existiert.

Sobald ich recursion no; weglasse geht alles wie es sein sollte. Ich möchte den deaktivieren damit keine unnötigen anfragen kommen die beantwortet werden müssen.

Könnt Ihr mir da helfen?
Mitglied: Snowman25
26.02.2010 um 09:59 Uhr
Hallo rotewolke,

heißt der Befehl zum abschalten der Rekursiven Namensauflösung im BIND nicht so?
allow-recursion { none; } ;
Das ganze muss in die named.conf in den Options-Block.

Gruß
Snow
Bitte warten ..
Mitglied: rotewolke
26.02.2010 um 11:53 Uhr
Zitat von Snowman25:
01.
 allow-recursion { none; } ;
Das ganze muss in die named.conf in den Options-Block.

Nein es muss in named.conf.options sein.

recursion no;

dann ist auch ok aber der Mail server geht dann nicht. bzw. ich kann keine Mail verschicken die wo anders gehostet sind.
Bitte warten ..
Mitglied: Snowman25
26.02.2010 um 13:29 Uhr
Zitat von rotewolke:
[...] die wo anders gehostet sind

Was meinst du damit? Scheint wohl doch nicht so Standard zu sein...
Bitte warten ..
Mitglied: rotewolke
26.02.2010 um 15:33 Uhr
Wenn ich recursion no; eingeschaltet habe ists ok!

Mails können aber nicht mehr gesendet werden an zb. @hotmail.com adresse oder ähnliches!
Bitte warten ..
Mitglied: rotewolke
12.03.2010 um 10:17 Uhr
Hab alles nochmals überprüft... ich komme einfach nicht drauf.

Hat niemand eine Lösung?
Bitte warten ..
Mitglied: rotewolke
09.04.2010 um 09:30 Uhr
Hab da noch nichts gefunden...

Bin am verzweifeln... hat niemand eine Lösung oder Vorschlag
Bitte warten ..
Mitglied: Syncretist
18.06.2010 um 16:56 Uhr
Hallo rotewolke,

ist dein Problem noch aktuell? Wenn ja, dann kann ich dir vielleicht helfen. Es wäre allerdings gut, wenn du vorher noch so viele Hintergrundinfos zu deinem Setup posten könntest wie möglich. Das wären z.B. Konfigurationsdateien, Netzwerkpläne oder was sonst noch da ist. Wenn natürlich darin Infos enthalten wären, die du nicht veröffentlichen willst, wäre es ratsam diese irgendwie unkenntlich zu machen.

Wenn du dein Problem in der Zwischenzeit schon selbst gelöst hast, dann fände ich es gut, wenn du deine Lösung auch hier posten könntest.

Lg
Syncretist
Bitte warten ..
Mitglied: rotewolke
17.04.2012 um 16:46 Uhr
Hi Syncretist

Nein dieses Problem habe ich nicht gelöst. Ich habe alles frisch aufgesetzt. Ich weiss es nicht warum es nicht ging. Sorry. Würde mich auch wundernehmen!
Bitte warten ..
Ähnliche Inhalte
Internet Domänen
No-ip.org Frage (13)

Frage von Axel90 zum Thema Internet Domänen ...

Exchange Server
DNS und Relay-Server(SmartHost) (4)

Frage von oce zum Thema Exchange Server ...

E-Mail
Email: No route to host (4)

Frage von Pawlik zum Thema E-Mail ...

Windows Netzwerk
gelöst DNS - Weiterleitung zu DNS-Server in anderer Domain (7)

Frage von Schauer zum Thema Windows Netzwerk ...

Neue Wissensbeiträge
Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

(2)

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Viren und Trojaner

CNC-Fräsen von MECANUMERIC werden (ggf.) mit Viren, Trojanern, Würmern ausgeliefert

(4)

Erfahrungsbericht von anteNope zum Thema Viren und Trojaner ...

Windows 10

Windows 10: Erste Anmeldung Animation deaktivieren

(3)

Anleitung von alemanne21 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Netzwerkprotokolle
gelöst Leiten "dumme" Switches VLAN-Tags mit durch? (26)

Frage von coltseavers zum Thema Netzwerkprotokolle ...

Netzwerkgrundlagen
Kann auf Freigabe nicht Zugreifen (16)

Frage von leon123 zum Thema Netzwerkgrundlagen ...

Windows Server
gelöst Neues KB für W10 1607 und W2K16 wieder mal nicht im WSUS 3.0, hat das noch jemand? (16)

Frage von departure69 zum Thema Windows Server ...

Router & Routing
FTTH bzw FTTB Router (13)

Frage von ukulele-7 zum Thema Router & Routing ...