Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Redhat HTTPD Nur Unterverzeichnis erreichbar

Frage Linux RedHat, CentOS, Fedora

Mitglied: pixelflat

pixelflat (Level 1) - Jetzt verbinden

26.02.2009, aktualisiert 14:52 Uhr, 3144 Aufrufe, 3 Kommentare

Habe hier einen Redhat Server mit Apache.

Leider kann ich über die IP des Server den Webserver nicht erreichen. Allerdings komme ich auf beliebige(!) Unterverzeichnisse (http://123.123.123.123/Unterverzeichnis).
Die httpd.conf sieht so aus.

Leider kann ich keine Probleme damit erkennen. Kann es auch noch an einer anderen Konfigurations-Datei liegen?

Edit: Wichtiger Hinweis: Über localhost komme ich auf die Startseite. Extern jedoch nicht!

Danke
Mitglied: Cubic83
26.02.2009 um 22:04 Uhr
Hallo,

warum postest du die Datei nicht hier? In einem Jahr werden deine Links ins Nirwana führen.

Aufgefallen sind mir in deiner config:

01.
 
02.
#ServerName www.example.com:80 
03.
 
04.
besser:  
05.
 
06.
ServerName www.example.com 
07.
 
08.
============================ 
09.
 
10.
#NameVirtualHost *:80 
11.
 
12.
besser: 
13.
 
14.
NameVirtualHost *:80 
15.
 
16.
============================ 
17.
 
18.
 
19.
#<VirtualHost *:80> 
20.
#    ServerAdmin webmaster@dummy-host.example.com 
21.
#    DocumentRoot /www/docs/dummy-host.example.com 
22.
#    ServerName dummy-host.example.com 
23.
#    ErrorLog logs/dummy-host.example.com-error_log 
24.
#    CustomLog logs/dummy-host.example.com-access_log common 
25.
#</VirtualHost> 
26.
 
27.
besser 
28.
 
29.
<VirtualHost *:80> 
30.
    ServerAdmin webmaster@dummy-host.example.com 
31.
    DocumentRoot /www/docs/dummy-host.example.com 
32.
    ServerName dummy-host.example.com 
33.
    ErrorLog logs/dummy-host.example.com-error_log 
34.
    CustomLog logs/dummy-host.example.com-access_log common 
35.
</VirtualHost> 
36.
 
wobei example.com deine Domain ist. Ich weiss nicht ob das hilft; ist mir halt aufgefallen. Weiter kannst du ja die Logs löschen und nach einem Aufruf der Seite die logs anzeigen lassen.

Die Logs liegen bei Debian unter /var/log/apache2/error.log und access.log.


Weiter fällt mir auf dass du "etwas" auf den Port 3443 laufen lassen willst. 443 ist ein SSL Port, deswegen könnte ich mir vorstellen dass du SSL laufen lassen willst? Wenn ja: SSL funktionniert (meines Wissens) nicht IP bassiert sondern domain bassiert.

mfG
Bitte warten ..
Mitglied: pixelflat
27.02.2009 um 08:22 Uhr
Hallo, danke für die Antwort.
Habe die Config nicht hier gepostet, weils doch etwas viel Text ist (und es in einem Jahr nicht mehr relevant ist ;) ).

Mittlerweile funktionierts. Ich kann aber nicht sagen, wo es gehakt hat, da sich jemand anders daran gesetzt hat.

PS: Auf Port 3443 läuft kein SSL, einfach nur eine andere Seite.
Bitte warten ..
Mitglied: Cubic83
27.02.2009 um 08:39 Uhr
Könntest du vielleicht trotzdem mal die httpd.conf pasten? Würde mich interessieren worans lag.

mfG
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
DNS
gelöst Sophos UTM9 - FTP nur über IP erreichbar (4)

Frage von PronMaster zum Thema DNS ...

Netzwerke
gelöst Manche Websites nicht erreichbar (9)

Frage von cyber40014 zum Thema Netzwerke ...

Netzwerkgrundlagen
gelöst Heimnetzwerk über Server im Internet und OpenVPN erreichbar machen (16)

Frage von byt0xm zum Thema Netzwerkgrundlagen ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...