Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Remote.domain.de und autodiscover immernoch Zertifikatsabfrage

Frage Microsoft Exchange Server

Mitglied: Maximilian1979

Maximilian1979 (Level 1) - Jetzt verbinden

10.01.2012 um 14:40 Uhr, 15663 Aufrufe, 11 Kommentare

Hallo zusammen,

ich bin ganz neu in der Branche und habe mir wohl auch gleich einen dicken Stein ans Bein gebunden.
Es geht um das viel diskutierte Fall, dass beim Start von Outlook zuerst eine Zertifikatsabfrage von autodiskover und dann direkt danach eine von remote.domane.de.
Ich bin bestimmt schon 3-4 Tage nur damit beschäftigt irgend welche Meldungen und Fehlerbehebungsszenarien über Google zu suchen, aber mittlerweile verzweifle ich weiß auch nicht mehr weiter.
Was ich etwas sehr merkwürdig finde ist, dass als Lizenznehmer unser Mailprovider enthalten ist. Ich habe mich auch bei denen gemeldet und auch die konnten sich das nicht erklären. (auch das ist leider eine kleine Firma die wohl nicht so die Erfahrung damit hat)
Ein Schulkollege sagte mir, das es sein könnte, dass ich als Hostname für pop,imap oder smtp den hostnamen autodiscover.domäne.de verwende und nicht die des Servers bei dem wir die Mails abholen, eingetragen ist.

Vielleicht noch eins zur Konfiguration:
Es ist ein SBS2008 mit exch2007.
Konfiguriert ist das ganze für einen SMTP Server und abgeholt werden die mails über den MS-Hauseigenen Pop3Connector.

So, nun wieder zu der Aussage meines Schulkollegen:
Er sagte ich solle den Hostnamen von autodiscover auf den Servernamen des Providers ändern.

Ich habe beim Smarthost die richtige Adresse des Servers eingetragen und auch beim pop3 connector ist der pop server der Server des Providers..

Gibt es noch einen Punkt an dem ich etwas ändern muß?Ich habe mich mal beim Exchangeserver im Bereich Sendeconnector umgesehen und dort noch folgenden Eintrag gefunden:

Geben Sie den FQDNan, den dieser Connector als Antwort auf HELO oder EHELO bereitstellen soll:
remote.domäne.de

Was ist das ? Die zweite Zertifikatsabfrage ist ja genau dieser " remote.domäne.de" .


Ich komme echt nicht weiter.. ich hoffe das mir jemand auf die Sprünge helfen kann...
An meinen Schulkollegen komme ich leider nicht drann.. aber ich muß den Fehler finden !
Vielleicht muss ich auch noch mal ein Internes eigenes Zertifikat erstellen, da ich gelese habe, dass die Standard erstellten Zertifikate nach einem Jahr ablaufen. (Serverinstallation ist aber erst 2 Monate Herr )

Danke schon mal für Eure Hilfe !

Gruß
Maxi
Mitglied: bloodstix
10.01.2012 um 15:45 Uhr
Da hat dein Schulkollege recht. Ich kann dir zwar nicht genau sagen wo es steht. Aber es gibt ein SSL-Zertifikat, welches im Exchange hinterlegt ist.
Das _muss_ für alle Domains ausgestellt sein (domain1, domain2, domain3, ...) die damit in Verbindung stehen und über die es
angesprochen wird. Bei uns war das so, dass das auf "sites.domaene.local" ausgestellt war und für mail.firma.de auch immer
diese Abfragen kamen.

Schau mal im Zertifikatsspeicher nach ... Ausführen -> certmgr.msc
glaube ich

Dann habt ihr das Problem nicht mehr.
Bitte warten ..
Mitglied: Maximilian1979
10.01.2012 um 16:35 Uhr
uff.. für den Fall wäre es echt super zu wissen wo ich das finde.
habe grad noch mal mit unserem Provider gesprochen und da ist wirklich mal einer dran gewesen, der mir was dazu sagen konnte. Leider haben die keine Windowssysteme aber er sagte:

Wenn Sie jetzt einfach den Hostnamen für POP, IMAP und SMTP von autodiscover.ihre domäne.de in s11.pixelx.de ändern, wird auch der Zertifikatsfehler nicht mehr auftauchen.

... aber woooooo ? ich weiß nicht wo ich das finden/ändern soll..

Vielen Dank schon mal für die Hilfe!!!!
Bitte warten ..
Mitglied: bloodstix
10.01.2012 um 17:50 Uhr
Das sollte dir helfen, oder zumindest den Schubs in die Richtung geben:
http://blogs.technet.com/b/exchange/archive/2007/04/30/3402138.aspx

Alles weitere kannst du anhand von Begriffen und Wissen aus diesem Artikel googeln ;)
Bitte warten ..
Mitglied: Pjordorf
10.01.2012 um 21:22 Uhr
Hallo,

Zitat von Maximilian1979:
ich bin ganz neu in der Branche und habe mir wohl auch gleich einen dicken Stein ans Bein gebunden.
Ja. Und dazu noch eine ganz dicken. Einen SBS 2008

Es ist ein SBS2008 mit exch2007.
Dir ist schon bekannt das ein SBS mehr als nur einfach ein Server ist, oder? Ein SBS (Small Business Server) beinhaltet neben den DC noch sein DNS, DHCP, WINS, Sharepoint Services für Intranet, WSUS, Exchange und alles was ich noch vergessen habe. Ein SBS kommt auch mit einer anderen Verwaltungskonsole als nur ein Server. Ein SBS hat auch ganz andere Asisstenten als nur ein Server. Kurzum, dein SBS ist sehr viel und das alles auf einem Stück Blech. Und es funktioniert. Ein der wichtigsten Regeln beim SBS - Nutze die Asisstenten. Die Regeln fast alles für dich und legen auch immer Protokolle und Logs an. Diese Asisstenten wissen genau wo wann und wie an welchen Einstellungen etc gedreht werden muss. Du musst denen nur sagen was du willst. Auch deine Exchange Einstellungen inkl. zertifikat wird hierrüber eingestellt. Du kannst die Asisstent auch immer wieder laufen lassen. Natürlich kannst du auch selbst an alles Hand anlegen, aber lasse zuerst die asisstenten laufen. Die Hilfen zu den jeweiligen Asisstenten und deren schritte sind umfangreich. F1 ist dein Freund. Auch wo der SBS die Zertifikate ablegt ist hinterlegt. F1...

Konfiguriert ist das ganze für einen SMTP Server und abgeholt werden die mails über den MS-Hauseigenen Pop3Connector.
Ändern?

Vielleicht muss ich auch noch mal ein Internes eigenes Zertifikat erstellen, da ich gelese habe, dass die Standard erstellten Zertifikate nach einem Jahr ablaufen. (Serverinstallation ist aber erst 2 Monate Herr )
Evtl. stehst du dir besser ein zertifikat zu kaufen. Einen SBS mit selbsterstellten zu betreiben ist seit SBS 2008 ein wenig komplizierter als noch beim SBS 2003.http://blog.kazmarek.com/2010/11/17/renew-ssl-self-signed-certificate-i ...

Gruß,
Peter
Bitte warten ..
Mitglied: Maximilian1979
11.01.2012 um 16:25 Uhr
hallo zusammen,
vielen Dank erstmal für Eure Hilfe!

ich komme der Sache langsam näher.

Ein gültiges zertifikat habe ich heute mit dem Zertifikatshersteller pws zusammen auf dem Server installiert.

der Aufruf remote.domäne.de verweist sogar auf den Server , aaaber wenn ich autodiscover.domäne.de einen PING zusende, dann geht dies auf die externe Adresse unseres Mailproviders!
Jetzt gibt es , wenn ich richtig liege, ja nur einen Ort an dem man den Rechnern über DNS sagen kann das er bei autodiscover.domäne.de zum Server gehen soll.
aber da finde ich leider nirgends einen Hinweis in dem das hinterlegt ist!

Könnt Ihr mir da noch mal bitte noch mal helfen!?

Also im DNS Server ist nirgends ein Hinweis auf autodiscover.domäne.de aber woher weiß er jetzt das er zur externen IPadresse unseres Providers gehen soll ? die Ip auf die autodiscover verweißt ist die 80.86.184.26. aber er soll doch auf dem Server gehen !

Ich habe auch schon daran gedacht im DNS autodiscover.domäne.de weiter zu geben an den server... aber wie mache ich das eventuel und irgendwie habe ich das Gefühl, dass dies auch einfacher gehen muß!

hat das vielleicht was mit dem dämlichen Consolenassistenten zu tun " Internetadresse einrichten "? Muss ich da vielleicht irgend was spezielles einrichten ?
ich weiß nicht weiter !

Vielen Dank schon mal für Eure Hilfe!
Bitte warten ..
Mitglied: Pjordorf
11.01.2012 um 17:21 Uhr
Hallo,

Zitat von Maximilian1979:
Also im DNS Server ist nirgends ein Hinweis auf autodiscover.domäne.de aber woher weiß er jetzt das er zur externen IPadresse unseres Providers gehen soll ?
Nun, wenn in deinem DNS es nirgends einen Eintrag dazu gibt, dein WINS auch keinen hat, deine lmhosts und deine hosts Dateien ebenfalls keinen Eintrag dazu haben dann bleibt doch nur noch eine Stelle übrig, oder? Schon mal in den DNS bei deinem Hoster geschaut (Deine internetdomäne) Da ist doch bestimmt der Eintrag gesetzt (auch ein * auf alle nicht vorhanden subdomänen zur IP ....), evtl auch nur eine Subdomäne eingerichtet (autodiscover.domäne.de) und diese zeigt auf dein mailprovider. Die IP wird ja korrekt auf die IP deines nur dir bekannten Mailproviders aufgelöst. Also muss der Eintrag auch zu finden sein. Welcher DNS ist denn zuständig, oder willst du die DNS für das Internet auch komplett machen? Glaube ich kaum. Dein DNS hat doch nur eine Weiterleiung an Öffentliche DNS wenn er es nicht auflösen kann. Ein NSLookup mit type=NS sollte dir da klarheit verschaffen können wer der zuständige NS ist..

Gruß,
Peter
Bitte warten ..
Mitglied: Maximilian1979
12.01.2012 um 14:06 Uhr
Hallo Peter,

in den Providereinstellungen habe ich schon herum gewühlt. Leider ohne erfolg. Aber ich habe garnicht an nslookup gedacht.
wenn ich nslookup ausführe (ohne parameter) dann steht da:
report.domäne.de
Server servername.domäne.de
Adresse: 192.168.5.200

nicht autorisierende Antwort:
name report.domäne.de
Adresse: externe ip des Providers

und das gleiche geht auch bei autodiscover.domäne.de

sehe ich das richtig, dass der Server die Adresse nicht auflösen kann und dann ins Internet zur suche geht?

wenn ich type=ns ........ eingebe kommt folgendes
server : report.domäne.de
adresse: externe ip des providers

wie macht der das ? Beim provider steht unter Subdomains nichts!
oder sollte ich noch mal bei denen Anrufen ? aber ich will halt erst klären ob es vielleicht doch an dem Server liegt... Wo könnte ich denn noch nachsehen ?

Vielen Dank für deine Hilfe!!!
Bitte warten ..
Mitglied: Pjordorf
12.01.2012 um 14:53 Uhr
Hallo,

Zitat von Maximilian1979:
wie macht der das ? Beim provider steht unter Subdomains nichts!
Nun, irgendwo muss ja dieses definiert sein. Entweder dein DNS stellt alles für den rest der Welt bereit oder DNS im Internet tun das für dich (weiterleitung deines DNS). Einer muss ja diesen Eintrag auf einer IP auflösen. Und da die IP ja wohl eindeutig zu euch oder euren gemieteten Produkten (Webhosting etc) gehört, muss diese sich auch finden lassen. Ob da jetzt DynDNS oder andere eingebunden sind, nun, nur du kannst das Wissen. Einen Wildcard Eintrag (*) ist auch nirgends eingetragen? Was liefert den ein ping habichnochtnicht.domäne.de? Da dürfte ja wohl kein Eintrag für existieren, oder

Und was liefert nslookup den nun zurück?

CMD Fenster starten
nslookup (enter)
set type=ns (enter)
autodiscover.domäne.de (enter)

Als Antwort kommt dann irgendetwas wie:
Server:  UnKnown 
Address:  xxx.xxx.xxx.xx 
 
edvklaper.de 
        primary name server = nsxx.hoster.de 
        responsible mail addr = hostmaster.hoster.de 
        serial  = 2011062001 
        refresh = 28800 (8 hours) 
        retry   = 7200 (2 hours) 
        expire  = 604800 (7 days) 
        default TTL = 86400 (1 day)
oder wenn nicht existenter eintrag (habichnochnicht.domäne.de):
Server:  UnKnown 
Address:  x.x.x.x (gleiche IP wie schon zuvor) 
 
*** Keine name server (NS)-Einträge für habichnochnicht.domäne.de verfügbar.
Gruß,
Peter
Bitte warten ..
Mitglied: Maximilian1979
13.01.2012 um 09:38 Uhr
Guten Morgen Peter,

Also nslookup bringt mir den zweiten eintrag und zwar wie folgt:

Server: autodiscover.domäne.local
Address: 192.68.6.210
*** Keine name server (NS)-Einträge für autodiscover.domäne.de verfügbar.

was ich hier grad sehe ...
ich mache ein nslookup auf autodiscover.domäne.de und er schaut nach autodiscover.domäne.local

Aber ich habe mal eine Zwischenfrage:
Der SBS ist ja bemüht den Server auch von Außen erreichbar zu machen. Wenn ich also in dem Internetadressenassistenten gesagt habe.
Ich habe bereits eine Domain und verwalte die Selber! Kann es sein, dass der Server dann genau deswegen an die Domain diese anfrage stellt und da es keine Weiterleitung von dem Provider zurück zum Server gibt, die Anfrage beim provider hängen bleibt und ich auch deswegen das Zertifikat vom Provider bei der Autodiscover Abfrage angezeigt bekomme .???

Ich hoffe ich habe das jetzt verständlich geschrieben!
also ich stelle mir das so vor:

Outlook 2007 fragt autodiscover.domain.de oder remote.domain.de
der geht zum Server und der Server sagt .. domain.de kenn ich evtl. ich gebs weiter nach Außen
dort landet die Anfrage sofort bei meinem Provider domain.de und verbleibt dort, weil die Anfrage nicht zurück geschickt wird.

Aber irgendwie .... aaahh.. es sollte ja von innen sofort zum server gehen ! ! ..
Ich habe noch mal im DNS geschaut .. da gibt es kein * oder irgend ein hinweis für eine Weiterleitung. Beim Provider allerdings auch nicht. Daher war halt meine Vermutung... ich habe als Internetdomäne domäne.de angegeben .. vielleicht rennt er deswegen direkt zum Provider...
Da weiß ich aber einfach nicht wie sich der sbs verhält oder wo er seine infos her holt !

Was meinst du dazu ?
Bitte warten ..
Mitglied: Pjordorf
13.01.2012 um 13:21 Uhr
Hallo,

Zitat von Maximilian1979:
Also nslookup bringt mir den zweiten eintrag und zwar wie folgt:
*** Keine name server (NS)-Einträge für autodiscover.domäne.de verfügbar.
Sollte der aber nicht aufgelöst werden können? Du willst dich doch schließlich damit verbinden, oder?

ich mache ein nslookup auf autodiscover.domäne.de und er schaut nach autodiscover.domäne.local
Das verstehe ich nun gar nicht. Wieso soll ich für eine andere URL ein ergebniss bekommen?

Ich hoffe ich habe das jetzt verständlich geschrieben!
nein.

Wie nennt sich deine Externe Domäne?
Wie nennt sich dein Interne Domäne?
Für welche Domäne ist dein Exhange zuständig?
Über welche Externe URLs soll dein Exchange erreichbar sein? (Autodiscover usw)
Für was sind deine Zertifikate ausgestellt?
Was hast du wo beim Asisstenten eingetragen?

Outlook 2007 fragt autodiscover.domain.de oder remote.domain.de
Remote eher weniger, oder?

der geht zum Server und der Server sagt .. domain.de kenn ich evtl. ich gebs weiter nach Außen
Wie ? Was? Hä? Die Anfrage kommt doch von aussen?

dort landet die Anfrage sofort bei meinem Provider domain.de und verbleibt dort, weil die Anfrage nicht zurück geschickt wird.
Und dein eintrag autodiscover.domäne.de zeigt dann wohin? Ins nichts? Sollte der nicht auf deinen Router WAN seite zeigen und von dort an dein SBS geleitet werden?

Aber irgendwie .... aaahh.. es sollte ja von innen sofort zum server gehen ! ! ..
Genau. Warum willst du von innerhalb deines Netzes erst rausgehen?

Da weiß ich aber einfach nicht wie sich der sbs verhält oder wo er seine infos her holt !
Nun, wo alles anderen auch. DNS. Der SBS macht es nicht anders als ein Exchange es tut. Lass die Asisstenten noch mal laufen und gebe ihnen korrekte Antworten. Dann sollte es gehen.

Was meinst du dazu ?
Ich habe keine Meinung

Hast du schon mal hier http://blogs.technet.com/b/sbs/archive/tags/windows+small+business+serv ... oder http://blog.sbsfaq.de/category/SBS-2008.aspx oder hier http://blog.sbspraxis.de/category/windows-server-2008 geschaut?

Gruß,
Peter
Bitte warten ..
Mitglied: Maximilian1979
17.01.2012 um 10:35 Uhr
Hallo Peter,

bitte entschuldige wegen der unverständlichen Ausdrucksweise.. ich glaube das wir schon das selbe denken, nur mich verwirrt dieser Server mit seinem Verhalten und das kommt in meinen Sätzen zum Ausdruck.

Also ganz kurz noch mal :
Ich habe den Server wie folgt eingestellt.

Servername: server.maxi.local
Domäne: maxi.local
vorhandene und bei Smarthost eingegebene Domain: maxi.de
Router ist eine Firewall und kann nicht vom SBS konfiguriert werden. Alle benötigten Ports sind freigegeben

Derzeit habe ich leider nur eine externe feste IP Adresse, aber ich habe so langsam das gefühl, dass ich eine zweite benötige.

WEnn ich einen ping auf autodiscover.maxi.de schicke, dann erscheint die ip meines Providers !! von Intern !!
DAs sehe ich genau so wie du .. das sollte auf den Server zeigen!
Jetzt ist es aber so, dass ich als Domänenname maxi.LOCAL (also eine Private adresse) und als Internetdomain maxi.de.
ich müsste also irgendwie im DNS hinterlegen, dass dns nicht nur bei autodiscover.maxi.LOCAL sonder auch bei autodiscover.maxi.DE erstmal auf den Server zeigt.
(Erstmal will ich nur von Intern schaffen Autodiscover zu nutzen!)
Es gibt wohl ein Splitting im DNS, aber wenn ich versuche eine Stubzone mit dem namen autodiscover.maxi.de einzurichten, sagt mir mein DNS: Die Zone kann nicht erstellt werden. die IP-Adresse ist ungültig. Das stimmt aber nicht .. denn das ist die IP des Servers!
Oder wie würdest du versuchen von der internen Domäne maxi.local einen Verweis auf die domain maxi.de, die zusätzlich im DNS des Internen-Servers verwaltet wird, zu verweisen?

Ich hab mir ein Buch gekauft vom Addison-Wesley Verlag und das ist richtig gut !
Aber vielleicht kannst du mir eine Sache erklären...? Im Exchange gibt es unter Organisationskonfiguration den Hub-Transport und dort im Allgemeinen Reiter den eintrag remote.maxi.de.
Was ist das für ein Eintrag ? Wofür ist der da? ( in der Hilfe steht für mich nur Unverständliches. so ganz komme ich damit nicht klar!)
Kann ich diesen Eintrag einfach mal ändern ?

Dank Deiner Erklärung kann ich jetzt nachvollziehen was der Server da genau von mir will.

Punkt 1. Er findet von Intern nicht den Weg über autodiscover.maxi.de zum Server wo die xml datei für autodiscover liegt. (Fehlender eintrag im DNS. s.o.)
Punkt 2. Er geht dann den Weg über extern DNS und landet dann bei meinem Provider, wo aber noch kein Redirect zur externen festen IP eingestellt ist und somit auch nicht wieder zurück auf den Server verweißt!

Mein Ziel ist es jetzt erstmal den verweis von Intern über maxi.de auf den Server zu schaffen . Die Verbindung von Extern über den Provider auf den Server krieg ich glaube ich hin !

Eine Interessante Sache steht noch in dem Buch:
Man kann im DNS einen Eintrag hinterlegen der sich Dienstidentifizierung (SRV) heißt . Dieser muß mit ein paar Einträgen in der Forward Lookup Zone hintelegt werden. Der Eintrag wird autom. hinterlegt, wenn man die Domain über die von Microsoft vorgeschlagene Anbieter bezieht, aber man muß ihn selber eintragen wenn man eine bereits vorhandene Domain besitzt!
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
Windows Powershell Remote Domain Controller (4)

Frage von FabianBaumgart zum Thema Windows Server ...

Batch & Shell
gelöst PowerShell Domain Join (2)

Frage von Patrick-IT zum Thema Batch & Shell ...

Erkennung und -Abwehr
Spam mit eigener Domain (12)

Frage von NoobOne zum Thema Erkennung und -Abwehr ...

Windows Netzwerk
gelöst DNS - Weiterleitung zu DNS-Server in anderer Domain (5)

Frage von Schauer zum Thema Windows Netzwerk ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (34)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...