Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

RemoteApp startet nicht bei normalem User - bei Admin schon

Frage Microsoft Windows Server

Mitglied: Saggi

Saggi (Level 1) - Jetzt verbinden

05.01.2010, aktualisiert 10:50 Uhr, 7999 Aufrufe, 3 Kommentare

Hallo und guten Morgen,

ich habe folgendes Problem:

Hardware:

Server1 - Terminalserver
Jeder Nutzer wählt sich ein und bekommt eine Fremdsoftware bzw. ein Menü gestartet. (Fibu) - sieht also keinen Desktop
In diesem Menü ist eine Datei eingebunden, welche ein Programm via RemoteApp auf Server2 startet.

Server2 - Aplikationsserver
Hier ist ein Archiv und die Archivsoftware zum betrachten der Belege installiert
Diese Software wird auf Server1 via RemoteApps gestartet.


Problem:
Fall1)
Ich bin auf dem Server1 eingeloggt - bekomm nicht nur das Menü sondern sehe den ganzen Desktop - starte das Menü dann manuell.
Starte ich (Admin) das rdp File (Button im Menue, welcher eine .bat startet - diese dann das rdp), so wird die Verbindung zu dem Programm wunderbar gestartet.

Fall2)
Startet ein "normaler" User das Program, welcher auf Server1 eingeloggt ist, so wird ein Konto auf Server2 angelegt etc etc. aber es wird kein Programm gestartet. Klicke ich auf Details, so ist der "Bildschirm" blau. Ich sehe direkt am Anfang die Loginmeldungen - bis Desktop wird vorbereitet. Danach ist halt alles blau.

Fall3)
Ein normaler User ist aif dem Server1 eingeloggt und sieht sein Menü. Er startet die rdp und wir geben als login bei dem rpd die Admindaten anstatt der "normal User" Daten ein.
Ergebis ist das gleiche wie in Fall2!

Fall4)
Ich starte das rdp von meiner Workstation aus als admin - klappt wunderbar!

Kann sich einer das Problem erklären?

Es ist übrigens das gleiche Problem, wenn ich ein Programm einbinde, welches direkt auf Server1 läuft - z.B. Paint!


Mit freundlichen Grüßen
Mitglied: mayho33
06.01.2010 um 11:40 Uhr
Hallo!

Hm, Ich kenne das von unserere Firma. Wir arbeiten zwar nicht mit ServerApps aber das Prinzip ist doch immer gleich.

Ich tippe auf fehlende Rechte. Wenn die App als Admin lädt aber als Normalbenutzer nicht so will die App eventuell was auf der Platte ablegen. Einige Bereiche sind für standarduser gesperrt. Vielleicht kannst du auf das Verzeichnis in dem die App arbeitet testweise volle Rechte geben und dann schauen was passiert?

Grüße

Mayho
Bitte warten ..
Mitglied: Saggi
06.01.2010 um 13:34 Uhr
Hallo,

wie bereits geschrieben habe ich einem Testuser sogar Adminrechte gegeben in der Domäne!

Desweiteren laufen die Programme - lokal ausgeführt auf Server1 wunderbar - heißt, dass Sie via Netzlaufwerk geladen werden. Es sind keine Programme, welche installiert werden müssenm!

Nur belasten Sie dann auch Server1 und das soll nun vermieden werden, da der Server2 komplett ohne Belastung ist - und das ist ja unnütz!


Mit freundlichen Grüßen
Bitte warten ..
Mitglied: Saggi
12.01.2010 um 21:26 Uhr
ich habe rausgefunden woran es liegt.

das problem besteht nur, wenn ein user vorher im AD ein zu startendes programm vorgegeben bekommen hat..also unter dem reiter "UMGEBUNG" in der benutzerverwaltung.

nun gibt es 2 möglichkeiten warum:

1) ein benötigter dienst auf server1 wird nicht gestartet - die verbindung kann somit die dienste auf server2 nicht korrekt starten
2)
und das denk ich viel eher...

auf server2 will sich auch die softwareumgebung starten.....meine frage nun...kann ich das irgendwie unterdrücken - also das auf dem server nichts gestartet wird und jeder benutzer den richtigen desktop sehen würde?


Mit freundlichen Grüßen
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Windows Systemdateien
Keine Berechtigung trotz Domänen-Admin User (10)

Frage von M.Marz zum Thema Windows Systemdateien ...

Windows Userverwaltung
gelöst Programmupdates ohne Adminrechte für die User einer Domäne (3)

Frage von M.Marz zum Thema Windows Userverwaltung ...

Microsoft Office
gelöst Sharepoint Cached User Infos ? (4)

Frage von joehuaba zum Thema Microsoft Office ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...