Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

RemoteApp unter WIndows XP x64

Frage Microsoft Windows XP

Mitglied: toto1988

toto1988 (Level 1) - Jetzt verbinden

19.01.2010 um 15:32 Uhr, 6043 Aufrufe, 11 Kommentare

Hallo Community,

habe in den letzten Tagen einen Windows 2008 Server R2 aufgesetzt. Die Maschine soll als Terminalserver
fungieren und dazu gibt es ja die nette Funktion der RemoteApps! Wie ihr ja mit Sicherheit wisst, wird dazu
mindestens der TS Client 6.1 benötigt.

Diesen gibt es nicht für XP 64bit und genau das ist mein Problem. Habe auf einer VM mit x64 bereits den Client WIndows 7
laufen aber das mit den RemoteApps will trotzdem nicht hinhauen.

Es erscheint folgende Fehlermeldung:
RemoteApp: Your Computer was unable to connect to the remote computer

Nein an der Verbindung liegt es nicht. Die Verbindung zu ts1 (Terminalserver) funktioniert wenn ich die Verbindung per mstsc -admin aufbaue.

Hat irgendwer eine Idee wie man das Problem lösen kann?

Vielen Dank
Tobias Hartmann
Mitglied: 48507
19.01.2010 um 15:49 Uhr
Ich nehme an, du exportierst die Remote-Apps als *.rdp. Öffne die *.rdp mit einem Texteditor, und schau nach, ob alles stimmt.

Läuft die VM über NAT oder Brigded? Versuch mal den Bridged-Modus.
Bitte warten ..
Mitglied: HubertN
19.01.2010 um 17:03 Uhr
Moin

Damit RemoteApp überhaupt funktioniert, solltest du auf jeden Fall erst einmal Single Sign On aktiviert bekommen. Das hat dann nichts mit der Version des RDP-Clients zu tun (o.k. die aktuelle Version muss schon da sein...), sondern muss von Hand auf der Maschine eingerichtet werden. Ab Vista lässt es sich per GPO regeln, aber Microsoft hat diese Funktion aus dem SP für XP wieder rausgenommen. Macht ja auch irgendwie keinen Sinn, wenn du jedes mal, wenn du die Anwendung starten willst erst einmal nach deinem benutzernamen und em kennwort gefragt wirst...

Außerdem wird nicht jede Anwendung das voll unterstützen. Ich habe selbst mal RemoteApp bei einem Kunden einsetzen wollen, musste das Projekt dann aber wieder mit normaler Konfiguration realisieren, weil die Anwendung (die fpür den Terminalserverbetrieb durchaus zugelassen ist) das einfach nicht wollte...

In Kurzform:

- HKLM\SYSTEM\CurrentControlSet\Control\Lsa "Security Packages" um den Wert tspkg erweitern (!!! - also nächste Zeile hinzufügen !!!)
- HKLM\SYSTEM\CurrentControlSet\Control\SecurityProviders "SecurityProviders" um den Wert credssp.dll erweitern
- unter HKLM\SOFTWARE\Policies\Microsoft\Windows\CredentialsDelegation die folgenden Werte erstellen:
"AllowDefaultCredentials"=dword:00000001
“ConcatenateDefaults_AllowDefault"=dword:00000001
- unterhalb deises Schlüssels einen neuen erzeugen "AllowDefaultCredentials"
- hier die Server definieren, wo die Anmeldung erlaubt sein soll (Typ REG_SZ)
1 = TERMSRV/<DNS-Name des 1. Terminalservers>
2 = TERMSRV/<DNS-Name des 2. Terminalservers>
3 = ...

etc,.

Du kannst auch über die Angabe von TERMSRV/*.domäne.local alle Server der Domäne aufnehmen


Gruß

Hubert
Bitte warten ..
Mitglied: 48507
19.01.2010 um 18:26 Uhr
Sorry, aber SSO hat doch nichts mit dem Funktionieren der Anwendung zu tun. Eine RemoteApp ist nichts anderes, als eine "versteckte" Session. Sprich, BEVOR du die Anwendung starten kannst, wirst du erstmal auf dem TS angemeldet. SSO ist hier eher ein zweitrangiges Problem (und nach den Registry-Einstellungen nen Neustart nicht vergessen ).
Bitte warten ..
Mitglied: toto1988
20.01.2010 um 07:37 Uhr
Hallo zusammen,

danke für die Tips. Bin jetzt im Editor einige Punkte durchgegangen und sobald ich remoteapplicationmode:i:1 auf 1 setze erhalte
ich die oben angegebene Fehlermeldung.

Your Computer was unable to connect to the remote computer

Sobald ich den Wert wieder auf 0 setze, funktioniert die Verbindung!
SSO ist dann an der Reihe wenn die Verbindung funktioniert Das ist wie gesagt momentan nicht das Problem weil ich ja nicht mal bis
zum Login komme.....

PS: VM läuft bereits im Bridged-Modus.
Bitte warten ..
Mitglied: HubertN
22.01.2010 um 15:23 Uhr
Ja natürlich hast du Recht, aber ich frage mich, wozu eine RemoteApp-Anwendung gut sein soll, wenn ich mich jedes Mal wieder authentifizieren muss ???

Und es ist eben nicht ganz so trivial. Wie ich schon schrieb, bin ich auch schon auf Anwednungen getoßen, die zwar für den Terminalserverbetrieb ausdrücklich zugelaaasen ware, per RemoteApp aber nicht funktionsfähig waren...


Frag doch mal Google...: Unistalling RDC 7 and reinstalling it manually fixed the issue.
Bitte warten ..
Mitglied: toto1988
26.01.2010 um 11:59 Uhr
Aber was bringt mir SSO wenn ich nicht mal ne Verbindung zum Server bekomme auf Grund des "falschen" Clients?
Der Calculator & Word sind lauffähige Remoteapps.........Es geht mir eigentlich um den Client für XP x64!! Da ist das grundlegende Problem! Deinen post werde ich mir zu Herzen nehmen wenn mal eine Verbindung zum TS Server besteht ;)

Hat sich noch keiner damit auseinander gesetzt?
Vielen Dank
Bitte warten ..
Mitglied: 48507
26.01.2010 um 19:30 Uhr
Ich hatte vorher RDP 6.1 und die RemoteApps funktionierten problemlos (unter XP). Dumme Frage: Hast du die RemoteApps über die RemoteApp-Konsole erstellt und "erlaubt"? Die Event-Logs auf beiden Seiten gecheckt?
Bitte warten ..
Mitglied: toto1988
26.01.2010 um 19:49 Uhr
Zitat von 48507:
Ich hatte vorher RDP 6.1 und die RemoteApps funktionierten problemlos (unter XP). Dumme Frage: Hast du die RemoteApps über
die RemoteApp-Konsole erstellt und "erlaubt"? Die Event-Logs auf beiden Seiten gecheckt?

Die remoteapps ansich funktionieren unter XP oder Win 7, aber der alte Client unter Win XP 64bit unterstützt das leider noch nicht.
und den 6.1 Client gibts nicht für XP x64 sonst wäre ja alles kein Problem

Und deswegen versuche ich das ganze anders zu lösen..............nur ist die frage wie ))
Bitte warten ..
Mitglied: toto1988
02.02.2010 um 10:52 Uhr
I need help........ hat keiner ideen? Irgendwer muss doch schon vor dem selbem Problem gestanden haben?
Bitte warten ..
Mitglied: toto1988
22.02.2010 um 15:29 Uhr
*push

Irgendwer muss doch da eine Lösung wissen ;)))
Bitte warten ..
Mitglied: toto1988
02.11.2010 um 14:26 Uhr
  • push

gibt es mittlerweile neuigkeiten?
Bitte warten ..
Ähnliche Inhalte
Grafikkarten & Monitore
Kaufberatung Grafikkarte für Windows 10 x64 Pro. PCI-E (8)

Frage von zeroblue2005 zum Thema Grafikkarten & Monitore ...

Windows XP
SP3 für Windows XP Embedded Version 2002 (4)

Frage von Michael-24 zum Thema Windows XP ...

Microsoft
Windows XP Embedded Partition verschwunden (4)

Frage von Tiloklom zum Thema Microsoft ...

Windows Installation
gelöst Nach Austausch SSD - Problem mit Windows 7 x64 Installation (5)

Frage von BigSnakeye zum Thema Windows Installation ...

Neue Wissensbeiträge
Tipps & Tricks

Wie Hackt man sich am besten in ein Computernetzwerk ein

(38)

Erfahrungsbericht von Herbrich19 zum Thema Tipps & Tricks ...

Humor (lol)

Bester Vorschlag eines Supporttechnikers ever: APC

(15)

Erfahrungsbericht von DerWoWusste zum Thema Humor (lol) ...

Heiß diskutierte Inhalte
Festplatten, SSD, Raid
POS Hardware und alternativen zu Raid 1? (21)

Frage von Brotkasten zum Thema Festplatten, SSD, Raid ...

Viren und Trojaner
Verschlüsselungstrojaner simulieren (15)

Frage von AlbertMinrich zum Thema Viren und Trojaner ...

Rechtliche Fragen
Hotspot rechtssicher betreiben? (14)

Frage von xSiggix zum Thema Rechtliche Fragen ...

ISDN & Analoganschlüsse
gelöst Splitter - RJ45 zu RJ11? (14)

Frage von Waishon zum Thema ISDN & Analoganschlüsse ...