Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Remotedesktop-Druckerumleitung funktioniert nur mit LPT-Druckern

Frage Microsoft Windows Server

Mitglied: 26431

26431 (Level 1)

06.03.2006, aktualisiert 07.05.2007, 14396 Aufrufe, 12 Kommentare

...nicht dagegen mit Netzwerkdruckern

Hallo zusammen, ich habe folgendes Problem:

Ein XP-Client benutzt einen LaserJet 1320n (Netzwerkdrucker), dieser ist mit dem Anschlusstyp Standard TCP/IP-Port installiert. In den Druckereigenschaften unter dem Reiter "Anschluss" sieht das dann so aus: IP_192.168.1.5 mit einem Haken davor. Soweit, so gut.
Jetzt meldet sich unser Client über VPN per RDP an einem Server 2003 an und möchte dort seinen Drucker sehen und benutzen. Kann er aber nicht, der ist nicht da!

Ich hab ein bisschen rumgespielt und unter anderem auch versuchsweise den Anschluss LPT1 in den Druckereigenschaften auf dem XP-Client gewählt und siehe da: Es funktioniert, die Druckerumleitung steht! Aber warum?

Leider hängt der Drucker halt nicht am Parallelport, sondern an IP_192.168.1.5. Und der Treiber auf dem W2k3 ist definitiv derselbe wie auf dem XP, sonst würde es ja mit Haken vor LPT1 nicht funktionieren. Tut es aber.

Freue mich auf Anregungen eurerseits.
Mitglied: meinereiner
06.03.2006 um 20:11 Uhr
Da kann wohl der Druckeranschluss nicht eingerichtet werden.
Füg den doch mal auf dem 2003 Server hinzu, dann wird es auch klappen.
Bitte warten ..
Mitglied: 26431
06.03.2006 um 22:50 Uhr
Du meinst, ich soll den Anschluss IP_192.168.1.5 auf dem Server einrichten? Das habe ich schon - so funktioniert mein Workaround. Aber richtig sauber finde ich das nicht, denn so ist der Drucker ständig und für alle TS-User sichtbar.
Sollte es nicht normalerweise so laufen, dass der Druckeranschluss TS00x des Servers auf den Client gemappt wird...?
Bitte warten ..
Mitglied: meinereiner
06.03.2006 um 23:00 Uhr
Der Anschluss muss vorhanden sein, nicht der Drucker.
Der wird dann schon automatisch eingerichten wenn der Anschluss da ist.

Wenn du in deinem Workaround jetzt den Drucker löscht, müsste der Anschluss bleiben und das Ganze funktionieren wie du willst.
Bitte warten ..
Mitglied: 26431
07.03.2006 um 08:11 Uhr
Danke, ich werd's versuchen, sobald ich wieder in diese Außenstelle komme.
Bitte warten ..
Mitglied: 26431
07.03.2006 um 19:16 Uhr
Tut mir Leid, das sagen zu müssen, aber daran lag's nicht. Ich hab's mit zwei Clients getestet, beide mit Win2k SP4, beim einen wird der Drucker eingerichtet und beim andern nicht, und zwar unabhängig davon, ob der Anschluss IP_192.168.1.5 auf dem Server vorhanden ist! Langsam fange ich echt an, an Dämonen in meinem Netz zu glauben, vielleicht sollte ich gelegentlich mal einen Exorzisten kommen lassen...

Hättest du vielleicht noch einen Tipp?
Bitte warten ..
Mitglied: meinereiner
07.03.2006 um 19:27 Uhr
Hmm, vielleicht sind es doch etwas andere Treiber.
Gibt den Drucker auf dem Client auf dem es nicht geht mal frei. Dann greif vom TS drauf zu. Wenn der den dann installiert sollten alle Treiber da sein. Danach kannst du den Drucker und die Freigabe wieder entfernen. Porbiere es dann nochmal.
Bitte warten ..
Mitglied: 26431
07.03.2006 um 22:53 Uhr
Mhm, den Trick hab ich in einem anderen Beitrag schonmal gelesen, und das ist auch tatsächlich der schönste Weg, eine exakte Treiberkopie zu ziehen.
Jedenfalls hab ich das schon ausprobiert, erfolglos.
Normalerweise meckert der Server ja im Ereignisprotokoll, wenn ein Treiber fehlt, das tut er hier aber nicht. Es scheint so, als ob der Server gar nicht merkt, dass da ein Client einen Drucker mitbringt.
Und dass es von einem anderen Client mit identischer Konfiguration funktioniert, das ist gelinde gesagt merkwürdig.
Bitte warten ..
Mitglied: meinereiner
07.03.2006 um 23:37 Uhr
Im Ereignisprotokoll steht dann auch nichts?!
Kann eine Policy Probleme machen?
Beim Teste von den zwei Clients hast du jedes mal den gleichen User genommen?

Irgend einen Grund muss das doch haben...
Bitte warten ..
Mitglied: 26431
09.03.2006 um 13:32 Uhr
Im Ereignisprotokoll steht dann auch
nichts?!

Nö.

Kann eine Policy Probleme machen?

Ich verbringe in letzter Zeit fast mehr Zeit im GPEdit als sonstwo...

Beim Teste von den zwei Clients hast du
jedes mal den gleichen User genommen?

Jepp.

Irgend einen Grund muss das doch haben...

Ich geb's jetzt auf. Der eine Client scheint übrigens der einzige im Unternehmen zu sein, bei dem's funktioniert.
Der Tipp mit net use lpt1 \\192.168.5.1, den ich irgendwo auf administrator.de gefunden habe, funktioniert auch nicht, da gibts dann einen Systemfehler 67, "Der Netzwerkname wurde nicht gefunden.".
Bitte warten ..
Mitglied: KaFuONE
18.09.2006 um 14:16 Uhr
Hallo,

ich habe dieses Problem seit einiger Zeit und ewig keine Lösung gefunden.

Die Hilfe vom Microsoft (http://support.microsoft.com/default.aspx?scid=kb;de;302361) war nicht wirklich eine.

Da ich die Drucker alle über Standard TCP/IP installiert habe, änderte ich beim Neuerstellen einfach den Portnamen von IP_XXX.XXX.XXX.XXX in USB XXX.XXX.XXX.XXX um. Da wie in dem oben aufgeführten Artikel der TS standardmässig nur Anschlüsse die mit LPT,COM und USB anfangen erkennt, findert er diese dann beim verbinden und ich kann auf meinen beiden Netzwerkdruckern bei mir zu Hause endlich ausdrucken.

Sollte jemand eine bessere Lösung haben währe ich sehr dankbar.
Bitte warten ..
Mitglied: Drohne
07.05.2007 um 10:45 Uhr
Hallo,

du kannst Drucker, die du über einen TCP/IP Anschluss installiert hast ganz einfach mit in die Session nehmen, das Geheimniss ist eigentlich ganz simpel.

Wie du schon sagtest, wird eigentlich nur der LPT Anschluss mit "durchgeschliffen", wenn du jedoch mal in die Eigenschaften des Druckers gehst, dort "Anschlüsse" auswählst klickst du auf "Hinzufügen". Dann wähle "Standart TCP/IP Port" aus und klickst auf "Neuer Anschluss". Dann gebe deine IP 192.168.1.5 ein. Im Feld Port klickst du nun mit der Maus VOR den Buchstaben IP_ und gibst LPT2 ein, das sieht dann so aus im Feld Port:

LPT2IP_192.168.1.5

Somit hast du Windows überlistet, denn jetzt "findet" er LPT und schleift es mit durch, kurios, aber ist so. So habe ich das bisher super geregelt.
Natürlich muss der gleiche Treiber des Drucker auf dem Terminalserver installiert sein am LPT dran, aber das haste ja schon gemacht. Den Drucker kannste dann natürlich sofort wieder löschen.

LG Drohne
Bitte warten ..
Mitglied: KaFuONE
07.05.2007 um 11:38 Uhr
Mit dem neuen 6.0-er Client scheint das Problem sowieso nicht mehr zubestehen.

Beim 5.0er giebts aber auch eine andere Lösung:

Man erstelle eine Reg-Datei mit folgendem Inhalt:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default\AddIns\RDPDR]
"FilterQueueType"=dword:ffffffff


Dann zusammenführen und schon werden beim Verbinden jeder Druckeranschluss überprüft und jeder mögliche verbunden!!!

Aber, wie schon erwähnt, mit dem neuen Client sollte das eh der Vergangenheit angehören.
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Router & Routing
Transparenter Proxy funktioniert nicht? (1)

Frage von mrserious73 zum Thema Router & Routing ...

Linux
LTSP: PXE Boot funktioniert nicht (23)

Frage von Fenris14 zum Thema Linux ...

Drucker und Scanner
USB-Drucker über virtuellen COM LPT- Port ansteuern (27)

Frage von magicman zum Thema Drucker und Scanner ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (23)

Frage von patz223 zum Thema Windows Userverwaltung ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (19)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...