Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Remotedesktopgateway hinter Apache 2.2.3 Reverse Proxy

Frage Microsoft Windows Server

Mitglied: spider0709

spider0709 (Level 1) - Jetzt verbinden

16.01.2014, aktualisiert 17:11 Uhr, 2548 Aufrufe, 5 Kommentare

Hallo Gemeinde,

ich versuche ein Remotedesktopgateway hinter einem Apache Reverse Proxy zum Laufen zu bewegen.
Ich erhalte bei den Verbindungsversuchen aus dem Internet in einer Endlosschleife immer wieder das
Benutzer-Anmeldefenster mit der Meldung

Anmeldung fehlgeschlagen.

Über den gleichen Reverse Proxy funktioniert jedoch die Synchronisation über Active-Sync mit einem
Exchange 2010, sowie der Aufruf des OWA-Clients aus dem Internet.

Laut Debug-Protokollen sehe ich auch, das der Apache mit dem Remotedesktopgateway kommuniziert.
Diese bricht aber immer wieder mit der Fehlermeldung:

Connection reset by peer: proxy: prefetch request body failed to xxx.xxx.xxx.xxx

Aus dem lokalen Netzwerk hingegen funktionieren die Aufrufe des Remotedesktopgateways.

Hat jemand eine Idee, was hier schief laufen könnte ?

Jede Hilfe ist mir hier willkommen.

Mitglied: certifiedit.net
16.01.2014, aktualisiert um 17:11 Uhr
Hallo spider,

bitte korrigier den Titel, zur Wiederfindbarkeit.

Zum Thema an sich: Das owa geht muss nicht unbedingt heissen, dass tsweb geht. Ich hatte letzten Sommer ein ähnlichen Fall mit einem kommerziellen Reverse Proxy, welcher offensichtlich auf OWA bereits angepasst wurde. Wollte ich das TSWeb darüber betreiben: Klägliches Scheitern. Wurde auch vom Hersteller so kommuniziert. War nicht darauf angepasst, da MS wohl noch sehr propritäre Aushandlungsmechanismen einsetzt - das gleiche Problem gab es bis vor einiger Zeit auch noch beim OWA. Sorry.

Aber Poste uns doch mal den ganzen Log.

LG,

Christian
Bitte warten ..
Mitglied: spider0709
16.01.2014 um 17:13 Uhr
Hallo Christian,

ich habe mal das Debug-Log angefügt und die Zertifikate entfernt. Kannst Du damit was anfangen ?

Viele Grüße

Andreas

[Thu Jan 16 13:05:56 2014] [info] Initial (No.1) HTTPS request received for child 5 (server tsweb.domain.com:443)
[Thu Jan 16 13:05:56 2014] [debug] mod_proxy_http.c(56): proxy: HTTP: canonicalising URL 192.168.1.3/rpc/rpcproxy.dll
[Thu Jan 16 13:05:56 2014] [debug] proxy_util.c(1488): [client xxx.xxx.xxx.xxx] proxy: https: found worker https:
192.168.1.3/rpc for https://192.168.1.3/rpc/rpcproxy.dll?localhost:3388
[Thu Jan 16 13:05:56 2014] [debug] mod_proxy.c(966): Running scheme https handler (attempt 0)
[Thu Jan 16 13:05:56 2014] [debug] mod_proxy_http.c(1960): proxy: HTTP: serving URL https://192.168.1.3/rpc/rpcproxy.dll?localhost:3388
[Thu Jan 16 13:05:56 2014] [debug] proxy_util.c(2044): proxy: HTTPS: has acquired connection for (192.168.1.3)
[Thu Jan 16 13:05:56 2014] [debug] proxy_util.c(2102): proxy: connecting https://192.168.1.3/rpc/rpcproxy.dll?localhost:3388 to 192.168.1.3:443
[Thu Jan 16 13:05:56 2014] [debug] proxy_util.c(2195): proxy: connected /rpc/rpcproxy.dll?localhost:3388 to 192.168.1.3:443
[Thu Jan 16 13:05:56 2014] [debug] proxy_util.c(2347): proxy: HTTPS: fam 2 socket created to connect to 192.168.1.3
[Thu Jan 16 13:05:56 2014] [debug] proxy_util.c(2449): proxy: HTTPS: connection complete to 192.168.1.3:443 (192.168.1.3)
[Thu Jan 16 13:05:56 2014] [info] [client 192.168.1.3] Connection to child 0 established (server tsweb.domain.com:443)
[Thu Jan 16 13:05:56 2014] [info] Seeding PRNG with 0 bytes of entropy
[Thu Jan 16 13:05:56 2014] [debug] ssl_engine_kernel.c(1747): OpenSSL: Handshake: start
[Thu Jan 16 13:05:56 2014] [debug] ssl_engine_kernel.c(1755): OpenSSL: Loop: before/connect initialization
[Thu Jan 16 13:05:56 2014] [debug] ssl_engine_kernel.c(1755): OpenSSL: Loop: SSLv2/v3 write client hello A
[Thu Jan 16 13:05:56 2014] [debug] ssl_engine_io.c(1810): OpenSSL: read 7/7 bytes from BIO#2b0965c304d0 [mem: 2b0965c49720] (BIO dump follows)
...
[Thu Jan 16 13:05:56 2014] [debug] ssl_engine_io.c(1810): OpenSSL: read 834/834 bytes from BIO#2b0965c304d0 [mem: 2b0965c49727] (BIO dump follows)
...
[Thu Jan 16 13:05:56 2014] [debug] ssl_engine_kernel.c(1755): OpenSSL: Loop: SSLv3 read server hello A
[Thu Jan 16 13:05:56 2014] [debug] ssl_engine_kernel.c(1205): Certificate Verification: depth: 0, subject: /CN=tsweb.domain.com, issuer: /CN=tsweb.domain.com
[Thu Jan 16 13:05:56 2014] [debug] ssl_engine_kernel.c(1205): Certificate Verification: depth: 0, subject: /CN=tsweb.domain.com, issuer: /CN=tsweb.domain.com
[Thu Jan 16 13:05:56 2014] [debug] ssl_engine_kernel.c(1755): OpenSSL: Loop: SSLv3 read server certificate A
[Thu Jan 16 13:05:56 2014] [debug] ssl_engine_kernel.c(1755): OpenSSL: Loop: SSLv3 read server done A
[Thu Jan 16 13:05:56 2014] [debug] ssl_engine_kernel.c(1755): OpenSSL: Loop: SSLv3 write client key exchange A
[Thu Jan 16 13:05:56 2014] [debug] ssl_engine_kernel.c(1755): OpenSSL: Loop: SSLv3 write change cipher spec A
[Thu Jan 16 13:05:56 2014] [debug] ssl_engine_kernel.c(1755): OpenSSL: Loop: SSLv3 write finished A
[Thu Jan 16 13:05:56 2014] [debug] ssl_engine_kernel.c(1755): OpenSSL: Loop: SSLv3 flush data
[Thu Jan 16 13:05:56 2014] [debug] ssl_engine_io.c(1810): OpenSSL: read 5/5 bytes from BIO#2b0965c304d0 [mem: 2b0965c49720] (BIO dump follows)
...
[Thu Jan 16 13:05:56 2014] [debug] ssl_engine_io.c(1810): OpenSSL: read 1/1 bytes from BIO#2b0965c304d0 [mem: 2b0965c49725] (BIO dump follows)
...
[Thu Jan 16 13:05:56 2014] [debug] ssl_engine_io.c(1810): OpenSSL: read 5/5 bytes from BIO#2b0965c304d0 [mem: 2b0965c49720] (BIO dump follows)
...
[Thu Jan 16 13:05:56 2014] [debug] ssl_engine_io.c(1810): OpenSSL: read 48/48 bytes from BIO#2b0965c304d0 [mem: 2b0965c49725] (BIO dump follows)
...
[Thu Jan 16 13:05:56 2014] [debug] ssl_engine_kernel.c(1755): OpenSSL: Loop: SSLv3 read finished A
[Thu Jan 16 13:05:56 2014] [debug] ssl_engine_kernel.c(1751): OpenSSL: Handshake: done
[Thu Jan 16 13:05:56 2014] [info] Connection: Client IP: 192.168.1.3, Protocol: TLSv1, Cipher: AES128-SHA (128/128 bits)
[Thu Jan 16 13:05:56 2014] [debug] ssl_engine_io.c(1810): OpenSSL: read 5/5 bytes from BIO#2b0965c304d0 [mem: 2b0965c49720] (BIO dump follows)
...
[Thu Jan 16 13:05:56 2014] [debug] ssl_engine_io.c(1810): OpenSSL: read 304/304 bytes from BIO#2b0965c304d0 [mem: 2b0965c49725] (BIO dump follows)
...
[Thu Jan 16 13:05:56 2014] [debug] mod_proxy_http.c(1737): proxy: start body send
[Thu Jan 16 13:05:56 2014] [debug] mod_proxy_http.c(1826): proxy: end body send
[Thu Jan 16 13:05:56 2014] [debug] proxy_util.c(2062): proxy: HTTPS: has released connection for (192.168.1.3)
[Thu Jan 16 13:05:56 2014] [error] (104)Connection reset by peer: proxy: prefetch request body failed to 192.168.1.3:443 (192.168.1.3) from xxx.xxx.xxx.xxx ()
[Thu Jan 16 13:05:56 2014] [debug] proxy_util.c(2062): proxy: HTTPS: has released connection for (192.168.1.3)
Bitte warten ..
Mitglied: certifiedit.net
16.01.2014, aktualisiert um 17:17 Uhr
Hallo Christian,

ist wie oben, sieht für mich danach aus, als wäre das genau der Punkt Linux < nicht kompatibel/angepasst > Windows. Beim Handshake davor läuft ja auch alles wunderbar.

Beste Grüße,

Christian

PS: Ist das Ding jetzt gelöst?
Bitte warten ..
Mitglied: spider0709
16.01.2014 um 22:02 Uhr
Hallo Christian,

mir ist beim Kommentieren der falsche Button dazwischen gekommen. Leider ist das Problem nicht gelöst.

Verstehe ich das jetzt richtig, das es wohl an der Nichtkompatibilität liegt ?

Gibt es eine Alternative für Apache2 ?

Viele Grüße

Andreas
Bitte warten ..
Mitglied: certifiedit.net
16.01.2014 um 22:14 Uhr
Hallo Andreas,

ja, wie gesagt, bei mir lag es damals daran und der Log scheint dahingehend eindeutig. Gelöst ist die Frage wohl schon (evtl noch das Posting mit "nicht kompatibel" als Lösung markieren) - nur leider eben nicht so, wie du willst. Beim tsWeb bin ich bisher dann notgedrungen über eine zweite IP gegangen.

Sorry.

Beste Grüße,

Christian
Bitte warten ..
Ähnliche Inhalte
Apache Server
Wordpress und Apache als Reverse Proxy (2)

Frage von sleaper zum Thema Apache Server ...

Server
gelöst Reverse Proxy mit IIS 8 (13)

Frage von maddig zum Thema Server ...

Apache Server
Apache2 als Reverse Proxy liefert die falsche Seite zurück

Frage von liquidbase zum Thema Apache Server ...

Router & Routing
gelöst Squid Revers Proxy Probleme - Exchange (1)

Frage von theoberlin zum Thema Router & Routing ...

Neue Wissensbeiträge
Windows Server

Umstellung SHA 1 auf SHA 2 - Migration der CA von CSP auf KSP

Tipp von Badger zum Thema Windows Server ...

Windows 10

Quato DTP94 unter Windows 10 x64 installieren und verwenden

Anleitung von anteNope zum Thema Windows 10 ...

Windows 10

Win10 1703 und Nutzerkennwörter bei Ersteinrichtung - erstaunliche Erkenntnis

(15)

Erfahrungsbericht von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Festplatten, SSD, Raid
gelöst Raid-Controller (Areca) Datenverlust trotz R5 (16)

Frage von sebastian2608 zum Thema Festplatten, SSD, Raid ...

Server-Hardware
Starker PC zum Virtualisieren (10)

Frage von canlot zum Thema Server-Hardware ...

Server-Hardware
HP ProLiant DL380 G7, POST Error: 1785-Drive Array not Configured (10)

Frage von Paderman zum Thema Server-Hardware ...

Microsoft Office
gelöst Office 365 Pro Domäne einrichten OHNE Webseite (9)

Frage von thklemm zum Thema Microsoft Office ...