Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Remotesteuerung bricht ab

Frage Microsoft Windows Userverwaltung

Mitglied: OliverK

OliverK (Level 1) - Jetzt verbinden

19.09.2012 um 16:38 Uhr, 4028 Aufrufe, 8 Kommentare

Hallo in die Runde,

habe hier ein kurioses Problem, was die Remotesteuerung betrifft, vorab die dafür vorhandene Umgebung:

-Terminalserver unter Windows Server 2008 und WS2k8 R2
-Client-PC für die Administration unter Win 7 Prof.

Wenn ich nun über den Client-PC eine RDP-Session zu einem Terminal aufbaue, baut sich ganz normal der Desktop auf und es lässt sich auch normal arbeiten. Nun aktiviere ich den Task-Manager und gehe bei Benutzer auf den User, der Hilfe anfordert und wähle REMOTESTEUERUNG aus.

Erst passiert nichts, dann wird der Bildschirm kurz schwarz und danach ist meine Sitzung wieder da, die Benutzer-Sitzung habe ich aber nicht gesehen.

Nun habe ich gelesen, das es an rdesktop liegen könnte, setze aber selbst ja WIN7 ein und demzufolge das dort installierte RDP der aktuellen Fassung. Auch auf den Servern liegt das MS-eigene RDP vor.

Früher unter Windows Server 2003 und Windows XP konnten wir problemlos damit den Usern helfen und support leisten, aber seit wir die WS2008er einsetzen, hakt es da immer.

Kennt einer das Problem und evtl. auch die Lösung?

Grüße
Oliver
Mitglied: DerWoWusste
19.09.2012 um 17:20 Uhr
Moin.

seit wir die WS2008er einsetzen, hakt es da immer
IMMER? Ging noch nie, oder ging schon mal?

Wenn die UAC an ist, muss man seit win2008 zunächst den Taskmanager elevaten, also beispielsweise auf "Prozesse aller Nutzer anzeigen" klicken, das ruft elevation (die UAC-Abfrage+anschließende Hochstufung) hervor. Dann erst kann man andere steuern.

Was sonderbar ist: es müsste nicht wie bei der Bildschirm kurz schwar werden, sondern "Zugriff verweigert" gemeldet werden. Oder ist Eure UAC aus?
Bitte warten ..
Mitglied: OliverK
19.09.2012, aktualisiert um 17:42 Uhr
Zitat von DerWoWusste:
Moin.

> seit wir die WS2008er einsetzen, hakt es da immer
IMMER? Ging noch nie, oder ging schon mal?

seit WS2008er-Zeiten, immer. Anfänglich gab es mal noch Fehlermeldungen die auf ein Protokollfehler verwiesen, seit zwei Monaten kommt aber auch diese Meldung nicht mehr, seit ein Update drüber ist, um evtl. Remotesteuerungsprobleme zu beheben.


Wenn die UAC an ist, muss man seit win2008 zunächst den Taskmanager elevaten, also beispielsweise auf "Prozesse aller
Nutzer anzeigen" klicken, das ruft elevation (die UAC-Abfrage+anschließende Hochstufung) hervor. Dann erst kann man
andere steuern.

Was sonderbar ist: es müsste nicht wie bei der Bildschirm kurz schwar werden, sondern "Zugriff verweigert" gemeldet
werden. Oder ist Eure UAC aus?

Wir gehen ja eigentlich über den Taskmanager und als Administrator ist da auch immer der Haken für alle Prozesse aktiv, als Admin erhalte ich aber keinen Hinweis auf UAC, diese haben wir aber aktiv auf den Servern.

So, hab es mal eben nochmal nachgestellt, mit folgender Umgebung:

- Anmeldung als Admin auf einem Terminal
- Anmeldung als User auf dem gleichen Terminal

Admin - startet TASK, haken für alle Prozesse ist schon vorhanden, gehe auf Register Benutzer, wähle User aus und klicke Remotesteuerung an.

User - erhält Hinweis DOMAIN\Admin fordert die Remoteüberwachung der Sitzung an, Nehmen Sie die Anforderung an? (Bildschirm Admin solange schwarz)
klicke auf JA

es passiert:
User - Remotedesktopsitzung wurde beendet
Admin - fällt in seine Sitzung zurück, Task Manager zeigt USER als getrennt an.


So, nun habe ich mir mal das Eventlog angesehen, unter Anwendung ist nichts aufgeführt, im Bereich System gibt es jedoch den Hinweis auf Fehler TERMDD - 50 - Die RDP-Protokollkomponente "DATA ENCRYPTION" hat einen Fehler im Protokollablauf festgellt und die Clientverbindung getrennt. Bei zwei Versuchen, kommt der Hinweis aber nur 1x vor.

An diesem Beispiel Terminal ist aber die UAC sogar deaktiviert, war eine Empfehlung in Bezug auf einige Anwendungen die interaktive Meldungen versenden, u. a. Druckermonitore.
Bitte warten ..
Mitglied: DerWoWusste
19.09.2012, aktualisiert um 17:41 Uhr
als Administrator ist da auch immer der Haken für alle Prozesse aktiv
Nein. Nur beim eingebauten Konto "Administrator" ist das so. Wenn die UAC an ist und wie empfohlen auf voll (und nicht wie bei Win7/2008R2 per default nur auf zweithöchster Stufe), dann ist der Haken bei normalen (Domänen-)admins nicht gesetzt und der Taskmanager ist nicht elevated.

Aber egal, wenn der Haken bei Dir gesetzt ist, läuft er elevated und das Problem kann auf dieser Schiene nicht angegangen werden.
seit ein Update drüber ist, um evtl. Remotesteuerungsprobleme zu beheben
Welches Update? Nennen, deinstallieren, Fehler reproduzieren, Meldung nennen.
Bitte warten ..
Mitglied: OliverK
19.09.2012 um 17:54 Uhr
Wenn ich das Update noch wüßte,... aber ohne kommt halt nur beim Admin sofort ein Fehlerhinweis und der User erhält erst gar nicht die Anforderung, von daher würde ich es nicht unbedingt entfernen wollen.

Meine Suche über Fehler der TERMDD-Quelle mit ID 50 verweist meistens auf XP-Rechner, habe aber hier einen WIN7 Rechner, sprich die Kommunikation und Sicherheitsaushandlung sollte ohne Probleme durchlaufen. Ein Hinweis für Server unter Win2000 verweist auf ein Zertifikatsproblem, tja, aber gilt das dann auch für einen 2008?
Bitte warten ..
Mitglied: OliverK
19.09.2012 um 18:08 Uhr
Hätte da jetzt noch eine Idee,.. der Server hat aktuell die RDC Version 6.0.6002, er selbst sagt das er nur bis 6.1 unterstützen kann.

Der Client liegt dagegen bei 6.1.7601 und unterstützt 7.1

Kann es sein das sich das kappelt? Das der Server einfach nicht versteht was für eine Version der Client führt, zwar soweit alles zulässt, aber bei der Remotesteuerung durcheinander kommt und abbricht?
Bitte warten ..
Mitglied: DerWoWusste
19.09.2012 um 23:12 Uhr
Das C in RDC steht für Client. Die Clientkomponente hat nichts mit seinen Eigenschaften als Server zu tun, aber auf den letzten RD-Client kannst Du den Server jedenfalls schmerzfrei und ohne Neustart upgraden, wenn Du es mit absoluter Sicherheit wissen willst.
Auch kannst Du es clientseitig (von xp oder Vista aus) ja mal mit 6.0 versuchen.


Ich würde das Update entfernen und mit der Meldung auf die Suche gehen. Kannst das Update ja sofort wieder einspielen.
Bitte warten ..
Mitglied: OliverK
20.09.2012 um 11:11 Uhr
Danke für die bisherigen Antworten, werde wohl oder übel mir am Wochenende die Updateverlaufliste ansehen und prüfen.
Mit XP oder Vista kann ich es leider nicht testen, da wir das überhaupt nicht mehr einsetzen.
Bitte warten ..
Mitglied: DerWoWusste
20.09.2012 um 11:15 Uhr
Mit XP oder Vista kann ich es leider nicht testen, da wir das überhaupt nicht mehr einsetzen.
Du kannst Vista ohne Key als Testversion installieren. XP nur mit Key, aber musst es ja nicht sofort aktivieren. Ich würde diesen Test machen.
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(1)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
DSL, VDSL
gelöst Telekom PPPoE Tunnel bricht ständig zusammen (13)

Frage von Phill93 zum Thema DSL, VDSL ...

Router & Routing
Bintec PPTP zu Provider bricht ab

Frage von steinbauerw zum Thema Router & Routing ...

Windows Server
MDT 2013 - Installation von Windows bricht ab (5)

Frage von BraucheKaffee zum Thema Windows Server ...

Notebook & Zubehör
gelöst Netzwerkverbindung per LAN bricht immer wieder weg. (Sekundentakt) (11)

Frage von Hendrik2586 zum Thema Notebook & Zubehör ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (14)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...