Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Remoteverbindung auf Netzwerk mit UMTS-Router und DSL-Router

Frage Netzwerke Router & Routing

Mitglied: smirgl

smirgl (Level 1) - Jetzt verbinden

02.06.2010, aktualisiert 18.10.2012, 8563 Aufrufe, 15 Kommentare

Hallo Spezialisten,

Habe in einem Büro einen DSL-Anschluss (384er) an einem Netgear DG834B der den Zugang zum I-Net bereitstellt und für Remoteverbindungen zum Server konfiguriert ist.
Jetzt habe ich für den I-Net-Zugang einen UMTS-Router (EasyBox 802 - IP: 192.168.1.1) installiert für nen schnelleren Zugang.

Nun hab ich folgendes Problem:
Remoteverwaltung über UMTS geht nicht. Also soll die bestehende DSL-Leitung ausschließlich dafür verwendet werden.
Der UMTS-Router stellt ausschließlich eine UMTS-Verbindung her und versorgt per DHCP die Clients (192.168.1.20-199)
Den DSL-Router habe ich mit der IP 192.168.2.1 und DHCP off eingestellt und eine Portweiterleitung für Remote auf die Server-IP( .100) eingestellt.
DSL-Router hat dyndns und lässt sich anpingen. Auf den Server komm ich allerdings nicht obwohl die Weiterleitung korrekt eingestellt ist.
DSL- Router hängt über LAN-Port an LAN-Port des UMTS-Routers.
Aus dem Netzwerk kann ich den DSL-Router über seine IP erreichen.

Hier ist der Punkt wo ich eure Hilfe brauche.
Was muss ich machen um über den DSL-Router auf den Server zu kommen???

Dank schon mal im Voraus.

Gruß Smirgl
Mitglied: Ch3p4cK
02.06.2010 um 08:39 Uhr
Welche IP hat dein Server? 192.168.2.100 oder 192.168.1.100? Ist das so schwer das auszuschreiben?

Probier folgendes:
Mach den alten Router ins gleiche Subnet (weiß nicht was bei dir dagegen spricht). Eventuell könnte es funktionieren. Ansonsten hast du ein Routing Problem. Du musst warscheinlich am Server den Standardgateway vom DSL-Router angeben. Ansonsten weiß dein Server nicht was er mit den Paketen anfangen soll und verwirft die.
Bitte warten ..
Mitglied: smirgl
02.06.2010 um 08:49 Uhr
Server-IP ist 192.168.1.100
Am Server hab ich den Gateway vom UMTS-Router. Mit dem Gateway vom DSL-Router konnte er keine Clients und auch den UMTS-Router nicht mehr erreichen nur noch den DSL-Router.
Der Server hat nur eine Netzwerkkarte für Lokales Netzwerk und Internetzugang.

Alle Clients und Router sind im selben IP-Netzwerk 192.168.1.xxx 255.255.255.0

Ach ja: Der DSL-Router sagt mir im Logfile dass er die Anfrage aus dem I-Net an der Server bekommt aber mit dem Zusatz "HTTPS Rule match"
Als der DSL-Router noch der einzige im Netz war hatte die Weiterleitung zum Server funktioniert. Hmm... ratlos???


EDIT: Hab da was falsch geschieben: Die jetzige IP vom DSL-Router ist die 192.168.1.2 und nicht die 192.168.2.1. Sorry
Bitte warten ..
Mitglied: Ch3p4cK
02.06.2010 um 09:09 Uhr
Ok. Dann probier doch mal dem Server den DSL-Router (192.168.1.2) als Standardgateway zuzuweisen. Ist der Server auch per DHCP konfiguriert? Ein kleiner Tip: Weise die Netzwerkeinstellungen am Server statisch zu. Aber Achtung: Keine IP aus dem DHCP Bereich verwenden!!!!
Bitte warten ..
Mitglied: smirgl
02.06.2010 um 10:07 Uhr
Server-IP ist statisch die 192.168.1.100
Habe den DHCP-Bereich geändert von 101-199
Beide Router neu gestartet.
DSL-Router hat statisch die 192.168.1.2

Zugriff immer noch erfolglos.
Meldung vom Netgear-Router: TCP Packet - Source:109.85.116.62,4567 Destination:{IP},443 - [HTTPS rule match]
Source= UMTS
Destination=die IP mit der ich aktuell mit dem DSL-Router verbunden bin (durch {IP} ersetzt)
Der Weg ansich stimmt.

Wenn dem Server der DSL-Router als Gateway zugewiesen wird kann der Server keine IP's mehr erreichen ausser die vom DSL-Router.
Lasse ich den DSL-Router "Alle angeschlossenen Geräte" auflisten, erscheinen dort auch alle Clienten, der UMTS-Router und der Server ausser der DSL-Router selbst.

Mein bisschen Logikverstand sagt mir, dass das eigentlich funktionieren sollte. Wieder ratlos!!??!!
Bitte warten ..
Mitglied: Ch3p4cK
02.06.2010 um 16:01 Uhr
Ok. Die Einstellungen sind von Router zu Router unterschiedlich. Ich arbeite nie mit solchen fertigen Geräten. Leider kann ich dir nich weiterhelfen...
Bitte warten ..
Mitglied: aqui
02.06.2010, aktualisiert 18.10.2012
@smirgl
Du hast gleich mehrere IP Design Fehler gemacht und dein Problem lässt sich so nicht lösen ! Außerdem ist es Unsinn das RDP über UMTS nicht rennt. Wie kommst du zu so einer Weisheit ?? Das klappt nur nicht wenn du [http://www.administrator.de/forum/vpn-per-umts-karte-tunnel-steht-aber-netz-dahinter-nicht-anpingbar-%21%3f-97337.html
dieses] Problem hast !!
a.) Falschen UMTS Router gekauft !
b.) Falsches IP Design ! Die o.a. Frickelei mit 2 IP Netzen funktioniert so de facto NICHT !

Zu den Punkten im einzelnen:
Normalerweise konfiguriert man sowas richtig indem man BEIDE Router in ein IP Netz hängt was du schon mal nicht gemacht hast. Der UMTS Router ist dann hier die 192.168.1.1 verteilt die IPs per DHCP z.B. im bereich .100 bis .150.
Der DSL Router bekommt eine statische IP im gleichen IP Netz die außerhalb der DHCP Range von Router 1 liegt z.B. 192.168.1.254. DHCP ist hier ABGESCHALTET !
Das sähe dann so aus:

e5a44d31ee9c25515edc49760a4fab87 - Klicke auf das Bild, um es zu vergrößern

Da alle default Gateways auf den UMTS Router zeigen offenbart sich hier schon dein Grundproblem:
Wenn du von außen mit deiner RDP Session zum Server mit einer öffentlichen IP Adresse von z.B. 80.1.1.1 kommst und du vom DSL Router mit Port TCP 3389 auf den Server weitergeleitet wirst dann will der Server dir ja antworten...logisch !
Dazu sieht er sich die Absender IP Adresse an und was sieht er da ???... 80.1.1.1. Nun merkst er das das ja nicht in seinem eigenen lokalen Netz liegt, denn das hat ja die 192.168.1.0 also befragt er sein Default gateway wo er das Antwort Paket hinschicken soll. Das ist nun aber der UMTS Router und er sendet das an diesen Router denn der weiss ja wie man zu 80.1.1.1 kommt....
Du siehst jetzt das Unglück was passiert...oder ?? Er adressiert das an 80.1.1.1 hat aber ein vollkommen andere Quell IP Adresse (NAT) im Internet.
An deinem RDP Client 80.1.1.1 kommt nun ein Antwortpaket an von einer Session und einer IP Adresse mit der der Client ja gar nicht kommuniziert.
Sowas schmeisst der TCP Stack im PC gleich in den Datenmülleimer...Ende Gelände ! Das ist dein derzeitiger Status.

Lösung:
Es gibt 2 Optionen, eine umsonst andere kostet etwas ist aber die technisch perfektere und wäre auch Standard bei dir gewesen wenn du nur etwas intelligent nachgedacht hättest beim UMTS Routerkauf !
1.) Das Problem ist also das du 2 Gateway IP Adressen hast. Da ein Server in einem Netzwerk NIEMALS eine dynamische IP Adresse haben solltest vergibst du ihm nun eine statische IP Adresse und konfigurierst ihm als Gateway NICHT den UMTS Router sondern den DSL Router mit der 192.168.1.254 (DNS setzt du auch statisch auf diese IP !) !!
Dann arbeitet NUR dein Server über den DSL Link und gut ist. Damit funktioniert dann nun auch wieder dein RDP Zugang zum Server !!

2.) Normalerweise löst man sowas mit einen Dual Port Router. Der große nachteil in deinem netzwerk ist nun nämlich du hast 2 tolle Internet Leitungen aber keine Redundanz.
Hättest du einen Dual Port Router genommen hätte ein Router beide Leitungen UMTS und DSL mit gegenseitigem Backup bedient. Auch deine RDP Verbindung hätte so ein Backup gehabt.
Also besser VOHER nachdenken bevor man was kauft !! Aber ein geeigneter Router wie z.B. ein Draytek 2910 kostet ja nicht die Welt und du kannst noch die Notbremse ziehen !!
http://www.draytek.de/Produkt_Vigor2910.htm
Hier steht wie man sowas technisch umsetzt:
http://www.draytek.de/Beispiele_html/Anwendungen/V2910_3G.htm
bzw.
http://www.draytek.de/Beispiele_html/Ethernet_WAN_LAN/Dual_WAN.htm
DAS....wäre der technisch richtige Weg gewesen !!
Bitte warten ..
Mitglied: smirgl
02.06.2010 um 20:51 Uhr
@Ch3p4cK
Danke trotzdem für deine Hilfsbereitschaft

@aqui
Du hast geschrieben:
"Normalerweise konfiguriert man sowas richtig indem man BEIDE Router in ein IP Netz hängt was du schon mal nicht gemacht hast."

UMTS-Router 192.168.1.1 | DSL-Router 192.168.1.2 ist doch das gleich IP-Netzwerk (???)
UMTS-Router: Range vom DHCP 192.168.1.101-199
DSL-Router: DHCP aus und statische IP
Server statische IP 192.168.1.100

...wie oben schon so angegeben.

Das mit der Antwort vom Server auf den Standard-Gateway leuchtet ein - Klar logisch eigentlich.
Wenn ich nun den Std.Gateway am Server auf den vom DSL-Router ändere hab ich aber das oben auch schon beschriebene
Problem, dass alle am UMTS-Router per DHCP angeschlossenen Clients und auch ein Intra-Server nicht mehr erreichbar sind.
Weiterhin denke ich dass dann alles was vom Server in Richtung I-Net angefragt wird. über den DSL-Router geht und somit
hab ich ja dann auch wieder mein Brems.Net und nicht das schnellere UMTS. ???

Hardware hab ich mit ner Tarifumstellung automatisch bekommen und somit keine Wahl gehabt.

Ich werde leider mit der Harware auskommen müssen die ich da habe. Das Ganze muss für ungefähr ein Jahr funktionieren,
weil erst dann der Ausbau der DSL-Versorung abgeschlossen sein wird.
Bitte warten ..
Mitglied: aqui
03.06.2010 um 18:22 Uhr
Dann stimmt was ganz erheblich mit deiner IP Adressierung im Netz niocht oder mit der DHCP Einrichtung. Es ist vollkommen unabhängig wo das Default gateway vom Server hinzeigt. Lokal im Netz ist der Server immer zu erreichen !!
Vermutlich ist schlicht und einfach nur deine DNS Konfig fehlerhaft wenn du dich namensbasierend verbindest. Das solltest du prüfen indem du mal statt Namen die IP verwendest !!
Eine andere Möglichkeit gibt es für dich so oder so nicht wenn du nicht andere Router HW einsetzen willst. Du hast also keine Wahl !!
Ausnahme ist du machst alles über den UMTS Router....das klappt natürlich auch !!
Bitte warten ..
Mitglied: Ch3p4cK
03.06.2010 um 20:10 Uhr
Zitat von smirgl:
Weiterhin denke ich dass dann alles was vom Server in Richtung I-Net angefragt wird. über den DSL-Router geht und somit
hab ich ja dann auch wieder mein Brems.Net und nicht das schnellere UMTS. ???

Wieso was soll ein Server denn im Internet machen? Wenn dann gehen die Clients im Netz surfen und nicht der Server. Zur Not richte nen Proxy ein über den du surfst.

Andernfalls könntest du dich noch für eine VPN-Lösung entscheiden, die ins Lokale Netz routet. So habe ich das bei mir gelöst. Ich habe auch 2 Gateways. Einen für statische IP (langsamere Verbindung) und einen für alles andere. Nur habe ich für VPN ein anderes Subnet, dass in das lokale Netz routet. Am Server habe ich dann die Route zum VPN-Subnet über den VPN-Router statisch eingetragen. Meine VPN-Verbindung ist desweiteren über ein Zertifikat abgesichert.

Mit der Lösung die du versuchst musst du bedenken, dass du den Standard RDP-Port der ganzen Welt sichtbar machst und somit auch die Kellertür auflässt. Wenn du kein VPN willst dann ändere wenigstens den Port. Nutze 23513 oder so irgendwas. Wenn du den Server nicht verbiegen willst dann verbiege den Router (Port Umleitung)
Bitte warten ..
Mitglied: aqui
04.06.2010 um 12:18 Uhr
....besser nicht 23513 ,denn das liegt noch im Bereich der fest von der IANA zugewiesen Ports !! 23513 gehört außerdem noch dem allseits bekannten Ballerspiel Duke_Nukem "Duke Nukem 3D#Source code Duke Nukem Ports" wie du anhand der IANA Portliste erkennen kannst:
http://en.wikipedia.org/wiki/List_of_TCP_and_UDP_port_numbers
Also eine mehr als eine denkbar schlechte Wahl für einen RDP Portverschleierung !! Vergiss das also ganz schnell !!

Freie Ports liegen im Bereich 49152 bis 65535 !! Diese sind meist auch bei allen bekannten Skript Kiddie Port Scannern ausgenommen.
Also mit 63389 oder 53389 hast du dann einen freien Port den du dir auch leicht merken kannst (RDP hat default 3389) und wo du keinen "Duke Nukem" Gamer auf deinem Router oder letztlich Server hast !!
Bitte warten ..
Mitglied: Ch3p4cK
04.06.2010 um 12:26 Uhr


War ja nur als Beispiel gedacht. Hab einfach wild in die Tasten gehauen. Dass ich damit Duke Nukem erwische war purer Zufall
Bitte warten ..
Mitglied: aqui
04.06.2010 um 12:35 Uhr
...deshalb immer "nachdenken" bevor man "wild" was raushaut !! Nicht alle die das hier lesen haben das gleiche technische Verständnis und verstehen das dann auch als "Zufall" !!
Bitte warten ..
Mitglied: smirgl
04.06.2010 um 14:21 Uhr
Danke schon mal für's Beteiligen.

Hab jetzt noch mal den Standard-Gateway auf'm Server in dem vom DSL-Router (192.168.1.2) geändert.
Nun nehm ich mal das Beispiel UMTS-Router (192.68.1.1)
Den erreiche ich nach der Umstellung nicht mehr, weder über IP noch über Namen.
Dann hab ich noch probiert die IP vom DSL-Router dem Server als weiteren DNS zu geben. War auch nix.
Im Server DNS-Dienst mal die Weiterleitung auf UMTS und DSL-Router eingestellt. Auch nix.

Hab schon andere Ports verwendet um das Teil nicht aller Welt zu präsentieren.
Alles hat auch vorher wunderbar funktioniert als der DSL-Router noch der einzige Router war.
Nur war halt die Leitung zu langsam und deshalb UMTS als Hauptzugang.

Bei meiner Variante UMTS kann ich von aussen nicht ran. Alles vom Provider blockiert.

Hab mir solche Geschichten wie Teamviewer auch schon mal angeschaut. Soll ja auch in so einem UMTS-Fall funktionieren.
nur kann ich dann nicht mehr Outlook over Http machen. Deshalb der versuch mit dem 2. Router als Anbindung dieser Dienste

Also mal zur Info: der Server ist ein Win SBS 2003 mit Exchange
Die Router stehen ja oben schon mal drin.

Welche Einstellungen IP-Gateway-DNS-Ports-usw würdet ihr denn vornehmen und die zu realisieren?
Vielleicht sollte ich einfach mal ganz von vorn anfangen und nicht immer dazu- und wegprobieren.
Bitte warten ..
Mitglied: aqui
04.06.2010 um 15:19 Uhr
Wenn du mal einen Client nimmst im Netz kann der beide Router .1 und .2 anpingen ??
Du solltest ebenso sicherstellen, das die .2 nicht schon irgendwo im DHCP Pool des UMTS Routers verwendet wird, dann kann es zu solchen Effekten wie dem deinen kommen. Besser ist man gibt ihm IP Adressen wie .254 o-ä. Wichtig ist den DHCP Pool zu kontrollieren im UMTS Router.
Ebenso wenn UPnP als Protokoll auf den Routern aktiviert ist. Das gehört abgeschaltet !!
Wenn der Server korrekt im Netzwerk konfiguriert ist mit einer statischen IP Adresse die sicher in KEINEM der DHCP Pools ist z.B. mit der .252 dann ist es völlig irrelevant auf welchen der 2 Router dieser Server zeigt.
Er weiss ja nix von dem UMTS Router folglich kann das also keinerlei Effekt auf die Konfig haben.
Spannend wäre ja mal wenn du den Server auf den DSL Router eingestellt hast und du den UMTS Router abziehst ob der Server dann immer noch nicht erreichbar ist ???
Relevant wäre aber mal nach der Umstellung auf den DSL Router der Ping eines Clients auf DSL Router, UMTS Router und Server.
Wenn das klappt ist alles OK.
Testweise kannst du ja diesen Client mal statisch umstellen auf den DSL Router und checken ob der dann auch im Netz "verschwindet".
Normalerweise ist das Unsinn und zeigt das dort ein anderes Problem mit UPnP, DNS oder doppelten IP Adressen innerhalb des DHCP Bereichs vorliegt oder irgendein anderes Problem mit falschen IP Adressen oder Masken...
Diese Konfig mit 2 Routern ist ein absolut bales Standard Design und wird auch so zuhauf verwendet. Da kommt es de facto niemals zu solchem "Verschwinden" eines Endgerätes nur weil sein Gateway auf eine andere IP Adresse in diesem Netz zeigt !
Kannst ja auch mal die Gateway IP ganz weglassen...
Bitte warten ..
Mitglied: smirgl
07.06.2010 um 08:39 Uhr
So, jetzt hab ich ewig hin und her probiert und nix war zu machen.
Jetzt hab ich einfach mal "DNS" und "Routing und RAS" vom Server geschmissen und wieder neu drauf.
Alles so eingestellt wie vorher und siehe da, auf einmal funktionierts.
Fragt mich jetzt nicht warum...???

Also an alle Beteiligten trotzdem ein dickes Dankeschön für's unterstützen.

Eine schöne Zeit
Euer smirgl
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
UMTS, EDGE & GPRS
LTE oder UMTS Router mit LAN Anschluss (6)

Frage von Stefan3110 zum Thema UMTS, EDGE & GPRS ...

Virtualisierung
gelöst VirtualBox offline (ohne Netzwerk bzw. Router) erreichen (5)

Frage von QnavWhat zum Thema Virtualisierung ...

Router & Routing
gelöst Proxmox Netzwerk: LAN Netz ohne Router (2)

Frage von sebastian2608 zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...