Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

RIS WDS WIM CLG PE WAIK usw - da soll einer durchsehen

Frage Microsoft Windows Server

Mitglied: hannsgmaulwurf

hannsgmaulwurf (Level 1) - Jetzt verbinden

17.09.2009 um 17:52 Uhr, 10741 Aufrufe, 9 Kommentare

Gesucht wird der berühmte rote Faden - vom "rohen" Installationsmedium zur angepassten & automatisierten Netzwerkinstallation.

Hallo zusammen, ich hoffe ich werde nicht als schwer von Begriff abgestempelt
Ich habe auf einem Domaincontroller und gleichzeitigem DHCP-Server (WinServer 2003 Std SP2) die Windows Bereitstellungsdienste im Gemischten Modus laufen. Soweit so gut - Remoteinstallationen funktionieren ohne Probleme. Aber jetzt gehts los:
Ich würde gern ein paar Kleinigikeiten einbinden, z.Bsp. die Seriennr., lokales Adminpasswort usw. Weiterhin fehlen oft Netzwerkkarten- oder Raid-/Festplattencontrollertreiber und verhindern so die Remoteinstallation des jeweiligen Abbildes... Kann doch nicht so schwer sein, dachte ich mir - wie konnte ich nur?!?
Hab schon wie ein verrückter diverse Hilfen, Tutorials, Foren usw. durchstöbert und je mehr ich lese um so koplizierter wird das Ganze... Um Treiber usw. einzubinden brauche ich WAIK.WAIK beinhaltet wiederum Windows PE 2.0 und damit muss ich ein Abbild erstellen und anpassen. Das ganze hat dann aber noch nix mit den WDS's zu tun..... Ich seh einfach nicht durch *heul* Kann mir vielleicht jemand erklären in welcher Reihenfolge man vorgeht bzw. wie die einzelnen Tools zusammen spielen bzw. aufeinander aufbauen? Mit N- bzw. VLITE war's doch sooo einfach.....
Mitglied: Xaero1982
17.09.2009 um 23:32 Uhr
Vor einem ähnlichen Problem stand ich auch vor Kurzem.

Allerdings handelt es sich hierbei um einen Windows Server 2008.
Von daher kann ich dir nur mal die Abfolge der Konfiguration dafür beschreiben, die sich so weit ich das gesehen habe nicht grds. vom 2003er unterscheidet.

Erst ein mal wollen wir ein paar Begrifflichkeiten trennen.

Beim Server 2003 nennt sich der Spaß RIS (Remote installation Service)
Beim Server 2008 nennt sich das ganze WDS (Windows Deployment Service)
Im Ergebnis machen beide das Gleiche sind aber für unterschiedliche Betriebssysteme bestimmt.

Dinge wie Seriennummer etc. pflegst du mit einer sysprep.inf ein.
Dazu lädst du dir sysprep herunter. Wahlweise findest du das auch auf der Windows XP CD im Ordner Tools, in der deploy.cab.

Dann entpackst du die und startest die setupmgr.exe. Das ist eigentlich selbsterklärend. Die erstellte sysprep.inf speicherst du dann.

In deinem RIS Server musst du dann ein Abbild hinzufügen. Gleiches galt und gilt natürlich für den WDS auch.
Standardinstallverzeichnis beim WDS ist x:\Remoteinstall\
Dort gibt es dann einen Pfad Images, in diesem einen Pfad Abbildgruppe

Der einfachheithalber mal der komplette Pfad in dem die sysprep.inf hinein muss.
Beispieldaten:
Dein Abbild heißt WindowsXP.???
So lautet der Pfad
x:\remoteinstall\images\Abbildgruppe 1\WindowsXP\1$\sysprep\sysprep.inf

Zum Einbinden von Treibern brauchst du kein WAIK, macht die Sache nur einfacher:

Mit den Tools Imagex und peimg
Mit Imagex.exe /mountrw x:\imagename 1(abbildnummer) x:\mount\
Kann man ein Image mounten und dann beliebig darin rumkopieren.
Mit imagex /unmount /commit x:\mount\ kannst du die Änderungen dann speichern.

Zuvor kann man mit peimg (mal googlen) die Treiber in das Image integrieren.

So im Groben erst mal ausm Kopf Hab gerade nichts an meinen Dokumenten parat ... wenn noch Fragen sind nur zu

LG
Bitte warten ..
Mitglied: hannsgmaulwurf
18.09.2009 um 00:09 Uhr
Guten Abend und erstmal vielen Dank für die ausführliche Hilfestellung!!
wenn noch Fragen sind nur zu
Das hättest du nicht schreiben dürfen ;)

Dinge wie Seriennummer etc. pflegst du mit einer sysprep.inf ein.
Mit sysprep habe ich mich noch nicht auseinandergesetzt, ich verzweifel eigentlich mehr an der Automatisierung von Vista und 7 und die hat doch mit sysprep nix zu tun, oder irre ich?

Zum Einbinden von Treibern brauchst du kein WAIK, macht die Sache nur
einfacher:
Aber um die Seriennr. einzutragen und sonstige hundert Einstellunen vorzunehmen... Und irgendwie muss ja auch'ne Unattend.xml erzeugt werden...

Mit den Tools Imagex und peimg
Verstehe ich das richtig? Mit dem Windows Bereitsstellungsdienst ein neues Abbild in einer Abbildgruppe erstellen --> in \Remoteinstall\ befindet sich dann irgendwo dieses Abbild in Form einer .wmi Datei --> diese Datei mit Imagex mounten --> beliebig darin rumkopieren (was denn zb? Kann ich hier zusätzliche Treiber in entsprechende Ordner legen?)
--> wenn man mit rumkopieren ;) fertig ist wieder "unmounten" womit die änderungen gespeichert werden --> das eben mit Windows Bereitstellungsdienst neu erstellte Abbild ist nun angepasst??? aber wo sind seriennummer und voreinstellungen wie bildschirmauflösung, automatische windows updates usw.?

Zuvor kann man mit peimg (mal googlen) die Treiber in das Image
integrieren.
Mit peimg muss man glaub ich jeden treiber einzeln einbinden...

>wenn noch Fragen sind nur zu
Wie gesagt, jetzt hast du den Salat

Danke und Netten Abend noch!!
Bitte warten ..
Mitglied: Xaero1982
18.09.2009 um 00:44 Uhr
> Dinge wie Seriennummer etc. pflegst du mit einer sysprep.inf
ein.
Mit sysprep habe ich mich noch nicht auseinandergesetzt, ich
verzweifel eigentlich mehr an der Automatisierung von Vista und 7 und
die hat doch mit sysprep nix zu tun, oder irre ich?
Du irrst. Die Sysprep.inf dient der Automatisierung bei WindowsXP. Die Unattend.xml dient wohl der Automatisierung Vista/Windows7?

> Mit den Tools Imagex und peimg
Verstehe ich das richtig? Mit dem Windows Bereitsstellungsdienst ein
neues Abbild in einer Abbildgruppe erstellen --> in \Remoteinstall\
befindet sich dann irgendwo dieses Abbild in Form einer .wmi Datei

Das wim Image erstellst du z.B. imagex bzw. mit dem WAIK

--> diese Datei mit Imagex mounten --> beliebig darin
rumkopieren
(was denn zb? Kann ich hier zusätzliche Treiber in
entsprechende Ordner legen?)
--> wenn man mit rumkopieren ;) fertig ist wieder
"unmounten" womit die änderungen gespeichert werden
--> das eben mit Windows Bereitstellungsdienst neu erstellte Abbild
ist nun angepasst??? aber wo sind seriennummer und voreinstellungen
wie bildschirmauflösung, automatische windows updates usw.?

> Zuvor kann man mit peimg (mal googlen) die Treiber in das Image
> integrieren.
Mit peimg muss man glaub ich jeden treiber einzeln einbinden...

>wenn noch Fragen sind nur zu
Wie gesagt, jetzt hast du den Salat

Danke und Netten Abend noch!!

So nu wirds mir zu spät ich werde mir das morgen noch mal ansehen und dir dann mehr schreiben, wenn ich meine Dokus habe.

LG
Bitte warten ..
Mitglied: hannsgmaulwurf
18.09.2009 um 00:51 Uhr
Du irrst. Die Sysprep.inf dient der Automatisierung bei WindowsXP.
Die Unattend.xml dient wohl der Automatisierung Vista/Windows7?
Sag ich doch ;)

So nu wirds mir zu spät
Hast Recht
Bitte warten ..
Mitglied: Xaero1982
18.09.2009 um 09:14 Uhr
So, morjen

Zunächst mal würde ich sagen du brauchst kein RIS Server, sondern kannst auch für den Server 2003 die WDS herunterladen.

Dann installierst du das WAIK (Windows Automated installation Kit)
Bei dem WAIK ist eine Datei bei in der 2 Windows PE Images enthalten sind. Eine ist für x64 und die andere für x86 Systeme.
Diese bindest du dann im WDS als Startabbild ein.

Anschließend solltest du dann schon mit F12 davon booten können.

Das bringt dir im Moment nichts, weil du noch kein Images hast.
Zum erstellen des Images klickst du rechts auf eines dieser Images und sagst: Aufzeichnungsabbild erstellen. Speicherst dieses und fügst das auch als Startabbild hinzu.
Wenn du das System fertig installiert hast musst du, wenn ich mich nicht irre, auch unter Vista, das System mit sysprep.exe bearbeiten. Sprich starten: Miniinstallation auswählen und erneut versiegeln klicken.
Danach startest du mit F12 das Aufzeichnungsabbild und dann wird ein Assistent gestartet. Dem folgst du und erstellst das Image. Nicht wundern, der Fortschrittsbalken bewegt sich nicht. Das dauert je nach Größe des Images und Geschwindigkeit des PCs einige Zeit.
Das Image am besten lokal speichern, weil das mit dem Upload auf den WDS Server meist im Fehler endet.

Anschließend muss das Image dann auf dem WDS Server kopiert werden. Hierzu vielleicht irgendeine Bootcd nehmen etc.

Dann das Image also die *.wim als Installationsabbild hinzufügen. Dazu muss eine Abbildgruppe angelegt werden.
Wenn du dann ein Rechtsklick auf das Image machst und auf Eigenschaften gehst kannst du die unattend.xml hinzufügen.

Die erstellst du :
http://blogs.itacs.de/HS/Lists/Beitraege/Post.aspx?ID=46
Mit dem WAIK

Anschließend kannst du dann, wenn du Via F12 eines der beiden ersten Images gestartet hast installieren.

Noch Fragen? Dann los

LG
Bitte warten ..
Mitglied: hannsgmaulwurf
18.09.2009 um 16:03 Uhr
Zunächst mal würde ich sagen du brauchst kein RIS Server,
sondern kannst auch für den Server 2003 die WDS herunterladen.
Jepp, dazu läuft der WDS dann ja im Gemischten Modus... Allerdings muss SP2 auf dem 2003er Server isntalliert sein.

Wenn du das System fertig installiert hast musst du, wenn ich mich
nicht irre, auch unter Vista, das System mit sysprep.exe bearbeiten.
Ich glaube du irrst ;)

Hab jetzt nicht mehr weiter getestet, werd mich mal am we oder Anfang nächster Woche wieder da rein knie'n.
Bis dahin erstmal vielen Dank, schönes Wochenende und bis die Tage!!
Bitte warten ..
Mitglied: Xaero1982
18.09.2009 um 17:33 Uhr
Naja anders kann ich mir das nicht vorstellen, weil der Assistent nur Festplatten erkennt die mit Sysprep bearbeitet worden sind und von daher glaube ich nicht, dass ich mich irre....

Arbeite hier aber nur mit XP....

LG
Bitte warten ..
Mitglied: hannsgmaulwurf
22.09.2009 um 12:12 Uhr
Hallo!
Werd mich nochmal dran machen und gaaanz von vorne anfangen - zumal ich ja noch nich soooo weit gekommen bin Werde berichten...
Bitte warten ..
Mitglied: hannsgmaulwurf
18.11.2009 um 17:36 Uhr
Nabend zusammen!
Ich muss mal wieder nerven...
Und zwar habe ich mich nach einer Weile mal wieder mit dem Thema befasst und folgende Schritte erledigt:
- WDS auf Windows Server 2003 installiert (gemischter Modus) & konfiguriert
- Startabbild von der Windows7-DVD hinzugefügt
- Installationsabbildgruppe erstellt und Installationsabbild hinzugefügt (Windows 7 Ulitmate 32 Bit DE)

Sowei so gut. Nun kann ich vom LAN booten, das Startabbild wählen und nach der Eingabe von Sprache und benutzer@domäne und Passwort das Installationsabbild auswählen, also Windows 7 Ultimate....
Jetzt beginnt der Installationsprozess wie man ihn von der CD/DVD-Installation kennt.
Um diesen Prozess zu automatisieren muss man dem Abbild in den Windows Bereitstellungsdiensten unter Abbildinstallation im Modus für unbeaufsichtigte Installation zulassen eine entsprechende xml-Datei zuweisen. Diese habe ich mit dem Windows System Image Manager erstellt (s.u.). Leider greift von meinen gewählten Einstellungen nicht eine einzige, so dass ich trotz (vermeindlich richtiger) xml-Datei die Daten wie Land/Region, Zeit/Währung, Tastaturlayout oder Product Key von Hand eintragen muss...

Könnt ihr vielleicht mal einen Blick auf die xml-Datei werfen??
Besten dank schonmal und schöne Grüße

Hier meine xml-Datei (die ich benennen und speichern kann, wie und wo ich möchte, oder?) - soll Sprache, Tastaturlayout usw. einrichten, Productkey eingeben und lokales Adminpasswort ändern/setzen.....

<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
<settings pass="windowsPE">
<component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<SetupUILanguage>
<UILanguage>de-DE</UILanguage>
</SetupUILanguage>
<InputLocale>de-DE</InputLocale>
<SystemLocale>de-DE</SystemLocale>
<UILanguage>de-DE</UILanguage>
<UILanguageFallback>de-DE</UILanguageFallback>
<UserLocale>de-DE</UserLocale>
</component>
<component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<DiskConfiguration>
<WillShowUI>Always</WillShowUI>
</DiskConfiguration>
<ImageInstall>
<OSImage>
<WillShowUI>Always</WillShowUI>
</OSImage>
</ImageInstall>
<UserData>
<ProductKey>
<WillShowUI>Never</WillShowUI>
<Key>12345-12345-12345-12345-12345</Key>
</ProductKey>
</UserData>
</component>
</settings>
<settings pass="auditSystem">
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<UserAccounts>
<AdministratorPassword>
<Value>blablabla</Value>
<PlainText>false</PlainText>
</AdministratorPassword>
</UserAccounts>
</component>
</settings>
<cpi:offlineImage cpi:source="wim:d:/win7u32de/sources/install.wim#Windows 7 ULTIMATE" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
</unattend>
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(1)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
WIM Images anpassen für WDS Server (5)

Frage von IT-Biene zum Thema Windows Server ...

Windows Server
gelöst WDS Aufzeichnungsabbild - Wim-Image (3)

Frage von rheingauner zum Thema Windows Server ...

Windows Server
gelöst Dell Server PE R300 - Windows Server 2016 (2)

Frage von fueak2000 zum Thema Windows Server ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...