Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

ROBOCOPY GUI 1 zu 1 Kopie mit Rechten

Frage Microsoft Windows Tools

Mitglied: Ruffy1984

Ruffy1984 (Level 1) - Jetzt verbinden

21.06.2011 um 11:07 Uhr, 6896 Aufrufe, 16 Kommentare

Hallo Community,

ich habe mal wieder eine frage.

ich möchte mit ROBOCOpy GUI einen Ordner mit --> 10 Unterordner 1 zu 1 kopieren. (Windows USER Profile)
Ich möchte das alle Zugriffberechtigungen und alle Attribute mit übernommen werden.

Ich habe dieses Tool noch nie benutzt, der Hintergrund es Tools, es geht hier um WIndows User Profile und das einfach kopieren funktioniert nicht.

Wenn ich jetzt Source und Targed unter ROBO COPY einstelle, kopiert es mir nur eine Datei die in meinem Hauptordner liegt.
Er versucht gar nicht die unterordner zu kopieren.

Ich habe folgende Haken gesetzt:

/COPY : DTO:ASU
/A : RHT :A
/COPYALL
/S
/A
/ZB


kann mir jemand sagen welche Haken ich setzten muss das er eine 1 zu1 kopie wie oben beschrieben auf meinen Zielserver kopiert.

Das wäre Bombe.

Vielen Danke
Mitglied: Blu3Scr33n
21.06.2011 um 11:19 Uhr
Hallo

Muss es unbedingt mit Robocopy sein?
Ich könnte dir da auch Total Comander empfehlen.
Dort funktioniert das Kopieren mit Rechten sehr einfach.
Einfach den ordner per Drag & Drop in den richtigen Pfad ziehen und dann den Haken bei "Kopiere NTFS-Permissions" setzen.
Hat bei mir auf dem Server ohne weiteres geklappt.

Beste Grüße,

Blu3Scr33n
Bitte warten ..
Mitglied: Nagus
21.06.2011 um 11:24 Uhr
Moin,
naja - warum nicht einfach von der Konsole starten, da sieht man auch was passiert.

Robocopy /??? liefert alle Befehle und man kann auch nur einen Copy Test starten ...

Gruß
Nagus
Bitte warten ..
Mitglied: Friemler
21.06.2011 um 11:34 Uhr
Hallo Ruffy1984,

mit den von Dir verwendeten Parametern hast Du Dich wirklich grob vertan.

Ich arbeite nicht mit der GUI. Eine ROBOCOPY-Befehlszeile für eine fast exakte Kopie der Quelle sollte ungefähr so aussehen:
robocopy "Quelle\Quellverzeichnis" "Ziel\Quellverzeichnis" *.* /ZB /E /COPY:DATSOU /DCOPY:T /IT /XJ
ROBOCOPY legt das Verzeichnis, dessen Inhalt kopiert werden soll, im Ziel nicht an sondern kopiert eben nur den Inhalt, deshalb die etwas seltsame Pfadangabe für das Ziel, damit wird das kopierte Verzeichnis in der Quelle angelegt.

Der Parameter /XJ wird ab Vista wichtig, da dann Benutzerprofile Hardlinks enthalten, die nicht sauber (zyklisch) implementiert sind und beim Kopieren zu einer Endlosschleife führen würden. /XJ schließt Hardlinks vom Kopieren aus.


@Blu3Scr33n:
Man muss nicht immer käufliche Tools verwenden, gerade ROBOCOPY ist eine wirkliche Perle unter den MS-Programmen.

Gruß
Friemler
Bitte warten ..
Mitglied: Ruffy1984
21.06.2011 um 11:55 Uhr
Hallo Friemler,

mir ist jetzt erst aufgefallen das er zwar unter der GUI sagt, daten wurden übertragen( nach ca 1 sekunde) aber er im Hintergrund weiter die Daten überträgt, ich weiss natürlich jetzt nicht wieviel ich angestoßen habe.

Das Problem ist halt das ich nicht auf jeden Verzeichnis Berechtigungen habe weil es User Profile sind, daher ja auch die Verwendung von ROBOCOPY!


Nochmal eine Frage zu dem " ROBOCOPY legt das Verzeichnis, dessen Inhalt kopiert werden soll, im Ziel nicht an sondern kopiert eben nur den Inhalt"

Bedeutet das das ich jeden Ordner per Hand anlegen muss um dann den Inhalt von diesem Ordner zu kopieren ?

ich habe einen Ordner Test wo 10 Unter Ordner sind....aber in den Unterordner sind ja wieder Unterordner. Das wäre ja nicht Sinn der SAche.

Ich werde jetzt nochmal ein Job anstoßen.

Vielen Danke aber schonmal
Bitte warten ..
Mitglied: Blu3Scr33n
21.06.2011 um 12:05 Uhr
Zitat von Friemler:

@Blu3Scr33n:
Man muss nicht immer käufliche Tools verwenden,
Ist richtig. Nur reicht dabei auch die Sharewareversion für das Vorhaben.

gerade ROBOCOPY ist eine wirkliche Perle unter den MS-Programmen.
Ist richtig. Ist bei uns dafür zuständig unsere Backups auf unser NAS zu ziehen.

Gruß
Friemler
Dito,
Blu3Scr33n
Bitte warten ..
Mitglied: Friemler
21.06.2011 um 12:23 Uhr
Hallo Ruffy,

nein, du musst jetzt nicht die komplette Verzeichnisstruktur vor dem kopieren von Hand anlegen. Das wäre ja eine Kopfschuss-Technik (Kopfschuss für den Programmierer einer solchen Methode ). Eigentlich musst Du garnichts anlegen, sondern ROBOCOPY eben nur sagen, es soll die Daten aus Quellverzeichnis X im Ziel auch in ein Verzeichnis X kopieren, X braucht vorher aber nicht zu existieren.

Beispiel: robocopy "C:\Users\Hans" "Z:\Sicherungen\Hans" *.* /ZB /E ....

Mit robocopy "C:\Users\Hans" "Z:\Sicherungen" *.* /ZB /E ....
würden alle Daten/Verzeichnisse von Hans direkt im Verzeichnis Z:\Sicherungen landen, es würde also kein Verzeichnis Hans angelegt.

Gruß
Friemler
Bitte warten ..
Mitglied: ThomasH.
21.06.2011 um 13:02 Uhr
Das Problem ist halt das ich nicht auf jeden Verzeichnis Berechtigungen habe weil es User Profile sind, daher ja auch die
Verwendung von ROBOCOPY!

Wenn du robocopy mit DEINEN Berechtigungen startest wird es nicht funktionieren. Wenn DU die Rechte nicht hast hat sie robocopy auch nicht. Du musst wenigstens lesende Rechte haben. Oder eben robocopy mit administrativen (oder einem berechtigtem Konto) Rechten starten.

Mit freundlichen Grüßen Th.
Bitte warten ..
Mitglied: Friemler
21.06.2011 um 13:06 Uhr
Zitat von ThomasH.:
robocopy mit administrativen (oder einem berechtigtem Konto) Rechten starten.

Genau. Ein berechtigtes Konto wäre auch ein Konto, das Mitglied der Gruppe Sicherungsoperatoren ist.

Gruß
Friemler
Bitte warten ..
Mitglied: Ruffy1984
21.06.2011 um 13:41 Uhr
Oh man , ich habe jetzt erst gepeilt das ihr "vor" BLuescreen geschrieben habt.

Das Home Verzeischnis der User hat funktioniert, er hat zwar 1 GB mehr ( weiss nicht woher die kommen) aber die Ordnerstruktur ist die selbe, daher ist es für mich uninteressant.

Wenn ich nun in die Eigenschaten der Profile auf dem Quellserver gehe , habe ich als " Administrator" nicht mal die Berechtigung die Sicherheit anzuschauen.

Ich habe versucht den kompletten Ordner Profile zu kopieren, dann kopiert er einen Ordner und das wars ( habe 20 Minuten gewartet | essen) , danach habe ich versucht unter Profile nur "einen" User zu kopieren in den gleich Pfad, aufeinmal hat er angefangen den JOb davor zu bearbeiten, irgendwie merkwürdig.


Das habe ich dadran gemerkt das er ORdner kopiert hat die ich beim zweiten Job nicht ausgewählt habe.
Bitte warten ..
Mitglied: ThomasH.
21.06.2011 um 13:57 Uhr
Zitat von Ruffy1984:
Oh man , ich habe jetzt erst gepeilt das ihr "vor" BLuescreen geschrieben habt.

Warum das dazwischen gerutscht ist weis ich auch nicht. Ich dachte immer es wird nach Zeit sortiert. ^^

Gruss
Bitte warten ..
Mitglied: Friemler
21.06.2011 um 14:15 Uhr
Zitat von ThomasH.:
Ich dachte immer es wird nach Zeit sortiert.

Nein, es kommt zusätzlich darauf an, auf welches Posting man antwortet. Schau Dir mal ganz oben unter "Diskussionsverlauf" die Threadstruktur an, dann wird es klarer.

Gruß
Friemler
Bitte warten ..
Mitglied: Friemler
21.06.2011 um 14:21 Uhr
Hallo Ruffy,

na ja, 1GB ist im Verhältnis zu den heutzutage riesigen Plattenkapazitäten nicht viel, aber absolut gesehen schon und wenn man bedenkt, dass das ja auch Zeit kostet (und evtl. Netzwerkbandbreite; mir ist noch nicht klar, ob Du lokal oder über ein Netzwerk kopierst) würde ich mich schonmal darum kümmern.

Wie war denn die ausgeführte Befehlszeile? Von welchem OS stammen die Benutzerprofile? Ich frage wegen den Hardlinks in den Benutzerprofilen ab Vista.

Gruß
Friemler
Bitte warten ..
Mitglied: Blu3Scr33n
21.06.2011 um 14:22 Uhr
Und dabei hatte ich extra noch auf Refresh gedrückt, bevor ich den Post "losgelassen" habe
Bitte warten ..
Mitglied: ThomasH.
21.06.2011 um 14:25 Uhr
Danke Friemel ... hast recht, wenn man oben schaut wirds klar mit der Struktur.

Na dann ...

... weitermachen
Bitte warten ..
Mitglied: Ruffy1984
21.06.2011 um 14:29 Uhr
Hallo Friemler,


ich kopiere von WIndows 2003 Standart zu Windows 2008 R2. nDas ganze über das Netz
Bitte warten ..
Mitglied: Ruffy1984
27.06.2011 um 09:44 Uhr
Hallo ,


ich würde die Finger von der GUI lassen. Nimmt die Kommandozeile, dort seht ihr dann auch in der Log wenn Daten verweigert wurden.
Bei mir war es der Fal das ich Profile kopieren wollte mit NTFS Berechtigungen wo nicht über der Administrator leseberechtigungen hatte.
Ich habe mit der GUI angenfangen und er hat auch alles Daten mit Leseberechtigungen kopiert , und wenn man die Größe verglichen hat , hat das auch gepasst, aber es haben die Daten gefehlt wo ich keine Berechtigungen hatte.

Mein Fehler war auch das ich bei der Gui nicht in die Log geschaut habe.


vielen Danke für eure Hilfe.

Problem ist gelöst.
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Windows Installation
gelöst 1:1 Kopie einer bootfähigen CF-Card mit Win embedded (7)

Frage von ben1310 zum Thema Windows Installation ...

Batch & Shell
gelöst Cmd Befehle in Powershell GUI aufrufen (5)

Frage von Markus2016 zum Thema Batch & Shell ...

Server
gelöst Robocopy RECYCLE.BIN (21)

Frage von swissbull zum Thema Server ...

Windows Tools
Robocopy . Datei im Zielverzeichnis nur überschreiben, wenn neuer (7)

Frage von gnrmarcel zum Thema Windows Tools ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (24)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...