Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Robocopy kopiert nur Ordner, keine Dateien

Frage Microsoft Windows Tools

Mitglied: Coreknabe

Coreknabe (Level 2) - Jetzt verbinden

13.11.2008, aktualisiert 24.11.2008, 14920 Aufrufe, 7 Kommentare

Hallo mal wieder,

ich versuche, von einer Serverfreigabe (Win Server 2003) auf eine Netzwerkfreigabe mit Robocopy Dateien zu kopieren. Es sind sehr viele Ordner und Unterordner vorhanden, in denen sich eben jeweils Dateien befinden.

Ich rufe auf dem Server nun Robocopy mit folgender Syntax auf:
01.
robocopy.exe D:\FREIGABE "\\IP-Netzwerkfreigabe\hierrein\darein" *.* /E /ZB /COPY:DAT /A+:A /M /R:0 /W:0 /TEE /ETA /LOG:"D:datsi.log"
Ergebnis:
Auf dem Ziellaufwerk landen nur die leeren Ordner, nicht aber die Dateien, die sich in den Ordnern befinden sollten. Und nun?
Mitglied: ElForum
13.11.2008 um 16:17 Uhr
Also wenn ich das auf lokalen Verzeichnissen mache funktioniert es. Handelt es sich beim Ziel um eine Netzwerkfreigabe gehts nicht (bzw nur die Ordner)...

Mit der Option /mir ist dir nicht geholfen? Damit funktioniert bei mir beides...
Bitte warten ..
Mitglied: paulepank
13.11.2008 um 16:22 Uhr
Hallo Coreknabe,

da du mit /M nur Dateien mit Archivattribut kopierst und das Archivattribut zurücksetzt, wird vielleicht aus einem früherem Versuch keines mehr dasein. Deshalb leere Ordner.
Kannst du leicht überprüfen mit ATTRIB.

cu paulepank
Bitte warten ..
Mitglied: Coreknabe
14.11.2008 um 09:24 Uhr
Hi Ihr beiden, danke für Eure Antworten.

Bei der Option /mir ist mir leicht unwohl... Habs aber mal ausprobiert, damit sichert er einige wenige Dateien mehr, sind aber insgesamt nur 5MB... Vielleicht irgendein Rechteproblem? In den Logs sehe ich allerdings nichts. Und Du hast recht, ist ne Netzwerkfreigabe (Buffalo).

Paule, kann so nicht sein, weil er die Dateien ja dann mindestens 1x hätte kopieren müssen, hat er aber nicht.
Bitte warten ..
Mitglied: Coreknabe
18.11.2008 um 11:18 Uhr
Hat vielleicht noch jemand eine Idee?
Bitte warten ..
Mitglied: paulepank
18.11.2008 um 17:08 Uhr
Hallo,

Paule, kann so nicht sein, weil er die Dateien ja dann mindestens 1x hätte kopieren müssen, hat er aber nicht.

Naja, hast du jetzt definitiv überprüft, ob bei den zu kopierenden Dateien auch das Archiv-Attribut gesetzt ist ?

cu paulepank
Bitte warten ..
Mitglied: Biber
18.11.2008 um 17:37 Uhr
.... und ob Du auf alle zu kopierenden Dateien denn auch das Schreibrecht hast auf diesem Share... Du willst ja das Archiv-Bit löschen....

Vielleicht war aber auch in einereinem der 58000 Security-hotfixes auch irgendeine Änderung, dass Robocopy-user inzwischen ein Backup-Authority-Recht haben müssen oder in der Gruppe Backup-Administrators oder irgendwas anderes Durchgeknalltes.

Kann doch nur ein Rechte-Problem sein...

Grüße
Biber
Bitte warten ..
Mitglied: Coreknabe
24.11.2008 um 21:33 Uhr
Hi nochmal Biber...

Schon komisch, hab den Attribut-Parameter weggelassen, trotzdem kopiert er nur die leeren Ordner ?!?

Mit NT-Backup klappts, aber auch hier fehlen ca. 10 Dateien, wenn ich das Ganze mal testweise kopiere und dann über "Eigenschaften" das Resultat vergleiche...

Erschliesst sich mir alles nicht ganz, aber ich denke, ich werde mal mit NT-Backup weiterfummeln. Finds aber sehr schade, weil Robocopy an sich ein cooles Tool zu sein scheint.
Bitte warten ..
Ähnliche Inhalte
Windows Server
Robocopy Ordner-Icons behalten (5)

Frage von sebastian2608 zum Thema Windows Server ...

Windows Tools
Robocopy . Datei im Zielverzeichnis nur überschreiben, wenn neuer (7)

Frage von gnrmarcel zum Thema Windows Tools ...

Windows Server
Schattenkopien mit Robocopy (11)

Frage von AveiroCR7 zum Thema Windows Server ...

Batch & Shell
gelöst Xcopy-script kopiert nur 1 datei? (2)

Frage von f0rml0s zum Thema Batch & Shell ...

Neue Wissensbeiträge
Windows Tools

Zeit für Energiesparmodus, Bildschirmabschaltung etc. schnell anpassen

Anleitung von hannsgmaulwurf zum Thema Windows Tools ...

Linux Netzwerk

Ping und das einstellbare Bytepattern

(1)

Erfahrungsbericht von LordGurke zum Thema Linux Netzwerk ...

Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

(4)

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Heiß diskutierte Inhalte
Switche und Hubs
gelöst Cisco 2960x Stacking über mehrere Etagen (12)

Frage von b3scher zum Thema Switche und Hubs ...

Firewall
Richtige Grundeinstellungen der Pfsense für mein Netzwerk (12)

Frage von Spitzbube zum Thema Firewall ...