Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Frage Microsoft Windows Tools

Robocopy kopiert nur Ordner, keine Dateien

Mitglied: Coreknabe

Coreknabe (Level 2) - Jetzt verbinden

13.11.2008, aktualisiert 24.11.2008, 15217 Aufrufe, 7 Kommentare

Hallo mal wieder,

ich versuche, von einer Serverfreigabe (Win Server 2003) auf eine Netzwerkfreigabe mit Robocopy Dateien zu kopieren. Es sind sehr viele Ordner und Unterordner vorhanden, in denen sich eben jeweils Dateien befinden.

Ich rufe auf dem Server nun Robocopy mit folgender Syntax auf:
01.
robocopy.exe D:\FREIGABE "\\IP-Netzwerkfreigabe\hierrein\darein" *.* /E /ZB /COPY:DAT /A+:A /M /R:0 /W:0 /TEE /ETA /LOG:"D:datsi.log"
Ergebnis:
Auf dem Ziellaufwerk landen nur die leeren Ordner, nicht aber die Dateien, die sich in den Ordnern befinden sollten. Und nun?
Mitglied: ElForum
13.11.2008 um 16:17 Uhr
Also wenn ich das auf lokalen Verzeichnissen mache funktioniert es. Handelt es sich beim Ziel um eine Netzwerkfreigabe gehts nicht (bzw nur die Ordner)...

Mit der Option /mir ist dir nicht geholfen? Damit funktioniert bei mir beides...
Bitte warten ..
Mitglied: paulepank
13.11.2008 um 16:22 Uhr
Hallo Coreknabe,

da du mit /M nur Dateien mit Archivattribut kopierst und das Archivattribut zurücksetzt, wird vielleicht aus einem früherem Versuch keines mehr dasein. Deshalb leere Ordner.
Kannst du leicht überprüfen mit ATTRIB.

cu paulepank
Bitte warten ..
Mitglied: Coreknabe
14.11.2008 um 09:24 Uhr
Hi Ihr beiden, danke für Eure Antworten.

Bei der Option /mir ist mir leicht unwohl... Habs aber mal ausprobiert, damit sichert er einige wenige Dateien mehr, sind aber insgesamt nur 5MB... Vielleicht irgendein Rechteproblem? In den Logs sehe ich allerdings nichts. Und Du hast recht, ist ne Netzwerkfreigabe (Buffalo).

Paule, kann so nicht sein, weil er die Dateien ja dann mindestens 1x hätte kopieren müssen, hat er aber nicht.
Bitte warten ..
Mitglied: Coreknabe
18.11.2008 um 11:18 Uhr
Hat vielleicht noch jemand eine Idee?
Bitte warten ..
Mitglied: paulepank
18.11.2008 um 17:08 Uhr
Hallo,

Paule, kann so nicht sein, weil er die Dateien ja dann mindestens 1x hätte kopieren müssen, hat er aber nicht.

Naja, hast du jetzt definitiv überprüft, ob bei den zu kopierenden Dateien auch das Archiv-Attribut gesetzt ist ?

cu paulepank
Bitte warten ..
Mitglied: Biber
18.11.2008 um 17:37 Uhr
.... und ob Du auf alle zu kopierenden Dateien denn auch das Schreibrecht hast auf diesem Share... Du willst ja das Archiv-Bit löschen....

Vielleicht war aber auch in einereinem der 58000 Security-hotfixes auch irgendeine Änderung, dass Robocopy-user inzwischen ein Backup-Authority-Recht haben müssen oder in der Gruppe Backup-Administrators oder irgendwas anderes Durchgeknalltes.

Kann doch nur ein Rechte-Problem sein...

Grüße
Biber
Bitte warten ..
Mitglied: Coreknabe
24.11.2008 um 21:33 Uhr
Hi nochmal Biber...

Schon komisch, hab den Attribut-Parameter weggelassen, trotzdem kopiert er nur die leeren Ordner ?!?

Mit NT-Backup klappts, aber auch hier fehlen ca. 10 Dateien, wenn ich das Ganze mal testweise kopiere und dann über "Eigenschaften" das Resultat vergleiche...

Erschliesst sich mir alles nicht ganz, aber ich denke, ich werde mal mit NT-Backup weiterfummeln. Finds aber sehr schade, weil Robocopy an sich ein cooles Tool zu sein scheint.
Bitte warten ..
Ähnliche Inhalte
Windows Tools
ROBOCOPY kopiert Ordner mit Bildern
Frage von xchr1sWindows Tools10 Kommentare

Hallo Administrator.de-User, ich habe momentan ein ROBOCOPY-Script, welches alle 10 Sekunden ausgeführt wird. Momentan kopiert ROBOCOPY stumpf Ordner + ...

Windows Tools
Robocopy kopiert täglich unveränderte Dateien
Frage von Tobias15Windows Tools8 Kommentare

Hallo zusammen, Ich habe zwar sehr aufmerksam die Fälle gelesen wo der unscharfe /FFT Parameter erfolgreich dazu führt, dass ...

Batch & Shell
Robocopy einzelner Datei kopiert auch gleichebnige Ordner allerdings leer
gelöst Frage von chrisdi91Batch & Shell5 Kommentare

Hallo, ich hab eine Batch-Datei, die von einer Daten/Ordner-Strukter nur gewisse Ordner und Strukturen an eine andere Stelle kopiert. ...

Batch & Shell
Robocopy kopiert nicht alle Verzeichnisse
gelöst Frage von mike7050Batch & Shell12 Kommentare

Hallo zusammen, ich bekomme es einfach nicht hin! Ich führe den Befehl robocopy auf einem Win 7 Prof PC ...

Neue Wissensbeiträge
Linux

Meltdown und Spectre: Linux Update

Information von Frank vor 2 TagenLinux

Meltdown (Variante 3 des Prozessorfehlers) Der Kernel 4.14.13 mit den Page-Table-Isolation-Code (PTI) ist nun für Fedora freigegeben worden. Er ...

Tipps & Tricks

Solutio Charly Updater Fehlermeldung: Das Abgleichen der Dateien in -Pfad- mit dem Datenobject ist fehlgeschlagen

Tipp von StefanKittel vor 2 TagenTipps & Tricks

Hallo, hier einmal als Tipp für alle unter Euch die mit der Zahnarztabrechnungssoftware Charly von Solutio zu tun haben. ...

Sicherheit

Meltdown und Spectre: Wir brauchen eine "Abwrackprämie", die die CPU-Hersteller bezahlen

Information von Frank vor 2 TagenSicherheit12 Kommentare

Zum aktuellen Thema Meltdown und Spectre: Ich wünsche mir von den CPU-Herstellern wie Intel, AMD oder ARM eine Art ...

Sicherheit

Meltdown und Spectre: Realitätscheck

Information von Frank vor 2 TagenSicherheit10 Kommentare

Die unangenehme Realität Der Prozessorfehler mit seinen Varianten Meltdown und Spectre ist seit Juni 2017 bekannt. Trotzdem sind immer ...

Heiß diskutierte Inhalte
E-Mail
Erfahrungen mit hMailServer gesucht
Frage von it-fraggleE-Mail10 Kommentare

Hallo, meine neue Stelle möchte einen eigenen Mailserver. Ich als Linuxkind war direkt geistig mit Postfix dabei. Leider wollen ...

Entwicklung
VBS: alle PDF-Dateien in einem Ordner gleichzeitig öffnen
gelöst Frage von JuweeeEntwicklung9 Kommentare

Hallo, ich habe in deiner Ordnerstruktur (.\Tagesberichte\xx.18\) mehrere dynamische PDF-Formulare (mit LCD erstellt). Die Berichtsformulare sind im Layout alle ...

Firewall
Penetrationstester-Labor - Firewalls
Frage von Oli-nuxFirewall9 Kommentare

Mich würde interessieren warum man beim Einrichten eines Penetrationstester-Labor (VMs) die Firewall der Systeme deaktivieren soll? Hat das nur ...

Netzwerkgrundlagen
IPv6 Inter-VLAN Routing
gelöst Frage von clSchakNetzwerkgrundlagen8 Kommentare

Hi ich befasse mich gerade mit der Implementierung von IPv6 was bisher (in einem VLAN) korrekt funktioniert inkl. DNS ...