Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Robocopy kopiert täglich unveränderte Dateien

Frage Microsoft Windows Tools

Mitglied: Tobias15

Tobias15 (Level 1) - Jetzt verbinden

08.12.2014 um 13:49 Uhr, 1240 Aufrufe, 8 Kommentare

Hallo zusammen,

Ich habe zwar sehr aufmerksam die Fälle gelesen wo der unscharfe /FFT Parameter erfolgreich dazu führt, dass robocopy Dateien als "unverändert" ansieht jedoch bringt es für mich keinen Erfolg.

Ich kopiere Verzeichnisinhalte meines PCs zum einen auf externe Festplatten was seit Jahren perfekt funktioniert. Mehrere TeraByte werden in wenigen Sekunden analysiert und nur die geänderten/hinzugefügten im Ziellaufwerk aktualisiert.

Massive Probleme habe ich mit einem Netzlaufwerk.
Ich habe an meinem Router eine externe USB Festplatte welche als Netzlaufwerk gemappt wird.

Im Ziel befinden sich 800GB Dateien von denen aber viele (nicht alle und auch nicht immer die gleichen) als NEUER identifiziert werden und somit jeden Tag erneut kopiert werden. D.h. der liebe robocopy kopiert jeden Abend viele Dateien die sich gar nicht geändert haben und ist somit ca. 3-4h am unnötigen kopieren. Gibts da einen Trick den ich benutzen muss, damit das auch mit einem Netzlaufwerk funktioniert?

robocopy "F:" "\\192.168.x.x\Backup_2000\Fotostore" /FFT /ZB /XO /E /FP /ETA /R:5 /W:5

Bitte dringend um Hilfe.

Viele Grüße
Tobias
Mitglied: Lochkartenstanzer
08.12.2014, aktualisiert um 14:12 Uhr
Zitat von Tobias15:

Im Ziel befinden sich 800GB Dateien von denen aber viele (nicht alle und auch nicht immer die gleichen) als NEUER identifiziert
werden und somit jeden Tag erneut kopiert werden. D.h. der liebe robocopy kopiert jeden Abend viele Dateien die sich gar nicht

chau dir als erstes mal die Timestamps der betreffenden dateien an. Wenn diese sich nämlich etqwas mehr als die zwei Sekuden "Rundungsgenauigkeit" von FAT unterscheiden, hast Du ein problem. Insbesodnere soltelst du auch die Synchronizität der Uhren prüfen, z.B. ob der Fileserver ein paar Sekunden "nachgeht". das kann ggf. dazu führen, daß die dateien auf dem Server "älter" erscheinen, als sie es tatsächlich sind, weil sie einen "veralteten2 timetamp beim aktualisierne verpaßt bekommen.

lks
Bitte warten ..
Mitglied: emeriks
08.12.2014 um 14:23 Uhr
Hi,
@Lochkartenstanzer
chau dir als erstes mal die Timestamps der betreffenden dateien an. Wenn diese sich nämlich etqwas mehr als die zwei Sekuden "Rundungsgenauigkeit" von FAT unterscheiden, hast Du ein problem. Insbesodnere soltelst du auch die Synchronizität der Uhren prüfen, z.B. ob der Fileserver ein paar Sekunden "nachgeht". das kann ggf. dazu führen, daß die dateien auf dem Server "älter" erscheinen, als sie es tatsächlich sind, weil sie einen "veralteten2 timetamp beim aktualisierne verpaßt bekommen.
Genau dafür wäre ja "/FFT", was offensichtlich in diesem Fall nicht funktioniert.

@Tobias15
robocopy "F:" "\\192.168.x.x\Backup_2000\Fotostore" /FFT /ZB /XO /E /FP /ETA /R:5 /W:5
Da Du offenbar keinen Spiegel machst, könntest Du alternativ auch das gute alte XCOPY mit Schalter /S /E /D verwenden. Nicht schön, aber funktional.

Bei EMC gibt es das EMCOPY. Dieses ist fast identisch zu ROBOCOPY, funktioniert aber in manchen Fällen etwas anders. Allerdings brauchst Du da einen Zugang im EMC Portal.

E.
Bitte warten ..
Mitglied: Lochkartenstanzer
08.12.2014 um 14:28 Uhr
Zitat von emeriks:

Genau dafür wäre ja "/FFT", was offensichtlich in diesem Fall nicht funktioniert.

FFT berücksichtigt nur 2 sekudne differenz. es kann aber durchaus größere differenzen geben. deswegen sollst Du ja die timestamps und die Uhrzeiten vergleichen.

lks
Bitte warten ..
Mitglied: emeriks
08.12.2014 um 14:56 Uhr
Ich? Wieso ich?

@Tobias15
Schon mal explizit angegeben, dass er den Zeitstempel kopieren soll?

Schalter /COPY:DAT

E.
Bitte warten ..
Mitglied: Lochkartenstanzer
08.12.2014 um 14:57 Uhr
Zitat von emeriks:

Ich? Wieso ich?

Ups, dachte, daß wäre die Antwort vom TO. War ein versehen.

lks
Bitte warten ..
Mitglied: Tobias15
08.12.2014 um 17:39 Uhr
Die Dateien haben leider genau das gleiche Datum und Uhrzeit. 06.09.2014 15:24
Ich habe auch bereits den windowsrechner mit einem Zeitserver syncronisiert.
Kein Effekt. Sichtkontrolle ergibt keine abweichung zwischen den Sekunden im Rechner und NAS.
Aber irgendwie scheint der Router doch was mit dem Datum zu murksen.

WÄHREND des kopierens ist das aktuelle Datum für die Datei angezeigt.
Eine mit STRG+C abgebrochener Kopiervorgang zeigt 01.10.2008
Aber nach dem kopieren ist Windows Filesystem und Gemapptes Netzlaufwerk perfekt gleich.

Trotzdem sagt er "NEUER" sobald ich nochmal anstarte.
Bitte warten ..
Mitglied: emeriks
08.12.2014, aktualisiert um 17:42 Uhr
Wenn hier ein Zeitproblem besteht, dann liegt das im Sekunden-Bereich!
Also "15:24" ist da als Vergleich zu ungenau.

E.
Bitte warten ..
Mitglied: Lochkartenstanzer
08.12.2014, aktualisiert um 18:17 Uhr
Moin,

die Optionen /w und /t von dir sollten Dir genauere Zeiten ausgeben. Mintutenbereiche sind zu ungenau. Du solltest Dir /T:A, /T:C und /T:W amschauen.

lsk
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
Robocopy kopiert nicht alle Verzeichnisse
gelöst Frage von mike7050Batch & Shell12 Kommentare

Hallo zusammen, ich bekomme es einfach nicht hin! Ich führe den Befehl robocopy auf einem Win 7 Prof PC ...

Netzwerke
Kopiert Robocopy oder Windows schneller?
Frage von multitalentd99Netzwerke4 Kommentare

HAllo, bis heute dachte ich immer das Robocopy 100% zuverlässig schnell kopiert und zudem den Vorteil hat, die Übertragungsgeschwindigkeit ...

Windows Tools
ROBOCOPY kopiert Ordner mit Bildern
Frage von xchr1sWindows Tools10 Kommentare

Hallo Administrator.de-User, ich habe momentan ein ROBOCOPY-Script, welches alle 10 Sekunden ausgeführt wird. Momentan kopiert ROBOCOPY stumpf Ordner + ...

Backup
Robocopy kopiert zwar alles, nur sind auf dem Ziel danach keine Dateien zu sehen
gelöst Frage von Maverick6Backup6 Kommentare

Hallo zusammen, ich habe hier ein Phänomen mit Robocopy, was ich mir nicht erklären kann. Ich möchte Daten von ...

Neue Wissensbeiträge
Internet

USA: Die FCC schaff die Netzneutralität ab

Information von Frank vor 52 MinutenInternet2 Kommentare

Jetzt beschädigt US-Präsident Donald Trump auch noch das Internet. Der neu eingesetzte FCC-Chef Ajit Pai ist bekannter Gegner einer ...

DSL, VDSL

ALL-BM200VDSL2V - Neues VDSL-Modem mit Vectoring von Allnet

Information von Lochkartenstanzer vor 4 StundenDSL, VDSL1 Kommentar

Moin, Falls jemand eine Alternative zu dem draytek sucht: Gruß lks

Windows 10

Microsoft bestätigt DMA-Policy-Problem in Win10 v1709

Information von DerWoWusste vor 4 StundenWindows 10

Wer sein Gerät mit der DMA-Policy absichert, bekommt evtl. Hardwareprobleme in v1709 von Win10. Warum? Weil v1709 endlich "richtig" ...

Verschlüsselung & Zertifikate

Die Hölle friert ein weiteres Stück zu: Microsoft integriert OpenSSH in Windows

Information von ticuta1 vor 8 StundenVerschlüsselung & Zertifikate

Interessant Die Hölle friert ein weiteres Stück zu: Microsoft integriert OpenSSH in Windows SSH-Kommando in CMD.exe und PowerShell

Heiß diskutierte Inhalte
Windows Server
RODC kann nicht aus Domäne entfernt werden
Frage von NilsvLehnWindows Server19 Kommentare

HAllo, ich arbeite in einem Universitätsnetzwerk mit 3 Standorten. Die Standorte haben alle ein ESXi Cluster und auf diesen ...

Hardware
Kein Bild mit nur einer bestimmten Grafikkarten - Mainboard Konfiguration
gelöst Frage von bestelittHardware18 Kommentare

Hallo zusammen, ich hatte schon einmal eine ähnliche Frage gestellt. Damals hatte ich genau das gleiche Problem. Allerdings lies ...

Netzwerkmanagement
Mehrere Netzwerkadapter in einem PC zu einem Switch zusammenfügen
Frage von prodriveNetzwerkmanagement18 Kommentare

Hallo zusammen Vorweg, ich konnte schon einige IT-Probleme mit Hilfe dieses Forums lösen. Wirklich klasse hier! Doch für das ...

Hardware
Links klick bei Maus funktioniert nicht
gelöst Frage von Pablu23Hardware16 Kommentare

Hallo erstmal. Ich habe ein Problem mit meiner relativ alten maus jedoch denke ich nicht das es an der ...