Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Robocopy löscht keine Ordner im Zielverzeichnis

Frage Microsoft Windows Tools

Mitglied: Coachi81

Coachi81 (Level 1) - Jetzt verbinden

05.01.2010 um 12:51 Uhr, 5250 Aufrufe, 7 Kommentare

Hallo,

ich versuche mit Robocopy meine Verzeichnisse auf eine Netzwerkfreigabe zu sichern. Jetzt hab ich festgestellt das ich im Quellverzeichnis Ordner mit Inhalt gelöscht habe die mir Robocopy aber bei der Sicherung im Zielverzeichnis nicht löscht bzw. er löscht nur den Inhalt der Ordner aber nicht die Ornder selbst. Mein Befehl schaut so aus:

robocopy d:\web X:\Web /MIR /LOG:X:\log.txt

Müsste doch eigentlich funktionieren mit "/MIR" oder? Hab mal versucht die Dateien lokal auf dem Rechner zu sichern, und komischerweise hat er hier dann auch die Ordner gelöscht nur übers Netz gehts halt nicht. Weiss jemand Rat???

mfg
Mitglied: 2hard4you
05.01.2010 um 13:04 Uhr
Moin,

/PURGE ........................... Deletes destination files and directories that no longer exist in the source.

Gruß

24
Bitte warten ..
Mitglied: Coachi81
05.01.2010 um 13:07 Uhr
geht auch nicht ausserdem is ja /PURGE in /MIR schon enthalten wenn ich das richtig verstanden hab
Bitte warten ..
Mitglied: 48507
05.01.2010 um 13:27 Uhr
Bei d:\web fehlt ein Backslash, also d:\web\
Bitte warten ..
Mitglied: Coachi81
05.01.2010 um 13:34 Uhr
hm, habs grad probiert. geht mit und auch ohne. ändert aber nichts an der Tatsache, das hat irgendwas mit dem Netzlaufwerk zu tun weils ja lokal richtig funktioniert
Bitte warten ..
Mitglied: manuel-r
05.01.2010 um 13:44 Uhr
Nur mal interessehalber:
Hast du mal getestet was passiert, wenn du als Ziel anstelle des gemappten Laufwerks den UNC-Pfad angibst?

Manuel
Bitte warten ..
Mitglied: Coachi81
05.01.2010 um 13:46 Uhr
ja hab ich, leider gleiches ergebnis. bin grad am rumprobieren und testen aber irgendwie hat nichts geholfen bis jetzt
Bitte warten ..
Mitglied: Coachi81
05.01.2010 um 14:02 Uhr
ich hab jetzt herausgefunden das es anscheinend direkt an meinem NAS System liegt. Auf einer anderen Netzwerkressource die auf einem Windows XP System liegt arbeitet Robocopy ohne Probleme. Kann es sein das es Probleme gibt weil das NAS auf Linux Basis ist??? Ich hab ein ICY Box NAS901
Bitte warten ..
Ähnliche Inhalte
Windows Server
Robocopy Ordner-Icons behalten (5)

Frage von sebastian2608 zum Thema Windows Server ...

Batch & Shell
gelöst Robocopy rechte im Ordner hinzufügen und nicht ersetzen (25)

Frage von blackhawk17 zum Thema Batch & Shell ...

Backup
Ausversehen robocopy MIR auf Laufwerk ausgeführt (7)

Frage von vBurak zum Thema Backup ...

Neue Wissensbeiträge
Windows Update

Novemberpatches und Nadeldrucker bereiten Kopfschmerzen

(14)

Tipp von MettGurke zum Thema Windows Update ...

Windows 10

Abhilfe für Abstürze von CDPUsersvc auf Win10 1607 und 2016 1607

(7)

Tipp von DerWoWusste zum Thema Windows 10 ...

RedHat, CentOS, Fedora

Fedora 27 ist verfügbar

Information von Frank zum Thema RedHat, CentOS, Fedora ...

Heiß diskutierte Inhalte
Batch & Shell
Batch Programm verhalten bei shoutdown -p (18)

Frage von Michael-ITler zum Thema Batch & Shell ...

Windows Server
Kennwort vergessen bei Hyper vserver 2012r (12)

Frage von jensgebken zum Thema Windows Server ...

Linux Desktop
Bildschirmauflösung unter Linux festlegen (12)

Frage von itebob zum Thema Linux Desktop ...