Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Robocopy löscht keine Ordner im Zielverzeichnis

Frage Microsoft Windows Tools

Mitglied: Coachi81

Coachi81 (Level 1) - Jetzt verbinden

05.01.2010 um 12:51 Uhr, 5235 Aufrufe, 7 Kommentare

Hallo,

ich versuche mit Robocopy meine Verzeichnisse auf eine Netzwerkfreigabe zu sichern. Jetzt hab ich festgestellt das ich im Quellverzeichnis Ordner mit Inhalt gelöscht habe die mir Robocopy aber bei der Sicherung im Zielverzeichnis nicht löscht bzw. er löscht nur den Inhalt der Ordner aber nicht die Ornder selbst. Mein Befehl schaut so aus:

robocopy d:\web X:\Web /MIR /LOG:X:\log.txt

Müsste doch eigentlich funktionieren mit "/MIR" oder? Hab mal versucht die Dateien lokal auf dem Rechner zu sichern, und komischerweise hat er hier dann auch die Ordner gelöscht nur übers Netz gehts halt nicht. Weiss jemand Rat???

mfg
Mitglied: 2hard4you
05.01.2010 um 13:04 Uhr
Moin,

/PURGE ........................... Deletes destination files and directories that no longer exist in the source.

Gruß

24
Bitte warten ..
Mitglied: Coachi81
05.01.2010 um 13:07 Uhr
geht auch nicht ausserdem is ja /PURGE in /MIR schon enthalten wenn ich das richtig verstanden hab
Bitte warten ..
Mitglied: 48507
05.01.2010 um 13:27 Uhr
Bei d:\web fehlt ein Backslash, also d:\web\
Bitte warten ..
Mitglied: Coachi81
05.01.2010 um 13:34 Uhr
hm, habs grad probiert. geht mit und auch ohne. ändert aber nichts an der Tatsache, das hat irgendwas mit dem Netzlaufwerk zu tun weils ja lokal richtig funktioniert
Bitte warten ..
Mitglied: manuel-r
05.01.2010 um 13:44 Uhr
Nur mal interessehalber:
Hast du mal getestet was passiert, wenn du als Ziel anstelle des gemappten Laufwerks den UNC-Pfad angibst?

Manuel
Bitte warten ..
Mitglied: Coachi81
05.01.2010 um 13:46 Uhr
ja hab ich, leider gleiches ergebnis. bin grad am rumprobieren und testen aber irgendwie hat nichts geholfen bis jetzt
Bitte warten ..
Mitglied: Coachi81
05.01.2010 um 14:02 Uhr
ich hab jetzt herausgefunden das es anscheinend direkt an meinem NAS System liegt. Auf einer anderen Netzwerkressource die auf einem Windows XP System liegt arbeitet Robocopy ohne Probleme. Kann es sein das es Probleme gibt weil das NAS auf Linux Basis ist??? Ich hab ein ICY Box NAS901
Bitte warten ..
Ähnliche Inhalte
Windows Userverwaltung
gelöst Ordner Rechte Keine Zugriffsrechte trotz gesetzte Berechtigung (2)

Frage von Hans3003 zum Thema Windows Userverwaltung ...

Windows Server
Robocopy Ordner-Icons behalten (5)

Frage von sebastian2608 zum Thema Windows Server ...

Windows Systemdateien
Liste aller geschützten Ordner - Keine Berechtigung zum Zugriff

Frage von Highend01 zum Thema Windows Systemdateien ...

Neue Wissensbeiträge
Drucker und Scanner

Samsung SL-M4025ND, firmware update und (kompatible) Tonerkassetten

(1)

Erfahrungsbericht von markus-1969 zum Thema Drucker und Scanner ...

Router & Routing

PfSense auf Supermicro Intel Xeon D-15x8 SoC Bare Bone

Tipp von Dobby zum Thema Router & Routing ...

Windows Server

Exchange 2010 auf Windows Server 2016 und AD

(2)

Tipp von Herbrich19 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Basic
Programmierung von Windows Programmen (9)

Frage von Ghost108 zum Thema Basic ...

LAN, WAN, Wireless
Brauche Hilfe: Mit (schnellem) WLAN Strecke überbrücken (8)

Frage von pierrehansen zum Thema LAN, WAN, Wireless ...

C und C++
Fehlendes verständiss von C und C++ (8)

Frage von zelamedia zum Thema C und C ...