Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Robocopy - Pfadangaben fehlerhaft

Frage Entwicklung Batch & Shell

Mitglied: nutellafan

nutellafan (Level 1) - Jetzt verbinden

02.05.2010, aktualisiert 11:08 Uhr, 3114 Aufrufe, 2 Kommentare

Hallo,
ich schlage mich gerade mit robocopy rum, bekomme es allerdings nicht hin dass er die root eben und alle darunterliegeneden Ordner und Dateien sichert.

Was ich will:
Es soll mir ein Datenbackup von der Festplatte D auf die Festplatte E in den Ordner backup machen.
Dabei sollen alle Ordner und Dateien die auf Festplatte D liegen kopiert werden.

Was ich gemacht habe:
1. Eine CMD Datei erstellt
2. Dort folgenden Inhalt rein
C:\test\robocopy.exe "D:\" "E:\backup" /COPYALL /MIR /ZB /w:30 /r:1 /v /NP /log:"C:\test.log"

Das seltsame ist, dass es mir so nichts sichert. Wenn ich aber bei der Quellenangabe D:\abc einen konkreten Ordner nehme macht er eine Kopie und schreibt auch etwas in die Log file.
Weis nicht wo da bein Fehler liegt. Bei anderen muss es so auch funktioniert haben.

Vielen Dank
Mitglied: MACeeE
02.05.2010 um 11:56 Uhr
Hallo,

meiner Erfahrung nach kommt robocopy nicht klar, wenn der abschliessende '\' einer Pfadangabe mit in den Anführungszeichen steht.
So sollte es also gehen: C:\test\robocopy.exe "D:"\ "E:\backup" /COPYALL /MIR /ZB /w:30 /r:1 /v /NP /log:"C:\test.log"

Bin mir aber nicht sicher, ob die Verwendung beider Schalter /COPYALL und /MIR zusammen probleme bereiten könnte,
da /MIR ja eigentlich /COPYALL einschliessen müsste. Habe ich aber nicht getestet, da ich die Schalter nie verwende!

Gruß
Bitte warten ..
Mitglied: nutellafan
02.05.2010 um 12:32 Uhr
Hallo,
danke das wars. copyall und mir macht er auch zusammen. der Slash darf aber nicht mit in den "" stehen. Danke
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
gelöst Robocopy und der Abgleich von Verzeichnissen (2)

Frage von Stefan007 zum Thema Batch & Shell ...

Administrator.de Feedback
gelöst Bug in einzelnen Threads: Antwortübersicht fehlerhaft bzw. unvollständig (4)

Frage von em-pie zum Thema Administrator.de Feedback ...

Windows Server
Robocopy Ordner-Icons behalten (5)

Frage von sebastian2608 zum Thema Windows Server ...

Batch & Shell
gelöst Robocopy geht und geht nicht gerade nicht (9)

Frage von TicTakTeo zum Thema Batch & Shell ...

Neue Wissensbeiträge
Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(4)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(9)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Heiß diskutierte Inhalte
Exchange Server
Exchange 2016 Standard Server 2012 R2 Hetzner Mail (41)

Frage von Datsspeed zum Thema Exchange Server ...

Windows 7
gelöst Lokales Adminprofil defekt (25)

Frage von Yannosch zum Thema Windows 7 ...

LAN, WAN, Wireless
gelöst Statische Routen mit ISC-DHCP Server für Android Devices (18)

Frage von terminator zum Thema LAN, WAN, Wireless ...

Exchange Server
gelöst Migration Exchange 2007 zu 2013 - Public Folder teilweise weg (16)

Frage von Andy1987 zum Thema Exchange Server ...