Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Robocopy Syntaxfehler

Frage Entwicklung Batch & Shell

Mitglied: perfectsky

perfectsky (Level 1) - Jetzt verbinden

17.09.2009, aktualisiert 23.09.2009, 6814 Aufrufe, 6 Kommentare

Hallo zusammen,

ich möchte eine Voll- und Differentielle Sicherung durchführen, mit verschiedenen Quellen und Zielen, und auch einzelnen nach Datum benannten Log-Dateien.
für die Sicherung stehen mir zwei Festplatten zur Verfügung. Auf die Erste will ich alles sichern, und dann wiederum auf die Zweite mirrorn.

Dabei entstehen zwei kleinere Probleme, die mich aber doch nerven, weil ich keine Ursache erkennen kann.

1) Also, hier beginnt mein erstes Problem:

336abb927f1c23c3f90adc1e1dd3f0e1-backup_zb2 - Klicke auf das Bild, um es zu vergrößern
Ihr könnt erkennen das meine Log-Zeile irgendeinen Syntaxfehler enthält. Das ist die Batch:
robocopy H:\ I:\ /MIR /V /NP /ZB /LOG:"h:\LOG\I(MIR)\%date%.txt" /R:10 /W:30
Aber ich hab keine Korrerktur gefunden, die konform ist mit der vorgeschriebenen Syntax.


2) Ein anderes Problem ist, das ich in den Pfaden des Ziels keine kopierten Dateien erkennen kann.

2b12326bb48e7c4d35be78881dd90840-backup_zb - Klicke auf das Bild, um es zu vergrößern
Hier bekommt ihr einen ungefähren Eindruck, wie die Log-dateien angelegt werden sollen (auch die Zielordner sind erkennbar,naja teilweise).
Eigentlich sollten in den Ordnern "Full" und "DIFF" noch Unterordner sein (alle Daten die gesichert wurden, der einzelnen Quelllaufwerke).

Ähnlich wie die Logs, sollen auch die Ziele weggeschrieben werden und werden sie auch. Obwohl ich im Explorer nix erkennen kann, kann ich die Zieldaten finden indem ich den bekannten Zielordner manuell eintrage. Im Zielordner sind die kopierten Daten dann auch vorhanden.

- erst wird ein Full-Backup erstellt
- danach das Archiv-Bit zurückgesetzt
- dann inkrementell bzw. differentiell gesichert

(Voll, da es kein Archivbit erkennen kann, und um für die Laufzeit des inkr. bzw. dif. Backups, bis zum nächsten Vollbackup die Daten auch wirklich inkr. oder dif. zu sichern)

Vielleicht frag ich jetzt wirklich ein wenig dumm, da mir da noch einige Gedankengänge fehlen, aber ist das zweite Backup im inkr. bzw. dif. modus nicht Vollsicherung genug, da kein Archivbit gesetzt wird? Und reicht es da nicht aus, einfach zwischendurch das Archivbit zurückzusetzen, um wieder ein quasi Full-Backup zu haben?

Danke im vorraus.

MfG Marcel
Mitglied: perfectsky
23.09.2009 um 11:22 Uhr
hallo liebe leser,

also selbst wenn ich das script mit dem gui erstelle meldet es fehler bei der ausführung.
es ist, als ob die durch das gui erstellten parameter auch nicht stimmen würden.

mfg
Bitte warten ..
Mitglied: 81825
23.09.2009 um 11:42 Uhr
Hi,

setze mal den Pfad hinter /LOG: in Anführungszeichen und nicht den gesamten Parameter.
Bitte warten ..
Mitglied: perfectsky
23.09.2009 um 21:11 Uhr
hi,

ja das hab ich auch schon probiert, wirkt aber so wie im screenshot wiedergegeben.
irgendwie wird das nicht richtig interpretiert, scheint mir.
in der batch steht es so drin:

robocopy H:\ I:\ /MIR /V /NP /ZB /LOG:"h:\LOG\I(MIR)\%date%.txt" /R:10 /W:30

also erklären kann ich mir das auch nicht so wirklich. ich hab mir auch schon zur kontrolle, mit dem GUI von MS noch mal ne batch erstellt, mit genau dem inhalt, wie hier oben drüber. aber selbes bzw. ähnliches ergebnis. hatte auch schon verschiedene positionen für die anführungszeichen ausprobiert, aber kein funktionsfähiges resultat erhalten.

mfg
Bitte warten ..
Mitglied: 81825
23.09.2009 um 21:20 Uhr
Dein Log-Verzeichnis existiert offenbar nicht. Leg mal H:\LOG\I(MIR) an, dann wird auch der Fehler weg sein.
Bitte warten ..
Mitglied: perfectsky
29.09.2009 um 09:37 Uhr
:D der Tipp war super 81825!

Hört sich gut an wenn die Festplatte leise vor sich hinsurrt beim abarbeiten.
Danke erstmal!!!

Aber mein anderes Problem besteht weiterhin...

greetz
Bitte warten ..
Mitglied: perfectsky
06.04.2011 um 10:20 Uhr
also hier nochmal ne kleine aktualisierung zu diesem thread bevor ich ihn ungelöst schließe.

die ordner, die dann auf den festplatten angelegt wurden waren versteckt und nachträglich auch nur mit größtem aufwand wieder zu entfernen.
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
gelöst RoboCopy Log Fehler? (14)

Frage von clragon zum Thema Batch & Shell ...

Windows Server
Schattenkopien mit Robocopy (6)

Frage von AveiroCR7 zum Thema Windows Server ...

Windows Tools
Robocopy - ACL für übergeordnete Verzeichnisse bei Option -S

Frage von grefabu zum Thema Windows Tools ...

Backup
Robocopy Inkrementelle Sicherung Windows Share (3)

Frage von firevegeta zum Thema Backup ...

Neue Wissensbeiträge
Tipps & Tricks

Wie Hackt man sich am besten in ein Computernetzwerk ein

(29)

Erfahrungsbericht von Herbrich19 zum Thema Tipps & Tricks ...

Humor (lol)

Bester Vorschlag eines Supporttechnikers ever: APC

(15)

Erfahrungsbericht von DerWoWusste zum Thema Humor (lol) ...

Heiß diskutierte Inhalte
Netzwerke
LAN2LAN Verbindung sehr langsam flaschenhals gesucht (27)

Frage von PixL86 zum Thema Netzwerke ...

LAN, WAN, Wireless
Rogue Access Point (20)

Frage von Axel90 zum Thema LAN, WAN, Wireless ...

E-Mail
Fake E-Mail in Outlook für Demonstartionszwecke (12)

Frage von sascha382 zum Thema E-Mail ...

Linux Netzwerk
gelöst Debian Neuinstallation 2.Netzwerkkarte keine Verbindung (10)

Frage von terminator zum Thema Linux Netzwerk ...