Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Robocopy Syntaxfehler

Frage Entwicklung Batch & Shell

Mitglied: perfectsky

perfectsky (Level 1) - Jetzt verbinden

17.09.2009, aktualisiert 23.09.2009, 6787 Aufrufe, 6 Kommentare

Hallo zusammen,

ich möchte eine Voll- und Differentielle Sicherung durchführen, mit verschiedenen Quellen und Zielen, und auch einzelnen nach Datum benannten Log-Dateien.
für die Sicherung stehen mir zwei Festplatten zur Verfügung. Auf die Erste will ich alles sichern, und dann wiederum auf die Zweite mirrorn.

Dabei entstehen zwei kleinere Probleme, die mich aber doch nerven, weil ich keine Ursache erkennen kann.

1) Also, hier beginnt mein erstes Problem:

336abb927f1c23c3f90adc1e1dd3f0e1-backup_zb2 - Klicke auf das Bild, um es zu vergrößern
Ihr könnt erkennen das meine Log-Zeile irgendeinen Syntaxfehler enthält. Das ist die Batch:
robocopy H:\ I:\ /MIR /V /NP /ZB /LOG:"h:\LOG\I(MIR)\%date%.txt" /R:10 /W:30
Aber ich hab keine Korrerktur gefunden, die konform ist mit der vorgeschriebenen Syntax.


2) Ein anderes Problem ist, das ich in den Pfaden des Ziels keine kopierten Dateien erkennen kann.

2b12326bb48e7c4d35be78881dd90840-backup_zb - Klicke auf das Bild, um es zu vergrößern
Hier bekommt ihr einen ungefähren Eindruck, wie die Log-dateien angelegt werden sollen (auch die Zielordner sind erkennbar,naja teilweise).
Eigentlich sollten in den Ordnern "Full" und "DIFF" noch Unterordner sein (alle Daten die gesichert wurden, der einzelnen Quelllaufwerke).

Ähnlich wie die Logs, sollen auch die Ziele weggeschrieben werden und werden sie auch. Obwohl ich im Explorer nix erkennen kann, kann ich die Zieldaten finden indem ich den bekannten Zielordner manuell eintrage. Im Zielordner sind die kopierten Daten dann auch vorhanden.

- erst wird ein Full-Backup erstellt
- danach das Archiv-Bit zurückgesetzt
- dann inkrementell bzw. differentiell gesichert

(Voll, da es kein Archivbit erkennen kann, und um für die Laufzeit des inkr. bzw. dif. Backups, bis zum nächsten Vollbackup die Daten auch wirklich inkr. oder dif. zu sichern)

Vielleicht frag ich jetzt wirklich ein wenig dumm, da mir da noch einige Gedankengänge fehlen, aber ist das zweite Backup im inkr. bzw. dif. modus nicht Vollsicherung genug, da kein Archivbit gesetzt wird? Und reicht es da nicht aus, einfach zwischendurch das Archivbit zurückzusetzen, um wieder ein quasi Full-Backup zu haben?

Danke im vorraus.

MfG Marcel
Mitglied: perfectsky
23.09.2009 um 11:22 Uhr
hallo liebe leser,

also selbst wenn ich das script mit dem gui erstelle meldet es fehler bei der ausführung.
es ist, als ob die durch das gui erstellten parameter auch nicht stimmen würden.

mfg
Bitte warten ..
Mitglied: 81825
23.09.2009 um 11:42 Uhr
Hi,

setze mal den Pfad hinter /LOG: in Anführungszeichen und nicht den gesamten Parameter.
Bitte warten ..
Mitglied: perfectsky
23.09.2009 um 21:11 Uhr
hi,

ja das hab ich auch schon probiert, wirkt aber so wie im screenshot wiedergegeben.
irgendwie wird das nicht richtig interpretiert, scheint mir.
in der batch steht es so drin:

robocopy H:\ I:\ /MIR /V /NP /ZB /LOG:"h:\LOG\I(MIR)\%date%.txt" /R:10 /W:30

also erklären kann ich mir das auch nicht so wirklich. ich hab mir auch schon zur kontrolle, mit dem GUI von MS noch mal ne batch erstellt, mit genau dem inhalt, wie hier oben drüber. aber selbes bzw. ähnliches ergebnis. hatte auch schon verschiedene positionen für die anführungszeichen ausprobiert, aber kein funktionsfähiges resultat erhalten.

mfg
Bitte warten ..
Mitglied: 81825
23.09.2009 um 21:20 Uhr
Dein Log-Verzeichnis existiert offenbar nicht. Leg mal H:\LOG\I(MIR) an, dann wird auch der Fehler weg sein.
Bitte warten ..
Mitglied: perfectsky
29.09.2009 um 09:37 Uhr
:D der Tipp war super 81825!

Hört sich gut an wenn die Festplatte leise vor sich hinsurrt beim abarbeiten.
Danke erstmal!!!

Aber mein anderes Problem besteht weiterhin...

greetz
Bitte warten ..
Mitglied: perfectsky
06.04.2011 um 10:20 Uhr
also hier nochmal ne kleine aktualisierung zu diesem thread bevor ich ihn ungelöst schließe.

die ordner, die dann auf den festplatten angelegt wurden waren versteckt und nachträglich auch nur mit größtem aufwand wieder zu entfernen.
Bitte warten ..
Neuester Wissensbeitrag
Windows Update

Windows Update-Suche nach Win7 Neuinstallation wieder schneller

(1)

Erfahrungsbericht von the-buccaneer zum Thema Windows Update ...

Ähnliche Inhalte
Batch & Shell
gelöst Robocopy geht und geht nicht gerade nicht (9)

Frage von TicTakTeo zum Thema Batch & Shell ...

Batch & Shell
gelöst Batch Syntaxfehler, aber finde ihn nicht :( (5)

Frage von PinkFLuffyUnicorn zum Thema Batch & Shell ...

Batch & Shell
gelöst Robocopy log Angabe der Zeiten - Verständnissfrage (3)

Frage von NetMare zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Exchange Server
Bestehende eMails autoamatisch weiterleiten (21)

Frage von metal-shot zum Thema Exchange Server ...

Hyper-V
gelöst Reiner Hyper- V Server oder lieber Rolle (21)

Frage von Winuser zum Thema Hyper-V ...

SAN, NAS, DAS
gelöst Synology Version 6.1 Probleme (18)

Frage von Hendrik2586 zum Thema SAN, NAS, DAS ...

Router & Routing
gelöst IP Kamera für drei unabhängige Netzwerke (16)

Frage von ProfessorZ zum Thema Router & Routing ...