Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Robocopy XP010 Bug mit Server2k8 ?

Frage Microsoft Windows Tools

Mitglied: polYtoX

polYtoX (Level 1) - Jetzt verbinden

01.09.2011 um 15:20 Uhr, 4675 Aufrufe, 2 Kommentare

Ich habe hier ein Problem mit einem Server 2008 auf dem ein Robocopy (XP010) Batch läuft .

Hallo

wie gesagt -> Ich habe hier ein Problem mit einem Server 2008 auf dem ein Robocopy (XP010) Batch läuft das quasi in der Nacht mehrere Shares kopiert. Neuerdings bekomme ich haufenweise ERROR 5 Fehler (Zugriff verweigert).

Ich habe jetzt ein wenig herum gedoktert und hab folgendes bemerkt.
Wenn ich einen Ordner von Rechner A auf B mit Robocopy XP010 kopieren möchte funktioniert es.
Wenn der Ordner aber "Schreibgeschützt" ist (also wenn die File-Attribs gesetzt sind) dann bekomme ich diese suspekten ERROR 5 Fehler.

Noch dazu bekomme ich pro File einmal diesen Fehler und beim zweiten Versuch (funktioniert es dann). Das ganze sieht dann so aus:

..
..
New File 30 P:\Projekte2\xxxx.yyy
2011/08/31 08:00:55 ERROR 5 (0x00000005) Time-Stamping Destination File P:\Projekte2\xxxx.yyy
Zugriff verweigert

Waiting 30 seconds... Retrying...
New File 30 P:\Projekte2\xxxx.yyy
..
..usw.


Wenn ich am Source Folder die Schreibschutz-Attribs aufhebe....funktioniert es ganz normal.

Hat vielleicht jemand eine Idee dazu ??

XP027 ist keine Alternative, da diese version leider Gottes nicht sofort anfängt zum Kopieren sonder zu Beginn anscheinend erst den ganzen Verzeichnisbaum einliest oder whatever und das dauert dann ewig (Fileserver).

lg/p
Mitglied: Friemler
01.09.2011 um 16:21 Uhr
Hallo polYtoX,

hast Du schon die Version XP026 getestet? Erhältlich hier. Dabei handelt es sich um ein Installerpaket, das Du mit UniExtract (RAR-Datei, portabele Version, Installer, integriert sich ins Explorer-Kontextmenü) entpacken kannst. Dazu sind aber 3 Schritte nötig:

  • Die heruntergeladene EXE entpacken. Erzeugt eine UTILIT~1.EXE.
  • Die UTILIT~1.EXE entpacken. Erzeugt ein Verzeichnis UtilitySpotlight, das u.a. eine Setup.msi enthält
  • Die Setup.msi entpacken. Das erzeugt 3 Verzeichnisse und einige Dateien (u.a. eine GUI für Robocopy und eine Doku als DOC-Datei)

Im Verzeichnis System Folder befindet sich die Robocopy.exe XP026.

Gruß
Friemler
Bitte warten ..
Mitglied: polYtoX
02.09.2011 um 12:08 Uhr
Hallo,

danke für dein Kommentar. Ich hab jetzt vorab noch-einmal die XP027 ausprobiert:

XP010:

Total Copied Skipped Mismatch AILED Extras
Dirs : 28877 7 28870 0 0 5
Files : 154992 81 154911 0 0 78
Bytes : 521.222 g 280.31 m 520.948 g 0 0 964.47 m
Times : 0:16:18 0:00:22 0:00:00 0:15:55

Speed : 13038042 Bytes/sec.
Speed : 746.042 MegaBytes/min.

Ended : Tue Aug 30 18:16:21 2011


XP027:

Insgesamt Kopiert šbersprungen Keine šbereinstimmung FEHLER Extras
Verzeich.: 28879 0 28879 0 0 0
Dateien: 155001 20 154981 0 0 3
Bytes: 521.267 g 37.52 m 521.230 g 0 0 330
Zeiten: 0:56:28 0:00:03 0:01:45 0:54:39


Geschwindigkeit: 10552466 Bytes/Sek.
Geschwindigkeit: 603.816 Megabytes/Min.

Beendet: Fri Sep 02 00:23:54 2011




Hie ist ein Unterschied von 19 Minuten zu 57 Minuten !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Die Robocopy Stapel die normalerweise 3 Stunden laufen, laufen mit XP027 bis in den Tag hinein (

Das heißt ich probiere jetzt noch einmal die XP026 aus und hoffe, das jemanden noch etwas einfällt......


lg/p
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Administrator.de Feedback
Bug? "m f g" (ohne Leerzeichen) wird auch in URL ersetzt (5)

Frage von emeriks zum Thema Administrator.de Feedback ...

Administrator.de Feedback
gelöst Bug beim Übernehmen der Überschriften-Texte von Links? (2)

Frage von Lochkartenstanzer zum Thema Administrator.de Feedback ...

Administrator.de Feedback
gelöst Bug bei Textanzeige im Tab (Browser) (3)

Frage von Alexander.Schmitt zum Thema Administrator.de Feedback ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...