Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Frage Microsoft Windows Tools

Robocopy XP010 Bug mit Server2k8 ?

Mitglied: polYtoX

polYtoX (Level 1) - Jetzt verbinden

01.09.2011 um 15:20 Uhr, 4784 Aufrufe, 2 Kommentare

Ich habe hier ein Problem mit einem Server 2008 auf dem ein Robocopy (XP010) Batch läuft .

Hallo

wie gesagt -> Ich habe hier ein Problem mit einem Server 2008 auf dem ein Robocopy (XP010) Batch läuft das quasi in der Nacht mehrere Shares kopiert. Neuerdings bekomme ich haufenweise ERROR 5 Fehler (Zugriff verweigert).

Ich habe jetzt ein wenig herum gedoktert und hab folgendes bemerkt.
Wenn ich einen Ordner von Rechner A auf B mit Robocopy XP010 kopieren möchte funktioniert es.
Wenn der Ordner aber "Schreibgeschützt" ist (also wenn die File-Attribs gesetzt sind) dann bekomme ich diese suspekten ERROR 5 Fehler.

Noch dazu bekomme ich pro File einmal diesen Fehler und beim zweiten Versuch (funktioniert es dann). Das ganze sieht dann so aus:

..
..
New File 30 P:\Projekte2\xxxx.yyy
2011/08/31 08:00:55 ERROR 5 (0x00000005) Time-Stamping Destination File P:\Projekte2\xxxx.yyy
Zugriff verweigert

Waiting 30 seconds... Retrying...
New File 30 P:\Projekte2\xxxx.yyy
..
..usw.


Wenn ich am Source Folder die Schreibschutz-Attribs aufhebe....funktioniert es ganz normal.

Hat vielleicht jemand eine Idee dazu ??

XP027 ist keine Alternative, da diese version leider Gottes nicht sofort anfängt zum Kopieren sonder zu Beginn anscheinend erst den ganzen Verzeichnisbaum einliest oder whatever und das dauert dann ewig (Fileserver).

lg/p
Mitglied: Friemler
01.09.2011 um 16:21 Uhr
Hallo polYtoX,

hast Du schon die Version XP026 getestet? Erhältlich hier. Dabei handelt es sich um ein Installerpaket, das Du mit UniExtract (RAR-Datei, portabele Version, Installer, integriert sich ins Explorer-Kontextmenü) entpacken kannst. Dazu sind aber 3 Schritte nötig:

  • Die heruntergeladene EXE entpacken. Erzeugt eine UTILIT~1.EXE.
  • Die UTILIT~1.EXE entpacken. Erzeugt ein Verzeichnis UtilitySpotlight, das u.a. eine Setup.msi enthält
  • Die Setup.msi entpacken. Das erzeugt 3 Verzeichnisse und einige Dateien (u.a. eine GUI für Robocopy und eine Doku als DOC-Datei)

Im Verzeichnis System Folder befindet sich die Robocopy.exe XP026.

Gruß
Friemler
Bitte warten ..
Mitglied: polYtoX
02.09.2011 um 12:08 Uhr
Hallo,

danke für dein Kommentar. Ich hab jetzt vorab noch-einmal die XP027 ausprobiert:

XP010:

Total Copied Skipped Mismatch AILED Extras
Dirs : 28877 7 28870 0 0 5
Files : 154992 81 154911 0 0 78
Bytes : 521.222 g 280.31 m 520.948 g 0 0 964.47 m
Times : 0:16:18 0:00:22 0:00:00 0:15:55

Speed : 13038042 Bytes/sec.
Speed : 746.042 MegaBytes/min.

Ended : Tue Aug 30 18:16:21 2011


XP027:

Insgesamt Kopiert šbersprungen Keine šbereinstimmung FEHLER Extras
Verzeich.: 28879 0 28879 0 0 0
Dateien: 155001 20 154981 0 0 3
Bytes: 521.267 g 37.52 m 521.230 g 0 0 330
Zeiten: 0:56:28 0:00:03 0:01:45 0:54:39


Geschwindigkeit: 10552466 Bytes/Sek.
Geschwindigkeit: 603.816 Megabytes/Min.

Beendet: Fri Sep 02 00:23:54 2011




Hie ist ein Unterschied von 19 Minuten zu 57 Minuten !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Die Robocopy Stapel die normalerweise 3 Stunden laufen, laufen mit XP027 bis in den Tag hinein (

Das heißt ich probiere jetzt noch einmal die XP026 aus und hoffe, das jemanden noch etwas einfällt......


lg/p
Bitte warten ..
Ähnliche Inhalte
Visual Studio
Dot.Net Bug?
gelöst Frage von MarabuntaVisual Studio2 Kommentare

Ich habe möglicherweise einen Bug gefunden, da der Befehl aus C# u.o. DotNet kommt, wollte ich fragen ob ihr ...

Windows 10
Keine Rechte oder Bugs nach einer automatischen Reperatur
Frage von GeomaxWindows 101 Kommentar

Hallo liebe User! Ich habe ein großes Problem, denn mein Windows lässt sich so gut wie nicht mehr bedienen. ...

Administrator.de Feedback
Sammelthread für Bugs in der Formatierung
Frage von 114757Administrator.de Feedback10 Kommentare

Hallo Kollegen, liebe Forumsnutzer, damit wir die manchmal etwas nervigen Fehler der Formatierungsanweisungen los werden habe ich diesen Thread ...

Administrator.de Feedback
Bug beim Antwortcounter?
gelöst Frage von SheogorathAdministrator.de Feedback6 Kommentare

Moin, es ist mir bereits heute Nacht aufgefallen, aber ich dachte im ersten Moment, dass da vielleicht einfach irgendwas ...

Neue Wissensbeiträge
Linux

Meltdown und Spectre: Linux Update

Information von Frank vor 1 TagLinux

Meltdown (Variante 3 des Prozessorfehlers) Der Kernel 4.14.13 mit den Page-Table-Isolation-Code (PTI) ist nun für Fedora freigegeben worden. Er ...

Tipps & Tricks

Solutio Charly Updater Fehlermeldung: Das Abgleichen der Dateien in -Pfad- mit dem Datenobject ist fehlgeschlagen

Tipp von StefanKittel vor 2 TagenTipps & Tricks

Hallo, hier einmal als Tipp für alle unter Euch die mit der Zahnarztabrechnungssoftware Charly von Solutio zu tun haben. ...

Sicherheit

Meltdown und Spectre: Wir brauchen eine "Abwrackprämie", die die CPU-Hersteller bezahlen

Information von Frank vor 2 TagenSicherheit12 Kommentare

Zum aktuellen Thema Meltdown und Spectre: Ich wünsche mir von den CPU-Herstellern wie Intel, AMD oder ARM eine Art ...

Sicherheit

Meltdown und Spectre: Realitätscheck

Information von Frank vor 2 TagenSicherheit10 Kommentare

Die unangenehme Realität Der Prozessorfehler mit seinen Varianten Meltdown und Spectre ist seit Juni 2017 bekannt. Trotzdem sind immer ...

Heiß diskutierte Inhalte
Batch & Shell
Meltdown Microsoft Prüf Script - .zip Datei leider leer
gelöst Frage von MasterBlaster88Batch & Shell13 Kommentare

Hallo zusammen, ich patche gerade unsere Windows Server bzgl. der Meltdown Lücke. Patch vorhanden, Reg Keys gesetzt Um das ...

Batch & Shell
Shell-Skript - Syntax error: Unterminated quoted string
Frage von newit1Batch & Shell13 Kommentare

Hallo Ich schreibe ein Skript das eine CSV-Datei in eine mySQL Datenbank schieben soll. Bekomme nach start des Skrips ...

E-Mail
Erfahrungen mit hMailServer gesucht
Frage von it-fraggleE-Mail10 Kommentare

Hallo, meine neue Stelle möchte einen eigenen Mailserver. Ich als Linuxkind war direkt geistig mit Postfix dabei. Leider wollen ...

Entwicklung
VBS: alle PDF-Dateien in einem Ordner gleichzeitig öffnen
gelöst Frage von JuweeeEntwicklung9 Kommentare

Hallo, ich habe in deiner Ordnerstruktur (.\Tagesberichte\xx.18\) mehrere dynamische PDF-Formulare (mit LCD erstellt). Die Berichtsformulare sind im Layout alle ...