Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Router hängt sich dauernd auf und Probleme mit Switchen

Frage Netzwerke

Mitglied: DrCox

DrCox (Level 1) - Jetzt verbinden

12.12.2007, aktualisiert 12.02.2008, 8633 Aufrufe, 28 Kommentare

Ich verwalte ein Netzwerk das folgendermaßen aufgebaut ist.
Router -> Verbindung zu Switch -> Verbindung zu 2 weiteren Switchen, wovon einer davon nochmal auf 4 weitere Switche verlinkt.
Erst einmal das Switch-Problem. Es sind HP-Switche und sie lassen sich seit geraumer Zeit nicht mehr ansprechen, funktionieren sonst aber einwandfrei. Es sind genau die Switchte, die von beiden Seiten (Switchen) Daten erhalten können (ich habe oben bei der Ausführung vergessen zu erwähnen, dass das ganze sternförmig angeordnet ist - also die Switche sind nochmals untereinander verbunden).
Nun zum Router Problem. Seit einigen Wochen hängt sich dieser immer auf und startet dann neu. Währenddessen ist er nicht ansprechbar. Das passiert meist bei hoher Netzauslastung. In den Logfiles des Routers wird nichts ungewöhnliches angezeigt.
Deshalb meine Frage: Wie kann ich da am besten vorgehen? Oder ist es offensichtlich, dass das an den Switche liegt? Der Router ist aus der Cisco 1800er Serie und etwa 2 1/2 Jahre alt.
Mitglied: DownhillDom
12.12.2007 um 13:29 Uhr
Sind die 4 Switche (4-7) auch noch mit dem 1. und dem 2. Switch verbunden?

Also:

Router
|
Switch 1 ------- Switch 3 ---- Switches 4-7
|
Switch 2

Gruß Dominik
Bitte warten ..
Mitglied: DrCox
12.12.2007 um 14:52 Uhr
Es ist so aufgebaut:

Router
|
Switch 2 ----------------------------Switch 1 (der selbe Switch, wie unten)
|
Switch 3
|
Switch 4
|
Switch 5
|
|
Switch 1-------------Switch 6----------------Switch 7
|
---------------------------------------------------Switch 7


Da leider hier nicht mehr als ein Leerzeichen möglich ist, sieht das leider nicht so übersichtlich aus. Switch 1 ist quasi so etwas, wie der Zentralswitch, der mit Switch 2, 5,6 und 7 verbunden ist. Hoffe es verwirrt jetzt nicht, dass Switch 1, einmal oben und dann noch unten ist. Das ist der selbe und soll nur ausdrücken, dass er mit 2 und 5 verbunden ist.

Probleme machen Switch 4 und Switch 6. Ich habe die Zahlen jetzt nochmals umbenannt, damit es besser vedeutlicht, dass der Switch 1, eigentlich so etwas, wie der Zentralswitch ist, der die anderen Switche versorgt.
Bitte warten ..
Mitglied: aqui
13.12.2007 um 12:01 Uhr
Dein Netzwerk müsste dann so aussehen wenn man deine Zeichnung richtig interpretiert:

56c45b7535e3ddc68a0d2f4572f93121-switches7 - Klicke auf das Bild, um es zu vergrößern

Da die Switches 2, 3, 4 und 5 über Switch 1 in einem Loop hängen ist es zwingend ! wichtig das du auf den HPs Spanning Tree aktivierst um nicht einen Loop zu generieren, der dein Netz zum Stillstand bringt !!
Der Cisco dürfte weniger das Problem sein als deine Switches !
Wichtig ist das du alle HPs erstmal wieder in einen managebaren Zustand versetzt !
Dazu solltest du sie von der HP Support Seite mit dem aktuellsten Image versehen, rebooten und ihnen dann eine freie IP Adresse aus dem Netz verpassen als Mangement IP, die natürlich NICHT in irgendwelchen DHCP oder Client IP Ranges des restlichen Netzes liegt. Meist bieten sich Adressen an am oberen Rand des Netzwerkes, also ab .254 abwärts. (Hängt von deiner Adressierung ab..)
In dem jetzigen Zustand kannst du rein gar nichts troubleshooten und alle Suche nach Ursachen ist Kaffesatzleserei...
Die wichtigsten Schritte sind also:
Spanning Tree unbedingt aktivieren !
Image Update und Mangement IPs konfigurieren, Switchreboot !
Wahrschenlich fixt das schon dein Problem. Wenn nicht kann man dann danach mal weitersehen !
Bitte warten ..
Mitglied: DownhillDom
13.12.2007 um 15:33 Uhr
@ aqui
Hatte mir auch gedacht, dass die Switches an nem Loop krepieren. Wollte dazu erstmal wissen, wie das Netz aufgebaut ist, um erkennen zu können, ob irgendwo sowas entstehen könnte.
Aber wenn man sich die Grafik ansieht, schreit das quasi nach nem Loop, insofern kein SpanningTree aktiviert ist
nochmal @ aqui: Hast du Cisco CCNA absolviert?
Bitte warten ..
Mitglied: DrCox
13.12.2007 um 17:00 Uhr
Erst einmal danke für diese tolle und ausführliche Antwort. Die Zeichnung trifft den Aufbau fast haargenau. Ich hätte das mit meiner Beschreibung wohl eher nicht verstanden. Einziger Fehler ist, dass Switch 6 und Switch 7 auch noch untereinander verbunden sind.

Ich hätte da jetzt noch eine Frage: Ist auch Multicast Filtering wichtig? Das ist nämlich auch nicht bei allen Switchen aktiviert. Oder hat das eher keinen Sinn?

Spanning Tree ist bei allen funktionierenden Switchen bis auf Switch 5 aktiviert. Das könnte eigentlich eine Erklärung sein, wieso Switch 3 nicht mehr ansprechbar ist. Also sollte ich auf Switch 5 jetzt spanning tree aktivieren, wenn ich es nicht falsch verstanden habe. Leider wird mir dann angezeigt, dass automatic management konfiguriert ist. Wenn ich dann auf die Adresse (server) gehe, dann kommt nichts. Die Adresse lässt sich auch nicht anpingen. Also ist da einfach der Management Server down? Bzw. wo sollte der nun eigentlich konfiguriert sein? Oder ist der überhaupt wichtig?


Die Frage ist auch noch, wie ich so ein Image Update mache. Direkt an den Switch anschließen oder kann man das auch anders erzwingen? Er lässt sich ja nicht mehr per Telnet ansprechen, sondern nur anpingen.


Hoffe das sind nicht zuviele Fragen. Wäre sehr dankbar, wenn mir diesbezüglich noch geholfen werden könntel.

freundliche Grüße
Bitte warten ..
Mitglied: aqui
14.12.2007 um 20:10 Uhr
Ja, Switch 5 benötigt zwingend Spanning Tree denn er ist ja direkt Teilnehmer des gesteckten Loops. Es wäre tödlich den ohne STP laufen zu lassen.
Das gleiche gilt natürlich für Switch 6 und 7 wenn di verbunden sind. Dann haben die über Switch 1 auch einen Loop.
Es ist natürlich fahrlässig, wenn du die Switces im Netzwerk nicht erreichen kannst per IP.
Als allererstes solltest du bewaffnet mit einem Konsolenkabel und einem Terminal Programm wie z.B. TerTerm jeden Switch abklappern und ihn auf eine korrekte IP Konfiguration überprüfen.
Eine korrekt HP Konfig sieht z.B. so aus:

...
vlan 1
name "DEFAULT_VLAN"
untagged 1-24
ip address 172.16.1.254 255.255.255.0
no untagged 23-24
exit
...

So eine IP muss jeder Switch haben und pingbar sein UND auch per Telnet erreichbar sein, denn du willst ja nicht immer mit einem Terminal rumlaufen, oder ??
Auto Management kannst du vergessen, da holt sich der Switch eine IP per DHCP und du weisst gar nicht welche IPs die Switches im Endeffekt haben (scheinbar bei dir der Fall ?!) ohne auf den DHCP Server zu gehen und nach den MAC Adressen in den Leases zu schauen um dann die korrekte IP zum Switch rauszubekommen...ein mühsames Unterfangen und nur für Leute die nicht wissen was sie tun....
Solche Devices haben immer statische IPs im Netzwerk !!!
Ein Update machst du dann mit einem TFTP Server im Netz wie z.B. der Pumpkin-TFTP Server für Windows. Hier kopiert man das Image und läd es mit dem Kommando copy tftp flash <ip> >filename> in den Switch.
Die HP Webseite sagt dir genau wie..
Bitte warten ..
Mitglied: DrCox
18.12.2007 um 11:05 Uhr
Jetzt nur noch eine letzte Frage: Kann es vielleicht auch damit zusammenhängen, dass in der Konfiguration der Befehlt "no ip-domain lookup" fehlt. Es ist allerdings auch kein Befehlt ip-domain lookup da. Weiß jetzt auch gar nicht, wie ich den in die Konfiguration bringen kann. Laut Beschreibung von Cisco sollte das auch nicht wichtig sein, oder?
Bitte warten ..
Mitglied: aqui
19.12.2007 um 11:57 Uhr
Nein, das Kommando hat mit der Funktion der Switches rein gar nichts zu tun !!
Mit no ip-domain lookup schaltest du lediglich generell das DNS Lookup ab. Also wenn du zum Beispiel dann ping name.domain auf der Kommandozeile des Switches oder Routers eingibst löst er dann den Namen name.domain nicht mehr auf. Er akzeptiert dann nur IP Adressen.
Das ist ein rein kosmetisches Kommando und hat mit der Funktion der Switches selber überhaupt nichts zu tun.
Um das Kommando auf den Switch oder Router zu bekommen, telnettest du den Router oder gehtst mit Terminal an den seriellen Konsolanschluss.
Dort am Prompt authentifizierst du dich, gibst enable als Kommando an, dann conf t was dich in den Konfigurationsmodus bringt.
Hier gibst du nun ein (no) ip-domain lookup und schon ist das Komamndo aktiv oder eben nicht aktiv wenn du den Parameter no verwendest davor.
Danach dann mit ctrl-z raus aus dem Konfig Modus und nicht vergessen mit write die Konfig zu speichern damit sie nach dem nächsten Reboot nicht wieder flöten geht...

Als Tipp solltest es aber besser auf dem Router aktiv lassen, denn dann kannst du von dort auch mit Namen und auch IP Adressen Erreichbarkeit (Ping traceroute) etc. testen oder auch Namen in ACL listen konfigurieren usw..
Bitte warten ..
Mitglied: DrCox
20.12.2007 um 11:43 Uhr
Ok. Das dachte ich mir schon.
An die Switche komme ich derzeit nicht ran. Ich denke außerdem, dass das Hauptproblem eher vom Router kommt. Wenn der Router nämlich nicht reagiert, dann funktioneren alle anderen Switche (bis auf die, die nicht mehr reagieren) noch ganz normal.
Deshalb führe ich derzeit das von Cisco beschriebene Troubleshooting durch. Wenn ich am Router show stacks eingebe, dann erhalte ich unter interrupt level stacks: host/PCI Bridge Interrrupt und M8500_TIMER_Interrupt sehr viele Calls. Fehler werden allerdings nicht angezeigt. Deutet das jetzt auf einen Loop?
Bitte warten ..
Mitglied: DrCox
20.12.2007 um 11:57 Uhr
Weiß vielleicht auch noch jemand über spurious interrupts (unechte Unterbrechungen) Bescheid? Da werden sehr viele angezeigt (über 100.000). Auf der Cisco-Seite steht, dass das auf Hardware oder Software-Fehler zurückzuführen ist.
Bitte warten ..
Mitglied: aqui
20.12.2007 um 17:05 Uhr
Das kann mit deinem eigentlichen Fehler nichts zu tun haben, denn der Router ist ja nur einbeinig angebunden (hoffentlich ?!). Er ist also in einen eventuellen Loop gar nicht involviert. Folglich kann dein Grundproblem mit ihm nicht zu tun haben.

Zu vermuten ist eher das du ein dummes flaches Layer 2 Netz betreibst mit einer ziemlichen Anzhahl von Endgeräten und das Grundrauschen im Netz (Broad- und Multicasts) dem Router Probleme bereiten. Wenn dann noch Loop Problematiken dazukommen ist das eher bedenklich...
Hast du mal darüber nachgedacht dein Netz zu segmentieren und in VLANs aufzuteilen ??? Wenn du mit einem tagged Link auf den Cisco geht kann der zentral die VLANs verbinden und gewährt allen einen WAN/Internet Zugang.
Das ist aber nur eine vage Vermutung..
Du solltest als allererstes deine Spanning Tree Probleme im Netz in den Griff bekommen und die Switches erstmal so konfigurieren, das das Netz sauber und ohne Probleme läuft und auch die Switches management technisch problemlos zu erreichen sind.
Vermutlich lösen sich dann alle Folgeprobleme von selbst...
Bitte warten ..
Mitglied: DrCox
04.01.2008 um 10:25 Uhr
Wie kopiert man am besten ein Image?

copy run tftp [IP-Adresse des TFTP-Server] [Name der Datei].cfg ?

Diesen Befehl bei einem anderen Switch durchführen? Ich habe ´mir die Konfigurationsdatei kopiert. Würde es auch reichen, wenn ich die in ***.cfg umbenenne und dann per TFTP auf den Switch lade?
Bitte warten ..
Mitglied: aqui
04.01.2008 um 13:18 Uhr
Nein, das o.a. kopiert nur die Konfig Datei auf den TFTP Server.
Ein Image wird mit

copy tftp flash <ip_adresse> <dateiname> -> ins Flash des Gerätes
und
copy flash tftp <ip_adresse> <dateiname> -> aus dem Flash auf den TFTP

gesichert
Bitte warten ..
Mitglied: DrCox
05.01.2008 um 11:55 Uhr
Ist das Configurationsfile jetzt gleich dem Image-File?
Und muss ich das über das Terminal machen oder kann ich auch über eine normale Verbindung es kopieren?
Bitte warten ..
Mitglied: aqui
07.01.2008 um 08:20 Uhr
Nein, die Konfiguration bzw. der Konfigurations File sind die Daten die du mit einem show run oder show conf siehst. Das ist ein ASCII File der das System KONFIGURIERT !!!

Das Image ist die FIRMWARE also quasi das Betriebssystem des Gerätes. Das sind 2 grundverschiedene Dinge wie dir sicher selber klar ist.

Was ist für dich eine "normale Verbindung" ??? Das ist unklar und diffus, da man sich darunter nichts vorstellen kann
Mit normal meinst du vermutlich eine Verbindung über das Netzwerk oder ???

OK, ist dem so dann kannst du die Konfigurationsdatei über folgende Techniken sichern:

  • Per Konsolanschluss und Cut and Paste
  • Per Konsolanschluss und einem Terminal mit Log Datei Funktion wie z.B. TERATERM. Log Datei eröffnen und dann "show run" und output in die Log Datei laufen lassen.
  • Per TELNET Verbindung und Cut and Paste
  • Per TELNET Verbindung und einem Terminal mit Log Datei Funktion wie z.B. TERATERM oder PUTTY. Log Datei eröffnen und dann "show run" und output in die Log Datei laufen lassen.
  • Per TFTP Transfer wie oben beschrieben !

Die Konfigurationsdatei lässt sich übrigens mit genau diesen Mitteln auch wieder rückkopieren um so das gerät wieder zu konfigurieren !

Ein Image (Firmware) Update kann nur und ausschliesslich mit einer TFTP Verbindung und TFTP Server (z.B. Pumpkin) über das Netz erfolgen. Wenn du so willst ja auch eine "normale Verbindung" nach deiner Definition....
Bitte warten ..
Mitglied: DrCox
08.01.2008 um 16:01 Uhr
Danke für die ausführliche Erklärung. Jetzt habe ich die Methode mit Terra Term probiert. Dabei kam mit show run folgendes Image zustande (im Editor geöffnet):

E[?25h
Running configuration:

; J4900B Configuration Editor; Created on release #H.08.60

hostname "SD"
interface 19
speed-duplex 10-full
exit
ip default-gateway 172.16.0.1
snmp-server community "public" Unrestricted
snmp-server host 172.16.2.225 "public" Not-INFO
vlan 1
name "DEFAULT_VLAN"
untagged 1-26
ip address 172.16.254.5 255.255.0.0
exit
spanning-tree
password manager
password operator

[?25hHP2626-DV3# [?25h

Bis auf die Zeichen am Ende und Anfang ist dies ja mit dem Konfigurationsfile identisch. Ist das dann so richtig? Und kann ich im Editor gleich die Ip-Adresse ändern? Und ist es eigentlich egal, wie ich die Datei nenne?
Bitte warten ..
Mitglied: aqui
08.01.2008 um 18:40 Uhr
Ja das ist egal, und ja du kannst die IP Adresse darin ändern, musst aber die Konfig dann wieder zurückspielen !

Am besten ist du änderst sie gleich online mit
conf t
ip address 192.168.1.254 255.255.255.0
(Wenn 192.168.1.254 deine neue Adresse ist...)
Dann mit <ctrl z> aus dem Config Modus springen..

und sicherst dann erstmal lokal mit wr und dann wieder als Log oder TFTP Datei oder Cutn past
Bitte warten ..
Mitglied: DrCox
10.01.2008 um 11:07 Uhr
Ich hab mich gerade mal ein wenig in die VLan-Thematik eingelesen. Hier auf dieser Seite gibt es dazu leider nicht sehr viele Beiträge. Meist haben Sie ja auch dazu was gepostet (2aqui).
Jetzt frage ich mich, wie ich das am besten bei meinem Netzwerk hier umsetze. Sollte ich vielleicht einfach auf dem einen Switch, der die 4 anderen Switche versorgt, jeweils ein eigenes VLan erstellen, damit diese 4 dann getrennt sind? Ich glaube für meine Situation ist ein dynamisches VLan geeignet, oder? Vielleicht kennt jemand noch einige gute Tutorials. Das bisher gefundene ist eher dürftig.
Bitte warten ..
Mitglied: aqui
11.01.2008 um 08:46 Uhr
Ohne das du mal schreibst was du eigentlich vorhast mit der Trennung deines Netzes in Segmente ist eine Ratschlag fast unmöglich. In der Beziehung sind deine Angaben eher dürftig und verführen zum wilden Raten....

Klassisch ist bei VLAN Benutzung die Aufteilung von VLANs im Core Switch und dann die Benutzung von tagged Links für die Uplinks, die diese VLANs dann transparent auf die Access (Etagen) Switches verteilen. Eigentlich ein sehr einfaches Konzept für das man keine so großen Tutorials benötigt...
Bitte warten ..
Mitglied: DrCox
11.01.2008 um 11:03 Uhr
Also ich will eine Entlastung des Routers und auch, dass die Nutzer untereinander nicht mehr auf die freigegebenen Daten zugreifen können. Bei dem Switch kann ich ja einstellen, ob die Verbindungen bei VLan taged, no, untagged und forbid sein sollen. Sollte ich jetzt für jeden Switch eine eigene VLan-Verbindung einrichten? Bzw. ein Switch verbindet ja zu den anderen Switchen. Sollte dieser auch eine eigene VLan-Verbindung bekommen?
Bitte warten ..
Mitglied: aqui
11.01.2008 um 15:36 Uhr
Dann ist es ganz einfach:
Du richtest auf den Switches die VLANs ein und die Verbindungen der Switches untereinander (Uplinks) sind alle "tagged Links" (tagged).
In so einem tagged Link nach IEEE 802.1q Norm wird vor jedem Packet immer die VLAN ID (Vlan Nummer) geschrieben, so das jeder Switch diese Packete wieder dem entspr. VLAN zuordnen kann wenn er sie empfängt oder sendet.
So hast du dann schon einmal alle VLANs transparent im Netz erreichbar gemacht.
Als letztes weist du nun den Endgeräten and den Switches ihre Ports und auch die VLANs zu (untagged) und schon hast du erreicht was du willst.
Alle Endgeräte pro VLAN sehen dann nur ihr VLAN, nicht aber die anderen mehr in den anderen VLANs...

Eine gute Erklärung zur Funktion und Einrichtung von VLANs findest du hier:

http://www.heise.de/netze/artikel/77832
Bitte warten ..
Mitglied: DrCox
12.01.2008 um 12:41 Uhr
Ich war im Datenraum und jetzt frage ich mich, ob es nicht angezeigt werden müsste, wenn das Image nicht in Ordnung ist. Es wurde gar nichts angezeigt und die Ip-Konfiguration scheint auch in Ordnung zu sein. Selbst Spanning tree ist weiterhin an.
Außerdem ist die Image-Größe eine andere, als ich mit show run aufgezeichnet habe. Diese Datei hat nur 1 kb und kann deshalb gar nicht kompatibel zu diesem Flash-Image sein.

Primary Image : 2876374 02/08/05 H.08.60
Secondary Image : 2876374 02/08/05 H.08.60
Boot Rom Version: H.08.02
Current Boot : Primary

Von daher muss ich wohl doch noch irgendwie anders zu einem Image kommen.
Ber Terra Term konnte ich außerdem nich übe die Konsole rein, da ich über USB die Konsole anschließe und Terra Term nur 4 Com-Verbindungen hat. der Usb-Treiber weist meiner Verbindung jedoch den Com 6 zu.

Kann man mit der Log-File des Switches etwas anfangen?
I 01/01/90 06:44:02 ports: port 23 is now on-line
I 01/01/90 06:45:14 ports: port 16 is Blocked by LACP
I 01/01/90 06:45:17 ports: port 16 is Blocked by STP
I 01/01/90 06:45:17 ports: port 16 is now on-line
I 01/01/90 06:52:42 ports: port 24 is Blocked by LACP

I 01/01/90 06:52:45 ports: port 24 is Blocked by STP
I 01/01/90 06:52:45 ports: port 24 is now on-line
I 01/01/90 06:58:32 ports: port 23 is now off-line
I 01/01/90 06:58:35 ports: port 23 is Blocked by LACP
I 01/01/90 06:58:38 ports: port 23 is Blocked by STP
I 01/01/90 06:58:38 ports: port 23 is now on-line
I 01/01/90 07:09:19 ports: port 23 is now off-line
I 01/01/90 07:09:21 ports: port 23 is Blocked by LACP
I 01/01/90 07:09:24 ports: port 23 is Blocked by STP
I 01/01/90 07:09:24 ports: port 23 is now on-line
I 01/01/90 08:04:16 ports: port 23 is now off-line
I 01/01/90 08:04:18 ports: port 23 is Blocked by LACP
I 01/01/90 08:04:21 ports: port 23 is Blocked by STP
I 01/01/90 08:04:21 ports: port 23 is now on-line
I 01/01/90 08:19:20 ports: port 2 is Blocked by LACP
I 01/01/90 08:19:23 ports: port 2 is Blocked by STP
I 01/01/90 08:19:23 ports: port 2 is now on-line
I 01/01/90 08:19:55 ports: port 2 is now off-line
I 01/01/90 08:19:57 ports: port 2 is Blocked by LACP
I 01/01/90 08:20:00 ports: port 2 is Blocked by STP
I 01/01/90 08:20:00 ports: port 2 is now on-line
I 01/01/90 08:21:30 mgr: SME CONSOLE Session - MANAGER Mode

Kann es eigentlich auch sein, dass das Image in Ordnung ist? Es würde doch sonst das secondary flash image geladen werden, oder?
Außerdem ändert sich das doch nicht einfach so.
Bitte warten ..
Mitglied: DrCox
14.01.2008 um 09:32 Uhr
Bin nun doch zum Image gekommen. War wirklich sehr einfach. Wollte dann gleich das Image hochladen. Dazu hab ich mir die offizielle Methode ausgewählt. Also die, die im HP-Switch-Handbuch steht. Einerseits war das ein wenig unkonkret. Aber ich kam dann doch ans Ziel. Jetzt jedoch das Problem. Wenn ich über das Terminal (Konsole) dann die Datei hochladen möchte, dann muss ich noch bestätigen mit Y. Allerdings kommt bei dieser Taste nur ein Paragraphen-Zeichen. Woaran könnte das liegen? An einer amerikanischen Tastatur sollte das ja kaum liegen.
Bitte warten ..
Mitglied: aqui
14.01.2008 um 09:36 Uhr
Welches Image du benutzt kannst du ganz einfach auf der CLI Konsole mit dem Komamndo show flash sehen !
Ein show version zeigt dir an welches aktuelle Image gerade auf dem Switch/Router läuft !

Nochmal zur Erinnerung für dich falls du es immer noch verwechseln solltest:
Eine Image ist die Firmware also das Betriebssystem der Maschine. Also was z.B. Windows oder Linux für ein PC ist ist das Firmware Image für einen Router oder Switch !!
Eine Konfig ist nichts als eine ASCII Textdatei die die Konfiguration eines Routers/Switches bestimmt. Diese hat mit der Firmware nichts zu tun.
Beide werden aber in einem Flash Speicher auf dem Systeme gesichert.

Und...ja ein Image ändert sich natürlich niemals einfach so.. ! Es sei denn du lädst der Maschine mit dem copy tftp flash xxx Kommando eine neues Image auf den Flash speicher !? Wie gesagt ein show flash zeigt dir welches Image im Flash ist.
Das Flash kann wie eine Festpaltte mehrere Images halten. In der Konfig kann man dann mit dem Kommando boot system flash <dateiname> sagen welches Image man booten möchte sofern man mehrere hat.
Was sich ändern kann ist die Konfig ! Die ist natürlich nach jedem eingriff in die Konfiguration verändert und wird auch so abgespeichert sofern man das wr Kommando nicht vergisst nach der Änderung !
Und ...ja mit der Log Datei kann man auch was anfangen:
I 01/01/90 06:44:02 ports: port 23 is now on-line
Erstmal kann man sagen das deine interne Uhr vollkommen falsch geht und nicht eingestellt wurde entweder mit dem Time Protokoll SNTP oder manuell mit dem "clock" Kommando !
Desweiteren ist Port 23 online das heist aktiv ist da ein Uplink oder Endgerät dran.

I 01/01/90 06:45:14 ports: port 16 is Blocked by LACP
Auf Port 16 scheint irgendwie ein Trunk (Aggregation) zu arbeiten und ein Port ist durch das LACP (Link Aggregation Control Protokoll) ins Blocking gegangen, forwardet also keinen Traffic mehr...

I 01/01/90 06:45:17 ports: port 16 is Blocked by STP
Die Uhr geht immer noch falsch und auf diesem Port hat der Spanning Tree zugeschlagen und ihn ebenfalls ins Blocking versetzt so das kein Traffic mehr durchgeht und damit wohl ein Loop verhindert wird. Scheinbar ist dein Netzwerk redundant aufgebaut...
I = steht für Informational als kein Warning oder Error sondern nur eine Informationsmeldung für den Admin.
usw. usw.
Bitte warten ..
Mitglied: DrCox
14.01.2008 um 14:08 Uhr
Also leider ging das alles ziemlich schief. Dieses Y war denke ich identisch mit dem Zeichen. Ich konnte auf jeden Fall das Image hochladen. Dabei ist nur leider der Laptop abgestürzt. Die CPU war stark ausgelastet und es kam eine Fehlermeldung. Das hat der Switch in einen seltsamen Zustand versetzt, der immer wieder sich neu installieren wollte. Dann habe ich nochmals das Image hochgeladen über TFTP-Server. Ich denke, dass das unter Umständen nicht korrekt war, weil der Switch sich immer neu konfigurieren wollte. Ich konnte da auch nicht viel mehr machen. Das ganze hat dann nicht viel gebracht und deshalb hab ich einfach einen Reset gemacht und jetzt ist es genauso, wie vorher.
Bitte warten ..
Mitglied: aqui
14.01.2008 um 17:41 Uhr
Du verwechselst scheinbar immer noch Firmware, Image und Konfig Datei, so das man nicht wirklich weisst was du nun eigentlich genau vorhast. Firmware Update oder einfach nur die Konfig sichern oder einspielen...
Hoffentlich hast du dir vorher die Konfig dann in eine .txt Datei gesichert ??!

Nach deinen Ausführungen willst du scheinbar eine Konfig Datei laden und KEINE Firmware Datei ??!! Richtig ??

Der Switch will sich nicht konfigurieren, selbst kann er das ja gar nicht, das ist Unsinn. Vermutlich hat dein Termiprogramm Probleme damit die Kommandos rüberzusenden durch einen zu kleinen Zeichenpuffer.
Wenn du mit 9600 Baud Terminal und Cut'n Paste arbeitest willst als ASCII .txt Textdatei dann solltest du besser TeraTerm verwenden, das funktioniert besser als das MS Hyperterm.
TeraTerm findest du hier:
http://hp.vector.co.jp/authors/VA002416/teraterm.html
(Die NT Variante rennt auf XP, 2k und 2k3)

Dort kannst du die Konfig auch in eine Log Datei laufen lassen die du vorher eröffnest und dann show run eingibst.

Wenn du die Konfig per TFTP Server laden willst dann kannst du das z.B. mit dem Pumpkin TFTP Server machen, den du logischerweise vorher starten musst.
Wenn die Konfig .txt ASCII Datei dort im Verzeichnis ist kannst du die auch mit dem Kommando:
copy tftp <ip_adresse_tftp> <konfig.txt> startup
per TFTP laden.
Wie gesagt die Cut'n Paste Methode übers Termi ist einfacher für Laien !
Bitte warten ..
Mitglied: DrCox
12.02.2008 um 12:30 Uhr
Mittlerweile war ein Techniker hier und trotzdem ist man nicht schlauer. Die Fehler treten weiterhin auf. Dabei wird im Router jeweils immer nur angegeben, dass ein DHCP-Konflikt mit einer Adresse zustande gekommen ist. Aber deshalb sollte doch nicht für kurze Zeit das ganze Netz ausfallen.
Hat jemand eine Idee, was ich noch machen kann?
Bitte warten ..
Mitglied: DrCox
15.03.2009 um 21:16 Uhr
Nun habe ich leider wieder das selbe Problem.
Der Router meldet dauernd einen DHCP-Adresskonflikt. nämlich diesen hier:

%DHCPD-4-DECLINE_CONFLICT : DHCP address conflict: client [chars] declined [IP_address].

Explanation The DHCP client has detected an address conflict. Another host is using the specified IP address.

Recommended Action Resolve the misconfiguration. Clear the conflict from the DHCP database. After resolving the conflict, use the clear ip dhcp conflict command.


Nun nehme ich an, dass es daran liegt, dass es neue Netzwerkteilnehmer gibt und da einer wohl einen Router im Betrieb hat, dessen DHCP-Server eingeschaltet ist.

Oder sehe ich das falsch? Der Router reagiert leider auch nur noch sehr langsam. Kann es vielleicht auch am DHCP-Server des Routers liegen? Die Problemlösung von Cisco sagt mir, dass ich den Konflikt klären soll. Nur, wie kann ich hier vorgehen?
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...