Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Router Netgear DGNB3800B mit richtiger Konfiguration DynDns Zugriff auf QNAP TS239Pro VHosts ermöglichen

Frage Netzwerke Netzwerkmanagement

Mitglied: CDRowell

CDRowell (Level 1) - Jetzt verbinden

10.11.2012, aktualisiert 08:09 Uhr, 7659 Aufrufe, 16 Kommentare

Ich bin am verzweifeln, seitdem ich meinen alten ProSafe Netgear Router gegen den DGNB3800B getauscht habe kann ich nicht mehr auf meine DynDns-VHosts zugreifen. Ich habe mehrfache Einstellungsänderungen vollzogen, jedoch erwirken Änderungen nicht den gewünschten Zugriff. Habe ich etwas übersehen, vergessen, nicht gewusst? Ich danke für mögliche Unterstützung

Meine jetzigen Konfigurationen:

  • Konto DynDns = okay, IP meines Providers ist zugeordnet

  • Router DGNB3800B = DynDns-Check WAN IP okay, "DMZ" = IP QNAP TS239Pro

  • Server QNAP TS239Pro = Webserver Port 80, 21 aktiv, aktivierte VHosts, WAN IP okay

  • Zugriff auf WAN führt mit Zugriff über LAN auf Passwortabfrage Backend des DGNB3800B oder über Internet auf NICHTS...

Welche Infos fehlen, um korrekten Zugriff zu erhalten? Welche Einstellungen würdet Ihr ändern oder ergänzen?

Ich danke für Tipps, Tricks und Unterstützung

Beste Wünsche und Grüße
CDR
Mitglied: MrNetman
10.11.2012, aktualisiert um 10:34 Uhr
Hi CDR Zweifler,

Ist das Ding in deinem eigenen LAN?
Ein DYNDNS Zugriff ist ja kein Zugriff via DynDNS sondern nur eine von DynDNS bediente Namensabfrage.
Also erst einmal deine WAN-Verbindungen checken und diese Einträge prüfen.
Hifreich:
Ping
tracert
nslookup
mit den verschiedenen Parametern.

Das Einloggen auf dem Ziel hat nicht mit DynDNS zu tun.

Gruß
Netman
Bitte warten ..
Mitglied: aqui
10.11.2012, aktualisiert um 08:58 Uhr
Und wieder ein NetGear Opfer...
Hast du das Port Forwarding im Router entsprechend auf die lokalen IP Adressen der Hosts konfiguriert ?
Denk dran das du fur Port TCP 80 Forwarding den remoten Web Zugriff über den WAN Port des Routers deaktivieren musst. So oder so gehört das immer deaktiviert aus Sicherheitsgründen.
Ein Screenshot der Port Forwarding Einstellungen wäre hilfreich hier !
Bitte warten ..
Mitglied: CDRowell
10.11.2012 um 13:04 Uhr
Hallo,

danke für Deine Antwort, eine Weiterleitung wurde wie folgt eingerichtet. Die habe ich leider nicht erwähnt.

Portweiterleitung/Port-Triggering
Dienstname Anfangs-Port End-Port IP-Adresse des Servers
HTTP 80 80 192.168.0.1?? (?=bestimmte Zahl)
FTP 20 21 192.168.0.1?? (?=bestimmte Zahl)

Ich komme durch LAN nur auf Routerlogin :-O

Ich freue mich wenn Netgear mich nicht als "Opfer" irgenwelcher "Du-zahlst-und-bekommst-nicht-was-du-brauchst" Ideologien verfallen bin.

Mit dem FWP114P lief alles ohne Beanstandungen, bis der nach fast 9 Jahr ausgetauscht werden musste...

Anscheinend übersehe ich die Möglichkeit für Deaktivierung des Web-Zugriffs? - Ich find (3 Mal rauf und zurück) keinen Eintrag, der passen könnte...

Danke für die Tipps, klappt noch nicht probiers jedoch weiter!
Bitte warten ..
Mitglied: MrNetman
10.11.2012, aktualisiert um 13:12 Uhr
naja, wenn dein Router die 192.168.0.1 hat ist das wohl nicht weiter verwunderlich ...
Du wirst wohl auch eine gültige IP in deinem Netzwerk angeben müssen.
Bitte warten ..
Mitglied: CDRowell
10.11.2012 um 13:19 Uhr
Dankendes Hallo!

Ping zeigt:
Antwort auf die richtige IP u. Bytes u. TTL

nslookup:
Ohne erfolg, egal welche IP, Domain usw. :-O

Trace:
03 xe-1-1-1.atuin.as6724.net (85.214.0.71)
04 decix-te2-1.ffm.r-kom.net (80.81.192.52)
05 er1-ge1-8.rgbg.r-kom.net (212.77.162.121)
06 cr1-te4-1.rgbg.r-kom.net (212.77.160.55)
07 komro2.rgbg.r-kom.net (212.77.162.182)
08 217.72.223.86 31.627 ms 31.596 ms 31.359 ms
09 217.72.223.162 30.998 ms 30.309 ms 30.850 ms
10 * * *
11 217.72.2??.1?? [open]

Anscheinend gehts irgendwie...

Danke für deinen Tipp. Das Problem mit dem nslookup macht mir echt Angst!!

Freue mich über weitere Tipps


Danke.
Bitte warten ..
Mitglied: CDRowell
10.11.2012 um 13:31 Uhr
Hallo,

was meinst Du genau damit:
"Du wirst wohl auch eine gültige IP in deinem Netzwerk angeben müssen."
Verstehe das nicht genau...

Danke für kurze Erklärung.

Grüße
Bitte warten ..
Mitglied: MrNetman
10.11.2012 um 14:45 Uhr
nslookup:
Die Frage wird an einen DNS-Server gestellt um die spezifische Antwort zwischen Namen und IP zu erhalten.

Beim Tracert fehlt wohl was:
Wo gehts du raus und wo willst du ankommen.
Eines kommt automatisch als ersten in der Liste und eines wird als Parameter für tracert angegeben.

Eigenes Netz:
Du hast Konfigurationen mit zwei Fragezeichen markiert und "bestimmte Zahl" dazu geschrieben. Das hört sich an wie die Portnummer. Du brauchst aber als Ziel eine IP in deinem privaten Netz.
Und mit den Adressen vom privaten Netz brauchst du nicht wirklich geheim umgehen. diese gibts zu Tausenden, Millionen gleich.

lg
Netman
Bitte warten ..
Mitglied: CDRowell
10.11.2012 um 16:01 Uhr
Hallo und danke für Deine Beschreibungen.

die Funktion mit nslookup ist nun für mich besser nachzuvollziehen.

traceroute sounds.ddns.ms
1 gw.ffm.de.netclusive.de (89.110.131.1) 3.746 ms
2 217.68.144.249 (217.68.144.249) 0.678 ms
3 gi1-1-103.bg2.fr2.eu.equinix.net (217.68.155.77) 0.299 ms
4 decix-te2-1.ffm.r-kom.net (80.81.192.52) 0.503 ms
5 er1-ge1-8.rgbg.r-kom.net (212.77.162.121) 8.943 ms
6 cr1-te4-2.rgbg.r-kom.net (212.77.160.39) 9.087 ms
7 komro2.rgbg.r-kom.net (212.77.162.182) 16.656 ms
8 217.72.223.86 (217.72.223.86) 18.664 ms
9 217.72.223.162 (217.72.223.162) 17.348 ms
nun sollte meine WAN-IP erscheinen, jedoch folgt kein weiterer Eintrag.

"...Du hast Konfigurationen mit zwei Fragezeichen markiert und "bestimmte Zahl" dazu geschrieben. Das hört sich an wie die Portnummer. Du brauchst aber als Ziel eine IP in deinem privaten Netz."

Es handelt sich um eine IP. Portnummern würden meines Wissens mit einem Doppeltpunkt beginnen.
Sollte jetzt ich z. B. explizit 192.168.0.1??:80 angeben?
Bitte warten ..
Mitglied: aqui
10.11.2012, aktualisiert um 17:40 Uhr
Die o.a. Port Weiterleitung MUSS auf die lokale IP deines Servers zeigen !!
Wenn die 192.168.0.1 dein Server ist, ist alles gut. Nach der IP geraten sieht das aber auch ggf. nach der Router IP aus und dann wäre die Weiterleitung natürlich vollkommen falsch !
Hat dein Server also z.B. die .100 im Netz dann muss die Weiterleitung in der NetGear Gurke lauten:
HTTP 80 80 192.168.0.100 ?? (?=bestimmte Zahl)
Denke daran den Servern immer statische IPs im Netz zu geben, damit die Weiterleitung durch die Dynamik von DHCP nicht mal ins Leere läuft. Abgesehen davon sollten Server immer statische IPs im Netzwerk haben.
Das diese zudem noch außerhalb des DHCP Bereich des Routers (oder DHCP Server) liegen muss sollte klar ebenfalls sein !
Bitte warten ..
Mitglied: Aba-it
10.11.2012, aktualisiert um 19:39 Uhr
Hallo

Meinst du vielleicht ein DGND3800B? Denn einen DGNB3800B finde ich nicht?
Ich habe mir mal das Handbuch angeschaut. Anscheinend kann man einen "Zeitplan für Firewall-Dienste" erstellen (Seite 50). Überprüf mal ob nicht der Zeitplan so eingestellt ist, dass die Weiterleitung, die meiste Zeit über blockiert ist.

Sollte jetzt ich z. B. explizit 192.168.0.1??:80 angeben?
Nein. Für den Port gibt es ein entsprechendes Eingabefeld dem Handbuch zufolge.

Ansonsten ist es eigentlich so wie die Vorredner bereits beschrieben haben. Portweiterleitung einrichten und als Serveradresse die lokale LAN Adresse des NAS.

Übrigens ist es für dich nicht notwendig die Adressen aus dem lokalen Bereich geheim zu halten ("192.168.0.1??"). Falls man über diese Adresse auf deinen Server was anstellen könnte, dann wäre diese Weiterleitung sowieso sinnlos.

Gruss
Bitte warten ..
Mitglied: CDRowell
18.11.2012 um 05:44 Uhr
Hallo,

danke für die Infos, aufgrund meiner verspäteten Raktion: -> gebe ich weiter unten antwort.

Beste Grüße
CDR
Bitte warten ..
Mitglied: CDRowell
18.11.2012 um 08:39 Uhr
Hallo und verzögertes Danke für Eure Bemühungen, da ich länger stark durchterminiert war, nun die Ergebnisse!

Danke für den Hinweis zu meinem Schreibfehler, den von Dir bezeichnerten Router meine ich!

Das Handbuch liest sich gut und ich habe folgende Einstellungen übernommen:

Meine Portweiterleitung:
1 DYNDNS-IP01 80 80 192.168.0.100
2 DYNDNS-IP02 8080 8081 192.168.0.100
3 DYNDNS-IP03 20 21 192.168.0.100
4 und so weiter...

Meine Dienste sperren: zur Überprüfung aufgehoben.
Check:
Zuweisung durch Router auf feste IP ist gesetzt.
Überprüfung mxtoolbox.com/DNSLookup.aspx DynDNS augenscheinlich korrekt konfiguriert.
Cache im Browser gelöscht, sicherheitshalber anderen Browser genutzt.
Routerneustart, Serverneustart, damit wirklich keine Frage offen bleibt getätigt.
Über LAN ist Server erreichbar.
Eingabe im Browser: des DYNDNS-Host-Service-Namen = GREIFT UNVERMITTELT AUF ROUTER VON NETGEAR ZU!

Da bekomme ich gleich Lust den Router vorbereitend für den Sperrmüll mit Aggressionen zu konfigurieren... (Kann es sein, dass der Router defekt ist und einfach nicht bietet, was er sollte?!) Wahnsinn, was ich hier erlebe...

Ich werde nun den NETGEAR SUPPORT fragen, ob die ne Lösung vorschlagen können.

Danke für Eure Unterstützungen.

Ich melde mich, wenn ich Antwort habe.

Beste Wünsche und Grüße
CDRowell
Bitte warten ..
Mitglied: aqui
18.11.2012, aktualisiert um 14:37 Uhr
Das kann so auch niemals funktionieren da deine Port Weiterleitung völliger Blödsinn ist, jedenfalls die Einträge 2 und 3 und undsoweiter vermutlich auch.
Scheinbar fehlt dir das das nötige Hintergrundwissen zur TCP/IP Kommunikation. Sorry aber da liegt der Fehler diesmal nicht am Router (auch wenn es ne NetGear Gurke ist) sondern zwischen Stuhl und Keyboard...
Regel 1 is ja noch OK.
Eingehender Port TCP 80 wird auf die lokale IP 192.168.0.100 weitergeleitet.
OK, damit ist ein lokaler Server mit der IP 192.168.0.100 von aussen dann via Browser und DynDNS IP erreichbar.
Der 2te Eintrag macht Port Translation also ein eingehender TCP 8080 Connect wird auf den lokalen Server 192.168.0.100 mit TCP 8081 weitergeleitet. In so fern Blödsinn, denn dann müsste der Webserver ebenfalls auf 8081 antworten, was er vermutlich nicht tut denn er macht ja HTTÜ auf 80 sonst wäre Regel 1 wieder Blödsinn....also Fehlschlag.
Der 3te Eintrag ist völliger Unsinn, denn da geht es vermutlich um FTP ?! Hier drehst du mit Port Translation den FTP Command Port TCP 20 auf den FTP Datenport TCP 21 um, ein technisches NoGo. Wie soll so jemals eine FTP Verbindung zustandekommen ?? Das ist so wenn du Autos mit einer Umleitung in eine Sackgasse schickst...
Lies dir also erstmal die Grundlagen von FTP respektive TCP Ports durch bevor du da weiter so einen Unsinn machst, sorry !
Die FTP Ports darfst du niemals verbiegen !
Also TCP 20 eingehend muss auch auf TCP 20 lokal rauskommen ! Ebenso TCP 21 auf lokal 21 !
Das FTP Protokoll nutzt beide Ports aktiv !!
Also erstmal Grundlagen lesen, dann machen wir weiter hier !!
Bitte warten ..
Mitglied: CDRowell
18.11.2012 um 17:40 Uhr
Hallo,

ich freue mich über Deine offene Kommunikation und danke Dir für Deine Rückmeldung, die hier anscheinend ins Schwarze trifft. Das das Problem vor dem Monitor und sich über der Tastatur befindet, kann zudem zutreffen...

Zudem bin ich gerne bereit dazu zu lernen, daher setzt ich mich auch der Möglichkeit aus, dass meine Fehler hier auf sachbezogene Kritik stoßen. Und die nehme ich nun zum Anlass zu Fragen, welche Lektür oder Webseiten würden sich hier gut anbieten?

Danke für Die Unterstützung und evtl. Möglichkeit zur Übermittlung zur jetzigen Anfrage.

CDRowell
Bitte warten ..
Mitglied: CDRowell
20.11.2012 um 20:19 Uhr
Hallo,

da ich es leid war mich mit dem Router DGND3800B zu ärgern, setzte ich nun zum "Spaß" die F.B7390 auf und: ALLES LÄUFT AUF ANHIEB, auch "ohne ausreichende" Kenntnisse. Seltsam oder? Nun gut... Ich danke Euch für Eure Zeit und Unterstützung = Hier war das Problem anscheinend nicht zwischen Monitor und Stuhllehne...

Mit besten Wünschen und Grüßen
CDRowell
Bitte warten ..
Mitglied: aqui
21.11.2012, aktualisiert um 12:11 Uhr
Nein, das Problem heisst hier wie immer "NetGear" !!
Sieh dir die anderen zahllosen Leidens Threads hier an zu NG dann weisst du warum !!

Wenns das denn nun war bitte dann auch
http://www.administrator.de/faq/32
nicht vergessen !!
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(1)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
RedHat, CentOS, Fedora
Centos 7 Uhrzeit ist falsch trotz richtiger Konfiguration (6)

Frage von vGaven zum Thema RedHat, CentOS, Fedora ...

Netzwerkmanagement
VLAN Konfiguration inkl. Management VLAN Zugriff auf NETGEAR Smartswitches (1)

Frage von tobitobsn zum Thema Netzwerkmanagement ...

MikroTik RouterOS
Mikrotik BaseBox 5 Wirless Bridge Konfiguration richtiger Ansatz? (7)

Frage von chrisbs zum Thema MikroTik RouterOS ...

Heiß diskutierte Inhalte
DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (9)

Frage von JayyyH zum Thema Switche und Hubs ...

Backup
Clients als Server missbrauchen? (9)

Frage von 1410640014 zum Thema Backup ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...