Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Router - Router - Proxy und weiter ... Probleme mit der Weiterleitung im Proxy

Frage Netzwerke Router & Routing

Mitglied: microstorm

microstorm (Level 1) - Jetzt verbinden

13.03.2008, aktualisiert 17.03.2008, 4572 Aufrufe, 5 Kommentare

Habe ein Problem im Routingbereich. Da die Konfiguration aber sehr problematisch ist, würde ich diese erstmal im Vorfeld genauer aufzeichnen:
Für den Internetanschluss existiert eine SDSL Leitung mit vorkonfig. Router. Nach diesem kommt ein Netgear (derzeitig ein 318er, wird nächstens gegen einen SSL312 ersetzt), der für VPNs zuständig ist.
Danach geht’s zu einem Proxy, der mit zwei Netzwerkkarten ausgestattet ist und ebenfalls als Router arbeitet (Konfiguration WinServer2003 mit Routerfunktion). Dieser übernimmt Aufgaben als MailServer, Proxy und verwaltet statische Routen zu anderen Standorten des Firmennetzes (Festnetzleitungen), sowie Zugang SAP über einen eigenen Router.
Alles funktioniert prächtig. Bis zur Konfiguration VPN.
Ich komme ohne Probleme in den Netgear und kann per https den Netgear von extern konfigurieren. Auch die VPN funktioniert tadellos. Aber leider nur bis zur 1. Netzwerkkarte des ProxyServers. Die kann ich noch anpingen, komme von dort aber nicht weiter ins nächste Netz.
Setze ich einen Ping vom Netgear an die externe Proxy Adresse (meinetwegen 192.168.1.2)- alles ok. Setze ich einen Ping an die interne Netzwerkkarte (z.B. 10.172.38.70, Subnetz), kommt nix an. NAT und Firewalls am Proxy sind raus und beide Netzwerkkarten als privat gekennzeichnet.
Mit VNC komme ich auch auf die externe Schnittstelle des Proxys und kann diesen verwalten. Aber weiter geht’s nicht.
Andersrum geht es. Ich kann vom internen Netz bis an den SDSL Router pingen. Aber andersrum nicht. Riecht ja nach Firewall, aber da diese am Proxy faktisch abgeschaltet ist, kann das auch nicht sein.
Es dürfte aber am Proxy liegen, da ich bis an seine externe Netzwerkkarte vom Netgear komme.

Hat jemand eine Lösung??
Mitglied: aqui
13.03.2008 um 11:36 Uhr
Dies Tutorial hat die Lösung für dich:

http://www.administrator.de/Routing_mit_2_Netzwerkkarten_unter_Windows_ ...

Bei dir fehlt schlicht und einfach die statische Route auf dem NetGear zum Zielnetz hinter dem Server !
Zielnetz: 10.172.38.0, Maske: 255.255.255.0, Gateway: 192.168.1.2

Oder: 2. Möglichkeit du hast vergessen dem Proxy Routing beizubringen. Wie das geht steht im Tutorial.
Bitte warten ..
Mitglied: microstorm
13.03.2008 um 16:20 Uhr
Hallo Aqui,
vielen Dank für Deine schnelle Antwort.

Aber so einfach ist es leider nicht.

Das Problem ist (siehe geschlossene Router Telekom und SAP), dass alle Hosts im internen Netz über einen anderen Gateway gehen, nämlich den der Festnetzwerbindungen zu den anderen Standorten. Die OnlineDienste gehen ja alle über den Proxy- und Mailserver.
Wenn ich so wie Du glaubst vorgehe, bleibe ich im Proxy hängen und komme leider nicht an die dahinter liegenden Clients. Ich kann an den beiden anderen Routern (Festnetz und SAP) auch keine Änderungen vornehmen, da diese geschlossen sind. Aus diesem Grunde mußte ich auch den Proyxy als Router "mißbrauchen". In diesem sind dann alle Routen für die Festnetzverbindungen aller Standorte und SAP Zugriff mit statischen Routen festgelegt.
Bitte warten ..
Mitglied: aqui
14.03.2008 um 09:20 Uhr
Routingtechnisch ist das ein komplett falsches Design, was man so schon im Vorwege hätte niemals umsetzen sollen. Ein Default Gateway darf niemals auf einer Maschine liegen die man nicht selber administrieren kann, das ist klar.
Du hast dann nur die Chance das du auf jedem einzelnen PC eine Route mit route add.... einträgst.
Das ist genau so ein Unsinn wie oben, denn nun muss man eine unsinniges Routing Design mit unsinnigen Workarounds wieder glattziehen
Generell muss das aber funktionieren...auch wenn man es so nach dem Motto "von hinten durch die Brust ins Auge..." löst.
Bitte warten ..
Mitglied: microstorm
14.03.2008 um 11:11 Uhr
Leider ist das mit "unsinnig" für mich zwar nachvollziehbar, aber wenn ich das Netz in dieser Form übernehme und aufgrund der zwangsläufig verwendeten Dienste keine andere Lösung möglich ist, muss ich eben auch mit so einem "Irrsinn" klar kommen.
Dazu steht, dass das gesamte ERP System über statische Routen der Festnetzverbindungen Läuft und ich da im laufenden Betrieb keine Chancen habe, etwas zu ändern. Und wenn IntraSelect sogar den IP Bereich für die Subnetze festlegt.... Übel.
Interessant ist, das "route add" sogar ehemals auf einigen Clients zur Anwendung gekommen ist, um Richtung SAP zu routen. Das habe ich als erstes gekillt und als stat. Route im Proxy festgelegt.
Das funktioniert ja ohne Probleme.

Aber im Falle der neuen Anbindung des Netgears, geht weder die (ordnungsgemäß definierte) stat. Route am Netgear, noch die auf dem Proxyserver. Alle Einstellungen sind ok, trotzdem komme ich nur bis externLAN am Proxy.
Bitte warten ..
Mitglied: aqui
17.03.2008 um 14:53 Uhr
Das lässt dann nur eine Schlussfolgerung zu, das der Proxy dann nämlich nicht routet ! Entweder du schaffst da einen Workaround das du eben über den Proxy nicht routen musst oder du forscht mal warum der Proxy die Packete nicht weiterroutet...
Bitte warten ..
Ähnliche Inhalte
Router & Routing
gelöst Probleme mit Sophos Proxy UTM9 SG230 (11)

Frage von Leo-le zum Thema Router & Routing ...

Router & Routing
gelöst Squid Revers Proxy Probleme - Exchange (1)

Frage von theoberlin zum Thema Router & Routing ...

LAN, WAN, Wireless
Proxy Performance-Probleme Testmöglichkeiten (4)

Frage von clubmate zum Thema LAN, WAN, Wireless ...

Neue Wissensbeiträge
Windows Server

Umstellung SHA 1 auf SHA 2 - Migration der CA von CSP auf KSP

Tipp von Badger zum Thema Windows Server ...

Windows 10

Quato DTP94 unter Windows 10 x64 installieren und verwenden

Anleitung von anteNope zum Thema Windows 10 ...

Windows 10

Win10 1703 und Nutzerkennwörter bei Ersteinrichtung - erstaunliche Erkenntnis

(15)

Erfahrungsbericht von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
CNC Maschinen verlieren Netzwerkverbindung (kurioser Fehler) (21)

Frage von NoHopeNoFear zum Thema LAN, WAN, Wireless ...

Drucker und Scanner
Erfahrungen mit Enterprise-Tintenstrahldruckern A4 und A3 (11)

Frage von User1000 zum Thema Drucker und Scanner ...