Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Routing, bzw. Bridge zwischen VWIFI (Hotspot) und LAN Schnittstelle

Frage Microsoft Windows Netzwerk

Mitglied: jst007

jst007 (Level 1) - Jetzt verbinden

06.02.2012, aktualisiert 18.10.2012, 3866 Aufrufe, 5 Kommentare

Ich suche eine Lösung um unter Windows 7 eine Bridge zwischen einem Virtuellen Wifi Netzwerkadapter & einer Lan Schnittstelle herzustellen.

Ich habe ein kleines Problem mit einem Windows 7 System, welches ich gerade nicht gelöst bekomme.

Auf dem Windows 7 System läuft VirtualBox mit einem Linuxsystem. Dieses Linuxsystem (u. A. SQID als Proxy, IPTables mit NAT, DHCP) stellt auf einer LAN Karte Internet zu Verfügung (Der Windows 7 Rechner selbst hängt per WLAN oder UMTS Einwahlverbindung am WAN).
Dieser LAN Port läuft nun wunderbar - ein darauf angeschlossener Rechner erhält (durchgereicht vom virtuellen System) eine IP per DHCP und wird auch über den Proxy versorgt. Soweit so gut.

Nun habe ich unter dem Windows 7 System noch einen Hotspot aufgesetzt. Das läuft relativ easy ab - Microsoft bietet hierzu einen virtuellen WiFi Adapter an. Wer es noch nicht kennt, siehe hier:
http://www.youtube.com/watch?v=4ddQLowGRMw

Zu diesem "Hotspot" kann ich mich nun auch wunderbar verbinden, erhalte auch eine IP-Adresse (vom Linux System), nur Internet läuft irgendwie noch nicht. Meine Vermutung liegt darin, dass sich irgendwo beim "NATen" vom Win7 und der VM ein Problem eingeschlichen hat. Kurzum: ich komme nicht dahinter.

Meine Idee war daher die, dass ich den virtuellen WiFi Adapter mit der LAN Schnittstelle Windows-seitig via Bridge verbinde und die am Hotspot (virtuellen WiFi Adapter) angemeldeten Geräte sich dann verhalten wie wenn sie per LAN angeschlossen wären.
Naja, leider klappt das nicht so wie geplant, da Microsoft keine Bridge vom virtuellen WiFi Adapter aus zulässt.

Hat von Euch jemand eine Idee wie ich das gebacken bekomme?
Evtl. via Routing? Hier bin ich leider nicht so fit und würde mich über eine kleine Hilfestellung freuen.

Danke & schöne Grüsse
Mitglied: aqui
06.02.2012, aktualisiert 18.10.2012
Du hast ja gerade gesagt der WLAN Adapter macht die WAN Verbindung also die verbindung ins Internet. Dein virtueller Host muss ja wenn er NAT usw. macht auch mindestens 2 Adapter "sehen" denn sonst könnte ein Proxy bzw. NAT irgendwohin ja niemals funktionieren.
Folglich muss also der WLAN Adapter in einem anderen IP Netzwerk sein als der lokale LAN Adapter...logisch ! Anders könnte Winblows damit auch nicht umgehen. Siehe hier:
http://www.administrator.de/wissen/routing-mit-2-netzwerkkarten-unter-w ...
Der virtuelle AP hat aber immer eine Bridging, also einen simple Layer 2 verbindung rein auf Basis der Mac Adressen auf die WLAN Physik.
Folglich hepelst du also dein gesamtes Konzept aus denn nun stellst du per WLAN eigentlich den "roten" WAN Port zur Verfügung, oder...sollte UMTS der "rote" Port sein hängt das WLAN irgendwo isoliert in der Gegend rum als normaler 3ter Adapter unter Windows ohne eine Verbindung auf das LAN Interface wo ja eigentlich dein internes LAN ist.
Damit kommt es aber zu einem Problem, denn dieses Segment müsste ja auch irgendwie an den internen "Linux" Router angeflanscht sein als 3tes Segment.
Bridging scheidet ja aus wegen der Limitierungen von Winblows.
Sinnvoller ist also du setzt einen kleinen UMTS Router ein:
http://www.administrator.de/wissen/mifi-router-statt-umts-gsm-usb-stick ...
Damit spart man sich die Frickelei mit der nicht funktionierenden Bridge. Den Linux Client kannst du dann daran als Client hängen um so im LAN dann den Proxy zu realisieren.
Sinnvoller wäre da ein feste Firewall Lösung wie z.B. die Monowall:
http://m0n0.ch/wall/
die auch gleich plug and play fertig in einer VM Version vorliegt:
http://m0n0.ch/wall/downloads.php
Damit hättest du ein erheblich geringeres Sicherheitsproblem und weit mehr Möglichkeiten was einen wirklichen Hotspot anbetrifft:
http://www.administrator.de/wissen/wlan-oder-lan-gastnetz-einrichten-mi ...
Bitte warten ..
Mitglied: jst007
06.02.2012 um 17:21 Uhr
Eine externe Hardware fällt leider aus diversen Gründen aus, sonst wäre ich schon längt auf etwas derartiges gewechselt. Es handelt sich um ein "embedded device", da kann leider nichts externes mehr mit dazu, das hat Spannungsversorgungs-, Temperatur- und Bauplatzgründe.

Das Project Monowall sehe ich mir mal näher an - sieht interessant aus.
Wenn ich keinen Denkfehler habe, dann hat meine Monowall in der VM dann 3 Netzwerkkarten.

1x für das NAT von Windows zur VM
1x LAN-Port (dort liefert die Monowall Internet) - Ist per VirtualBox als "Bridged Adapter" verbunden
1x virtual WiFi Port (dort liefert die Monowall Internet) - Ist per VirtualBox als "Bridged Adapter" verbunden
Bitte warten ..
Mitglied: aqui
07.02.2012 um 18:25 Uhr
Ja richtig. Theoretisch würden auch 2 reichen aber diese Option fällt aus da du den virtuellen AP unter Winblows nicht über eine Netzwerkbrücke verbinden kannst. (Nebenbei bemerkt: Hättest du ein Linux verwendet mit Mad WiFi hättest du diese Einschränkungen nicht gehabt !)
Also hast du nur die Option ihn an den 3ten VM Adapter zu hängen per VM Bridging.
Ist technisch auch besser, denn so kannst du einen wirklichen Hotspot an dem Interface realisieren über die Captive Portal Funktion der Monowall.
Bitte warten ..
Mitglied: jst007
07.02.2012 um 20:06 Uhr
Danke für die Antwort.

Ich habe jetzt mal ein m0n0wall System aufgesetzt.
Zum Testen möchte ich erst mal mit der Lan Schnittstelle testen.

Diese habe ich gebridged und ich erhalte auch schon wunderbar eine IP per DHCP zugewiesen.
Ich kann auch von meinem Notebook aus (das ist testweise angeschlossen) pingen, auch eMails empfangen und versenden (Port 25 / 110 ist offen), nur surfen geht nicht.
In der Console des Notebooks kurz ausprobiert: Tatsache - über Port 80 komme ich nicht raus?
Jetzt muss ich wohl an die m0n0wall ran - nur fehlt mir hier erst mal das KnowHow, bzw. mir ist noch nicht ersichtlich wieso ich nicht via Port 80 vom Notebook aus rauskomme.

Habt Ihr hierzu vielleicht eine Idee?
Bitte warten ..
Mitglied: aqui
10.02.2012 um 10:41 Uhr
Wenn du am LAN Port dran bist gibt es keine FW Regel die das verhindern würde.
Wenn du in die FW Regeln im WebGUI siehst steht dort * any any also jedes Protokoll nach überallhin darf durch.
Da hast du also irgendwo anders ein Problem !!
Kann es sein das du einen Proxy im Browser eingestellt hast ?
Die Monowall filtern NICHT bestimmte Ports am LAN Interface. Dort ist wie gesagt die Default any zu any Regel aktiv.
Anders sieht es bei den anderen Ports aus. Die sind wie es sich für eine Firewall gehört per default alle komlett geblockt und da musst du erst freischalten was DU erlauben willst !!
Fazit: Es lieht also nicht an der FW !!
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
LAN, WAN, Wireless
Client Mode oder Bridge Mode bei Anbindung an einen AP per W Lan (3)

Frage von xpstress zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
WLAN zu LAN Switch oder Bridge (4)

Frage von Stefan3110 zum Thema LAN, WAN, Wireless ...

Router & Routing
gelöst Routing zwischen zwei Netzen (31)

Frage von Xaero1982 zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...